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0. Legal information
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This document is copyrighted. All rights reserved. No part of this document may be reproduced or
transmitted in any form or by any means, without our express consent. Information in this document
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topicality of the information contained herein and any errors or damage resulting from the information
provided.
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1. Representation

The following representations and conventions for instructions are used throughout the doc-
umentation:

Representation Description

Control element All graphical user interface controls are displayed in bold

Menu > menu
command

Whenever running a command involves clicking a series of menus, the single
GUI controls such as menu commands or dialog tabs are linked by >.

Value All data that have to be entered by the user or data that represent a field value
are displayed in Courier New. Also, file names and path names are dis-
played in Courier New.

STRG Keys to be pressed are displayed in CAPITAL LETTERS.

<Placeholder> Placeholders in instructions and user input are displayed in italics and in
<angle brackets>.

1. Instruction Procedures to be carried out step by step are realized as numbered steps.

Result System responses and results are displayed in italics.

Abbreviations and acronyms

Abbreviation Description

AD Active Directory , directory service of Microsoft Windows Server

EBKGUI Interface of the eLux Builder Kit (Tool for creating eLux software packages)

EPM eLux package module (.epm, software package)

FPM Feature package module (.fpm, part of a software package)

FQDN Fully qualified domain name

GB Gigabyte

GHz Gigahertz (processing speed)

HDD Hard disk drive (flash memory)

IDF Image Definition File (.idf)

IIS Internet Information Services: Microsoft Web server

MB Megabyte

OU Organizational unit
Unit or group within the organizational structure

VPN Virtual Private Network
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2. Overview

The eLux Image Administration Service (ELIAS) allows you to easily manage the firmware of devices
running eLux. Default images such as recovery.idf contain the operating system and applic-
ations but can be modified by using ELIAS. ELIAS helps you create new image definition files (IDF)
or modify the existing ones.

For an individual client image, you select exactly those software packages for your IDF you want to
have installed on the devices' flash memory. An IDF is a structured package list defining all software
packages for the operating system and applications.

Administrators can select all required software packages available in a container and define them in
an IDF. Once created, an IDF can be used as target for a firmware recovery or a firmware update.
After successful recovery or update to an individual IDF, the firmware image installed on a device is
consistent with the image defined in the relevant IDF.

ELIAS is part of the Scout Enterprise Management Suite and is installed as a component of it. For fur-
ther information, see Installing Scout Enterprise Management Suite in the Installation guide.

ELIAS offers the following features:

User-friendly graphical interface that allows you to easily create software images

Easy management of device firmware by using the “container method”

Software components can be activated/de-activated to optimize the use of available resources

Image size bar to avoid exceeding flash size

Automatic check of software dependencies

Import feature to add the latest software versions

Export feature to export a package along with its software dependency information

Digital signatures to verify the originality of software packages and IDFs.

Creating USB Recovery sticks or disk images containing an individual software image

2.1. Starting ELIAS

From the Scout Console: 

Click View > ELIAS.

From the Windows start menu: 

Click Programs > Scout > ELIAS.

If you have installed the Scout Enterprise Management Suite by using the default settings, ELIAS
automatically opens the defined container at start-up. Otherwise, you have to select the relevant con-
tainer in a first step.
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2.2. Keyboard shortcuts

Keys
Selected ele-
ment

Description

↑ ↓ Any list entry Moves selection

TAB Anywhere Screen navigation in the ELIAS window

CTRL+← Available
packages
list entry

Adds selected package to the Defined packages list

DEL Available
packages
list entry

Removes the selected package from the container

INSERT Available
packages
list entry

Opens the Import package dialog

→← Defined
packages
list entry

Shows or hides feature packages (FPM) of the selected package

CTRL+→ Defined
packages
list entry

Removes the selected package from the Defined packages list

SPACE Defined
packages
list entry

1. Expands/collapses the selected eLux package (EPM)

2. Activates/deactivates the selected feature package (FPM)
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2. Interface

The ELIAS application window is divided into the Image section on the left and the Container section
on the right.

To view the available packages on the container, select the relevant software container from
your web server or FTP server.

To view an existing image definition file (IDF), open the relevant .idf file from the selected con-
tainer. If you create a new image definition file, you start with an empty list in the left section.

With both lists in front of you, you can easily define your image, adding software packages from the
container, and if required, removing packages from the IDF.
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Legend to numbers

1 Image definition file (.idf) with name, total size of all packages selected so far, number
of defined files and storage location

The current image size is graphically represented on a status bar on the bottom of the
window (7).

2 Software package defined in the IDF (eLux package module, .epm)

3 Details for the selected software package (selected in either the left or the right list):

Name, version, size, number of included files, signature status, signature proof date as
well as the copyright information and the description of the selected feature or package

4 Subordinate features of the software package (feature package module, .fpm)

5 Selected software container with name, description and storage location

6 Software packages provided in the software container (.epm)

7 Image size based on currently selected software packages
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3. Installation: eLux Container

The eLux container is a compilation of software packages used to create the firmware (IDF) of a cli-
ent. The administrator selects a subset of the software package pool to define an IDF (Image defin-
ition file) that can be installed on the devices.

The software packages can be provided via the container installation on a web or FTP server (legacy
ELIAS) or via the ELIAS 18 web service in a MongoDB (locally or in combination with IIS).

Note
If you use the web-based ELIAS 18, there is no need to install the eLux container. In ELIAS 18, you
simply import the relevant software packages or the AllPackages bundle. For further information,
see Importing software packages in the ELIAS 18 guide.

For the operating system versions eLux RP 6 / 64-bit, eLux RP 6 / 32-bit and eLux RP 5, dedicated
containers are provided.

If you install the eLux container to be used by the legacy ELIAS, the containers are stored on the
FTP or HTTP server root directory as follows:

…\eluxng\UC_RP6_X64 (for eLux RP 6.3 and later versions)

…\eluxng\UC_RP6 (eLux RP 6.1 and 6.2)

…\eluxng\UC_RP5

3.1. Installing a container

The installation is covered by the Installation guide. For further information, see Installing a
container.

3.2. Exporting packages and containers

Important Use the ELIAS Export feature instead of copying files by using the Windows
Explorer. This is to ensure that all sub-components and basic information on depend-
encies are included.

From ELIAS, you can export all packages of an IDF or individual packages:

By clicking Image > Export... you create a new container to which all the packages defined in
the relevant IDF are copied. This is particularly useful if you want to update your devices from
a USB mass storage device and all packages (optional: only these) should be included on the
USB stick to which you want to update.

By clicking Container > Export Package... you export individual packages, for example to
provide them on the Scout Server without internet access. As for the import feature, all fea-
tures of the software packages are automatically transferred and there is no need to copy any-
thing manually.

8

elias18_packages_import.htm
install_container_install.htm
install_container_install.htm


Exporting all packages of an IDF into a new container

1. Click Container > Select... to open the existing container.

2. Click Image > Open... to open an existing IDF, or click Image > New to create a new image.
See also "Creating a new IDF" on page 11.
Alternatively, use the provided icons.

3. Click Image > Export...

4. Click Browse and select a target directory as the new container, and then type a name for the
IDF.
Confirm with Save.

5. Optional: If the target directory, for example on an eLux Recovery USB stick, already contains
packages but you only want the defined packages from the IDF, select the option Deleting
packages that are not defined in the IDF from the target directory.

6. Confirm with OK..

The IDF and the defined packages including all features (components) are copied into the new con-
tainer located in the target directory. The container includes both, the activated and the non-activated
features.

Exporting individual packages

1. To open the relevant container, click Container > Select....

2. On the right, select one of the packages of the container.

3. Click Container > Export package....

4. Select the target directory and confirm with Save.

The standard name of the package must not be changed. The package is saved to the selec-
ted directory.

5. Repeat these steps until all required packages have been exported.

3.3. Importing packages into a container

A container published on our technical portal includes all software packages which have been
released for the relevant eLux operating system version. In some cases, there is no need to down-
load a complete container as only few packages suffice.

The Import Packages feature allows you to import either a new software package or to overwrite an
already existing package in your container. All features and the software dependencies of a software
package are kept.

Important To import packages, use the ELIAS Import feature instead of copying files in
the Windows Explorer. This is to ensure that all sub-components and basic information
on dependencies are included.
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Important Do not unpack the .zip file. This is done by ELIAS.

1. To download individual software packages, sign in at myelux.com.

2. Under Download > eLux Software Packages, select the container for the required eLux ver-
sion and download the relevant package.

3. Save the package on your web server into the directory containing the relevant container. Do
not save the package directly into the container!

The software package is saved as a .zip file.

4. Start ELIAS and open the required container by clicking Container > Select...

5. Click Container > Import Package.

6. Select the .zip file from the file system and click Open. You can open more than one .zip
file in one step.

The software package is added to the container currently opened in ELIAS.

3.4. Deleting packages from a container

To remove out-of-date software from a container, delete the relevant software package.

Important Deleting packages cannot be undone. Before deleting, check if the relevant
package is part of any image definition file (.idf). To restore packages that have been
deleted accidentally, import the package once again.

1. In ELIAS, open the relevant container.

2. Select the software package you want to delete.

3. Press DEL.

4. Confirm the message with Yes.
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4. IDF

An image definition file is a structured package list defining all software packages for the operating
system and applications.

One of the basic ELIAS features is the built-in mechanism checking for conflicts and dependencies
regarding other packages. Required packages are automatically identified and requested. They can
easily be added with just one click. This prevents software incompatibilities in the image definition
file.

4.1. Creating a new IDF

In a image definition file, you define those software packages you want to have installed on the
devices' flash memory. This allows you to compose images to be installed according to individual
requirements.

In ELIAS, the first step is to load the contents of a software container. These are then shown as avail-
able packages on the right. From the available packages, create a list of the packages you want to
include in the IDF on the left.

Note
To avoid conflicts, we recommend that you always use the latest packages provided with an eLux
operating system version.

During the definition process, note that details on the software packages and the current IDF are
shown on the bottom. For further information, see "Interface" on page 6.

Creating a new IDF

1. Make sure that the relevant container is shown on the right. If this is not the case, click Con-
tainer > Select... and, in the file system, on the FTP or HTTP server, open the relevant con-
tainer directory (Example: UC_RP6) with the container.ini file.

The available container packages are listed on the right under Available packages.

2. Click Image > New.

On the left, the list of Defined packages is empty when you start.

3. On the right, click a container package. You might begin with the relevant BaseOS package.
Alternatively, you can begin with the required application, for example Citrix Workspace-App.

For the selected package, the details are shown below.

4. Click the left arrow button <== to add the selected package to your IDF.

The container package selected on the right is copied to the Defined packages list on the left.

5. If a package requests further packages or features for correct installation, confirm with OK.

The requested packages are also copied.
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Note
ELIAS continues requesting required software packages until the defined firmware is oper-
ational. You can only save an IDF that is operational. For example, the BaseOS, XWindows
and GNOME Desktop packages represent a minimal eLux firmware.
Depending on the device's hardware, additional drivers packages might be required such as
VIA or ATI graphics drivers.

6. To activate/deactivate individual features within a defined package, click the + icon of the pack-
age on the left, select the relevant feature and press the SPACEBAR. For further information,
see below.

7. Add all relevant packages to the Defined packages list.

All packages displayed on the left will be included in the IDF.

8. Click Image > Save, choose a descriptive name and save the new IDF to the container.

Activating/Deactivating features in defined packages

Each .epm package contains different components, the so-called features (.fpm). To expand the
package and show the features, click the + icon in front of the package symbol. The features have dif-
ferent symbols:

gray box Mandatory component that cannot be deactivated

white box Feature you can activate or deactivate

Press the SPACEBAR to activate or deactivate
or
select the feature and click Deactivate/Activate.

Deleting packages from an IDF

1. Select a package from the Defined packages list on the left.

2. Click ==>.

The package is removed from the Image Definition File.

Size restriction

While defining an IDF, there is no restriction regarding the maximum size. The total size of an image
may be greater than the capacity of the flash memory as long as you are trying and testing. The final
IDF, however, must not exceed the size of the flash memory. Check the total size before saving the
IDF.
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4.2. Updating existing IDFs

Updating the firmware of your devices can become necessary or reasonable when specific packages
are available in a newer version, for example. In ELIAS, you can easily replace individual packages
in your IDF.

Note
The installed BaseOS can be replaced quickly and safely by another BaseOS version. All pack-
ages required are also replaced by the respective versions, provided you confirm the replacement
in the upcoming dialogs.

Note
To avoid conflicts, we recommend that you always use the latest packages provided with an eLux
operating system version.

1. Make sure that the relevant container is shown on the right. If this is not the case, click Con-
tainer > Select... and, in the file system, on the FTP or HTTP server, open the relevant con-
tainer directory (Example: UC_RP6) with the container.ini file.

The available container packages are listed on the right under Available packages.

2. Open the relevant IDF. To do so, click Image > Open... and load the relevant .idf file.

On the left, the list of Defined packages is shown.

3. To add packages to your IDF, select them on the right and click the left arrow button <==

4. To activate/deactivate individual features within a defined package, click the + icon of the pack-
age on the left, select the relevant feature and press the SPACEBAR.

5. To delete a package from the IDF, in the Defined packages list on the left, select the package
and click ==>.

For further information, see "Creating a new IDF" on page 11.

6. Click Image > Save, or click the relevant icon to save the updated IDF to the container.

The devices will be updated to the modified IDF without further action if they are configured to check
for new versions on start or shutdown.

Note
If an IDF is unchanged, the devices will not update to it as Scout checks the file for modifications.

4.3. Saving an IDF 

1. Check the total size of the image shown in the upper section under Image.The total size of an
image must not exceed the capacity of the devices'flash memory.

2. Select Image > Save or Image > Save as...

3. Choose a descriptive file name without white spaces for your IDF.
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4. Make sure the target directory is pointing to the correct container directory. Normally, the con-
tainer is located in the root directory of the FTP or HTTP server.

5. Click Save.

The IDF is saved to the respective container.

4.4. Signing an IDF

ELIAS provides the possibility to sign image definition files (IDFs) by using private code-signing cer-
tificates. To do so, you need to import an appropriate certificate into the ELIAS certificate man-
agement.

1. Create and import a code signing certificate (.pem/.cer Base64-encoded) in the certificate
management of ELIAS. To do so, select Security > Manage certificates... > Import...

Note
The Organization attribute of the certificate must be filled to use a certificate in ELIAS.

2. To sign the IDF currently opened in ELIAS, ensure that it is saved, and then select Security >
Sign IDF…

Depending on the format of the certificate, the signing process might involve specifying the file
path of the private key file.

The generated signature file is saved to the directory (container) of the IDF. Once an IDF is
signed, the string signed is added to the IDF file name shown in the image title.

3. Transfer the code signing certificate and root certificate to the devices to /setup/cacerts.
To do so, use the Scout feature Files configured for transfer. For further information, see Files
configured for transfer in the Scout guide.

4. Make sure the signature verification for the devices is enabled. Signature verification is an
option of the device configuration in Device configuration > Firmware > Security. For further
information, see Firmware security through signature.

Note
Any changes to the signed IDF in ELIAS will delete the signature. After having changed and saved
a signed IDF, repeat the signing procedure.

The result of the signature verification is documented in the update log on the device. After the
update is performed, the update log file is sent to the Scout Server and can be viewed for the selec-
ted device in the Properties window by double-clicking the Update status field.
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4.5. Exporting an IDF

This feature helps you export the currently opened IDF and the herein defined software packages to
another local directory, to a network file server or to a USB storage device.

1. Click Image > Export....

2. Click Browse and select the required target directory.

3. If required, change the default file name recovery.idf.

4. Click Save.

5. To delete packages from the target directory that are not defined in the IDF, select the relevant
option.

6. Confirm with OK..

The IDF is exported as defined.

4.6. Printing an IDF

For documentation purposes, it might be useful to print a list of the software packages of a particular
IDF.

1. To choose layout and printer options, click Image > Print Options...

2. If required, click Image > Print Preview.

3. Click Image > Print....
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5. USB recovery stick

Note
This feature is provided for eLux RP 5 – UEFI devices included – and eLux RP 6. Alternatively, for
all eLux versions, we provide a predefined recovery image on our portal on myelux.com for down-
load. For further information, see Recovery via USB in the Recovery guide.

ELIAS helps you create a USB recovery stick that you can use to install individual eLux images on
your devices.

In addition, to make it distributable, you can use the generated USB recovery stick to create a disk
image in .zip format.

The installation of eLux with an individual USB recovery stick is carried out in the same way as a
USB recovery installation with a USB image from our portal. The installation process is started right
after the system prompts you for confirmation of the eLux RP recovery. For further information, see
Performing a USB recovery in the Recovery short guide..
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5.1. Creating an individual USB recovery stick

Requires

PC running Windows 10 or later versions with the ELIAS tool installed

Administrator rights for ELIAS

Write access to a local USB port

Connected USB stick with 2 GB memory space

Creating a USB recovery stick

1. In ELIAS, open the relevant IDF (.idf).

2. Click Image > Create USB stick ...

3. In the Recovery USB stick creation dialog, in the first list field, select the operating system of
the relevant devices for which you want to create the recovery flash drive:

eLux RP 6 X64 Recovery eLux RP 6 (64 Bit) with and without UEFI

eLux RP 5 Recovery eLux RP 5

eLux RP 5 UEFI Recovery eLux RP 5 with UEFI

Note that, depending on the selected system, the image must contain the relevant eLux pack-
ages for the 64 bit kernel and UEFI.

4. In the second list field, select the appropriate USB drive. If more than one USB storage device
is connected, select the relevant one.

5. To delete the contents on the selected USB stick or reset an existing recovery system, click the
Delete all stick data button.

6. Click Create recovery system.
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Creating a USB recovery stick involves two important steps:

Creating the recovery system on the USB storage device to turn the USB stick
bootable

Transferring the individual IDF containing the relevant eLux packages to the con-
tainer directory on the USB stick.

A progress bar at the bottom indicates the status of the copying process. As soon as the USB stick is
fully written, a message is displayed.

After having created your USB recovery stick, you can optionally create a disk image in terms of a
.zip file to make it distributable.

Creating a disk image of the USB recovery stick

1. Immediately after the creation of the USB recovery stick, click Yes.

2. Select a storage location and name for the .zip file.

ELIAS creates a .zip file containing an image of the USB recovery stick as a DD file. In addition, the
.zip file includes the application StickWizz.exe and a text file with a description .

The StickWizz tool helps you create a bootable USB stick out of the image. For further information,
see Preparing a recovery image for USB in the Recovery guide.

Note
Hint: Alternatively create an stw file from your image on a local or network drive. The StickWizz
tool then helps you create a bootable USB stick out of the stw file. For further information, see
"Writing an image to USB (with StickWizz)" on page 20 in the Recovery guide.
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5.2. Creating an individual StickWizz file as an installation base
You might want to create a disk image of your image as an installation base on a local or network
drive. StickWizz helps you create a bootable USB stick out of the .stw file.

Requires

PC running Windows 10 or later versions with the ELIAS tool installed

Administrator rights for ELIAS

1. In ELIAS, open the relevant image (.idf).

2. Click Image > Create StickWizz image...

3. In the Create recovery image for StickWizz dialog, in the first list-field, select the operating
system of the relevant devices for which you want to create the recovery flash drive:

eLux RP 6 X64 Recovery eLux RP 6 (64 Bit) with and without UEFI

eLux RP 5 Recovery eLux RP 5

eLux RP 5 UEFI Recovery eLux RP 5 with UEFI

Note that, depending on the selected system, the image must contain the relevant eLux pack-
ages for the 64 bit kernel and UEFI.

4. In the second list-field, choose a name for your .stw file. To change the storage location, click
Browse.

By default, the .stw file is saved to the container selected in ELIAS.

5. Click Create recovery image.

ELIAS creates a recovery image as a disk image in a DD-like format.

By using StickWizz, you can create a bootable USB stick out of the .stw file. For further information,
see Preparing a recovery image for USB in the Recovery guide.
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5.3. Writing an image to USB (with StickWizz)

Requires

Image file as a .stw or .dd file on a PC running Windows 10 or later versions

StickWizz application on your PC (see Preparing a recovery image for USB)

USB stick on local port with 4 GB memory space, write access

1. Plug the USB stick into the PC.
Note that the Windows Explorer must not be open on the USB drive.

2. Run the StickWizz.exe program.

The language depends on the Windows display language selected.
The checksum is calculated and compared to the one provided.

3. Check whether the appropriate source under Image file (1) and the appropriate destination
under Device (3) are selected.

4. Click Write (7).

The image is written to the USB stick. A message confirms the successful completion.

1 After StickWizz is started, it shows
a .stw or .dd file located in the
same directory.

2 Browse to select your image file
from another directory, if required.

3 Device /drive, on which a USB stick
is connected

Choose a different drive if required.

4 Delete all data from the selected
device (before writing the image)

5 During the write process, each writ-
ten data packet will be compared to
the source.

6 As soon as StickWizz opens with
the specified file, the checksum is
calculated and displayed.

7 Start writing
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6. Security menu

Option Description

Checking for signature auto-
matically during import

Signatures are automatically verified during import of the pack-
ages.

Check all packages in the con-
tainer

Verifies the signatures of all packages in the container

Checking selected package Verifies the signatures of a selected package and its com-
ponents in the container or image window

Signature and certificate inform-
ation...

Displays the security status of a package selected in a container
or image list and of its components

Signing IDF... Allows to sign image definition files (IDF) by using private cer-
tificate-based signatures (pem/p12)

Requires the configuration of an appropriate certificate in the
ELIAS certificate management

Manage certificates... Enables the management of certificates in the "trusted list" of
ELIAS

Settings... An Online Certificate Status Protocol (OCSP) server is used to
verify the status of a certificate (valid, revoked, unknown).

Proxy server (optional): If you use a proxy server to connect to
the Internet, enter the proxy server IP address (or name) and the
port.
OCSP server: In general, the OCSP server is automatically read
from the certificate. If this information is not available, you can
enter a default OCSP server in URL format and the port manu-
ally. Format: http://<OCSP server URL>
Default: http://ocsp.openvalidation.org and port 80
OCSP check when packaging: Before signature check, the
validity of the certificate is automatically verified.
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