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1. Representation

The following representations and conventions for instructions are used throughout the documentation:

Representation Description

Control element All graphical user interface controls are displayed in bold

Menu > menu
command

Whenever running a command involves clicking a series of menus, the single
GUI controls such asmenu commands or dialog tabs are linked by >.

Value All data that have to be entered by the user or data that represent a field value
are displayed in Courier New. Also, file names and path names are displayed
in Courier New.

STRG Keys to be pressed are displayed in CAPITAL LETTERS.

<Placeholder> Placeholders in instructions and user input are displayed in italics and in <angle
brackets>.

1. Instruction Procedures to be carried out step by step are realized as numbered steps.

Result System responses and results are displayed in italics.

Abbreviations and acronyms

Abbreviation Description

AD Active Directory , directory service of Microsoft WindowsServer

EBKGUI Interface of the eLux Builder Kit (component of Scout Enterprise)

EPM eLux packagemodule (.epm, software package)

FPM Feature packagemodule (.fpm, part of a software package)

FQDN Fully qualified domain name

GB Gigabyte

GHz Gigahertz (processing speed)

HDD Hard disk drive (flashmemory)

IDF Image Definition File (.idf)

IIS Internet Information Services: Microsoft Web server

MB Megabyte

OU Organizational unit
Unit or group within the organizational structure

VPN Virtual Private Network
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2. Overview

2.1. Features of the Scout Enterprise Management Suite

Scout EnterpriseManagement Suite is themanagement solution for Thin Clients or PCs running the
operating system eLux. In addition, Windows-based devices can bemanaged by using basic Scout man-
agement features.

Scout EnterpriseManagement Suite consists of several components. Most of the components listed
below are included in the standard installation but can be optionally excluded when choosing custom
installation.

Component Description Installation

Scout
Server

The service controls andmanages eLux devices aswell as
Windows devices on which Scout Agent for Windows has
been installed.

Scout

Enterprise.exe

Scout Con-
sole

User interface for themanagement of eLux devices and for
themanagement of Windows-based devices on which
Scout Agent for Windows has been installed

Server communication only via database

Multiple consoles can bemanaged with one Scout data-
base.

Scout
Enterprise.exe

Recovery
service

Customized TFTP service to realize a PXE recovery envir-
onment for eLux endpoints

Scout
Enterprise.exe

ELIAS Legacy dialog program eLux Image Administration Service
(ELIAS) for creating individual image definition files (.idf)
for modular firmware updates of the eLux devices. The leg-
acy ELIAS will be replaced by ELIAS 18.

Scout
Enterprise.exe1

ELIAS 18 New web-based platform-independent ELIAS application
for creating individual image definition files (.idf)

separate
(
EliasInstaller.exe

)

Scout
Report
Generator

Tool for creating freely definable reports across all currently
existing devices, applications andOUs in the Scout Console

Scout
Enterprise.exe

Scout Stat-
istics Ser-
vice

Service for the evaluation of device status information and
dynamic asset details

Scout
Enterprise.exe

1for Scout EnterpriseManagement Suite Version 15.7 and later versions, the legacy ELIAS is no longer
included in the standard installation. To install the feature, select User-defined.
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Component Description Installation

Scout
Dashboard

Web-based console for themanagement of eLux devices
and for themanagement of Windows-based devices on
which Scout Agent for Windows has been installed

Scout
Enterprise.exe

WebAPI1 Application programming interface for themanagement of
eLux devices and for themanagement of Windows-based
devices on which Scout Agent for Windows has been
installed

Scout
Enterprise.exe

Scout
Command
Interface

Command line interface for Scout commands Scout
Enterprise.exe

Scout Data-
base Con-
nection
Editor

Tool for modifying database connection settings of the
Scout Server and Scout Console

Scout
Enterprise.exe

Scout
CloudGate-
way

Cloud gatewaywith VPN backend for convenient con-
nection of devices from the Internet to a Scout infrastructure

separate

Scout
Agent for
Windows

Service providing an interface for Windows-based devices
to bemanaged through Scout EnterpriseManagement
Suite

separate

The features are described in the following guides:

Scout EnterpriseManagement Suite:
Configuration, control andmanagement of the client devices using the Scout Console
Scout Statistics Service

ELIAS

ELIAS 18

Scout Report Generator

Scout Command Interface

Scout Dashboard

Scout CloudGateway

Recovery procedures for eLux devices are described in the eLux Recovery procedures short guide.

Note
To compose and use your own image files, in addition to the Scout EnterpriseManagement
Suite installation, you need an eLux container for the software packages.
For further information, see Installing a container.

1for Scout EnterpriseManagement Suite 15.0 and later versions
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2.2. Communication between Thin Client and Scout Server

Note
The certificate-basedmanagement protocol ensures secure communication between Scout
Server and clients.1For further information, see Certificate-basedmanagement protocol in
the Installation guide.

During system start the client devices connect to their Scout Server and verify if their configuration data
is up-to-date. Updated data can concern device configuration, application definitions, files defined for
transfer and advanced file entries. For further information about identifying and transferring updated
configuration data, see Configurationmethod.

The communication between client and server can proceed in three ways: 

Client accesses the Scout Server. The Scout Server has no updated configuration data. Client
continues booting with its configuration.

Client accesses the Scout Server. The Scout Server reports new configuration data and trans-
fers the data to the Thin Client. If required, the client restarts using the new configuration.

Client cannot access the Scout Server due to network or other problemswhich result in aman-
agement timeout (see Advanced network settings). The Thin Client continues booting with its con-
figuration.
Depending on the handshake settings the client retries connecting to be able to synchronize the
configuration data. For further information, seeOptimizing with handshake.

Updated configuration data can relate to device configuration (setup), application definition, files con-
figured for transfer and advanced file entries.

During operation of a client device there is no data exchange between the Scout Server and Thin Client.
During shutdown, the client reports its current status to the Scout Server (except for VPN connections).

2.3. Installation

All contents relating to installation and setup are covered by the Installation guide. For further inform-
ation, see Installing Scout EnterpriseManagement Suite.

1for Scout EnterpriseManagement Suite 15.1 / eLuxRP 6.1 and later versions
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2.4. Keyboard shortcuts

Keys
Selected ele-
ment

Description

CTRL+SHIFT+INSERT Individual OU Opens the Advanced device configuration1 of the selec-
ted OU

Applications Opens the Application Properties dialog to define a new
application

Devices Opens the Information dialog to enter aMAC address

CTRL+SHIFT+DELETE Individual
OU

Deletes the selected organization unit

Individual
application

Deletes the selected application

Individual
device

Deletes the selected device

F2 Individual
OU

Rename the selected organization unit

Individual
device

Rename the selected device

Individual
application

Rename the selected application

F5 _ Updates the configuration of all devices

CTRL+F _ Activates the Quick search field for simple search

CTRL+SHIFT+F _ Opens the Search window for advanced search

CTRL+X Individual
device

Cuts the selected device

CTRL+V Devices or
individual
device

Pastes the device from the Clipboard to the selected pos-
ition

CTRL+A Individual
application or
device in the
List window.

Selects all applications/devices in the List window

CTRL+E Individual
device

Performs a setup comparison

CTRL+P _ Opens the Print dialog to print the list of available devices

1formerly Advanced settings
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3. Interface of the Scout Console

3.1. Organizational structure

Themain window of the Scout Console shows a tree view in the upper left corner that reproduces the
organizational structure with all managed devices.When you log in for the first time, you will see the
organizational units Lost&Found and Enterprise1which are created by default. The latter serves as the
top node of your organizational structure.

At the top level, three applications are provided that you can use to connect to a back-end:2RDP,
StoreFront and VMware Horizon. For further information, see Defining applications.

To each organizational unit – hereafter referred to asOU – you can add applications, devices and other
OUs. EachOU can contain subordinate OUs, applications and devices.

By default, inheritance is active. Application definitions and device configuration data are inherited by
subordinate OUs and devices.

If you add a new device to anOU, it will receive all application definitions and device configuration data
from thisOU.

Individual devices and applications can bemoved from oneOU to another by using a drag-and-drop
operation or the Clipboard. The devices then are assigned the properties of the new OU (if inheritance
is active).

For further information, see Device configuration/Concept.

For the element selected in the tree view, you can view various details in the Properties window.

1for Scout EnterpriseManagement Suite 15.0 and later versions
2for Scout EnterpriseManagement Suite 15.0 and later versions
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Adding a new OU

1. For the relevant OU, on the context menu, click Add > Organization unit...

The Advanced device configuration1 dialog opens.

2. Enter a unique name for the new OU.

3. If required, enter further information into the Info fields and edit fields on the other tabs.

4. Confirmwith Apply andOK.

The new OU is shown in the tree structure. It contains the folders Applications and Devices.

3.2. Icons in the tree view

Icon Description

Organization unit (OU)

Applications

Device, not connected to Scout Enterprise yet (Example: Device import)

Device, running and ready for operation

Device, switched off or not available

Device, desktop is initializing or the log-on screen is shown

Device, firmware update is running

Device, missingmanagement license

3.3. Windows

Click View > Windows to show further windows next to the organizational structure:

Window Description

Properties Properties of the selected application, OU or device

For further information, see Properties.

1formerly Advanced settings
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Window Description

Assets (only for
devices)

Hardware information of the selected device

Is shown as a tab of the Properties window

For further information, see Hardware information.

Dynamic Client
Groups

Shows the defined Dynamic Client Groups (list view)

Independent con-
figurations1

ShowsOUs and devices that do not use the parent device configuration (list
view)

For further information, see Blocking inheritance – independent configuration

Compare con-
figurations2

Shows differences in the device configuration between devices or OUs

OU devices/ap-
plications

Devices or applications of anOU view without icons (list view)

Double-clicking on a device shows the corresponding device in the tree view.
This feature can be disabled, see below.

All devices Shows all deviceswithout icons (list view)

The device data are only loaded from the Scout Enterprise database when you
click the Refresh button. This ismeant to prevent unintentional loading of
huge amounts of data.

The context menu offers the same functions as in the tree structure. Several
functions such as commands can be applied tomultiple devices. To do so,
select the devices by pressing CTRL or SHIFT

Double-clicking on a device shows the corresponding device in the tree view.
This feature can be disabled, see below.

To search window content, use the Search field of the toolbar, type (the begin-
ning of) a name and press SHIFT+RETURN. Press SHIFT+F3 to find the next
match. For further information, see Searching for applications, devices or OUs.

Sorting columns

Click a column header to sort rows.

Showing/Hiding properties

Click the button to define which properties you want to show.
Alternatively, use the context menu.

1formerly setups
2formerly setups
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Disabling the 'Double-click shows device' feature

By default, double-clicking a device within a device list causes the tree view to show the corresponding
device. This behavior can be disabled.

Define the following registry entries with value type DWORD:32 and value 1:

HKEY_CURRENT_USER\Software\UniCon\Scout\Settings
DisableDoubleClick_OUDevices_View
DisableDoubleClick_AllDevices_View
DisableDoubleClick_DCG_View

3.3.1. Properties

The properties of the selected application, OU or device are displayed.

Many properties come from the device configuration (devices andOUs) and application definition
(applications) and are updated with each configuration update. For further information, see Con-
figurationmethod.

Some device properties come from the Scout Server and are updated dynamically.

Date and time fields are shown according to the international standard ISO8601.

Note

By default, not all fields are displayed. To show or hide fields, click the icon.

Device properties

Examples:

Option Description

Name Host name of the device

Configuration Origin of the device configuration, mostly inherited from parent instance

Manager IP address of the Scout Server the device is assigned to

Info1-3 The Info fields are shown on the device in the Configuration panel under Inform-
ation and can be enabled for users for editing (user rights). They are already
provided in the First ConfigurationWizard.

OS version Version of client operating system

Container eLux container configured for the device in the firmware device configuration

Update time Time stamp of the last firmware update

For further information, see Command results and update information

14



Option Description

Last contact Time stamp of the last contact between server and device

The field is not only updated on a device restart but also on each successful con-
nection set-up from the server to the device.

Status Example: Switched on

The status of a device is triggered by the 'keep alive' mechanism and by active
statusmessages of the device on start, shutdown, logoff, performing updates
andmore.

Status time Time stamp of the last status refresh

PrimaryMAC
address

Device address of the hardware (MAC=Media AccessControl)

Simple device
identifier

Temporary device identifier usersmay request for support cases

Client identifier1 Globally unique identifier for the device or eLux Portable USB stick

Partitions The system, setup and update partitions are displayed with their respective sizes.

OU properties

Examples:

Option Description

OU Shows the ID of an OU

In addition to the decimal value, you can show the hexadecimal value. This
requires a new registry entry:

Key: HKEY_CURRENT_USER\Software\UniCon\Scout\Settings
Value name: DisplayHexOUID
Value type: DWORD:32
Value data: 1

Device count Number of devices in the OU and the subordinate OUs

Quick links in the Properties window of devices and OUs

Make use of the links shown in blue to quickly browse the relevant configuration and information in
each context. Double-click the links:

Selected
element

Option Description

Device Configuration Opens the relevant Device configuration

1for Scout EnterpriseManagement Suite 15.10 and later versions
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Selected
element

Option Description

Device Image Opens ELIAS with the image configured for this device in the relevant
container

The connection to ELIAS ismade with the data configured in the
ELIAS settings of the Scout Console. For further information, see
"Access to applied images" on page 281

Device Update State Double-click or ... opens the Update-Info for the device providing
information on performed updates. For further information, see
Command results and update information

OU Configuration Opens the relevant Device configuration

OU Update Opens the relevant Update settings in the Advanced device con-
figuration or Advanced options.

OU Screen, Printer,
Mouse/Keyboard

Opens the relevant configuration (Device configuration or Advanced
device configuration) for Screen, Printer or Mouse/Keyboard.

3.3.2. Hardware information

For the selected device, in the Properties window, on the Assets tab, device-specific hardware inform-
ation is shown:

Hardware information of the device

Hardware information of connected devices such asUSB devices andmonitors

Note

By default, not all fields are displayed. To show or hide fields, click the icon.

Hardware information of the device

Examples:

Option Description

Device type Product details provided by the hardwaremanufacturer (character string)

Mainmemory Mainmemory size

Flashmemory Flashmemory type

Flash size Size of the flashmemory

Hardware information of connected devices

Examples for a USB device:
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Option Description

Product Type of USB device

Vendor Vendor name

Serial number Serial number of the USB device

Revision number1 Firmware version of the USB device

3.4. Status bar

On the right of the status bar, the total number of devices and applications are displayed.When you per-
form large operations such as importing, moving, exporting or deleting a large number of devices, they
are also displayed on the status bar.2

Double-click the lamp icon to view alert messages (Error, Warning, Info) such as Scout Server ter-
minated or Could not write Scout server log file. The color of the lamp icon changes to yellow as soon
as there is a new entry.

3.5. View settings

Some preferences regarding the view can be set via themenu View > Settings:

Option Description

Refresh display of devices

In the tree view Time span in seconds for periodically refreshing the display of devices, OUs and
applications in the tree view

In the list view Time span in seconds for periodically refreshing the display of devices, OUs and
applications in the list view

Show new
devices auto-
matically in tree
view3

New devices after onboarding are automatically added to the tree view (disabled
by default).

Status bar/
Refresh totals

Time span in seconds for periodically refreshing the number of all devices and
applications across the infrastructure

On console start /
Show recently
used element

After the console is restarted, the last selected item in the tree view is highlighted.

1fromScout Enterprise 15.8
2fromScout 15 2110
3fromScout Enterprise 15.8
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Option Description

Show con-
firmationmes-
sages / Before
view is refreshed

After you press F5 or click View > Refresh, the system prompts you before
refreshing the view.

Check inde-
pendent con-
figurations

When youmodify a device configuration, all subordinate independent con-
figurations are checked. You then receive a list of the relevant parameters and
can conveniently determine whether and to which instances themodifications
are to be transferred.

For further information, see Blocking inheritance - independent device con-
figuration.

Verbose level For level 1, a confirmationmessage is shown before commands are executed,
indicating the number of affected devices.

3.6. Changing language

The console is started with the dispaly language you have chosen for the Scout EnterpriseMan-
agement Suite installation. You can change the display language at any time: gewählt haben. The lan-
guage setting refers to the display of interface elements and can be changed at any time:

1. Click View > Select language and choose your language.

2. Restart the Scout Console.

The console is started with the selected language.

Important Individual window layouts will not be restored after the language change.

3.7. Searching for devices, OUs or applications

Quick search

1. Click into the tree view to set the focus.

2. PressCTRL+F or click into the Search field of the toolbar.

3. Type the name of an application, device or OU.

If configured accordingly, you can type partial words.

4. PressRETURN or click themagnifier icon.

The first matching object is shown in the tree view.

5. To find the next match, press F3 or click themagnifier icon.

18



Note
The search is performed using the search parameters set in the Find dialog.

Quick search in the All devices window

1. Click into the All devices window to set the focus.

2. PressCTRL+F or click into the Search field of the toolbar.

3. Type the name of a device.

If configured accordingly, you can type partial words.

4. PressRETURN or click themagnifier icon.

The first matching object is shown in the All devices window.

5. To find the next match, press F3 or click themagnifier icon.

Note
You can also search the All devices window when it does not have focus: Press
SHIFT+RETURN to start searching for the specified object. Press SHIFT+F3 to find the next
match.

Searching the tree view and setting search parameters

1. PressCTRL+SHIFT+F or click Edit > Find...

The Find window opens.

2. Type the name of an application, device or OU.

If configured accordingly, you can type partial words.

3. If required, modify the search parameters.

Option Description

Match case Search is case-sensitive

Match whole word Only exact matches are found, no partial words.

Find in properties Search is also applied to Properties and Assets fields.
This allows you to search for a vendor or aMAC address.
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Note
The search parameters remain active after the search and are also applied to the Quick
search

The first matching object is shown in the tree view.

4. To find the next match, click Find next or press F3.

Advanced search view

The Advanced search window1 provides further options that allow you to search for devices including
multiple filter criteria and wildcard search. You can perform commands and notifications on search res-
ults.

1. Show the Advanced search window. To do so, click View > Window > Advanced search.

Some fields are shown as columns including a search field.

2. To show or hide fields as columns, click the button.

The Adjust dialog with all available fields opens. Configure which fields to show.

Fields that cannot be used for a search contain the entry N/A.

3. To change the order of the columns, also use the Adjust dialog.

The column order is relevant if you want to definemultiple filter criteria.

4. In the desired column, in the search field, enter a search term. To replace characters, you can use
the wildcard character % at the beginning or end of the search term.

5. To start the search, click the filter icon.

6. To narrow the search, use additional filter criteria in allowed columns.

Use the context menu to perform commands and notifications on the search results.

1for Scout EnterpriseManagement Suite 15.2 and later versions
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3.8. Moving and copying elements

Devices, OUs and applications can bemoved from oneOU to another OU within the tree view of the
organizational structure. If inheritance is active, after you havemoved a device or OU, it receives the
properties of the new parent OU.

Moving devices, OUs or applications

1. In the tree view, show the source and target position of the relevant element.

The target position can be the icon of the target OU or any valid position subordinate to the tar-
get OU.

2. Use a drag-and-drop operation tomove the element from the source to the target position.
or
Move the element via context menu or CTRL-X to the Clipboard and paste it via context menu or
CTRL-V at the target position.

3. Confirmwith Yes.

Confirm your changes again and the element ismoved to the target OU.

Moving devices to another OU via context menu

1. In the tree view, in the OU devices window or in the All devices window, for the relevant device,
open the context menu.

2. Click Edit > Move...

3. In the dialog, expand the organizational structure and select the target OU.

4. Confirmwith OK.

Confirm your changes again and the element ismoved to the target OU.

Copying applications

Note
Applications in the tree view are application definitions and do not include software. The soft-
waremust be configured and provided separately via IDF.

1. Show the source and target position of the relevant application in the tree view.

The target position can be the icon of the target OU or the Applcations node subordinate to
the target OU.

2. Use a drag-and-drop operation while pressing CTRL tomove the application from the source to
the target position.
or
Copy the application via context menu or CTRL-C to the Clipboard and paste it via context menu

21



or CTRL-V at the target position.

3. Confirmwith Yes.

The application is copied to the target OU.

Note
Applications can also be copied from any client device to a Scout Enterprise OU. For further
information, see Uploading applications from client to Scout Enterprise.

3.9. Switching OU to top-level

Note
This feature can only be applied to anOU.

For the relevant OU, on the context menu, click Edit > Convert to base-OU.

The relevant OU ismoved to the highest level. It becomes one of the base-OUs. Device configuration
and inheritance remain as defined. If inheritance is active, all settings are adopted from the base device
configuration.
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4. Device management

To be able tomanage client deviceswith eLux or other operating systems, Scout Enterprisemust know
their MAC addresses. There are several approaches to register new devices such as

Self-registration of devices

Discovery: Searching for devices

New devicesmust be assigned to an organizational unit (OU). You can configure whether new devices

are added to a specified OU (default OU)

are assigned automatically by the OU filter according to definable criteria

are created in terms of proxy profiles even before connecting (Reserving device profiles)

The way you want to deal with new devices ismainly defined under Options > Advanced Options >
Devices.

Note
As the devices are organized hierarchically in OUs, you can use Dynamic Client Groups to
apply commands to several devices irrespective of their OUs.

4.1. Self-registration of devices

By default, the first time a Thin Client boots, it automatically searches for an available Scout Server. The
client requires the IP address of the Scout Server.

Requirements for self-registration:

Thin Client must be in initial state (either upon delivery or by performing a factory reset)

Thin Client must be connected to the network

The Scout Enterprise IP addressmust be configured in one of the following ways:

DHCP: A configured DHCP option is set to the IP address/name of the Scout Server. You
can also specifymore than one Scout Server and a destination OU. For further inform-
ation, see DHCP configuration.

or

DNS: The DNS server resolves the host name ScoutSrv (no case-sensitivity).

If the Scout Server's IP address cannot be determined, neither by the DNS nor byDHCP, a First Con-
figurationWizard automatically runs on the Thin Client to help the local user through the initial con-
figuration.
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Registering a device automatically

Turn on the Thin Client.

If the requirements for self-registration aremet, the device contacts the Scout Server and enters itself in
the definedOU or the standard OU. It receives the configuration of the OU and is restarted with the new
configuration.

The flow chart roughly shows the way a new device is assigned to a Scout Server and to anOU. Details
such as the Accept only known devices have not been considered.
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4.2. DHCP configuration

– optional –

Note
DHCP options can only be applied to eLux clients.

A new client booting for the first time can retrieve the following information from aDHCP server:

IP address or name of the Scout Server (option 222)

List of Scout Servers (option 224)

ID of the destination OU on the Scout Server (option 223)

This requires configuring the DHCP server via one of the two followingmethods.

In method 1 (recommended), you define a new vendor class, set the new options, and then apply the val-
ues. Method 2 uses the DHCP Standard Options 222, 223 and 224.

The following instructions are based on the DHCPmanager of WindowsServer 2012.

Method 1: Defining user-defined vendor class

Requires
DHCP server compliant with RFC 2132, supporting user-defined vendor classes. Otherwise
usemethod 2.

1. Open the DHCPmanager.

2. Select the relevant DHCP server, and then click Action > Define...

3. Click Add... to create a new class:

Option Value

Display name eLuxNG

Description eLux specific options

Code
(in ASCII
column)

ELUXNG

The entry is automatically extended with the related hexadecimal number (45
4C 55 58 4E 47).

4. Click Action > Set Predefined Options.... Then, in the Option class list field, select eLux NG.

5. To define one Scout Server, click Add... and edit the new option as follows:

Option Value

Name Scout Server

Data type String
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Option Value

Code 222

Description Name or IP address of the Scout Server

6. To definemore than one Scout Server, click Add... and edit the new option as follows:

Option Value

Name Scout Server list

Data type String

Code 224

Description Server names/IP addresses, comma-separated

7. To define a specific OU that you can assign new devices to, click Add... and edit the new option as
follows:

Option Value

Name Scout Enterprise OU ID

Data type Long

Code 223

Description ID of the destination OU

8. To assign the options, for the relevant DHCP server, select either the Server Options, the Scope
options or the Reservations. Then click Action > Configure Options... > Advanced.

In the Vendor class list field, select elux NG. Select each option defined and enter its value into
the Data entry field:

Option Value

222 Scout Server <Name or IP address of the Scout Server>

223 Scout Enterprise OU
ID

<ID of the destination OU>

224 Scout Server list <Names or IP addresses of the Scout Servers, separated by
comma>
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Method 2: Using DHCP Standard Options

Requires
The DHCP Standard Options 222, 223 and 224must be available. Otherwise useMethod 1.

1. Open the DHCPmanager.

2. Select the relevant DHCP server, and then click Action > Set Predefined Options.... In the
Option class list field, select DHCP Standard Options.

3. Click Add... to create the following Standard Options, as described for Method 1:

Scout Server, String, 222

Scout Ernteprise server list, String, 224

Scout Enterprise OU ID, Long, 223

4. To assign the options, for the relevant DHCP server, select either the Server Options, the Scope
options or the Reservations. Then click Action > Configure Options... > General.

Select each option defined and enter its value into the Data entry field:

Option Value

222 Scout Server <Name or IP address of the Scout Server>

223 Scout Enterprise OU
ID

<ID of the destination OU>

224 Scout Server list <Names or IP addresses of the Scout Servers, separated by
comma>
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Disabling DHCP option 12 as source for host names

If you have configured DHCP option 12 (host name), when connecting new devices, you can have the
host names set via DHCP. To obtain the host name not via DHCP but from another source, such as the
name template defined in the Scout Console, prevent the take-over fromDHCP option 12. To do so,
use a terminal.ini parameter:

File /setup/terminal.ini

Section Network

Entry IgnoreDHCPHostname

Value true By default, the value is false.
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4.3. Searching for devices (Discovery)

Based on the IP address, you can search for devices throughout the entire network or within specific
subnets. Anymatching devices are automatically registered to Scout Enterprise and are added to the
specified OU (Destination group). The devices are restarted and receive the configuration of the des-
tination group (device configuration, application definitions, files defined for transfer and advanced file
entries).

Note
If the OU filter is active, the filter specifies the destination group or groups. For further inform-
ation, see Advanced device configuration/Devices.

Requirements:

The devices are turned on and connected to the network.

The devices are provided with valid IP addresses.

The device password is known.

Searching and registering devices

1. Make sure that the destination group is configured correctly.

2. Select Options > Search devices.

3. Edit the following fields:
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Start address First IP address of the range

Count Number of IP addresseswithin the range (restricted to 255)

End address Last IP address of the range

Password Device password (default: elux)

The passwordmust match the password currently set on the individual clients.

Destination
group

OU you want to assign the devices to

Default is the predefined Lost&Found group with the base device con-
figuration.

Important If the Destination group field is disabled, the OU filter is active and thematching
devices are assigned according to the OU filter rules.

Inform user The user is informed by amessage about the upcoming client restart. Specify in
seconds how long themessage shall be displayed.

User can can-
cel the com-
mand

Allows the user to suppress the client restart. The configuration is not updated
until the client is restarted.

4. Confirmwith OK.

Thematching devices receive the IP address of themanaging Scout Server. The devices are assigned
to their destination group and are restarted. The devices inherit the configuration of their new OU. Local
non-protected device configuration is overridden.With immediate effect, on each restart, the clients con-
nect to their Scout Server and, if available, are given the latest configuration and application definition
data.

If a device profile has been reserved for a client, the predefined profile is automatically assigned at Dis-
covery.

Tomodify response time andmaximum search time for the Discovery feature, chooseOptions >
Advanced options > Devices > Discover devices.

Note
Devices already registered to Scout Enterprise are not modified, but their status is updated
when connected.
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4.4. Reserving device profiles

Devices can be assigned to OUs even before the devices connect to the Scout Server for the first time.

By creating devicesmanually in the Scout Console, you reserve aMAC address device profile. As soon
as such amanually created device contacts its Scout Server for initial start-up, the registeredMAC
address is recognized and the device is entered. The configuration data of the relevant OU are trans-
ferred to the device.

Reserving device profiles can be applied for the following device registration procedures:

Discovery

DNS alias name ScoutSrv

DHCP option 222 for the Scout Server

Note
If an OU filter is active, the OU filter is applied prior to the device profile reservation.

Reserving a device profile

1. Select the OU you want to assign the device to, and show its sub tree.

2. Open the Devices context menu under the OU and select Add...

3. Enter the 12-digit MAC address of the device without hyphens.

If theMAC address is valid, the Device configuration dialog opens. The Use parent option is selec-
ted by default.

4. Confirmwith OK.

Scout Enterprise reserves a profile for the device with the respectiveMAC address. The actual regis-
tration ismade at the time of the first client connection.

Note
Importing devices also results in the reservation of device profiles within the OU structure.
To create new devices in a greater number, we recommend using the Import feature. For fur-
ther information, see Import/Export.

4.5. Device names

The devices' host names can either be taken from the deviceswithout modification or be set from the
Scout Console. In addition, name templates are available that use, for example, theMAC address or
the IP address of the devices. The settings for this can be found under Advanced options > Devices.
For further information, see "Devices" on page 157.

Device names are subject to the following format rules:
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The first character must be a letter (a-z, A-Z) or a digit (0-9).

The last character must not be a hyphen -.
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4.6. Secure device management with Scout Enterprise

An enhanced security level is available for adding new clients to Scout Enterprise.

Clients that are registered with their MAC addresses in the Scout Enterprise database (reserved device
profile) are accepted by the Scout Server and can be integrated into the Scout Enterprisemanagement.
In contrast, clients having an unknownMAC address are not accepted and therefore cannot beman-
aged by Scout Enterprise. Unknown clients are not provided with a license fromScout Enterprise's
license pool.

Accepting known clients only

1. In the Scout Console, select Options > Advanced options > Devices > New.

2. Select the Accept only known devices option.

If an unknown device tries to contact the Scout Server, an error message is displayed on the client say-
ing that a connection to the Scout Server was denied.

Note
Only the requests of those clients are accepted whoseMAC addresses have been saved to
the Scout Enterprise database by a device import or device profile.
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4.7. OU filter

TheOU filter can be used for automatic assignment of devices to an organization unit (OU). The assign-
ment is based on predefined criteria. This is particularly helpful when registering new devices or relo-
cating existing ones.

There are two options for configuring the OU filter:

The Subnet filter uses the client network address for filtering

The User-defined filter uses configured asset information of the devices for filtering

You can only use one filter at a time. For each filter, you can definemultiple filter rules and specify the
sequence you want the rules to be applied in.

Once defined, the filter rules are retained unless deletedmanually. Deactivate the filter rules that are cur-
rently not required but that you want to keep for future use.

TheOU filter has precedence over

OU assignment of devices via the DHCP option 223

Discovery of new devices via Scout Enterprise

selecting the OU in the First ConfigurationWizard locally on the Thin Client

the default OU specified in Advanced options > Devices.

For individual devices, you can ignore the OU filter (Advanced device configuration1 > Management).

Note
OU filters are included when you export the data category Advanced options. For further
information, see Import/Export.

4.7.1. Setting up an OU filter as subnet filter

You can use theOU filter to filter on client network addresses and assign thematching devices to an
OU.

1. ClickOptions > Advanced options... > Devices.

2. Under New devices, select the Assign OU depending on the OU filter option.

3. To open theOU assignment dialog, if required, click the ... button.

1formerly Advanced settings
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4. In the top section, from the Filter type list, select Subnet filter (client network
address).

5. In the Network address box, enter the scope of IP addresses.
Example: 192.168.16.0 covers all IPs starting with 192.168.16.

6. In the Netmask box, enter the relevant network prefix.

7. Click the button to browse theOU list.Select the OU you want to assign the devices to.

8. Click Add.

The filter rule is displayed in the field below.

9. If required, addmore filter rules and configure them. For further information, see Editing OU filter
rules.

10. In the bottom section, from the list Non-matching devices will be, select where you want to keep
the non-matching devices.

Important If you select assigned to the default OU, all non-matching devices and
even devices already assigned to other OUs are reassigned to the default OU.

11. Review all active filter rules thoroughly to avoid unintentional assignments.

12. Confirmwith OK.

All active filter rules are processed. On the next restart, thematching devices are assigned to the OUs
as defined by theOU subnet filter.Any user-defined filter rules will not be taken into account.
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4.7.2. Setting up an OU filter as user-defined filter

You can filter configured asset information of the devices to assign thematching devices to the appro-
priate OUs.

eLuxRP devices send anOU filter text field containing their device information to the Scout Server.
You can use theOU filter text field in the Scout Enterprise Report Generator and for the user-defined
OU filter. It includes the following information:

Host name, OS name, OS version, serial number, supplier, device type, BIOS, CPU speed, model, ker-
nel version, flash type, flash size, RAM size, graphics, IDF name,1MAC address.2

1. ClickOptions > Advanced options > Devices.

2. Under New devices, select the option Assign OU depending on the OU filter.

3. To open theOU assignment dialog, if required, click the ... button.

4. In the top section, from the Filter type list, select User-defined filter (configured
asset information).

5. In the Filter rule box, enter one or more filter criteria. A filter criterion consists of three parts:

asset information string fromOU filter text logical operator = value you want to filter by

Examples:

ELUX_HOSTNAME=Melissa;
ELUX_OSNAME=eLux RP;
ELUX_OSVERSION=6.1.0-3;
ELUX_SERIAL=7250O422542;
ELUX_SUPPLIER=WYSE;
ELUX_DEVICETYPE=ZQ Class;
ELUX_BIOS=1.0J;
ELUX_CPU=1500;
ELUX_PRODUCT=ZQ Class;
ELUX_KERNEL=4.9.30;
ELUX_FLASH=16GB SATA Flash;
ELUX_FLASHSIZE=15272;
ELUX_MEMORY=4096;
ELUX_GRAPHICS=ATI AMD Radeon HD8330E;
ELUX_IDF=rec5608.idf;3

ELUX_MAC=7CD30A22D0AE4

Use the logical operators AND andOR to linkmultiple filter criteria. Use capital letters for the oper-
ators.

1for eLuxRP 5.7/eLuxRP 6.2 and later versions
2for eLuxRP 5.7/eLuxRP 6.2 and later versions
3for eLuxRP 5.7/eLuxRP 6.2 and later versions
4for eLuxRP 5.7/eLuxRP 6.2 and later versions
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Wildcards are not supported, but all matches are found that begin with the specified string.

Examples for filter criteria:

Example 1: ELUX_OSNAME=eLux RP AND ELUX_OSVERSION=6.9.100
Example 2: ELUX_DEVICETYPE=D3314-A1 OR ELUX_DEVICETYPE=ZQ Class

6. In the OU list next to the Filter rule box, select the OU you want to assign the devices to. Click
to browse.

7. Click Add.

The filter rule is displayed in the field below.

8. If required, addmore filter rules and configure them. For further information, see Editing OU filter
rules.

9. From the list Non-matching devices will be, select where you want to keep the non-matching
devices.

Important If you select assigned to the default OU, all non-matching devices and
even devices already assigned to other OUs are reassigned to the default OU.

10. Review all active filter rules thoroughly to avoid unintentional assignments.

11. Confirmwith OK.

All active filter rules are processed in the specified order. On the next restart thematching devices are
assigned to the OUs as defined by theOU user-defined filter. Any user-defined subnet filter rules will not
be taken into account.

4.7.3. Editing OU filter rules

Once you have definedOU filter rules they remain until they are deleted explicitly. You can edit the filter
rules in the following ways:

1. ClickOptions > Advanced options > Devices.

2. Under New devices, select the option Assign OU depending on the OU filter.

3. To open theOU filter dialog, click the button.
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4. In the top section, from the Filter type list, select the required filter option.

5. Use the following features:

Option Action Description

Add Click button User-defined filter:

The filter criteria of the Filter rule field and the destination OU
selected in the OU field are added as a new filter rule to the list.

Syntax for a filter criterion:
<String from OU filter text>=<value>

You can combine two or more filter criteria by using one of the
logical operators AND or OR. Use capital letters for the operators.

For examples, see Setting up anOU filter as user-defined filter.

Subnet filter:

The data from the fields Network address, Netmask andOU are
added as a new filter rule to the list.

Delete Click button The selected filter rule is deleted.

Edit filter
rule

Select filter
rule and
press F2 or
double-click

You canmodify the filter rule directly in the list.

Activate /
Deactivate

Select/Clear
Activated
option

Deactivated filter rules are not executed.

Newly added filter rules are active by default.

Change
sequence of
processing
(user-
defined fil-
ter)

Edit
Sequence
field

Filter rules with low sequence number are processed prior to filter
rules with high sequence number.

6. From the list Non-matching devices will be, select where you want to keep the non-matching
devices.

Important If you select assigned to the default OU, all non-matching devices and
even devices already assigned to other OUs are reassigned to the default OU.

7. Review all active filter rules thoroughly to avoid unintentional assignments.

8. Confirmwith OK.

All active filter rules are processed in the specified order. On the next restart, thematching devices are
assigned to the OUs as defined by theOU filter.
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4.7.4. Deactivating OU filter for individual devices

If the OU filter is enabled, all active filter rules are applied and thematching devices are assigned to the
specified OU on their next restart. To exclude an individual device from the filter, deactivate the OU filter
for that device.

1. For the relevant device, open Advanced device configuration1 > Management.

2. Under New devices, select the Ignore OU filter option.

3. Confirmwith OK.

Or:

1. By using a drag-and-drop operation, move the device to another OU.

2. Confirmwith OK.

The device is assigned to the new OU and theOU filter is deactivated for this device.

4.7.5. Re-activating OU filter

TheOU filter can be deactivated for individual devices - either by applying the relevant option in the
Scout Console or bymoving devices by a drag-and-drop operation. To bring the relevant devices back
to the OU filter, use the Scout Console option Re-activate filter.

1. ClickOptions > Advanced options... > Devices.

2. Under New devices, select the option Assign OU depending on the OU filter.

3. To open theOU assignment dialog, if required, click the button.

4. In the upper right section, click Reactivate filter...2

1formerly Advanced settings
2For Scout EnterpriseManagement Suite Version 15.1 and earlier versions, the Activate... button can
be used to re-assign theOU filter to all devices. In later versions, you can also select a device group.
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5. Select to re-activate the OU filter for all devices, for an individual organization unit (OU) or for a
Dynamic Client Group.

6. To re-activate the OU filter for an OU or Dynamic Client Group, click the button next to the list-
field and select an OU or Dynamic Client Group.

To include subordinate OUs, select Include sub organization units.

7. Confirmwith Reactivate andOK.

TheOU filter is re-activated for the selected devices.
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4.8. Dynamic Client Groups

Dynamic Client Groups enable administrators to run cross-OU commands for freely definable device
groups. For example, you can send amessage to all deviceswith a specific image throughout the whole
organization. Or you can run a BIOS update on all deviceswith a specific BIOS version, across all OUs.
Even client relocation to another Scout Server can be applied to a Dynamic Client Group. The following
features can be applied:

Commands

Configuration run

Notifications for software deliveries or firmware updates

Notifications for relocation

Dynamic Client Groups are based on reports created in the Scout Report Generator. The reports are
exported to the Scout Console once, and from that point onward, are displayed as a Dynamic Client
Group. Commands applicable to OUs or to individual devices can also be applied to Dynamic Client
Groups.

Note
The report layout must include the Client identifyer1 or theMAC address2, respectively. The
report typemust be a list of Devices or Assets.
For further information on defining Dynamic Client Groups, see Creating Dynamic Client
Groups in the Scout Report Generator guide.

Dynamic Client Groups are displayed in the Scout Console in a special window and remain there for re-
use until they are deleted. They can be updated any-time with a click.

User rights

When you create Dynamic Client Groups, the user access rights are respected as defined in the admin-
istrator management.

By default, executing commands and other functions on a Dynamic Device Group is subject to the
object rights configured for the relevant devices andOUs.3This can result in a function not being
executed because at least one device does not have the required object rights. To avoid this, disable the
check for the underlying object rights under Security > Manage administrators > DCG rights.

4.8.1. Using Dynamic Client Groups

Dynamic Client Groups are usually based on reports created in the Scout Report Generator and expor-
ted to the Scout Console.

1fromScout Enterprise 15.10
2up to Scout Enterprise 5.9
3for Enterprise 15.1 and later versions
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For further information on defining and exporting DCGs, see Creating Dynamic Client Groups in the
Scout Report Generator guide.

Displaying Dynamic Client Groups

In the Scout Console, click View > Window > Dynamic Client Groups....

The Dynamic Client Groups window is displayed. The Dynamic Client Groups can be expanded to
show thematching devices.

Note
The Dynamic Client Group shows those devices that havematched the criteria at the time of
the latest report generation. Make sure that the Dynamic Client Group is up-to-date.

For a selected Dynamic Client Group, the Properties window shows the Creation date, Number of
devices and Filter criteria of the used report. The creation date refers to the date of the latest gen-
eration of the report the Dynamic Client Group is based on, and thus indicates if the Dynamic Client
Group is up-to-date.

If, for example, new devices have been integrated into the database andmatch the criteria of the report,
the Dynamic Client Group is not up-to-date any longer. You can, however, update the Dynamic Client
Group by re-creating the report right from the Scout Console.

If a Dynamic Client Group is not needed any longer, use the button to delete it. The report the
Dynamic Client Group was based on remains unaffected.

Updating Dynamic Client Groups

1. In the Dynamic Client Groups window, select the relevant client group.

2. On the toolbar of the Dynamic Client Groups window, click the Recreate button .

The relevant report is re-created and exported. The resulting devices are shown below the Dynamic Cli-
ent Group as extracted from the database. In the Properties window, in the Creation date field, the cur-
rent point of time is displayed.

Note
The Refresh button refers to the view only. The report is not updated by this command.
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Applying commands and notifications to Dynamic Client Groups

1. In the Dynamic Client Groups window, select the relevant Dynamic Client Group, and then check
the information shown in the Properies window.

2. To update the Dynamic Client Group, click the Re-create button. This way you ensure that
exactly the currentlymatching devices are affected.

3. Open the context menu of the Dynamic Client Group and select a command or notification.

If the required object rights are available, the commands and notifications are applied to thematching
devices, irrespective of their OU. The available commands can also be scheduled for later execution.

43



4.8.2. Special form of Dynamic Client Groups by import

To create a Dynamic Client Group, instead of using the Scout Report Generator, you can use the
Import feature of the Scout Console andmake up a client group based on a device list containingMAC
addresses. The advantage is that you are completely free to select any devices you want. They only
have to be registered in Scout Enterprise. Note that the Import feature is not used to import devices.

Creating Dynamic Client Groups by import

Requires
The relevant devicesmust be listed with their MAC addresses in a .csv file. Each linemust
begin with aMAC address. The linesmay contain further information but only the
MAC address is evaluated.

1. In the Scout Console, click File > Import > Devices....

2. In the Import devices dialog, in the bottom section, select the Create Dynamic Client Group
option.

All options related to the device import are disabled.

3. Click Select file... and select the relevant .csv file from the file system.

4. Click Create.

The .csv file is evaluated. Scout Enterprise creates a new Dynamic Client Group. It contains all
devices of the csv list whoseMAC address is registered in Scout Enterprise. The dynamic device
group adopts the name of the .csv file.

Displaying Dynamic Client Groups

In the Scout Console, click View > Window > Dynamic Client Groups....
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TheDynamic Client Groups window is displayed. The Dynamic Client Groups can be expanded to
show thematching devices.

Note
ynamic Client Groups that have been created via the import feature cannot be updated with

the Re-create button. To update the Dynamic Client Group, after havingmodified the
device list, save the *.csv file under the same name and perform a new import as described
above.

For a selected Dynamic Client Group, the Properties window shows some information such as the
Creation date and Number of devices. The Filter field shows the entry created by device
import.

Applying commands and notifications to Dynamic Client Groups

1. In the Dynamic Client Groups window, select the relevant Dynamic Client Group. Check the inform-
ation shown in the Properies window.

2. Open the context menu of the Dynamic Client Group and select a command or notification.

Commands and notifications are applied to thematching devices, irrespective of their OU. The available
commands can also be scheduled for later execution.
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4.9. Client relocation between Scout Servers

Relocating devices from one Scout Server to another can be very helpful in different scenarios of device
migration, for example when relocating devices from a test/QA server to a production server, or con-
solidating several Scout Servers to a single server (server fusion).

Client relocation can be performedwith and without the clients verifying the availability of the target
server. A so-called offline relocation does not require the target server to be physically available at the
time of relocation.
Example: External suppliers, in their environment, set up devices to be used in the customer's envir-
onment.

License information and local configuration can either be included in the transfer or left on the source
server.

Note
You can use the client relocation procedure also in Service Provider mode. Here there is no
need to carry license information.

4.9.1. Relocation procedure

The relocation procedure is initiated by the source server (device-releasing server) and, by default, com-
pleted by the target server (device-receiving server). The actual relocation procedure, however, is per-
formed by the devices. They check the conditions and transfer the license information.

Relocation is triggered by the notification Initiate client relocation for the relevant devices in the Scout
Console of the source server. The notification includes all required details. On the next device restart,
the devices receive the new configuration data of the source server and evaluate the relocation noti-
fication.

The devices then checkwhether the transmitted target server's address is available via the network.
Provided, the target server's Scout version is valid,1 the relocation process is started and the devices
are deleted from the source server.

By default, the devices bring their management and application licenses aswell as their proportional
Subscription validity with them to the target server. The license and Subscription information is then
deleted on the source server and added to the target server.

The new devices are assigned to the specified OU on the target server. If no destination OU has been
specified, the default OU or the OU defined byOU filter rules is used (configured in Advanced options >
Devices > New devices).

The relocation procedure is completed by an automatic device restart which activates the configuration
of the target server. If configured, locally defined configuration is pertained. If the OU filter is used, an
additional device restart is provoked by the system after assignment.

114.5.0 or later
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Options

In contrast to the default procedure, the administrator can configure the following options in the noti-
fication:

Offline relocation

The devices are removed from the source server without checking whether the target server is
available. Theymove to the target server only when they can connect to it.

Relocation without transfer of licenses

License and Subscription information is left on the source server so it can be used by other
devices. This includesmanagement licenses, application licenses assigned to the devices (if
any), and the subscription portion of the relevant devices.

Retain local configuration on new Scout Server1

If on the source server is configured that users' local configurations in unlocked fields should not
be overwritten by server-side configurations (Advanced options > Devices), then the local con-
figurations are carried along. The relocated devices receive the target server's device con-
figuration only where there are no local configurations.

Important Do not reserve device profiles by enteringMAC addresses of the new devices on
the target server before client relocation. If the devices are already registered on the target
server, licenses and Subscription will not be updated.

4.9.2. Relocation procedure / offline

The relocation procedure is initiated by the source server (device-releasing server) and completed by
the relevant client devices. If you perform an offline relocation, the devices do not verify whether the tar-
get server (device-receiving server) is available and ready to accept the devices.

The administrator still triggers the relocation by setting a notification Initiate client relocation for the rel-
evant devices in the Scout Console of the source server. The notification includes all required details.
On the next device restart, the configuration is synchronized with the source server, the notification is
analyzed and the configuration data are updated:

The relevant devices are removed from the source server without further verification. On the next
restart, the deviceswill try to connect to the target server.

License information and local configuration can either be included in the transfer or left on the source
server.

1fromScout 15 2110
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4.9.3. Relocation flow chart
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4.9.4. Initiating client relocation

Requires

On the target server, in Advanced Options > Devices, clear the option Accept only
known devices, if selected.

To ensure relocation success, the DHCP options of the client are not checked during
the relocation. If, however, Scout Server DHCP options for the source server have
been defined (222/223/224), on the target server, in Device configuration > Network
> LAN > Edit > Advanced select Ignore DHCP options.

1. Select a device, an OU, a Dynamic Client Group or deviceswithin the All devices window.

2. On the context menu, click Notifications > Initiate client relocation....

3. In the Client relocation notification dialog, in New Scout Server, type the name (FQDN) or the
IP address of the target server.

Note
To connect the devices via Scout CloudGateway to their target server, type the name
or IP address of the SCG instance. The Scout CloudGatewaymust be fully configured.

4. Edit the following fields:
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New OU-ID ID of the destination OU on the target server

If you do not specify a destination OU, the devices are assigned to the
default OU or to the OU defined by theOU filter rules.

Relocation without
transfer of licenses

The licenses of the relocating devices are left on the source server.The
subscription portion for these devices also remains at the source server.

Check availability of
new Scout Server

'online' relocation

Relocation is only done when the devices can access the target server via
the network.

selected by default

Retain local con-
figuration on new
Scout Server1

User-defined values of the local device configuration in unlocked fields
will be retained. This is relevant if the corresponding option in Advanced
Options > Devices is used.

Include sub organ-
ization units

All devices located in lower-level OUswill also bemoved.

Note
Notifications are always set or deleted for all selected devices regardless of whether
they are only available for individual devices.

5. Confirm the notification and confirmation.

The notifications for client relocation will be set. For the relevant devices, in the Properties window,
the Relocation notification field shows the value Activated.

1fromScout 15 2110
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Note

To define which fields you want to show in the Properties window, click .

For devices not involved in the relocation, the Relocation notification field remains empty.

The devices evaluate the notifications after their next restart and then start the relocation process.
Alternatively, trigger the relocation by command to control the time of relocation.

4.9.5. Scheduling relocation process

To carry out the client relocation outside working hours, for example, and to add a slight delay after each
device is processed, proceed as follows.

Requires
The relocation has been initiated and the relevant devices have their relocation notification.

1. In the Scout Report Generator, identify all deviceswith active relocation notification.

2. Export the identified devices to a Dynamic Client Group.

3. In the Scout Console, for your Dynamic Client Group, schedule a Restart device command:

In the Command dialog, choose date and time of the execution.

Specify a delay in milliseconds, that will be applied after the command execution of each
device..

The relevant devices are restarted at defined time and then start the relocation process. They obtain
their new configuration data from the target server. If you perform the relocation offline, the relevant
deviceswill be removed from the source server, but will only connect to their new server when they
can connect to it.
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4.9.6. Deleting relocation notification

1. For the relevant OU, device or Dynamic Client Group, on the context menu, click Notifications >
Delete relocation notification...

2. To include the devices of all subordinate OUs, in the Delete relocation notificationmessage, select
the option Include sub organization units.

The number of devices shown in brackets is updated dynamically.

3. Confirmwith OK.

After refreshing the Properties window, the Relocation notification status for the relevant devices is
deleted.

Note
Notifications are always set or deleted for all selected devices regardless of whether they are
only available for individual devices.
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5. Device configuration

5.1. Concept

Device configuration is the key tomanaging a large number of Thin Clients efficiently. Configuring as
many clients as possible in the sameway keeps IT processes simple, and costs low. All the same,
numerous different locations, heterogeneous hardware environments and additional requirements do
not allow for a unified device configuration.

Scout EnterpriseManagement Suite takes this into account by using an inheritance approach. By
default, the base device configuration defined at top level passes its properties on to the devices on
lower instances. The concept of inheritance helps you keep your configuration consistent and efficient.
To define any variations, simplymodify the relevant settings. Scout Enterprise provides flexibility to over-
ride any settings on all levels.

Note
Changes to the device configuration take effect on the next restart of the relevant clients.

Important The device configuration of a client depends on the software packages installed
on it.

5.1.1. Inheritance of configuration

The base device configuration and the configuration of OUs can be inherited by lower instances.

The base device configuration is the top-level instance. Lower instances can be other OUs or individual
devices.

If the option Use parent device configuration1 is active, the configuration of the superior element of the
hierarchy is applied to the current instance. By default, the option Use parent device configuration is
active, so a device inherits its configuration from the base device configuration.

Settings of the configuration can be edited on three levels in the Scout Console: 

Base device configuration (Options > Base device configuration)

OU (context menu > Device configuration)

Device (context menu > Device configuration)

On each level, you can inherit the device configuration from the superior level or define independent set-
tings. To be able to override settings, youmust block inheritance, that is disable the use of the parent
device configuration.

Note
Pay attention to the Device configuration dialog title. It indicates the location of the current

1formerly Use parent
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configuration. This can be the base device configuration, or a superior OU, or the individual
device.

Example: If inheritance is active and you open the configuration dialog of a device or OU subordinate to
France, the title bar showsDevice configuration of OU <France> is used. Tomodify any settings,
open the France configuration dialog.
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5.1.2. Blocking inheritance - independent device configuration

If you want to define independent settings for an individual OU or device, you have to block inheritance
for that instance.

1. Open the context menu of the relevant instance (OU or device) and click Device configuration...1.

The Device configuration dialog opens and the title bar shows the currently active device con-
figuration instance. This can be the base device configuration or a superior OU. For further inform-
ation, seeOpening device configuration dialogs.

2. On theGeneral tab, clear the Use parent device configuration2 option.

Inheritance is disabled. The title bar of the dialog shows the currently edited instance and the available
options are editable. This instance and all subordinate instances can be configured independently of
superior instances.

Note
The Independent configurations window shows all OUs and devices that do not use their par-
ent configuration.

Note
In View > Settings..., you can specify that when youmodify a device configuration, all of its
subordinate independent configurations are checked. You then receive a list of the relevant
parameters and can conveniently determine whether and to which instances themodifications
are to be transferred.

1formerly Setup
2formerly Use parent
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5.1.3. Supporting local configuration

User rights for modifying the local device configuration can be set for OUs and devices, even for indi-
vidual fields. You can lock and disable individual fields or tabs for security reasonswhereas other fea-
tures such asmonitor management can be allowed. For further information, see Changing user rights.

If individual (local) configuration is allowed, make sure that the relevant configuration data are pre-
vented from being overridden when the Scout Enterprise configuration is reloaded on the next restart of
the devices.

Retaining local device configuration

1. ClickOptions > Advanced options... > Devices.

2. Under Field update, select Retain local configuration (unlocked fields).1

When the Scout Enterprise device configuration data are reloaded, only locked tabs and fields are
updated. Local user configuration data in unlocked fields are kept.

Retaining local device configuration during factory reset

– fromScout Enterprise 15.7 and eLuxRP 6.7 –

1. Select the option Advanced options > Retain local configuration (unlocked fields), see above.

2. In the command dialog for the factory reset, select Retain local configuration (unlocked fields).

The client is reset to its initial state and the device configuration of the locked fields is reset. However,
the local user configurations in unlocked fields are retained.

For further information, see Factory reset command.

Initiating a one-time update of all device configuration data

In case of a defective user configuration, however, the administrator, in the Scout Console, can set a
flag to override all device configuration data on the next restart of the device.

In the Scout Console, for the relevant device, on the context menu, click Notifications > Initiate con-
figuration update...

The relevant device ismarked to obtain a copy of the relevant Scout Enterprise device configuration
data including unlocked fields, on the next restart.

1formerly: Only locked fields are updated
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5.1.4. Accessing device configuration

Opening the base device configuration

In Scout Enterprise, select Options > Base device configuration...

The Base device configuration dialog opens. It contains the global device configuration applying to all
devices, unless independent configuration instances are defined.

Opening Device configuration1 dialog for OUs and devices

Select an element in the tree view. Then click Edit > Device configuration...>2

or

For the relevant element, open the context menu. Then click Device configuration...

The Device configuration dialog of the selected element opens. Possibly, the options are disabled as
the Use parent device configuration3 option is selected. In this case, the relevant OU or the base
device configuration is specified in the dialog title.

The figure shows the device configuration of a device in the sub-tree of the OU IT_Rome. If the dialog
has been opened as described above, all options on all tabs are disabled. Only Use parent device con-
figuration can bemodified.

1formerly Setup
2formerly Setup
3formerly Use parent
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Opening the relevant Device configuration dialog (preferred method)

Thismethod allows you to quickly and easily access the point where the device configuration is defined
for the relevant devices.

1. In the tree view, select a device (or anOU).

2. To show the Properties window, click View > Window > Properties.

In the Properties window, next to Configuration, the instance is displayed fromwhere device con-
figuration data are applied to the selected element.

3. In the Properties window, double-click Configuration.

The Device configuration dialog of the displayed instance opens. It contains the device configuration
data applied to the selected instance. The options of all tabs can be edited as far as permitted by the
user rights.

The figure shows the relevant device configuration for the same device. This is the configuration of the
OU IT_Rome.

Note
To save your changes, in Scout EnterpriseManagement Suite 15.4 and later versions, click
Apply. In earlier versions, subsequently confirmwith OK tomake your changes persistent.
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5.1.5. Comparing device configurations between OUs or devices

The device configuration of different OUs or devices can be compared by using a dedicated window.

1. Click View > Window > Compare configuration.

The window Compare configuration is shown as a permanent window in the lower part of the con-
sole window.

2. Drag two or more OUs or devices into the Compare configuration window by using a drag-and-drop
operation.
Or:
On the context menu of the relevant OU or device, click Edit > Add to configuration compare....

3. On the icon bar of the Compare configuration window, click the icon.

The device configuration of the listed OUs or devices are compared. Differences in themain prop-
erties are shown.

4. To view all of the information, on the icon bar of the Compare configuration window, click the
icon.

All properties are shown.

Note
To compare actual and target settings of individual devices, use a report. For further inform-
ation, see Evaluating configuration data.

5.1.6. Locking configuration transfer

– for Scout EnterpriseManagement Suite 15.0 and later versions1 –

Individual devices can be excluded from the process of updating device configuration data.

Requires
Object right Activate/Lock configuration transfer

1. For the relevant device, open the context menu.

2. Click the option Lock configuration transfer.

The device is no longer provided with updated device configuration data but remains in the Scout
Enterprisemanagement.

Note
For newly added deviceswithout management license, the configuration transfer is auto-
matically locked.

1replaces theManagement off command of former Scout EnterpriseManagement Suite versions
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5.2. Configuration method

During system start of the clientsmanaged by the Scout EnterpriseManagement Suite, the clients con-
nect to their Scout Server and checkwhether any updated configuration data are available, taking inher-
itance into account. Theremay be updates for the following data:

Device configuration (formerly Setup)

Application definition

Files configured for transfer

Advanced file entries

The Scout Server identifies the relevant configuration data at runtime. That means that all modifications
made to configurations in the Scout Console until then are included.

5.2.1. Configuration run

If the system determines updated configuration data for a client, the relevant modified data are iden-
tified, compressed and saved to the database. They are then transferred to the client in one step.

Whenmodifying the configuration of a large number of clients (e.g. when changing the application defin-
itions due to amove to another back-end infrastructure), the administrator can initiate the process of
identifying and compressing the relevant data in a data object in advance, for instance at night. To do so,
the administrator uses the Configuration run command.With this command, the required configuration
data can be prepared to be ready for transfer on the next restart of the clients, whichmight be on the
next working day.

Performing a configuration run

Note
The configuration run command only prepares configuration data for clients with a con-
figuration delta.
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1. For the relevant OU or Dynamic Client Group, on the context menu, click Commands.

2. On the sub-menu, click the Configuration run... command.

3. Specify a time for execution and confirmwith Schedule.

The processing progress is shown in the Command history.
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5.3. Evaluating configuration data

The Scout Report Generator provides fields you can use to analyze configuration data:

Configuration
ID

ID for a compressed data object holding configuration data

Is created either as a result of a configuration run, or by synchronizing configuration
data on the first client to server contact after the configuration settings have beenmod-
ified

Configuration
up-to-date

Yes – client has the configuration that is currently defined for it in the Scout Console

No – client is running an earlier eLux version which cannot evaluate the field

Configuration
transfer

The option Lock configuration transfer is active for the client

For further information, see Locking configuration transfer.

Example:
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5.4. FollowMe Desktop

– for Scout Enterprise 15.8 and later versions –

Note
To use this feature, you will need user authentication via Active Directory.

FollowMeDesktop allows you tomake user-specific configuration settings that are valid across devices.

In addition to the device configuration option, which is bound to devices, the FollowMeDesktop feature
allows users to take their configuration settingswith them to any device. Users' configured desktop lay-
out and configured applications "follow" them to any device they log on to.

FollowMeDesktop is configured in the tree structure node of the same name and is implemented as one
of the top-level OUs. This FollowMeDesktop instance can be used right away or can act as a container
for further FollowMe configurations, which are added as subordinate OUs. This is how a device-inde-
pendent and cross-hierarchical structure of configurations ismapped, whichmight bemotivated by
users' subject-specific functions. For example, a FollowMe Helpdesk OU could contain all application
definitions and the desktop layout for Helpdesk employees.

A FollowMeDesktop configurationmay consist of application definitions and defined configuration val-
ues of the device configuration. For further information, see "Scope of configurable options" on page 65.

The FollowMe configurations are assigned to users via AD properties. The administrator applies filter
definitions to the FollowMeDesktop instance and all subordinate OUs, which then filter for the relevant
AD membership.

When an AD user logs on to a device that is enabled for FollowMeDesktop, the user's AD properties
arematched against the filter definitions of the FollowMeOUs. If a FollowMe configuration with match-
ing filter values is found, the desktop is loaded with the layout and applications defined in that FollowMe
OU.Whenworking with the FollowMe configuration, users canmake changes to it, such as placing
application icons freely on the desktop. These changes, however, will not be saved.

After the user closes his session and logs off, the original device configuration is reloaded.
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FollowMeDesktop configurations can be exported and imported.

5.4.1. Configuring FollowMe Desktop

To use the FollowMeDesktop feature, make one or more FollowMe configurations available to certain
AD users via filter definitions. Then define on which devices you want to allow the retrieval of a Fol-
lowMe configuration.

Creating FollowMe configurations

Requires
Administrator base right Show FollowMe Desktop OU

1. In the tree structure, below the FollowMe Desktop top-level OU, create further FollowMeOUs
such as a FollowMe Helpdesk OU. To do so, from the context-menu, choose Add > Organ-
ization unit.

2. Edit the device configuration of the new FollowMeOUs (Desktop, Drives, USB options, Power
management). Then add the relevant application definitions to the FollowMeOUs.

Note
New FollowMeDesktopOUs do not inherit configuration values from the base device
configuration or base applications.Within the FollowMeDesktop structure, however,
inheritance is active by default. Subordinate FollowMeOUs inherit the device con-
figuration and applications from the parent FollowMe instance, unless you disable inher-
itance.

The configuration values of a FollowMe-OU overwrite the device configuration values valid on the
device.

3. For each FollowMeOU, define a filter that filters for an AD membership. To do so, from the con-
text-menu, choose Set filter.

Note
The filter definitions are independent of any inheritance. For each FollowMeOU, define
a separate filter.
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In the filter rule, you can filter for the AD properties User, Group or Domain.
Syntax: USER|GROUP|DOMAIN=<Value>
Multiple filter rules are allowed.

Note
For deviceswith the FollowMeDesktop enabled, the user AD properties are written to
the eluxd.log file (search for FollowMeDesktop).

All active filter rules are processed in the specified order. AD usersmatching this filter definition
will have access to the applications and desktop properties configured in the FollowMeOU after
logging on to devices for which FollowMeDesktop is enabled.

User-related FollowMe configurations are defined. In the next step, define for which OUs or devices
these configurationsmay be retrieved.

Enabling devices for FollowMe Desktop

Specify the devices that shall have access tomultiple configurations. In some cases, usersmay prefer
the device configuration defined in the OU structure on their workstation device. On other devices, for
example in the service area, theymay prefer a FollowMe configuration.

In the device configuration of anOU / device (or in the base device configuration), you define whether a
device should retrieve Follow-Me configurationswhen authorized AD users log on.

In the device configuration of the relevant devices, under General > FollowMe Desktop, select
Request configuration for logged-on users.

After AD users log on, their AD properties are evaluated. If the Scout Server finds amatching FollowMe
OU, the configuration defined there is loaded.

5.4.2. Scope of configurable options

The following properties can be configured for FollowMeOUs:

All application typeswith all application properties

Software default settings for Firefox and Chromium (browser home directory)

Device configuration with following options
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Desktop All options except date and time

Desktop > Advanced Sort Configuration panel
System bar
Background picture

Drives All options

Hardware All USB options

Power management All options

Configuration values of a FollowMeOU will overwrite the configuration values of the "normal" device
configuration on this device. For options not listed, the values of the "normal" device configuration
remain active.

Note
Within a FollowMeOU, only those applicationswill be available that have been defined for it.

The administrator can further limit the scope of the configurable options of FollowMeOUs for oper-
ational administrators (Security > Manage administrators > Default object rights).
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5.5. General tab

Use parent

This option of the General tab is active by default and ensures that consistent device configurations are
used. If Use parent device configuration is selected, all other fields of the dialog are disabled: For the
relevant device or OU, the device configuration is used that is displayed in the title bar (in the figure IT_
Rome). This is where an administrator will normallymake any configuration changes.

Note
In some cases, it might be useful to disable the Use parent device configuration option tem-
porarily.

For further information, see Blocking inheritance.

Additional options

Option Description

Auto-request cli-
ent application
licenses

Enables the device to automatically request application licenseswhen licensed
applications are installed or used

To do so, in the License information dialog, select Auto-assign. For further
information, see Automatic assignment of application licenses in the License
management short guide.

FollowMe
Desktop / Request
configuration

Allows authorized users to usemultiple configurations on this device

For further information, see Configuring FollowMeDesktop.
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Hardware information for individual devices is listed in the Properties window of the Scout Console. For
further information, see Properties window.
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5.6. Network tab

Depending on the installed image and the hardware used, users can use different network connections.
In the Scout Console, you define network profiles for different network types. The user can then choose
from the defined network connections on the system bar.

The following network profiles are available:

LAN (only one profile, cannot be deleted)

Wireless LAN

Mobile Internet (WirelessWide Area Network)1

VPN2

Note
To create VPN nework profiles, use the Advanced device configuration for individual
devices. For further information, see "VPN" on page 162.

1fromScout EnterpriseManagement Suite 15.5
2fromScout EnterpriseManagement Suite 15 2101 For earlier versions, see "VPN" on page 162 in the
Advanced device configuration.
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5.6.1. Defining a LAN profile

1. For the relevant device or OU, open Device configuration > Network.

2. Select the LAN tab. Then, for the Default connection, click Edit.

3. In the Edit network profile dialog, under Ethernet, edit the following fields:

Option Description

Obtain an IP
address auto-
matically

The IP address is obtained automatically via DHCP.

Define a timeout period in seconds.

Later on, under Advanced, specify the behavior for failing DHCP requests.

Use following IP
address

Alternatively, specify a fixed IP address and the corresponding options.

Note
If you do not use DHCP options for Scout Enterprise, we recommend that you select
Advanced > Ignore Scout Server DHCP options.

4. Tomodify the network speed andMaximumTransmission Unit (MTU), edit theMedium tab.

5. Under Advanced, edit the following fields:

DHCP settings Specify the behavior for failing DHCP requests.

Proxy1 Define a system-wide proxy server for this network profile, see Proxy con-
figuration.

The proxy setting you define here is used by the System proxy option in
the browser application definition.

6. Under IEEE 802.1X authentication, edit the following fields:2

Activate Enable IEEE 802.1X authentication in general.

Allow LAN con-
nection without
802.1X if 802.1X
fails3

Specify whether a connectionmay be set up if a timeout or authentication
error for 802.1X occurs (for Ethernet connections only).

If the option is cleared, users can only connect after successful 802.1X
authentication.

1for Scout Enterprise 15.5 and later versions
2Up to Scout EnterpriseManagement Suite 15.8, use the Advanced tab to enable IEEE 802.1X
3for Scout EnterpriseManagement Suite 15.9 and later versions
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Number of auto-
connect retries1

Number of connection retries before aborting

Number of
authentication
retries2

Number of authentication retries for a successful connection before the
authentication is aborted

Timeout authen-
tication

Time period in seconds before an authentication try is aborted

Note
TheWPA encryption is performed using theWPA supplicant and the configuration file
wpa.conf. For further information, seeWPA support.

7. Confirmwith OK and Apply.

Use the Internet connection test option to check anytime whether web addresses are accessible via
the Internet.3For further information, see "Options for all network profiles" on page 80.

1for Scout EnterpriseManagement Suite 15.9 and later versions
2for Scout EnterpriseManagement Suite 15.9 and later versions
3for Scout EnterpriseManagement Suite 15.9 and later versions
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5.6.2. Advanced network settings

In Device configuration1 > Network > Advanced you will find a host list as well as features that apply
to all network connections.

Defining a timeout for a connection

Under Management timers, in the relevant fields, enter the desired timeout in seconds

when establishing a connection.

when the connection is in idle state.

After the indicated time, the connection is terminated.

The option Send Keepalive packet ensures that the client sends keepalive signals to the Scout Server
in the specified time interval, provided the Scout Statistics Service is installed. For further information,
see Defining statusmessages (keep alivemessages).

Defining a host list for networks without DNS server 

If the network is not equipped with a domain name server (DNS), host names can be resolved locally by
the device. All you need ito do is keep your host list up-to-date.

1. Click New.

2. Enter a host name and the IP address.

3. Confirmwith OK.

The host list is automatically transferred on the next restart.

1formerly Setup
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5.6.3. Defining a WLAN profile

The following configuration options are provided:

A. In the Scout Console, in the device configuration, you can create aWLAN profile for a device, OU
or for all devices, see below.
EAP authentication is not supported with thismethod.

B. Users can create individualWLAN profiles locally on the device. Local profiles and profiles cre-
ated in Scout Enterprise can bemerged automatically. This way you canmake them connect
depending on the user's location.

C. CorporateWLAN: AWLAN configuration can be distributed throughout the entire company net-
work by using aWPA configuration file with and without 802.1X.
Users can additionally create individualWLAN profiles locally on the client. ConfiguredWLAN net-
works can connect automatically depending on location and priority. For further information, see
WPA support.

Creating a WLAN profile in the Scout Enterprise device configuration

1. In the Scout Console, for the relevant OU, open Device configuration1 > Network.

2. On theWireless LAN tab, click Add.

3. Edit the following options:

Option Description

Profile name Freely selectable name for theWLAN profile

Connect auto-
matically

Note: If the option is cleared, there is no automatic use of any exisitngWifi
connection. In this case, the user must start aWLAN manually from the live
information on the system bar.

Internet con-
nection test2

For further information, see "Options for all network profiles" on page 80.

Medium > Net-
work name/SSID

Wifi name / Service Set Identifier

Medium >
Timeout

Time period in secondswaiting to connect

Medium > Chan-
nel

Selected automatically by default

1formerly Setup
2fromScout EnterpriseManagement Suite 15.9
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Option Description

Medium >
Encryption

Authentication type

None

WPA with pre-shared key (PSK)

WPA2 with pre-shared key (PSK)

To authenticate via EAP (Extensible Authentication Protocol), use aWPA
configuration file. For further information, seeWPA support.

Medium > Hid-
den SSID1

Select this option if aWLAN is hidden.

Below, the access point MAC address (BSSID) is shown. If the network has
multiple access points, theMAC addresses found are separated by semi-
colons.

BSSIDs are required for devices to automatically connect to a hidden
WLAN.

IP > Obtain an IP
address auto-
matically

The IP address is obtained automatically via DHCP.

Define a timeout value in seconds.

IP > Use fol-
lowing IP
address

Alternatively, specify a fixed IP address and the corresponding options.

Advanced
> DHCP settings

Specify the behavior for failing DHCP requests.

Note
If you do not use DHCP options for Scout Enterprise, we recommend that you select
Ignore Scout Server DHCP options.

Advanced /
Proxy2

Define a system-wide proxy server for this network profile, see Proxy con-
figuration.

The proxy setting you define here is used by the System proxy option in
the browser application definition.

4. Confirmwith OK.

Note
To create an individualWLAN profile locally on the client (B), apply the same steps in the eLux
device configuration, provided you have the necessary user rights.

1fromScout EnterpriseManagement Suite 15.10 and eLux RP 6.11
2for Scout Enterprise 15.5 and later versions
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Note
To check the network activities on the client, use the Diagnostics feature (Enhanced log level)
and the systemd-journal.log file.1

5.6.4. WPA support

To secure your LAN andWLAN, you can useWPA encryption with the help of the WPA-supplicant
software. This software provides key negotiation with theWPA authenticator and controls association
with IEEE 802.11i networks. WPA uses IEEE 802.1X andWPA2 uses IEEE 802.11i.

Authentication can be performed either with a pre-shared key (PSK) or, for IEEE 802.1X, via the
Extensible Authentication Protocol (EAP).

WPA is configured using the text file wpa.conf that can list accepted networks and security policies.
The configuration file is saved locally on the clients.

wpa_supplicant is a free software application. For further information, see http://w1.fi/wpa_sup-
plicant/.

Providing WPA configuration file

1. Create a text file named wpa.conf by using the wpa_supplicant program. See below for an
example.

2. To transfer the wpa.conf file to the clients, use the Scout Enterprise feature Files configured
for transfer. Use the following destination:

LAN setup/scep/

WLAN setup/wlan/

For further information, see Files configured for transfer.

Example of a WPA configuration file with 802.1X (WLAN)

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
ap_scan=1
network={

ssid="<WLAN name>"
scan_ssid=1
key_mgmt=WPA-EAP
eap=TLS
identity="<Common Name as specified in certificate>"
priority=6
ca_cert="/setup/cacerts/root-ca.pem"

1for eLuxRP 6.4 and later versions
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client_cert="/setup/cacerts/client.pem"
private_key="/setup/cacerts/client.key"

}

Note
Network profiles (LAN andWLAN) that are transferred to the device via a wpa.conf file can-
not be edited locally on the device.

For further information onWPA configuration and on using variables, see ConfiguringWPA supplicant
in the short guide IEEE 802.1X authentication.

5.6.5. Corporate WLAN

A corporateWLAN providing access to internal resources can be secured by 802.1X with firewall
policies tailored to specific needs.

After having set up your WPA configuration file, you can deploy it wherever required. For further inform-
ation, seeWPA support.

With a corporateWLAN, you can allow users to create their ownWLAN profiles in parallel. For
example, amobile Thin Client could use the provided LAN connection when it is attached to the docking
station on the job, but change automatically to the corporateWLAN when undocked. Once the device is
started in the home office, eLux connects to themanually configuredWLAN.

For eLux RP 5, for a corporateWLAN, an additional dummyWLAN profile must be configured in the
device configuration. For eLux RP 6, due to the new network stack, the steps described below are no
longer required.

Configuring corporate WLAN with dummy profile

– for eLux RP 5 only –

1. In the base device configuration, in Nework > Wireless LAN, create a newWLAN profile. This
profile serves as a dummy profile and is invisible on the client:

Option Wert Beschreibung

Name #DUMMY# Using this name and SSID ensures that theWLAN profile
on the client is invisible to the user. The name isman-
datory.

Connect auto-
matically

selected mandatory

SSID #DUMMY#

Timeout Use the default value.

Channel Use the default value.
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Option Wert Beschreibung

Encryption WPA (PSK)

PSK <Password> Use any string with eight or more characters.

For further information, see Defining aWLAN profile.

2. Define an advanced file entry to merge theWLAN profiles:

File /setup/terminal.ini

Section Network

Entry MergeWLANProfile

Value true

For further information, see Advanced file entries.

3. Distribute your corporateWLAN configuration via aWPA configuration file.

To define a higher priority than themanually createdWLAN profiles (priority 5), set the Priority
value to 6 or higher.

For further information, seeWPA support.

Users can create individualWLAN profiles on the local client in addition to the corporateWLAN:

Creating a local WLAN profile

– for eLux RP 5 only; for eLux RP 6 see Adding aWLAN profile in the eLux guide –

1. In the eLux control panel, in Setup > Network > Wireless LAN, add a new profile.

If no network connection is available, theWLAN profile editor is displayed.

2. In the Edit network profile dialog, select the Start automatically option.

3. Edit the remaining fields. For further information, see Defining aWLAN profile.

4. To connect to the definedWLAN for the first time, use the network icon of the systray and click the
Connect button.

If a network connection is available, the connected network is shown in the systray when themouse
pointer ismoved over the network icon.

5.6.6. Defining a Mobile Internet profile (WWAN)

– for Scout EnterpriseManagement Suite 15.5 and later versions –

For mobile devices equipped with an appropriate SIM card, define profiles that allow users to connect to
cellular data networks such as LTE or UMTS.
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1. In the Scout Console, for the relevant OU, open Device configuration1 > Network.

2. On theMobile Internet tab, click Add.

3. In the Edit network profile dialog, edit the following options:

Option Description

Profile name Name of the new profile

Connect auto-
matically

If the signal strength is sufficient, the client automatically attempts to con-
nect to the cellular network.

APN Access Point Name: Address used by the client to connect to the Internet
when the cellular data connection is used

PIN PIN of the SIM card (if used)

Username Username for themobile account

Password Password for themobile account

Roaming The cellular data connection remains intact when the device is outside the
mobile operator's network.

4. Confirmwith OK.

Unlock blocked SIM card via command

If, for example, a SIM card has been blocked due to incorrect PIN entries, use the PUK to create a new
PIN.

1. For the relevant device, open the context menu and click Commands > User-defined
command.

2. Enter the following command:
mmcli -i 0 --puk=<PUK code> --pin=<PIN code>

3. Select Run with system rights.

4. Click Execute.

5.6.7. Defining a VPN profile

– fromScout EnterpriseManagement Suite 15 2101 –

Note
To create VPN nework profiles in earlier versions, use the Advanced device configuration for
individual devices. For further information, see "VPN" on page 162.

You can define one or more VPN profiles for entire OUs.

1formerly Setup
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1. In the Scout Console, for the relevant OU, open Device configuration > Network.

2. On the VPN tab, click Add.

3. In the Edit network profile dialog, edit the following options:

Option Description

Profile name Name for the new VPN profile

Connect auto-
matically

The VPN client starts automatically and sets up a connection.

VPN client type Choose betweenOpenVPN, CiscoAnyconnect or a user-defined VPN cli-
ent.

If you use a user-defined VPN client, specify its ID number.

Configuration
(onlyOpenVPN)

Name of the OpenVPN configuration file without file name extension

The specified configuration file must be available on the devices.

4. Confirmwith OK.

For further information on creating OpenVPN andCisoco AnyConnect profiles, see "VPN" on
page 162.
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5.6.8. Options for all network profiles

Option Description

Name Name for the network profile (can be defined freely)

Connect
automatically

(except for LAN)

Internet con-
nection test1

Each time a connection is set up, the system checkswhether addresses on the Inter-
net can be reached via the current network profile (LAN andWLAN). If a connection to
the Internet cannot be set up, the system checks for the existence of a captive portal
and, if available, redirects to it.

Auto
(default)

A connection test is automatically performed for WLAN profiles, provided
that no central system proxy is defined.

On For LAN andWLAN network profiles, the Internet connection is auto-
matically tested.

Off No automatic connection test is performed. The device does not display
any content in the browser and does not attempt to connect to external ser-
vices or websites.

The option is protected by a dedicated object right (Device configuration > Network >
Handling of network profiles > Internet connection test) and by a dedicated user
right.2

1fromScout EnterpriseManagement Suite 15.9
2fromScout EnterpriseManagement Suite 15 2101
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5.6.9. Proxy configuration

For each network profile, you can define a proxy server that is used byweb clients or browsers. The
proxy server can be configuredmanually or automatically.

If you define the proxy server centrally in the device configuration, it can be accessed from all application
definitions (browsers). This central system proxy1 contains the proxy setting which can either be a
fixed server setting, automatically determined, or simply No Proxy.

Using an automaticWPAD configuration, all web clients of an organization can then be configured eas-
ily to the same proxy server or servers.

For the system proxy setting, in the network profiles, you will find the options described below.

Scout Console: Network > Advanced

eLuxRP 6: Network configuration > Advanced > Use proxy > Proxy settings

Option Description

No proxy No proxy server is used

Manual
(Proxy:Port)

Specify fixed proxy server with port number

Example: proxy.sampletec-01.com:3800

To define destinations that you do not want to access via proxy, in the Proxy
exception list, enter the relevant network addresses separated by semicolons.

Auto (URL) Proxy auto-config (PAC): Determines the appropriate proxy for each URL

Examples:
http://proxy.sampletec-01.com/proxy.pac
http://wpad.sampletec-01.com/wpad.dat

Pass-through
logon for proxy
(with AD user
authentication)2

If a central system proxy is configured with AD authentication, the AD logon
data are used for authentication.

Proxy authenticationmay be required if you use browser content redirection
under Citrix.

Proxy username3 Username for authentication on the system proxy

Proxy password4 Password for authentication on the system proxy

Note
When you define a browser application, the default proxy setting is Use system proxy.
The proxy setting defined in the relevant network profile is now active. For further information,
see Defining a browser application.

1for Scout EnterpriseManagement Suite 15.5 and later versions
2fromScout EnterpriseManagement Suite 15.8 and eLuxRP 6.7
3fromScout EnterpriseManagement Suite 15.8 and eLuxRP 6.7
4fromScout EnterpriseManagement Suite 15.8 and eLuxRP 6.7
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5.6.10. Internet Protocol version 6 (IPv6)

In addition to full support of Internet Protocol Version 4 (IPv4), IPv6 is used by default for local applic-
ations including automatic network configuration (DHCP, DNS, NTP).1

To disable IPv6, in the Scout Console, for the relevant clients, configure the following Advanced file
entry:

File /setup/terminal.ini

Section Network

Entry DisableIPv6

Value true (default = false)

For further information, see Advanced file entries.

5.6.11. Firewall for eLux devices

– for eLuxRP 6.8 and later versions –

To secure your eLux deviceswith a firewall, for example to allow exactly onemore connection besides
the connection to the Scout Server, use the eLux Firewall support package, which allows you to define
appropriate rules.

By default, nftables are used. Alternatively, the iptables syntax can be used.

Once the eLux Firewall support package is installed, the firewall rules are applied on system start. By
default, only data packets that are required for communication with the Scout Server are allowed to
pass. To allow further connections, define filtering rules and transfer them to the devices in a file.

If the Firewall support package has been installed on the device without filtering rules, the firewall will
only start if the feature package Strict firewall policy is installed. Then communication between the
Scout Server and the device is established via themanagement protocol (port 22125) and no other com-
munication is allowed.

Configuring firewall rules (nftables)

Note
The eLux package Firewall support and the included feature packages eLux firewall plugin
and firewall nftables programs and libraries must be installed on the clients. Thismay
requiremodifications of the image definition file on the web server via ELIAS.

1for eLuxRP 6.6 and later versions
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1. Create the nftables.conf file according to the following example:

table ip filter {
chain input {

tcp dport 22 accept
tcp sport 80 accept

}
chain output {

tcp sport 22 accept
tcp dport 80 accept

}
}

In the example, outgoing http and incoming ssh connections are accepted.

2. Transfer the files to the devices to /setup/firewall/nftables.conf. To do so, use the
Scout feature Files configured for transfer.
For further information, see Files configured for transfer in the Scout Enterprise guide.

Configuring firewall rules (iptables)

Note
The eLux package Firewall support and the included feature packages eLux firewall plugin
and Firewall iptables compatibility programs and libraries must be installed on the clients.
Thismay requiremodifications of the image definition file on the web server via ELIAS.

1. Create the file rules.v4 for IPV4 or rules.v6 for IPV6. Use the iptables syntax for the rules.

2. Transfer the files to the devices to /setup/firewall/rules.v4 or
/setup/firewall/rules.v6, respectively. To do so, use the Scout feature Files con-
figured for transfer.
For further information, see Files configured for transfer in the Scout Enterprise guide.

All rule files are included in the Diagnostics feature and are part of the System template.1

1for Scout Enterprise 15.8 and later versions
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5.7. Desktop tab

On the Desktop tab, you canmodify the eLux desktop layout.

1 Display language

2 Background and text colors

3 Keyboard shortcuts

4 Date and time settings

5 Advanced settings

5.7.1. Configuring language and colors

1. For the relevant device or OU, open Device configuration>1 > Desktop.

2. In the Language list, click the preferred desktop and application language.

The following languages are supported: English, German, French2 and Spanish3

Note
The language setting refers to the display of desktop elements. It does not affect text ser-
vices and input. For a smooth performance, ensure that the applications support the
selected language.

3. Click the Background color button to select a desktop background color.

4. Click the Text color button to select a text color for the application icons.4Make sure there is suf-
ficient contrast to the background color.

For further configuration options of the eLux RP 6 desktop, see "eLuxRP 6User Interface" on page 90.

5.7.2. Keyboard shortcuts

For switching applications and locking the screen, keyboard shortcuts are already predefined and you
are free to customize them. To define keyboard shortcuts freely, follow the syntax rules given.

1formerly Setup
2for eLuxRP 6.9 and later versions
3for eLuxRP 6.9 and later versions
4fromScout Enterprise 15.4
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Defining Keyboard shortcuts

1. Open Device configuration> Desktop > Keyboard shortcuts.

2. Youmay select keyboard shortcuts for the following actions:

Option Description How to define

Switch
applications

Switch between open applications or sessions

The default shortcut ALT+CTRL↑ helps avoid
conflicts with the shortcut ALT+TAB which is
used to switch between the taskswithin aWin-
dows session.

Select an option from the list-
field.

Log off1 Log off currently logged-on user (AD users)

The logon dialog is then displayed.

Specify the desired key com-
bination as free-text, see below.

Lock
screen2

Activate password-protected screen saver
(AD users)

Default: <Ctrl><Alt>End

Specify the desired key com-
bination as free-text, see below.
Otherwise, the default key com-
bination is active.

Furthermore, you can define a key combination for multi-monitor environments that allows users to
quickly switch between clonemode and extended desktop.3For further information, see "Multiple mon-
itors" on page 93.

Rules for specifying key combinations

Key combinations consist of a combination of one or moremodifier keys and a single non-mod-
ifier key

For the non-modifier key, you can choose from the following keys:
Letter keys, number keys, function keys,Windows logo keys, ESC key, position and numpad keys
as specified

Key combinationsmust be specified in the following format:

<modifier key><modifier key (optional)><modifier key
(optional)>additional key

No spaces or other charactersmay be placed between the keys.

The spelling of the key namesmust follow the specification, see examples. To receive a complete
list of allowed key names and their spelling, use the following command in an eLux shell:

Modifier key names: xmodmap -pm
Non-modifier key names: xmodmap -pk

1fromScout Enterprise 15.8 and eLuxRP 6.9
2fromScout Enterprise 15.8 and eLuxRP 6.9
3fromScout Enterprise 15 2101 and eLux RP 6 2101
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Examples

Option Description

<Ctrl><Alt>Escape

<Shift><Ctrl>l

<Mod4><Alt>F1 Mod4 corresponds to theWindows logo key

<Ctrl><Mod4><Alt>End

<Mod4>Super_R (= right Windows but-
ton if used as key)

Super_R corresponds to theWindows logo key on the
right if used as a key

<Mod5>KP_End Mod5 corresponds to ALTGR

KP_End corresponds to the END key of the numpad

Important If you define a key combination for eLux that is already defined within an applic-
ation/session, this key combination will only work for eLux. Avoid using the same key com-
binations in different environments.

Behavior of the CAPS LOCK key

In most environments, pressing the (CAPS LOCK) key in combination with letter keys results in the dis-
play of uppercase letters, while the number keys above the letter block output numbers despite the
CAPS LOCK key. To display the special characters of the number keys, the SHIFT keymust be pressed.

To let users write special characters with the CAPS LOCK key, for the relevant devices, configure the
following Advanced file entry:1

Datei /setup/terminal.ini

Abschnitt Keyboard

Eintrag ForceShiftLock

Wert true Default: false

For further information, see Advanced file entries.

The CAPS LOCK key then behaves like the SHIFT key.

5.7.3. Date and time

Option Description

Time
zone

Click Change time zone and select the required time zone from the list..

1from eLux RP 6 2107
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Option Description

Time
server

Under Time server, specify the relevant server name or IP address.

The time server must comply with the Network Time Protocol (RFC 1305) or the Simple Net-
work Time Protocol, a simplified form of NTP. Microsoft Windows operating systems include
theW32Time service which communicates via SNTP in older versions such as
Windows 2000, and usesNTP in later versions. The time service is started automatically.

The service runs on port 123 and uses the UDP protocol.

For further information on theWindows Time Service, see theMicrosoft documentation.
For further information on NTP, see http://www.ntp.org.

Time
format
1

The time can be displayed in 24 hour or 12 hour time format.

Auto (default)
The displayed time format depends on the configured display language (see same dia-
log).

12 hour

24 hour

5.7.4. Advanced desktop settings

System bar

Option Description

Show system bar The system bar will be displayed on the devices. Below, select its behavior and
the icons you want to show on the system bar.
(selected by default)

Always on top The system bar is always visible, even when applications are running in full-
screenmode.

Hide auto-
matically

The system bar is hidden by default. As soon as users point themouse to the bot-
tom of the screen, the system bar is displayed.

Show Desktop
icon

Users click this icon tominimize all open windows and show the desktop.
(selected by default)

Show live inform-
ation icons2

These icons allow users to view current status information such as plugged
USB devices.
for eLuxRP 6.8 and later versions via right-click
(selected by default)

1fromScout Enterprise 15 2101
2fromScout Enterprise 15.7 and eLuxRP 6.7

87



Option Description

Show time Shows the current time
When users point themouse to the time, the current date is shown.
(selected by default)

Show Config
panel icon1

Allows users to open the device configuration (Configuration panel)
(selected by default).

Important Only when the Configuration panel is displayed, can the administrator unlock the
configuration via device password locally on the device.

Quick Config:2 Quick access to Config Panel dialogs via system bar

All options are selected by default.

Option Description

Volume Volume control for input and output devices

Keyboard Keyboard language and key speed

Display Screen settings

Peripherals Settings for peripherals such asUSB and Bluetooth devices, and COMports

Network Network information and setup, disconnect/connect

Device information Information on the device

Date and time Date and time settings

Background

Different background images can be defined for primary/secondarymonitors and for the time
before/after the AD logon.3

Select a background image from the list-field. Then configure it via the buttons.

Option Description

Background pic-
ture

Desktop wallpaper (default)
If further pictures are defined, this one will be used only for the primarymonitor
and after AD logon.4

Additional picture Desktop wallpaper for secondarymonitors

1fromScout Enterprise 15.4 and eLux RP 6.8
2for eLuxRP 6.8 and later versions
3fromScout Enterprise 15.8
4fromScout Enterprise 15.8
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Option Description

Background pic-
ture AD

Desktop wallpaper until AD logon (primarymonitor)

Additional picture
AD

Desktop wallpaper until AD logon (second andmoremonitors)

Load Browse the file system and select a picture file. The picture file will be imported
into the database.

The following file formats are supported: .svg, .png, .jpg1

Maximum file size 500 KB

Delete Remove the current background image from the database.

Set URL2 As an alternative to a picture file from the file system, specify a web address for
loading pictures.

Note
Make sure you have enough flashmemory on the devices. The background image is stored in
the /setup directory of the flash card.

Further options

Option Description

Sort Con-
figuration panel

The Configuration panel dialogs are displayed in alphabetical order (default from
version 15.9)

Timer for shut-
down con-
firmation3

Before the device is shut down, amessage is displayed for the specified time
period (in seconds). This allows users to prevent the shutdown by clicking the
Cancel button or pressing the ESC key.
(deselected by default)

This option has its own user right and object right (for administrators). Both rights
are enabled by default.

Desktop sort
order4

Sort order of the desktop icons

The administrator can specify the sort order for users without the user right Sort-
ing desktop icons. Users who have this user right can freely place desktop icons
on the desktop.5

1.jpg cannot be previewed
2fromScout Enterprise 15.8
3fromScout Enterprise 15 2103 and eLux RP 6 2103
4fromScout Enterprise 15.10
5from eLuxRP 6.9
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5.7.5. eLux RP 6 User Interface

Requires
eLuxRP 6.0 or a later version

eLuxRP 6 clients comewith a new desktop interface that can be customized to your needs and that
provides a personal desktop view. For further information, see eLuxRP 6User Interface in the eLux
guide.

Customizing the layout of the eLux RP 6 User Interface

1. For the relevant OU, use the Advanced file entries feature of the Scout Console tomodify the cli-
ent file /setup/terminal.ini in the Layout section. Add the following new entries and spe-
cify the relevant values:

Entry Value range Description

DesktopLogo Path and name of the
picture file | none

Option 1 replaces the eLux Logo in the lower right sec-
tion by the specified picture file.
Example: setup/public/myPic.png

Option 2 removes the eLux Logo in the lower right
section.1

Note
To show an individual picture file, transfer the picture to the clients. For further inform-
ation, see Files configured for transfer.

DesktopTextColor #<rgb> Text color of application icons

DesktopHighlightedTextColor #<rgb> Text color of application iconswhen the
mouse pointer ismoved over them

DesktopTitleTextColor #<rgb> Color of the folder/tab title (All Applications,
StoreFront store name)

DesktopSearchTextColor #<rgb> Text color in the search field

DesktopSearchBackgroundColor #<rgb> Background color of the search field

DesktopSearchIconColor #<rgb> Color of search icon (magnifier)

DesktopSortIconColor #<rgb> Color of sort icon (A-Z)

2. To display a background image, configure the relevant picture file in the Advanced desktop set-
tings of the device configuration. For further information, see Advanced desktop settings.

For multiple monitors, the image will be used as a background image on eachmonitor.

1for eLuxRP 6.5 and later versions
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Note
The background image overrides the Background color defined on the Desktop tab.

3. To set a solid background color for the desktop, use the Background option on the Desktop tab.

To set a gradient background color, use the RGB values R 102, G 138, B 185.

4. To configure the position of the system bar,1 define the following entry in the
/setup/terminal.ini file in the Layout section:

Entry Value range Description

SystembarPosition 0|1 0: bottom of the screen
1: top of the screen

1for eLuxRP 6.8 and later versions
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5.8. Display tab

On the Display tab, you can choose between display settings and screen saver settings. To define dis-
play settings for one or moremonitors, open the Resolution/Layout dialog.

1 Define the number
of monitors
together with fur-
ther display
options in the Res-
olution/Layout dia-
log.

2 Configure the dis-
play:

Display
options per
monitor

multiple
monitors

3 Keyboard shortcut
to hide/show the
content of amon-
itor

4 Select and con-
figure a screen
saver

Note
For Scout EnterpriseManagement Suite 15.3 and later versions, you will find the power sav-
ing options on the Power management tab.

5.8.1. Configuring the display

1. If you have definedmore than onemonitor, in the Resolution/Layout dialog, select a bluemonitor
icon.
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2. For the selectedmonitor, use the list fields on the right to specify the screen resolution, frequency,
and rotation.

Resolution Screen resolutions that are not listedmay be added to the database table
dbo.Resolution. After modifying the table, restart the Scout Console.

Frequency Refresh rate

Rotation The screen display can be rotated 270° (left), 180° (inverted) and 90°(right).

Position Only for multiple monitors

3. To have the values supported by themonitor processed by the client, select Use monitor
Plug&Play Info (DDC).

Clear the option to activate theMonitor class field.

Note
If you decide to use adapters or the analog VGA port to connect monitors to Thin Cli-
ents, warranty for the operation of these clients will be excluded. These types of com-
binations are not part of functional acceptance tests.

4. To define the selectedmonitor as the primary one, select Primary monitor.

5. Confirmwith OK and Apply.

Important If your monitors do not support the settings you have defined, youmay have to
perform a factory reset of the device andmodify the desired screen settings.

5.8.2. Multiple monitors

Up to eight monitors can be configured.

Defining multiple monitors

1. In Device configuration > Display, click Resolution/Layout to open the dialog of the same
name.
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The field Number of monitors specifies onemonitor by default. In the field below, thismonitor is
represented by a bluemonitor icon with the number 1. By default, the first monitor is defined as
the primarymonitor (see option in the lower section).

For a different setting, see the instructions below.

2. In the Number of monitors list, select how manymonitors you want to connect to the Thin Client.

Once you have definedmore than onemonitor, their possible positions (horizontal and vertical)
are shown as graymonitor icons.

3. Double-click the graymonitor icon that shows the position of the secondmonitor.

The selectedmonitor icon is shown in blue with the number 2.

Note
Alternatively, right-click amonitor position to assign amonitor to it.

4. If you have specifiedmore than twomonitors, double-click the desired graymonitor icons, one
after the other.

Each of the definedmonitors is shown as a bluemonitor icon with its number.

5. To automatically adjust the layout after one of themonitors is removed, select the option Auto-
matic layout adjustment.1

If the option is not active, the current layout is retained regardless of the actual situation.

1fromScout EnterpriseManagement Suite 15.9
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Note
A four-monitor configuration is supported on the following devices: Dell Z50QQ, Hewlett-Pack-
ard t620 Plus and Hewlett-Packard t730.

Note
A five-monitor configuration is supported on the following devices: Fujitsu FUTROS940 and
Fujitsu FUTROS9010.

Defining positions of all monitors freely

To define the position of the first monitor, use a new layout.

1. In the Resolution/Layout dialog, in the Number of monitors list, select how manymonitors you want
to connect to the Thin Client.

The first monitor is shown as a bluemonitor icon. For each additionalmonitor, their possible pos-
itions (horizontal and vertical) are shown as graymonitor icons.

2. Click New layout.

For the number of monitors selected, all possible positions are shown as graymonitor icons:

3. Double-click the desiredmonitor position for the first monitor. Then, double-click the desiredmonitor
positions of the remainingmonitors.
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Cloning monitors (Clone mode)

If you have specifiedmore than onemonitor, by default the system configures themonitors as extended
desktops (one continuous desktop over all monitors). Alternatively, for individualmonitors, after having
defined them, you can activate the Clonemode (same display onmultiple monitors):

Right-click the last defined bluemonitor icon, and on the context menu, click Clone of x.

To deactivate the Clonemode, use the New Layout feature (see above).

Key combination for switching between clone mode and extended desktop

– fromScout Enterprise 15 2101 und eLux RP 6 2101 –

To allow users to quickly switch between the twomodes, define the following Advanced file entry for
the relevant devices:

File /setup/terminal.ini

Section Hotkeys

Entry CloneDisplays

Value <Mod4>p <Mod4> corresponds to theWindows logo key

For further information, see Advanced file entries in the Scout Enterprise guide.
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5.8.3. Screen saver

Configuring the screen saver

1. Under Display > Screen saver settings, choose between a black screen, a specific screen
saver or multiple screen savers.

2. Depending on the option chosen, select one or more screen savers from the list. To select mul-
tiple entries, press SHIFT or CTRL

Note
The HTML option allows you to choose a website.1

3. To configure each screen saver, use the settings on the right.

Enabling the screen saver

On the Power management tab, for each profile, select Enable screen saver after and specify a
waiting time inminutes.2

Locking the screen on the device

If the screen saver is enabled, eLux users can lock the screen before the configured waiting time with
the following key combination:

PressCTRL+ALT+END

Password-protected screen saver

Note
When user authentication is enabled, password protection of the screen saver becomes act-
ive and cannot be turned off.3

The password is set to $ELUXPASSWORD. For further information, seeWhere to apply user variables.

The screen saver becomes active after the defined time period and the system is locked. By pressing a
key or moving themouse, a dialog is displayed for unlocking. It provides the following options to users:

Option Button Description

The logged-on user unlocks
the screen by entering his/her
password / smart card

Unlock Default

1for Scout Enterprise 15.8 and later versions
2for earlier versions Screen > Screen saver
3for eLuxRP 6.3 and later versions
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Option Button Description

Another person leaves ames-
sage for the logged-on user

Message The screen remains locked. The logged-on user receives
a notification with themessage when he or she unlocks
the screen.

This function is enabled by default and can be disabled by
the following Advanced file entry:1File:
/setup/terminal.ini, section: xscreensaver_
dialog, entry: MessageEnabled, value: false

Another user authenticates to
log off the previous user (and
to log on), restart or shut
down the device.2

Log off Useful if devices are used bymultiple users:
Allows users to reuse devices that have been left without
logging off and therefore are blocked

Once the new user has authenticated, the Restart, Shut
down and Log off buttons become active. In any case, the
previously logged-on user is logged off.

This function is disabled by default and can be enabled by
the following Advanced file entry: File:
/setup/terminal.ini, section: xscreensaver_
dialog, entry: ShowSysCommandButtons, value:
true

Important Data lossmay occur if the Log off option is used followed by restart, shutdown, or
logoff. The user currently logged on is logged off regardless of whether the documents or
data last edited have been saved.

Download of pic ture fi les for screen saver

– for eLuxRP 6.5 and later versions –

The Scout Enterprise administrator can optionally configure the direct download of picture files to the
device into the screen saver's picture directory. To do so, use the FileFetch tool, which downloads
graphic files via wget.

Requires

The eLux package FileFetchmust be installed on the clients. Thismay requiremodi-
fications of the image definition file on the web server via ELIAS.

The picture filesmust be located in the specified directory and have the file extension
.gif, .jpg or .png. The filenamemust be numeric. Examples: 0001.jpg,
0002.jpg, 0003.png, 0004.gif

1for eLuxRP 6.8 and later versions
2for eLuxRP 6.8 and later versions

98



For the relevant clients, configure the web server and the directory of the picture files. To do so,
choose the Advanced file entries feature of the Scout Console:

File /setup/terminal.ini

Section FileFetch

Entry URL

Value <URL of the web server including path>
Example: http://webserver.sampletec-01.com/eluxng/pictures

For further information, see Files configured for transfer.

The FileFetch tool checks on each device restart whether new picture files are available on the web
server for download.

5.8.4. Hide display

– fromScout Enterprise 15 2103 –

Users can temporarily hide the content of amonitor using a predefined key combination. This can be
helpful whenmultiple monitors are used and certain information should not be visible to others present.

The following options are provided:

Option Default keyboard shortcut

1 Hide display of primarymonitor <Ctrl><Alt>1

2 Hide display of second and all other monitors <Ctrl><Alt>2

The digits 1 and 2 are fixed. Themodifier keys <Ctrl><Alt>may be defined differently by you.

Defining alternative modifier keys

Next to Hide display (Keyboard shortcut), enter the desiredmodifier keys. For further information
on how to spell the key names, see "Keyboard shortcuts" on page 84.
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5.9. Mouse/Keyboard tab

5.9.1. Configuring mouse

On theMouse/Keyboard tab, under Mouse, edit the following fields:

Option Description

Show mouse
pointer

To hide themouse pointer, clear the option.

Themouse type is automatically identified.

Touchpad1

(for mobile
devices)

On Enables touchpad (default)

Off Disables touchpad

Auto Disables touchpad when amouse is plugged in

Double-click
speed

Double-click speed defines the time interval between the two clicks of a
double-click.

Acceleration The faster themouse pointer, the smoother themovements.

1fromScout EnterpriseManagement Suite 15.9 and eLuxRP 6.9.0
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5.9.2. Configuring keyboard

On theMouse/Keyboard tab, under Keyboard, edit the following fields:

Option Description

Language Keyboard layout

Type If the value is set to Auto (default), the keyboard type is identified automatically by
the system.

Delay The delay controls how long a key needs to be pressed until the letter is retyped.

Speed The speed controls how fast a letter is retyped when a key is pressed.
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5.9.3. Advanced mouse and keyboard settings

1. On theMouse/Keyboard tab, click Advanced.

2. Edit the following fields:

Option Description

Left-
handed

Switches primary and secondarymouse buttons

Dead
Keys

Dead keys only produce visible output when they are followed by a second key-
stroke. Accent keys are dead keys as they need to be pressed before you press a
character key (`+ A => à).

Note: Some hardware platforms and some applications do not support this option.

Console
switch

Users can use key combinations to switch between consoles.

If the option is not selected, console 1 (eLux desktop) is always shown.

For further information, see Shortcuts in the eLux guide.

Extended
keys

Enablesmultimedia keys and other keyswith special functions on the keyboard.

Num
Lock

On Enables the numeric keypad of the client keyboard on device start
(default)

Off Disables the numeric keypad of the client keyboard on device start

Auto
1

Enables the numeric keypad onmobile devices and disables it on other
devices

3. Confirmwith OK and Apply.

Themodifications become active on the next restart of the Thin Client.

1for Scout EnterpriseManagement Suite 15.3 and later versions
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5.10. Firmware tab

The Firmware tab provides the relevant information required to perform a firmware update (software
update) of the devices via network.

1 Network protocol for software package transfer from the web server to the devices

2 Name or IP address of the web server providing the eLux software packages and the image files

3 Optional: alternative web server for devices connected via VPN1

4 Directory path of eLux software packages on the web server (container path)

5 Image file on the web server, also called image definition file or IDF, defines the software packages
to be installed on the devices

The image is created with the ELIAS application and thenmade available on the web server.

6 Optional: UEFI file in eLux container with assignment of device types and UEFI firmware to be
installed2

7 From 1-4 a URL is generated, which is used by the devices to update the firmware.

8 If a UEFI file is specified, the system generates a URLwhich is used by the devices to update the
UEFI system.

Note
The image file and the container path can be parametrized if required.

1fromScout 15 2107
2fromScout 15 2107
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5.10.1. Configuring firmware updates

Note
The fields Protocol, Server, Path and Image file are used to build a URL used by the devices
for firmware updates. The URL address is displayed below the Path field.
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1. For the relevant device or OU, in the Scout Console, open Device configuration > Firmware.

Option Description

Protocol Network protocol of the web server for software package transfer to the clients
(HTTP, HTTPS, FTP, FTPS)

Server Name (FQDN) or IP address of the web server containing the eLux software
packages and the image definition file

Optional: click to specify an alternative web server for devices connected
via VPN.1Enter its FQDN or IP address. The system displays amessage if the
name cannot be resolved or the IP syntax is incorrect.

Proxy
(optional)

IP address and port number (3128) of the proxy server
Format: IP address:port
Example: 192.168.10.100:3128

For Scout EnterpriseManagement Suite 15.3 and later versions, you can set a
role for the static proxy2 or choose Dynamic.

User and
Password
(optional)

Username and password (if required) to access to the eLux software container
of the FTP server

Path Directory path of eLux software packages on the web server

Use slashes / to separate directories.
Example: Use eluxng/UC_RP6 to refer to the IIS web server directory
W:\inetpub\wwwroot\eluxng\UC_RP6\

If you use ELIAS 18, specify the path name defined during the ELIAS 18 install-
ation.
Example: elias/UC_PR6_X64

To distinguish by installed eLuxmajor versions, use the container macro.

Image file Name of the image definition file (IDF) on the web server which is used for firm-
ware updates

Depending on the object rights, an IDF name can be entered or an IDF is selec-
ted from the list-field. For further information, see Protecting firmware con-
figuration.

To define an alternative image for specific hardwaremodels, use the Release
macro.

1fromScout 15 2107 and eLux RP 6 2110.1
2supported up to eLux RP 6.8
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Option Description

Check for new
version on
start / shut-
down

The device checks during start or shutdownwhether any firmware updates are
available and necessary.

To allow users to decline an update, select User must confirm update.

Elias... button Starts the ELIAS tool and opens the image definition file indicated in the Image
file field

Security... but-
ton

The Security settings allow you to define a signature check before update
through the client. Signature checks can be performed for the image definition
files and/or eLux software packages.

Reminder...
button

The Reminder Settings allow you to define whether a user is allowed to defer
a firmware update and for how long. Moreover, you can specify time intervals
for the update reminder.
For further information, see Update deferment by user.

2. Edit the following fields:

3. Test the Firmware settings on a client. To do so, on the eLux RP 6 device, on the Command
panel, click Update. For further information, see Updating the firmware in the eLux guide.

If the settings have been defined correctly, a connection to the Scout Server is set up to check
whether an update is necessary.

5.10.2. Protecting firmware configuration

Image definition files (IDF) are provided on the web server in an eLux container. Theymust be specified
in the device configuration under Firmware in order for the devices to access the intended image in the
event of an update request. Depending on the object rights defined, in the Firmware configuration,
administrators are allowed to enter individual IDF names as free text or need to select one of the pre-
defined IDFs from the list-field. The same applies to the software container (Path field) in the Firmware
configuration.

To protect such critical firmware configuration parameters, the IDFs and the container paths to be selec-
ted or configured for a firmware update can be defined in advance. In combination with the relevant
object rights, operational administrators can then only choose between predefined values.

For Scout 15 2107 and later versions, the firmware of UEFI systems1 can be updated via the same
mechanism as the software (firmware update). Therefore, an UEFI file field can be found in the same
dialog that behaves accordingly.

Setting object rights for firmware configuration fields

The object rights for the Image file, Path, and UEFI file fields are each divided into predefined and
user-defined. If you grant an administrator both rights, he can add new entries as free text as an

1from eLux RP 6 2107
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alternative to selecting a predefined entry from the list-field.

Requires
Administrator policies are enabled.

1. For the relevant OU, on the context menu, clickObject rights...

2. Select the relevant administrator /administrator group and click Edit object rights...

3. For Device configuration1 > Firmware, change the object rights as required by double-clicking
or pressing the SPACE bar:

Image file (pre-
defined)

The administrator can only select one of the IDFs provided in the Image file
list-field on the Firmware tab.

The list-field contains predefined IDFs (see below). If predefined IDFs are
missing, the list-field shows the recently used IDFs.

Image file (user-
defined)

The administrator is allowed to enter any IDF name into the text field.

Path (pre-
defined)

The administrator can only select one of the paths provided in the Path list-
field.

The list-field contains predefined paths (see below). If predefined paths are
missing, the list-field shows the recently used paths.

Path (user-
defined)

The administrator is allowed to enter any path into the text field.

The pathmust correspond to a software container on the web server.

UEFI file (pre-
defined)

The administrator can only select one of the files provided in the UEFI file
list-field.

The list-field contains predefined UEFI files (see below). If predefined files
aremissing, the list-field shows the recently used UEFI files.

UEFI file (user-
defined)

The administrator is allowed to enter anyUEFI file name into the text field.

4. Confirmwith OK.

For further information, see Administrator policy.

Predefining Firmware configuration values

1. On themenu, clickOptions > Advanced options > Predefined IDFs.

2. To add additional IDF names, click the Add button and edit the new entry. Note that the spelling
must match the actual names.

1formerly Setup
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3. For all entries you want to share in the firmware configuration, select the Valid option.

4. Confirmwith Apply andOK.

All valid IDFs, container paths and UEFI files are provided in the device configuration under Firmware
and can be used by authorized administrators.

Note
Scout Enterprise does not check the physical existence of files or container paths on the web
server.

For further information, see Predefined IDFs and containers.

5.10.3. Different hardware models

– from eLux RP 6 2103 –

To update the firmware of deviceswith an alternative image depending on the hardwaremodel, the
releasemacro is available. For example, you can update newer model types to a CR version, while
older models remain on their previous (LTSR) image. If there are no changes to the previous image, as
in the LTSR image example, all deviceswhose type is not whitelisted are unaffected by the update com-
mand.

For the releasemacro, in the firmware configuration, an __RM__ string is inserted into the image file
name.

Before an update is executed, an appropriately configured device resolves themacro using a whitelist:

If themodel type of the device is part of the whitelist, the __RM__ parameter is replaced by a
string you define. So the device will pull the alternative image with the newly created name.

If themodel type of the device is not part of the whitelist or the whitelist cannot be loaded, the __
RM__ parameter is removed from the image name. This leaves the device on the previous image
(image name as in the firmware configuration, but without the __RM__ string).

Creating a whitelist

Requires
The web server must support the file extension .mee in theMIME type settings.
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1. Create a text file named elux.mee. Then, enter the section name [__RM__].

Note
Make sure you use the correct spelling for the section name: Two underscores followed
by RM (uppercase) followed by twomore underscores.

2. Begin the second line with ReplaceWith= and then define a short string.

This stringmust be included in the image name for the alternative image, see below. If you do not
specify anything, the string CR is set by default.

3. Begin the third line with the string Product=. Then, enter all model types you want to receive the
alternative image in the same line.

Separate themodel types bywhite spaces.

Enter type names that contain white spaceswithout the white spaces.

You can retrieve themodel type of a device from the Scout Console. It is shown in the Properties
window in Asset > Hardware information > Type. On the devices, themodel type can be found
in the terminal.ini under HWInfo.Product.

4. Copy the elux.mee file into your UC_RP6_X64 container on the web server.

Preparing the software container on the web server (ELIAS)

1. Leave the existing image as you want the devices outside the whitelist to receive it.

Example: recovery.idf

2. In ELIAS, create an alternative image that you want the devices in the whitelist to receive.

For example, to be able to update newer models to a CR version, create an image containing the
eLux packages of the latest CR version.

3. Assign the same name to the alternate image, but include the string defined in the whitelist under
ReplaceWith=

Example: recoveryCR.idf

The software container now contains two imageswhose names differ only by the defined string, and the
whitelist elux.mee

Modifying device configuration

1. For your OU, open the device configuration under Firmware.

2. Under Image file, insert the __RM__ string into the file name, see screenshot above. The file
extension .idfmust be kept.
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Example: revovery__RM__.idf

Note
Make sure you use the correct spelling: Two underscores followed by RM (uppercase)
followed by twomore underscores.

3. Confirmwith Apply andOK.

The next update command on your OU will apply the alternative image to the whitelisted devices.

5.10.4. Different eLux versions

The __CONTAINER__ parameter is useful if you havemore than onemajor eLux version in use and
you want to update the firmware of multiple devices regardless of their major version. All updated
devices remain within their respectivemajor version.

The parameter replaces the container path in the URL

The __CONTAINER__ parameter is part of the directory path and parametrizes the relevant software
container (directory) on your web or FTP server. When the administrator sends an update command to
a device configured with container parameter, the parameter is resolved by amacro according to the
installed eLuxmain version.

Example:

If you run deviceswith both, eLuxRP 5 and eLux RP 6, the eLuxRP 5 devices require the UC_RP5 con-
tainer, while the eLuxRP 6 devices require the UC_RP6_X64 container. To provide all deviceswith
their appropriate software, in Device configuration > Firmware > Path of all devices , use the __
CONTAINER__macro parameter. The devices then resolve the container parameter according to their
installedmajor version to UC_RP5 or UC_RP6_X64, respectively. The advantage is that an image file
with the same name can be used for both platforms. So, in ELIAS, you would create an image with the
same name for eLuxRP 5 and for eLux RP 6.
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Note
In some cases, it can be useful to replace the container parameter by a fixed container name.
In this case, the entry in the Path field must correspond to the container name on the web
server.

ELIAS 18 containers

To use the container parameter with ELIAS 18, choose the following names for your containers:

UC_RP5 eLuxRP 5

UC_RP6 eLux RP 6.1 and eLux RP 6.2 (32-bit)

UC_RP6_X64 eLux RP 6.3 and later versions (64-bit)

For further information, see Creating a container in the ELIAS 18 guide.

Spelling of the container parameter

When replacing a fixed container name by the container parameter, make sure you use the correct
spelling:

Two underscores followed by the word CONTAINER (all uppercase) followed by twomore underscores.

Note
You can use the container parameter in the firmware configuration and in the recovery set-
tingsOptions > Recovery setttings....

5.10.5. Different BIOS systems (UEFI)

– For eLuxRP 6.2 and earlier versions –

Note
eLuxRP 5.3 and later versions support deviceswith UEFI (Unified Extensible Firmware Inter-
face). For these devices, the image file must contain the 64-bit kernel eLux package with integ-
rated UEFI support (such as kernel-4.4.x-1.UC_RP5-1.0.zip).
For eLuxRP 6.3 and later versions, the 64-bit kernel is used and the system automatically
identifies whether it is UEFI or non-UEFI.

To update UEFI devices and deviceswith a traditional BIOS in one step, use the Base
System parameter1 __BM__. It is meant for shared firmware configuration. Themacro string is inserted
into the IDF name.Whenever an update command is run, the device resolves the Base System para-
meter due to its BIOS system (device with UEFI | device without UEFI). Devices running eLuxRP 6.3 or
later versions ignore the Base Systemmacro in the image name.

1formerly: BIOS macro
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Configuring firmware updates for mixed environments

1. In ELIAS, create an image for the UEFI devices. Make sure you include the 64 bit kernel pack-
age. The image file namemust contain the string EFI.
Example: kaEFIrc.idf

2. In ELIAS, create a second image for the deviceswithout UEFI. The image namemust cor-
respond to the one for UEFI devices but without the string EFI.
Example: karc.idf

Note
The image files for UEFI devices and for non-UEFI devicesmay be located in different
containers if they are used for different eLux versions. The container parameter then
evaluates the relevant container.

3. In the Scout Console, for the relevant OU, open Device configuration1 > Firmware.

4. In the Image file field, enter the file name of your IDF. Instead of the EFI string within the file
name, insert the string __BM__ for the Base Systemmacro. The file name extension .idf and
the rest of the file namemust bemaintained.

The image file specified in the figure above requires the existence of the image karc.idf for
deviceswithout UEFI and of the image kaEFIrc.idf for UEFI devices.

5. Edit the other fields of the Firmware tab. For further information, see Configuring firmware
update.

When an update command is run, the relevant devices evaluate the Base System parameter due to
their BIOS system and convert the parameter either to EFI or to an empty string. In the example shown
above, the following URLs are generated:

1formerly Setup
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UEFI devices (x64) http://webserv.docu.sampletec.com/eluxng/UC_
RP6/kaEFIrc.idf

Non-UEFI devices (x86) http://webserv.docu.sampletec.com/eluxng/UC_
RP6/karc.idf

Devices running eLuxRP 6.3
or later

http://webserv.docu.sampletec.com/eluxng/UC_
RP6/karc.idf

The system automatically identifies whether it is UEFI or non-UEFI.

Special option for HP t630

TheHP t630 device can use a 64-bit kernel without UEFI.1TheHP t630 resolves the __BM__ para-
meter to the value x64. For the example above, the following URL is generated:

HP t630 non-UEFI
(x64)

http://webserv.docu.sampletec.com/eluxng/UC_
RP6/kax64rc.idf

Note
The HP t630 is only supported for the 64-bit Linux kernel, UEFI (x64) or non-UEFI (x64).

Spelling of the Base System macro string

Make sure to use the correct spelling:

Two underscores followed by the string BM (all uppercase) followed by twomore underscores.

Note
You can use the Base Systemmacro in the firmware configuration or in the recovery settings
Options > Recovery setttings...

5.10.6. Firmware security through signature

You can configure the firmware configuration in the Scout Console or on the client to have the client
check signatures each time before an update is performed. An update is then only performed if the sig-
nature of the image definition file (IDF) and/or the signature of the eLux software packages have been
successfully verified. The update cannot be run, however, if the IDF or one of the eLux software pack-
ages to be installed does not have a valid or verifiable signature.

Important A signature check of eLux software packages requires an update partition on the
client computer. On deviceswithout an update partition, signatures can only be checked for
image definition files but not for eLux software packages. For further information on update
partitions, see eLux partitions.

1for eLuxRP 5.7/6.2 and later versions
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Activating signature check

1. In the Scout Console, under Device configuration1 > Firmware, click Security....
On the eLuxRP 6 client, select Configuration panel > Firmware > Check signatures before
update.

2. Under Signature check before update, select the Image definition file option and/or the eLux
software packages option.

3. Confirmwith OK and Apply.

Note
In eLux, both options are provided on the Firmware tab or in the Firmware dialog.

The signature verification results are documented in the update log file on the client. After an update has
been performed, the update log file is sent to the Scout Server. To view it for the selected device, in the
Properties window, double-click the Update status field.

Certificates

Verifying the IDF signature on the client side requires the root certificate, but also the signature cer-
tificate in the local client directory /setup/cacerts. If you use own certificates for signing IDFs or indi-
vidually composed eLux packages, you can configure their transfer. To do so, use the Scout Enterprise
feature Files configured for transfer. For eLux packages provided byUnicon, all required certificates
are included in the BaseOS.

For further information on how to create IDF signatures, see Signing an image in the ELIAS guide.

1formerly Setup
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5.10.7. Update deferment by users

– applies to firmware updates (software) and UEFI updates1 –

This feature allows users to determine the update time as soon as the administrator runs an Update
command. This allows users to avoid firmware updateswhile using the device.

The client reports the current update process status to the Scout Server. The status can be viewed in
the Scout Console in the Update State/UEFI update state field of the relevant Properties window.

In addition, you can use the Report Generator to evaluate the Update State field by the value
Deferred (other: Successful, Not successful, Not necessary).

Configuring update deferment option for users

1. For the relevant devices, open Device configuration > Firmware > Reminder...

2. Select the Number of allowed deferments from the list.

3. In the Delays until next reminder list, click one or more time intervals fromwhich users can
choose when they receive the next reminder.

The ability for users to defer updates is enabled. If the admin performs an Update commandwith the
Inform user option, the user will receive a systemmessage including deferment options. For further
information, see User information before update.

Important Update deferment must be configured once on the Firmware tab and additionally
activated for each Update command you run in the Command dialog via the Inform user
option. For further information, see Performing updates via command.

1from eLux RP 6 2107
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5.11. Security tab

5.11.1. User rights

To prevent users from configuring defective or unwanted settings locally on the client, you can disable
user rights for individual features.

Functions that you disable via the user rights are not displayed on the device.

User rights can be configured for OUs and for individual devices, even for individual fields. For example,
for security reasons, youmight want to disable all tabs, but enable specific options such as some screen
settings.

Note
If you allow local device configuration for some features, you can prevent the relevant fields
and sections from being overridden by updating Scout Enterprise configuration data. For fur-
ther information, see Supporting local device configuration.

User rights are available for the following functions:

Device configuration

Application definition

General functions such as Log off

Modifying user rights for device configuration

1. On the Security tab, under Local Security, click User rights.
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TheDevice configuration node refers to the devices' device configuration and its structure cor-
responds to the Configuration panel dialogs of eLuxRP 6.

In addition, among the user rights under Security > Scout settings,1 you will find options for the
fields Info1, Info2 and Info3 shown in the Scout Console in the Properties window of a device. On
the devices, they are displayed in the Configuration panel under Information.2

2. Expand the Device configuration node and navigate to the desired function.

3. Tomodify the status of a function, double-click it or press the SPACE key.

Allowed functions are displayed in green, locked features are displayed in red.

Modified user rights become active on the next restart of the client.

Modifying user rights for application definitions

1. In the User rights dialog, expand the Application definition3 node.

2. To allow or block users from creating, editing, or deleting application definitions,change the func-
tion's status. To do so, double-click it or press the SPACE key.

Allowed functions are displayed in green, locked features are displayed in red.

1for eLuxRP 6 under Security > Info 1-3
2For eLuxRP 6.5 and later versions, only one user right is used for all tree Info fields (Security > Info1-
3).
3up to eLuxRP 6.2 and Scout Enterprise 15.3: Configuration

117



If you lock the Application definition node, on the device, the Applications tab of the Con-
figuration panel (LuxRP 6) is disabled and users will not be able to view the application defin-
itions.

Note
If you protect local device configuration and decide to lock the three application func-
tions, we recommend that you also lock the Application definition node to ensure that
the application definition data are updated correctly.

Modified user rights become active on the next restart of the devices.

5.11.2. Local security settings

Protecting control panel by device password

– for eLux RP 5 devices only –

As an administrator you can secure the opening of the control panel by requesting the device password.

On the Security tab, under Local security settings, select Lock control panel by device pass-
word.

Note
You can also hide the icon that opens the control panel. For further information, see the Sys-
tem bar settings under Advanced desktop settings.

5.11.3. Configuring mirroring

1. On the Security tab, under Mirroring, select Enable.

Note
After you enablemirroring, the device needs two restarts to be able to start the VNC
server.
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2. Click Settings... for configuration:

Option Description

Password
(optional)

If you define amirror password, the password will be reques-
ted before amirror session can be started.

The passwordmust have 6 charactersminimumand 8 char-
actersmaximum.

Read-only access Allows read access only

If not selected, in themirroring session, the user may still
select the Read only option so that the administrator has
read-only access.

User must confirmwithin Before themirror session can be started, the user must con-
firm.

Specify how many seconds you want to display the request
before the connection is aborted.

Logmirror session For eachmirror session, a log file is created and saved to a
sub-directory of the Scout Server files directory.

Encrypt data transmission Uses encrypted transmission

Allow fromScout Enterprise
only

Mirroring is only allowed if the Scout Console is used.

Log off on disconnection Automatic logoff as soon as the connection is aborted

3. Confirmwith OK and Apply.

For further information, seeMirroring.

Note
The user can cancel amirror session at any time.

5.12. User authentication

User logon and authentication can take place directly on the eLux device after device start-up or on the
back-end server to which the device connects.

eLux supports user authentication with Active Directory. This can be done via username and password
or via smart card. Both eLuxmethods are configured on the Security tab of the device configuration as
described below. Additionally, authentication via Evidian is supported.1

Note that for authentication under eLux, the appropriate eLux software packagesmust be installed on
the devices. For smart card check, in addition to the eLux functions, appropriatemiddleware and hard-
ware drivers for the smart card readers are required.

1fromScout Enterprise 15.11
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5.12.1. Configuring user authentication

Note
The eLux package User authentication modules must be installed on the clients. Thismay
requiremodifications of the image definition file on the web server via ELIAS.

1. In the device configuration, under Security > User authentication, choose from the following
authenticationmethods.

None Disables user authentication

Active Directory Active Directory (Microsoft directory service)

AD + smart card Smart card with Active Directory

Evidian1 Identity and accessmanagement via RFID or smart card

On the eLuxRP 6 client, under Security > User authentication, enable user authentication.
Then under Authentication type, choose themethod.

2. Click Edit.

3. On the AD directory tab, specify the server, server list or domains to which usersmay log on.
Definemultiple entries, if you want to create a selection for users when they log on.

For Evidian, on the Evidian server tab, specify a server or server list.

4. To help users log on quickly, select the Show last user option.

5. Only for AD: In the Domain field list, choose whether you want to show users the specified
domain so they can edit it, or whether you want to hide it.

6. Confirmwith OK.

After you have enabled user authentication, the users will be prompted for their username and pass-
word after the next device restart.
The screen saver is automatically protected by password.

Note
To devices that are not managed by Scout, administratorsmay log on with the username
LocalLogin and device password to correct any settings, if required.

1fromScout Enterprise 15.11
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Active Di rectory (AD)

Definemultiple domains that can be displayed with friendly names. In the client logon dialog, users can
then choose between default and alternative domains.

Note
To enable users to log on to different domains, the following software packagesmust be
installed on the devices: User authentication modules and Security libraries.

AD directory tab

Click Add to create one or more entries. Then edit the entry (F2 or double-click).

Option Description

Name (optional) Display name of the domain

Server, server list
or domain

IP address or name of the domain controller

To specifymore than one domain/server, separate them by spaces.

Example:
int.sampletec-01.com dev.sampletec-01.com

If the server is not located in the same subnet as the client, enter the fully qualified
domain name (FQDN).

If you definemore than one domain, users will be able to choose a domain from a
list. The domains are shownwith their display name. The first entry of the list is
the default domain in the AD logon dialog on the client. You can specify applic-
ations that are shown in only one of the domains.

Note
We recommend using aWindows time server. If the system time of the domain controller and
client differ, Active Directory queries cannot be run successfully.

User variables tab

Based on LDAP attributes, you can define local variables and use them in the device configuration and
application definition. For further information, see User variables.

Automated logon tab

– fromScout Enterprise 15.9 –

By using predefined logon data, terminals can, for example, run in kioskmode under an AD service
account.

Username, password and domain can be set as variables.
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Active Di rectory + Smart card

To enable users to use smart card readers, install the relevant middleware on the devices. sc/interface
byCryptovision is a smart cardmiddleware that integrates smart cards and other smart tokens into IT
environments. sc/interface supportsmore than 90 different smart card profiles. For further information,
see the Cryptovision web page.

Note
For smart card authentication, eLux packages for middleware (such as Cryptovision sc/in-
terface) and for the hardware drivers (such as PCSC Lite) must be installed on the clients.
Thismay requiremodifications of the image definition file on the web server via ELIAS.

Smart card tab

Option Description

Behaviour of smart card on
removal

If you choose Lock screen, in the Screen saver settings, Pass-
word protected will be selected.1

Allow logon with user-
name+password

Smart card application allows user/password logon via the User-
name & Password link.

Show Username+password
dialog by default2

Logon via username + password can be forced despite smart card
configuration.

To use this option, enable Allow logon with username+password.

Certificate tab

Certificate-based logon requires verification of the user certificate against the root certificate.

Select one or more root certificates, and then click Add....

The selected certificates are transferred to the device.

User variables tab

Based on LDAP attributes, you can define local variables and use them in the device configuration and
application definition. For further information, see User variables.

For the AD directory and Automated logon tabs, see Active Directory (AD).

1for eLuxRP 6.3 and later versions
2fromScout EnterpriseManagement Suite 15.5 and eLux RP 6.6
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Enhanced logging for smart card authentication

When using PCSC Lite, you can have an additional log file /tmp/PCSCDlog.txt created. To do so,
temporarily enable enhanced logging via Device configuration > Diagnostics > Enhanced logging for
smart card support1. After diagnosis, we recommend that you disable the enhanced logging function in
order to avoid unnecessary strain on the flashmemory capacity of the device.

Ev idian

Note
The eLux package Evidianmust be installed on the clients.
For smart card authentication, eLux packages for themiddleware (such as Cryptovision
sc/interface) and for the hardware drivers (such as PCSC Lite) must be installed on the cli-
ents. Thismay requiremodifications of the image definition file on the web server via ELIAS.

With Evidian accessmanagement, you can connect via RFID or smart card. Evidian uses the SOAP net-
work protocol.

On the Evidian server tab, create an entry and edit the following fields:

Option Description

Name (optional) Display name of the Evidian server

Server or server list Specify your Evidian server depending on whether you use HTTP or HTTPS in
the following format:

http://<FQDN or IP address>:9764/soap
https://<FQDN or IP address>:9765/soap

To specifymore than one server, separate them by spaces.

Use smart card Enables authentication via smart card

Allow logon with
user-
name+password

Usersmay alternatively log on with username and password.

Secret Copy the secret from the registry entry of the Enterprise AccessManagement
server

HKEY_LOCAL_
MACHINE\SOFTWARE\Enatel\WiseGuard\FrameWork\​Authentica

tion from the key ExternalRoamingSessionSecret. Do not encrypt.

You can configure to show users the system bar during logon. This allows them to access the Con-
figuration Panel and Command Panel. For further information, see "Starting Configuration panel from
logon dialog" on page 125.

1fromScout Enterprise 15.10 and 15.9.1000 for eLuxRP 6.8 and later versions

123



5.12.2. Additional options for AD users

If Active Directory is used for user authentication, users log on with their AD domain account and pass-
word on their device. Pass-through logon is supported by applicationswhich provide access to back-
end systems (Citrix, RDP, VMware).

On the device, in the Configuration panel under Information, the user logged on is shown.1

Change password

To change the password, users choose the eLux command Logoff and then click Change password:

Password-protected screen saver

Note
When user authentication is enabled, password protection of the screen saver becomes act-
ive and cannot be turned off.2

The password is set to $ELUXPASSWORD. For further information, seeWhere to apply user variables.

The screen saver becomes active after the defined time period and the system is locked. By pressing a
key or moving themouse, a dialog is displayed for unlocking. It provides the following options to users:

Option Button Description

The logged-on user unlocks
the screen by entering his/her
password / smart card

Unlock Default

1for eLuxRP 6.4 and later versions
2for eLuxRP 6.3 and later versions
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Option Button Description

Another person leaves ames-
sage for the logged-on user

Message The screen remains locked. The logged-on user receives
a notification with themessage when he or she unlocks
the screen.

This function is enabled by default and can be disabled by
the following Advanced file entry:1File:
/setup/terminal.ini, section: xscreensaver_
dialog, entry: MessageEnabled, value: false

Another user authenticates to
log off the previous user (and
to log on), restart or shut
down the device.2

Log off Useful if devices are used bymultiple users:
Allows users to reuse devices that have been left without
logging off and therefore are blocked

Once the new user has authenticated, the Restart, Shut
down and Log off buttons become active. In any case, the
previously logged-on user is logged off.

This function is disabled by default and can be enabled by
the following Advanced file entry: File:
/setup/terminal.ini, section: xscreensaver_
dialog, entry: ShowSysCommandButtons, value:
true

Important Data lossmay occur if the Log off option is used followed by restart, shutdown, or
logoff. The user currently logged on is logged off regardless of whether the documents or
data last edited have been saved.

Serv ice app

– for eLuxRP 6.4 and later versions –

You can enable AD users to start eLux in servicemode. To do so, define a service app that can be star-
ted from the logon dialog using the Service button. For further information, see Defining a service app.

Starting Configuration panel from logon dialog

– for eLuxRP 6.5 and later versions –

You can enbale AD users to access the Configuration panel before they log on. This allows them to con-
nect to aWLAN or VPN or to change the language before logging on.

You can show the system bar for users authenticating via Evidian before they log on. This allows them
to access the Configuration panel and Command panel.

For the relevant devices, under Security > User rights on the bottom, enable the user right Start
Config panel from logon dialog.

1for eLuxRP 6.8 and later versions
2for eLuxRP 6.8 and later versions
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AD: On the next restart, the logon dialog shows the button for opening the Configuration panel ,
so AD users can access the options you allow them to.

Evidian:While the Evidian authenticationmanager is displayed, usersmay open the Configuration
Panel dialogs and access commands such as Shut down and Restart in the Command Panel.

Note
By default, the user right Start Config panel from logon dialog is disabled.
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5.12.3. User variables

Note
If you want to use user variables, the User authentication modules andOpen LDAP pack-
agesmust be installed on the clients. Thismay requiremodifications of the image definition file
on the web server via ELIAS.

The values of user variables are used by the authentication server for the log-on process. User vari-
ables can also be used in some fields of the eLux control panel.

Predefined user variables are

$ELUXUSER
$ELUXDOMAIN
$ELUXPASSWORD

The variables are used when users log on and user authentication is active.

Where to apply user variables

Note
To use this feature, user authentication via Active Directory is required.

When they are applied, user variablesmust have a leading $. User variables can be applied in the fol-
lowing fields:

Device configuration

Field User variable

Drives Username $ELUXUSER

Password $ELUXPASSWORD

Directory, Server, Share Any $ELUX variable

Browser home directory Any $ELUX variable

Power man-
agement1

Enable screen saver
(alsomanual activation)

$ELUXPASSWORD

1for Scout Enterprise 15.2 and earlier versions: Screen tab
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Application definition

Field User variable

Citrix

RDP

VMwareView

Server Any $ELUXvariable

Username $ELUXUSER

Password $ELUXPASSWORD

Domain $ELUXDOMAIN

Browser Proxy type, Proxy port Any $ELUXvariable

Tarantella Server Any $ELUXvariable

Local / Custom
application

Parameter for all programs run from
the command line

Example:
eluxrdp /vint.sampletec-
01.com.de /u:$ELUXUSER
/p:$ELUXPASSWORD

Any $ELUXvariable

Defining new user variables

Note
To use this feature, user authentication via Active Directory is required.

You can define your own user variables as local variables based on LDAP attributes. The variable defin-
ition has the form Local variable = LDAP variable

1. On the Security tab, under User authentication,1 select Active Directory (AD) or
Active Directory + Smartcard.

2. Click Edit.

1formerly Access authorization
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3. Under User authentication > User variables, edit the following fields:

Option Description

Local variable The name of the local variablemust begin with the string ELUX (but without
$), which can be followed by any characters.
Example:
ELUXFULLNAME

More than one entry can be transferred if you append a # sign to the vari-
able name.
Example:
ELUXmemberOf#

LDAP variable To be able to use the LDAP variables, the relevant LDAP variable names
are assigned to the individual variable as an attribute.

Example 1:
ELUXFULLNAME = displayName

Example 2:
ELUXmemberOf# = memberOf

If there are several memberOf valueswithin the seach base on the authen-
tication server, they are assigned to the local variables ELUXmemberOf_
1, ELUXmemberOf_2 and so on.

4. Confirmwith OK and Apply.

Note
User variables are defined without a leading $, but when they are applied theymust begin with
$.
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5.13. Multimedia tab

The audio output devices are grouped in classes depending on their connector:

USB USB port

Analog TRS audio jack (phone connector) or integrated devices

Digital DisplayPort or HDMI

For each device class, you can control the volume level andMute option separately.

By default, the priority is defined: USB – Analog – Digital.

To change priority, move the list entries by using drag-and-drop operations.

The audio input devices are grouped in classes depending on their connector:

USB USB port

Analog TRS audio jack (phone connector) or integrated devices

For each device class, you can control the sensitivity andMute option separately.

By default, the priority is defined: USB – Analog.

To change priority, move the list entries by using drag-and-drop operations.
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Option Description

Volume (Output) Slider to control the playback sound level for the selected device class (0 to 100)

Sensitivity (Input) Slider to control the level of sensitivity for recording for the selected device class
(0 to 100)

Mute (Output and
input)

No sound is reproduced / recorded

System beep Acoustic feedback signal when switching off the client

Priority of device
classes

By using drag-and-drop operations, you can change the priority of the device
classes for input and output. The top entry has the highest priority.
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5.14. Drives tab

Define shared network directories on youWindows server as drives that can be accessed by the clients.
Any drive defined this way can for example be used as browser home directory.

5.14.1. Defining a network drive

1. In Device configuration > Drives > SMB Drives, click New.

2. Edit the following fields:

Option Description

Directory Any name for the directory

Server Name of the server including the path

Share Windows share name

Username and
password

Windows username and password to access the directory

Domain Can alternatively be specified in the User field:
<Domain\User> or <User@Domain>

AD authen-
tication
(only Scout
Enterprise)

The Active Directory logon data are used to access the directory.
The fields Username and Password are disabled.

Test
(only eLux)

Checks if the network share can be accessed with the specified data

Note
To access network driveswith AD authentication, the software package Network drive
share and the included feature package Linux Key Management Utilities must be
installed on the clients. Thismay requiremodifications of the image definition file on the
web server via ELIAS.

3. ClickOK and Apply.

The directory path /smb/ is automatically inserted before the directory name. The data are provided on
the local flash drive under /smb/<Directory name>.

Example: /smb/share
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Note
Here, youmay apply LDAP user variables. For further information, seeWhere to apply user
variables.

Tomake browser settings such as bookmarks permanently available, define a network drive as the
browser home directory. For further information, see Browser home directory.

5.14.2. Mount points

Mount points are used to access local resources through an application. The followingmount points are
provided by eLux:

Samba /smb

NFS /nfs

Internal CD-ROM /media/cdrom

USB devices /media/usbdisk*

*For USB devices, mount points are assigned chronologically: The first device is assigned
/media/usbdisk, the second one media/usbdisk0, etc.

Mounted devices are shown as live information icons. For managed devices, the administrator can sup-
press the display of live information icons.

Note
Due to security reasons, Allow mass strorage devices must be selected on the Hard-
ware/Peripherals tab.

Note
Drivemapping for access to local resourcesmust be defined in the relevant application defin-
ition. For Citrix ICA applications, see ICA software defaults. For RDP applications, see
Advanced application settings.
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5.15. Printer tab

eLux supports printing from local applications both to locally connected printers and to network printers.
In addition, other systems or servers within the network can use a locally installed printer on a Thin Cli-
ent running eLux. Next to the protocols LPR and TCP direct printing, proprietary protocols are also avail-
able.

In the Scout Console, in Device configuration > Printer > New, you can define and configure local
printers with logic names.

5.15.1. Defining a locally connected printer

1. In the device configuration, on the Printer tab, click New.

2. In the Define printer dialog, type a name for the printer.

3. In the Connection type list, choose how the printer is connected to the client.

4. In the Filter list, choose whether to use a filter. To print via a Linux Shell, select the text filter.
For further information on the filters, see Defining a network printer.

5. Confirmwith Apply andOK..
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5.15.2. Defining a network printer

1. In the device configuration, on the Printer tab, click New.

2. In the Define printer dialog, type a name for the network printer.

3. In the Connection type list, select Network.

4. In the Filter list, select one of the following options:

Option Description

None The printing data from the session are forwarded to the printer in an
unfiltered format.

Text Enables printing from a local shell

PCL2 Enables printing to non-postscript printers in PCL format

If the users do not print from aCitrix session, the connected printer must sup-
port one of the following languages: PCL2, PS(Postscript) or PDF.

5. In the Printer address field, enter the IP address of the server.

6. In the Printer queue field, enter the share name of the printer.

7. In the Driver name field, enter the printer's driver name. The driver is used for printing from aWin-
dows session.
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Important Make sure that the printer driver name is spelled in the sameway as the name of
the installed driver on the server. The name is case-sensitive and sensitive to white spaces.
If the names do not match, the server cannot identify the driver.

For further information, see Citrix auto-created printers.

8. Confirmwith OK and Apply.

For further information, see your printer'smanual.

5.15.3. Sharing printers

All printers defined in Device configuration1 > Printer can be shared with other systems via LPD within
the network.

1. In Device configuration > Printer, select the Print service activated option.

2. Activate theWindows LPD service (Line Printer Demon).

This option ensures that the print service is started at the client. All printers defined in the list can be
used to print jobs from network devices.

The printers are controlled by the CUPS server.

5.15.4. Selecting a default printer

1. In the Scout Console, for the relevant OU or device, open Advanced device configuration2 >
Printer.

2. In the Default printer list, select the printer that you want to be the default printer.

The list provides all defined printers for this element.

1formerly Setup
2formerly Advanced settings
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5.15.5. CUPS

TheCUPS server is installed by default on the clients (Print Environment (CUPS) package) and allows
printing from local applications and the use of locally attached printers.

The CommonUNIX Printing System™ (CUPS™) is a free-of-charge software fromEasy Software
Products. It provides a common printing interface within local networks and dynamic printer detection
and grouping. For further information, see www.cups.org.

The CUPS server can print to serial and parallel ports, USB and the network (LPD).

The CUPS printing system is particularly useful to print from local applications on the Thin Client (for
example fromAdobe Acrobat or a local browser). These local applications have PostScript as output
format. If you do not have a PostScript printer, you are required to install a filter such as PostScript to
PCL on the CUPS server.

CUPS web interface for print management

Note
The eLux package Print Environment (CUPS) and the included feature packageWeb admin-
istration servicemust be installed on the clients. Thismay requiremodifications of the image
definition file on the web server via ELIAS.

Tomanage print jobs, the user can access the CUPS web interface in a local browser with the following
URL:

http://localhost:631

Theweb interface can also be used by the administrator to configure the CUPS server. To do this, you
must enter the credentials for the local administrator account (LocalLogin and device password).
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5.15.6. Citrix auto-created printers

Citrix XenApp provides automatic configuration of printers (autocreated printers or dynamic printer
mapping). When the user logs on through a Citrix connection, an automatic printer definition is created
on the Citrix server. The printer definition can only be used by the logged-on user and is deleted when
the user logs off.

Citrix uses either the specified printer driver or, if not available, the universal Citrix printer driver, which is
not tied to any specific device.

Configuring local printer for auto-creating on the client:

1. In Device configuration > Printer, specify one or more printers.

2. In the Define Printer dialog, in the Name box, enter theMicrosoft Windows printer's name precisely
as listed in the drivers list of the server. The name is case-sensitive.

When the user connects to the Citrix server, the automatically created client printers are shown in the
printer settings.

If the specific driver is not installed on the application server or the name is not identical, the client printer
can not be created and the universal Citrix printer is used.

Citrix Universal Printing

The universal Citrix printer and various printer settings can be configured on the Citrix server, admin-
istrator rights provided.

For further information, see the Citrix Product Documentation.

5.15.7. TCP direct print

The print data can be received directly via TCP/IP and sent to the parallel port or USB port to the printer.
The data are not modified before printing and there is no spooling of print jobs. TCP/IP handles the flow
control.

Configuring TCP direct print

1. In Setup> Printer, under TCP direct print, select the option Enabled.

2. Specify the relevant port number for the communication.
The default port numbers are:
9101 for USB printers
9100 for parallel port printers

Note
Note that the specified ports are opened on the client.
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To print from aWindows session, for the printer port, choose a standard TCP/IP port. Specify the client
IP address and the TCP/IP port selected in the previous step. Select Raw for the protocol inWindows.

5.15.8. ThinPrint

ThinPrint software from ThinPrint GmbH allows optimized network printing across various platforms.
ThinPrint is a print protocol that, unlike TCP direct print, LPR or CUPS, allows bandwidth limitation. It is
therefore recommended for networkswith low bandwidth (WAN).

The software consists of a server component and a client component. The ThinPrint server processes
the print data for the target printer and sends them to the client in compressed form. The ThinPrint client
receives the print jobs from the server, decompresses and forwards them to the selected printer.
ThinPrint server and client are connected via TCP/IP.

Configuring ThinPrint

1. Install the ThinPrint client on the device.

2. Connect a printer.

3. In Device configuration1 > Printer > New, define the printer, and under ThinPrint, select the Con-
nect option. Optionally, enter a class name of up to 7 characters.

4. If you useWindowsCE clients, in Device configuration > Printer under ThinPrint, select the rel-
evant protocol.

5. Configure the ThinPrint server. For further information, see the ThinPrint documentation on
www.thinprint.com.

1formerly Setup
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5.16. Hardware tab

5.16.1. USB mass storage devices and card readers

Option Description

Allow mass stor-
age devices

Allows using connected USBmass storage devices

If the local use of USB devices viamountpoints is allowed, connected
USB devices are shown on the system bar in the systray (eLux RP 5) or live
information (eLux RP 6).1

No local use, only
USB redirection

Restricts the use of USBmass storage devices to USB redirection within con-
figured sessions on a backend. There are nomount points provided to use USB
mass storage devices locally on the eLux client.

Use rules Restricts the use of USBmass storage devices according to defined rules:

Using USBmass storage devices can be restricted to deviceswith specified VID
(Vendor ID) and/or PID (Product ID) such as an individual USB stickmodel.
Moreover, the USB rules can be applied to further USB device classes such as
smart card readers.

Edit Opens the USB rules dialog: Define rules to explicitly allow or deny individual
devicemodels.

1for eLuxRP 6.4 and later versions
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Option Description

Inform user on
changes

When a USBmass storage device is connected or disconnected, a live inform-
ationmessage1 is displayed.

Card reader Enables card readers on the selected port

Power line fre-
quency 2

Allows to set the refresh rate of webcams to 50 Hz or 60 Hz

COMport settings Set particular COMport settings such as speed, parity, stop bits

Write filter
(onlyWindows
Embedded)

The user is not allowed to store local data on their WindowsEmbedded client.

Note
To enable users to use smart card readers, ensure to install the relevant middleware on the cli-
ents. sc/interface byCryptovision is smart cardmiddleware that integrates smart cards and
other smart tokens into IT environments. sc/interface supportsmore than 90 different smart
card profiles. For further information, see the Cryptovision web page.
To use sc/interface, the eLux package Cryptovision sc/interface PKCS11must be installed
on the clients. Thismay requiremodifications of the image definition file on the web server via
ELIAS.

1for eLuxRP 6.4 and later versions
2fromScout Enterprise 15.10 and eLux RP 6 2103
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5.16.2. Defining rules for using USB devices

1. For the relevant OU or device, open Device configuration1 > Hardware > USB > Edit.

2. In the list-field, select a set of predefined rules as template.

3. Double-click into the relevant line, or select a line and press F2.

4. Modify the rule by using the example rules below.

The values of themanufacturer ID (VID) and product ID (PID) can be found on the device in the
Config panel under Peripherals > USB > Information):

5. Confirmwith OK.

1formerly Setup
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Example rules

Rule Code

Allow a specific USB mass
storage devicemodel only

ALLOW: VID=0781 PID=5151 # Allow particular USBmodel
(Example: SanDisk Cruzer Micro)
DENY: CLASS=08 # Deny all devices of the classMASS
STORAGE DEVICES.

Deny a specific smart card
model only

DENY: VID=18a5 PID=0302 # Deny particular smart cardmodel
(Example: OmnikeyCardMan 3821)
ALLOW: CLASS=0B # Allow all devices of the class SMARTCARD

Deny all printers, mass stor-
age devices, smart card read-
ers.

DENY: CLASS=07 # Deny all devices of the class PRINTERS
DENY: CLASS=08 # Deny all devices of the class
MASS STORAGE DEVICES
DENY: CLASS=0B # Deny all devices of the class SMARTCARD

Deny all devices DENY: # Deny all devices.

The syntax of USB rules corresponds to the syntax of Citrix USB policy rules.

Important The USB rules affect all USB device classes including 03 HID (Human Interface
Devices). If you deny the 03 HID class, themouse and keyboard will be deactivated. If you
deny all classes (DENY: # Deny all devices), also internal USB hubs and devices
with manufacturer-specific device classes such asWLAN modules on the client will be
affected. For specific hardware configurations, youmight encounter issues during the boot
process of the client. We strongly recommend performing tests before using this option.

5.16.3. Defining rules for USB redirection

For Citrix Receiver 13.x and later versions and VMware Horizon 4.1 and later versions, you can define
USB filtering rules for USB redirection of connected USB devices from eLux.

1. Type the required USB filtering rules into the appropriate configuration file:

Application Configuration file Examples

Citrix /setup/ica/usb.conf ALLOW: VID=0781 PID=5151
DENY: CLASS=08

VMware /setup/elux/.vmware/default-
config

viewusb.ExcludeFamily = "storage"
viewusb.IncludeVidPid = "vid-0781_
pid-5151"

2. To transfer the configuration files to the clients, use the Scout Enterprise feature Files configured
for transfer. For further information, see Files configured for transfer.

On the next restart of the relevant clients, the USB redirection rules become active.
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5.16.4. Safe removal of USB devices

Any connected USBmass storage devices should always be removed by using the Remove safely fea-
ture to ensure that all data are saved.

Users on their device can right-click the USB icon (live information icon) on the system bar1 and then
click Remove safely.

Defining a key combination for safe removal of all USB devices

In the Scout Console, you can define a key combination that allows the users to remove all connected
USBmass storage devices safely in one step. The following instructions use the key combination
ALT+WINDOWS+S as an example:

1. In the Scout Console, for the relevant clients, open Advanced device configuration > Advanced
file entries.

2. Define the following entry

File /setup/terminal.ini

Section Layout

Entry UsbUnmountHotKey

Value <Alt><Mod4><Hyper>s

For further information, see Advanced file entries.

5.16.5. Enabling Bluetooth audio devices

– for eLuxRP 6.6 and later versions –

You can allow the use of Bluetooth audio devices centrally from the console. Users can then search for
devices in the eLuxConfig panel and connect.

In the Scout Console, for the relevant clients, configure the following Advanced file entry:

File /setup/terminal.ini

Section Bluetooth

Entry Enabled

Value true

For further information, see Advanced file entries in the Scout Enterprise guide.

For further information, see also Connecting Bluetooth audio devices in the eLux guide.

1for eLuxRP 6.4 and later versions
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5.16.6. Webcams

Webcams on devices are listed under USB > Information even if they are built in. To allow users to pre-
view awebcam image, specify an app that can be used to display it.1The app supportsmultiple cam-
eras, both built-in and USB-connected cameras.

Defining an app for camera preview

– from eLux RP 6 2107 –

Note
In the eLux Desktop Extensions package, the feature packageWeb camera preview must
be installed on the devices. Thismay requiremodifications of the image definition file on the
web server via ELIAS.

1. Add a new application and, in the Application properties, select the application type Local.

2. Edit the following fields:

Option Description

Name Name for the application

Application Custom

Parameter bash cameraPreview

3. Confirmwith Apply andOK.

When users launch the app, they select one of the connected cameras to get a preview of the camera
image. If only one camera is available, the preview window is displayed when the app is started.

1from eLux RP 6 2107
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5.17. Diagnostics tab

TheDiagnostics tab allows you to configure the Device diagnostics feature that you can use to
request diagnostic files from a client:

Option Description

Debug level If the Debug level is set to On (Enhanced debugging), by using the Device dia-
gnostics feature you run predefined commands on the client and retrieve a set of
configuration and log files to a greater extent than without enhanced debugging.

If you require technical support fromUnicon, switch on enhanced debugging
before you performDevice diagnostics.

Note
Make sure to switch off the Debug level after having performed device diagnostics. Other-
wise, you risk to exceed thememory capacity of the Thin Client.

Send files to Destination for the files requested from the client

Enhanced logging
for smart card sup-
port1

Creates an additional log file /tmp/PCSCDlog.txtwhen PCSC Lite is used

Device diagnostics is performed by using an online command. For further information, see Device dia-
gnostics.

5.18. Power management tab

– for Scout EnterpriseManagement Suite 15.3 and later versions –

Especially when usingmobile devices, you will need options for power management. By using profiles,
on the Power management tab, you can pre-define power management settings for your computer.
These settings become active when you or the system enable the relevant profile:

High performance: Favors performance, but may usemore energy

Power saver: Saves energy by reducing computer performance and screen brightness

You can either explicitly activate one of the power management profiles or, for mobile devices, you can
let the system choose by selecting the Auto option: If the device is plugged in, the profile High per-
formance will be active. If the device is on battery power, the profile Power saver is activated.

For both profiles, you can additionally distinguish between working and non-working hours.2You can
further optimize energy consumption bymakingmore rigorous use of energy saving options outside
working hours. To do so, you are required to specify your working hours first. Once you have defined
working hours, based on these, the system automatically switches between theWorking hours profile

1fromScout Enterprise 15.10 and 15.9.1000
2for Scout Enterprise 15.8 and later versions
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and the Default (Non-working hours) profile. Important: If you choose not to define working hours, the
systemwill use the Default profile settings, regardless of the day of the week and time.

Setting a power management profile

On the Power management tab, from the Active power management profile list, select a profile or
the Auto option.

The settings defined in the profile become active.
The Auto option activates the High performance profile if the device is plugged in, and the Power
saver profile if the device is on battery power.

Profile-independent options

Option Description

Low battery noti-
fication

For deviceswithout power suppy:
Battery status in percent, fromwhich the user is notified

Log off user
before going to
sleepmode1

Usersmust log on after the computer wakes from sleepmode.

5.18.1. Configuring power management profile

Note
If you define your working hours, you can also specify which energy-saving options you want
to apply outside of working hours.2As long as you do not define working hours, the energy-
saving options apply non-stop (24/7).

1for Scout Enterprise 15.8 and later versions
2fromScout EnterpriseManagement Suite 15.8
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1. Next to Power management profiles, click Edit and then select the tab for the required profile.1

To define profiles for non-working hours, first define the working hours.2

1fromScout EnterpriseManagement Suite 15.8, formerly: from the Power management profile list,
first select a profile, then click Edit.
2fromScout EnterpriseManagement Suite 15.8
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2. For each profile you want to use, edit the following fields:

Option Description

Screen bright-
ness

Screen brightness in percent for the selected profile

Movemouse pointer over the slider to display the percentage.

Turn the display
off after

Determineswhether, after a specified number of minutes, the display is
turned off when the user is not using the device (idle state)

Enable screen
saver after

Determineswhether, after a specified number of minutes, the screen saver
is enabled when the user is not using the device (idle state)

On idle after –
Action

Determineswhether, after a specified number of minutes, the selected
action is performedwhen the user is not using the device (idle state):1

Shut down

Sleep mode
Restart2

Log off3

On idle – Action
(User logged
off)4

When the user is logged off:Determineswhether, after a specified number
of minutes, the selected action is performedwhen the user is not using the
device (idle state).5

Action on 'Clos-
ing the lid'

Action that is performedwhen the user is closing the lid:

No action
Turn the display off
Shut down
Sleep mode

Action on 'Press-
ing the power but-
ton'

Action that is performedwhen the user presses the power button:

No action
Turn the display off
Shut down
Sleep mode

1fromScout EnterpriseManagement Suite 15.9: Default is sleepmode after 20minutes (for High per-
formance profiles)
2fromScout EnterpriseManagement Suite 15 2101
3fromScout EnterpriseManagement Suite 15 2101
4fromScout EnterpriseManagement Suite 15.10
5fromScout EnterpriseManagement Suite 15.9: Default is sleepmode after 20minutes (for High per-
formance profiles)
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Option Description

Action on 'Press-
ing the Power-
/Sleep key'1

Action that is performedwhen the user is pressing the Power/Sleep key on
their keyboard (requires a suitable keyboard):2

No action
Shut down
Sleep mode3

3. Confirmwith OK.

Note
The sleepmode corresponds to Suspend to RAM (S3). For further information, see Sleep
mode (Suspend).

5.18.2. Defining working hours

– for Scout EnterpriseManagement Suite 15.8 and later versions –

Requires
User right Define working hours

1. On the Power management tab, next toWorking hours click Edit.

2. Select all weekdays that are working days and that are relevant to working times. To select mul-
tiple entries, press SHIFT or CTRL.

3. Select the earliest time for the start of work (From). This time refers to all defined working days.

4. Select the latest time for the end of work (To). This time refers to all defined working days.

1fromScout EnterpriseManagement Suite 15.5
2If this key is not available, the configuration has no effect.
3Default
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5. Confirmwith OK.

Once you have defined working hours, the High performance and Power saver profiles are divided into
sub-profiles for Working hours and Default (non-working hours). Switching between the two sub-pro-
files is based on the working times you have defined.
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5.18.3. Sleep mode (Suspend)

– fromScout EnterpriseManagement Suite 15.3 and eLuxRP 6.3 –

The sleepmode corresponds to Suspend to RAM (S3).

To put their device into sleepmode, users click a button in the extended Command panel. The sleep
mode can also be activated by the system if the power management options are configured accordingly.

When the device goes into sleepmode, the eLux user remains logged on by default. After reactivating
the device, users can continue working right away. This assumes that the backend is configured accord-
ingly: When an application is disconnected, the user must not be logged off automatically.

If you want users to log on and authenticate again after the device wakes from sleepmode, select Log
off user before sleep mode in the Device configuration > Power management.1The user is then
logged off and when the device wakes from sleepmode is given the eLux logon dialog.

Note
In the Scout Console, the Properties window shows the status of a suspended device as
Switched off (Suspended).

1fromScout Enterprise 15.8 and eLuxRP 6.7

152



5.19. Troubleshooting device configuration

The solutions provided below refer to the Scout Console in the first place.

Error / problem Reason Solution

When you use USB
multimedia devices
such as headsets or
webcams, the screen
freezes or the window
cannot be focused.

The USB operating ele-
ments register them-
selves as keyboard or
mouse devices in the
system.

Prevent the registration as input devices by defin-
ing a terminal.ini entry.

The basic functionality of the operating elements
is not affected.

For further information, see Preventing regis-
tration of USBmultimedia components.

Multimedia USB
devices, connected via
DisplayPort to eLux
RP 5 devices with an
AMD processor, do
not play back sound.

Sound reproduction via
DisplayPort is disabled.

Enable sound reproduction by defining a
terminal.ini entry. To do so, use the Scout
Enterprise feature Advanced file entries:

File /setup/terminal.ini

Section Screen

Entry Radeon.Audio

Value true

Alternatively, use a separate audio cable.

Monitor via DisplayPort
with AMD GPU: After
changing to lower res-
olution themonitor
brings anOut of range
error message.

The resolution on this
monitor interfereswith
the configured sound
reproduction via Dis-
playPort.

Disable sound reproduction via DisplayPort. This
will fix themonitor error. To do so, use the Scout
Enterprise feature Advanced file entries:

File /setup/terminal.ini

Section Screen

Entry Radeon.Audio

Value false

When you use a touch
screen, the location of
a fingertip touch is not
recognized precisely.

Themonitor has not
been calibrated pre-
cisely enough.

To calibrate themonitor, configure a custom
application by using the parameter
calibrator. Then start the application.
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Error / problem Reason Solution

Only eLuxRP 5.7.x:

In dual monitor mode,
if the secondmonitor is
configured to vertical,
the desktop icons are
not displayed (cor-
rectly).

For some resolutions,
the desktop icons on
the primarymonitor can-
not be displayed when
the secondmonitor is
vertically aligned and
the lower screen area is
referenced.

For eLux RP 5.7.3000 and later versions: Use a
new parameter to configure the vertical alignment
to the upper screen area (top). To do so, use the
Scout Enterprise feature Advanced file entries:

File /setup/terminal.ini

Section Screen

Entry VerticalAlignment

Value top

The default value is bottom.

Display/general graph-
ics issues

The feature package
for hardware accel-
eration HwVideoAc-
cDrivers is not
installed.

Activate the HwVideoAccDrivers FPMwithin the
XOrg package in the IDF.

Hardware acceleration
(installed with the
HwVideoAccDrivers
FPM) is not supported
by the device and
causes problems.

To exclude individual device types from hardware
acceleration, create a blacklist that is transferred
and locally saved to the clients by using the Scout
Enterprise feature Files:

/setup/hwaccBlacklist

In the text file hwaccBlacklist, list the rel-
evant device types, one per line. The name of the
device typemust be identical to the string that is
shown in the Scout Console, in the Properties
window under Asset > Hardware information >
Type.

Example:
FUTRO S920
D3314-B1
HP t620 Dual Core TC

For all device types listed in the blacklist, hard-
ware acceleration is disabled.

AD logon to eLuxRP
6.x does not work.

Port 389 is configured
for the authentication
server.

Do not define a particular port for the authen-
tication server.

Note
After the terminal.ini file has been updated on the client, another client restart might be
required to enable the new setting.
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5.19.1. Preventing registration of USB multimedia components

The registration of USB devices as input devices can be prevented by defining a terminal.ini
entry. To do so, use the Advanced file entries feature of the Scout Console.

1. In the Scout Console, for the relevant clients, open Advanced options > Advanced file entries.

2. Define the following entry

File /setup/terminal.ini

Section Xorg

Entry IgnoreUsbInput

Value
(VendorID)
or

VendorID_1:ProdID_1,VendorID_2:ProdID_2
Example: 0b0e:034c,047f:c01e

Important: Only use lowercase letters for hexadecimal values!

You can replace individual characters by the wildcard character ?.
Example: 0b0e:???? filters all products of a specific vendor.

Value
(VendorName)

Alternatively, you can filter by vendor name:
Example: Jabra,Netcom

White spaces or slashes in the vendor namemust be replaced by an
underscore _.

The vendor name can be entered as a sub-string.
Exxample: Netcom finds GN Netcom and GN Netcom A/S.

Vendor names can beOR-linked:
Example: Jabra|Sennheiser

Note: To identify vendor names or IDs, use the follwing command:
udevadm info --export-db | grep -Ew "(NAME|ID_
VENDOR)"

For further information, see Advanced file entries.

Note
After the terminal.ini file has been updated on the client, another client restart might be
required to enable the new setting.
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6. Advanced device configuration and Advanced options

The device configuration defined globally in Options > Base device configuration or for individual OUs
or devices in their Device configuration can be extended as follows:

Override applied options and add further options for individual devices or OUs by using the
Advanced device configuration1

The Advanced device configuration is applied onOU or device level.

Open the relevant context menu and click Advanced device configuration...

Note
Inheritance is used for Advanced device configuration, either. By default, the option
Use parent of Advanced device configuration2 is selected. You can, however, clear
this option on some of the tabs.

Apply further options to all devices by using the Advanced options

The Advanced options are applied to all devices.

On the Scout Consolemenu, clickOptions > Advanced options.

Some functions such as Files (configured for transfer), Advanced file entries and Update options can
be found in both dialogs. Use Advanced device configuration to apply the function to individual
devices. Use Advanced options to apply the function to all devices.

1formerly Advanced settings
2formerly Use parent advanced settings
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6.1. Devices

– only globally available for all devices (Options > Advanced options) –

Discover devices

Option Description

Maximumping-time (mil-
liseconds)

Maximum response time inmilliseconds bywhich clients should respond to
a ping command.

Maximumdiscover time
(seconds)

Total time for searching devices for Discovery. After the indicated time has
expired, Discovery is stopped.

Field update

Retain local con-
figuration (unlocked
fields) 1

Editable fields of the local device configuration are free for individual user
configuration and will not be overridden by Scout Enterprise. During syn-
chronization of configuration data from the Scout Server to the device, only
the values of the locked fields will be overridden.

Which options are allowed to the user for editing (unlocked fields) is determ-
ined by the administrator under Device configuration > Security > User
rights.

The local user configuration values of unlocked fields can additionally be
retained during a factory reset of the device.2

For further information, see Supporting local configuration.

Note
If users have set defective configuration data, you can, however, override unlocked fields and
set a flag for the relevant device in the Scout Console to reload all configuration data. For fur-
ther information, see Supporting local configuration.

New devices

Default OU OU new devices are assigned to, by default

Assign OU depending
onOU filter

Activates the OU filter for new devices

Click the ... button to configure the OU filter. TheOU filter has priority over
other methods but can be ignored for individual devices. For further inform-
ation, seeOU filter.

1formerly: Only locked fields are updated on the client
2fromScout Enterprise 15.7 and eLuxRP 6.7
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Lock config transfer for
new devices

Newly added devices are not synchronized with the server's device con-
figuration

Allow dynamic change
of OUs

Allows dynamic assignment of devices via DHCP

Accept only known
devices

The Scout Server accepts only deviceswith knownMAC addresses. For fur-
ther information, see Reserving device profiles.

Device name

Use the host name of
the device

The device name is the client host name and cannot be changed in the
Scout Console permanently.

To avoid duplicate
names, change name
of existing entry

When a new device with an already existing name is added, the name of the
existing device instead of the name of the new device is changed.

Name template Name template for new devices

Can be overridden for particular OUs (Advanced device configuration >
Management)

Apply name template
only on new devices

Name templates are not applied when youmove or relocate devices.

For further information, see "Device names" on page 31.

6.2. Update/Delivery

– not available for individual devices –

Option Description

Maximumnumber of parallel
updates or software deliv-
eries

Restriction for performance reasons

Maximum time to connect Time for setting up the connection before the next device is accessed

Note
The optimum values depend on the system.

6.3. Management

– only available for individual devices andOUs –
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Option Description

Note Free text field for internal comments

Can be shown in the Properties window

Visibility

– only for OUs –

The visibility refers to the list of OUs that new clients request when they initiallly
connect to the Scout Server to select an OU.

HiddenOUs are not shown in the list.

Visible OUs can be selected in the list but can be protected by password.

New devices

– only for OUs –

When new devices register automatically, they can be subject to a predefined
name template.

Device names are configured globally in the Advanced options on the Devices
tab. For further information, see Devices.

Ignore OU filter

– only for individual
devices –

If the OU filter is active (Advanced options > Devices), new devices are
assigned to OUs due to the defined criteria.

Individual devices can be excluded from theOU filter.

Bymoving deviceswithin the tree structure by a drag-and-drop operation, for the
relevant devices, the option is selected automatically.

6.4. Predefined commands

– only globally available for all devices (Options > Advanced options) –

User-defined commands can be centrally predefined and provided as ready-to-use commands for oper-
ative administratorsmanaging their clients remotely.

Active predefined commands are shown in Commands > Predefined command in the relevant list-
field.

In addition, you can set preferences for standard commands used by administrators.

For further information, see Creating predefined commands.

6.5. Predefined IDFs and containers

– only globally available for all devices (Options > Advanced options) –

By predefining certain configuration parameters of the Device Configuration > Firmware, you specify
values to be used by operational administrators. For example, you can restrict the selection of valid
image files.

Note
To use these functions effectively, configure the relevant object rights in the administrator
policies. For further information, see Protecting firmware configuration.
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To create a new list entry, click Add and then edit the new entry. The spelling of your entrymust cor-
respond to the existing file and path names. Note the following:

File and paths names are case-sensitive.

Do not use spaces.

File namesmust be specified with their extensions such as .idf

Section Option Description

Predefined
IDFs

Image
name

Name of an image file (IDF) that if marked as valid can be selected in the firm-
ware configuration under Image file

Example: myImage.idf

Used shows the number of devices using the image
Assigned shows the number of devices to which the image has been
assigned

Predefined
paths

Path
name

Container path for software packages and images, which can be selected in
the firmware configuration under Path if marked as valid

Example: eluxng/UC_RC6_X64

Predefined
UEFI files1

UEFI
file

Name of an .udf file that if marked as valid can be selected in the firmware
configuration under UEFI file

The UEFI file is needed to update a device's UEFI firmware with the appro-
priate binary data.2

Example: myUEFI.udf

1fromScout 15 2107
2from eLux RP 6 2107
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6.6. Wake On LAN

– only globally available for all devices (Options > Advanced options) –

WakeOn LAN is a feature supported by Scout Enterprise that helps you start turned-off thin clients.

Requires
WakeOn LAN is supported by the thin client and is configured in the device BIOS.

The Scout Server sends a so-calledmagic packet that is identified by the network adapter of the turned-
off devices. The thin clients are woken via port 67.

Themagic packet for WakeOn LAN is sent as a broadcast (UDP, eLux port 20000 incoming/outgoing)
within the current network subnet and cannot operate across the entire network. To wake up thin clients
in remote subnets, subnet directed broadcasts are required.

Subnet directed broadcasts

Subnet directed broadcasts can directly address the subnet of the thin client to be woken up via IP. The
IP broadcast address of the relevant subnet is determined from the IP address of the client and the con-
figured subnet mask. Themagic packet for WakeOn LAN is broadcasted (UDP) only within the
addressed subnet.

An IP broadcast address for the subnet must be configured once in the Advanced options.

Option Description

Server name Subnet mask for subnet directed broadcasts
(for earlier versions: IP address ofWakeOn LAN server – option also available in
the Advanced device configuration1)

1formerly Advanced settings
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Option Description

Generate an IP
broadcast
address for the
subnet

(only globally avail-
able in Advanced
options)

The packet is sent to the relevant subnet (dedicated subnet). Requires a subnet
address in the Server name field using the format /255.255.255.0 (Note the
leading slash).

Example: To wake up a device with IP address 192.168.10.44, enter
/255.255.255.0 in the Server name field. This causes Scout Enterprise to
generate the IP broadcast address 192.168.10.255 for the subnet.

By default, this option is disabled.

6.7. VPN

– only available for individual devices –

Note
One or more VPN profiles can be defined for entire OUs in Device configuration > Network.1

Scout Enterprise supports the following VPN (Virtual Private Network) clients for secure com-
munication:

Cisco AnyConnect

OpenVPN

Depending on the VPN client used, the client devicesmust have a configuration file. You canmodify the
configuration file by using the Scout Enterprise feature Advanced file entries.

6.7.1. Configuring Cisco AnyConnect

Note
For versions up to eLuxRP 6.5, the eLux package VPN System and the included feature
package Cisco AnyConnect must be installed on the clients.
From eLuxRP 6.6, the eLux package Cisco AnyConnect must be installed on the clients.

Thismay requiremodifications of the image definition file on the web server via ELIAS.

1. Transfer the root certificate to the clients to /setup/cacerts/ca. If you use the Scout
Enterprise feature Files configured for transfer, specify the destination file with destination path
/setup/cacerts/ca.

Note
Cisco AnyConnect only accepts certificate files in .pem format.

1fromScout EnterpriseManagement Suite15 2101
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Note
The certificates that are transferred from the VPN server are stored in
/setup/cacerts/client.

2. In the Scout Console, for the relevant device, open Advanced device configuration > VPN cli-
ent. Then, in the list-field, select Cisco AnyConnect VPN Client.

3. Restart the client. The client might require onemore restart to activate the VPN configuration
data locally.

Configuration file

As an option, you can create an AnyConnect configuration file or copy one from a reference client, and
then transfer the file to /setup/elux/.cisco/profile/1 via the Scout Enterprise feature Files
configured for transfer. In the configuration file, you can specify your back-end server address.

1from eLuxRP 6.4. For earlier versions: /setup/elux/.anyconnect
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6.7.2. Configuring OpenVPN

Note
For versions up to eLuxRP 6.5, the eLux package VPN System and the included feature
packageOpenVPN must be installed on the clients. Thismay requiremodifications of the
image definition file on the web server via ELIAS.

From eLuxRP 6.6, OpenVPN is an integral part of the eLux operating system.

1. Transfer the .ovpn configuration file and certificates to the clients to /setup/openvpn. If you
use the Scout Enterprise feature Files configured for transfer, specify the source and des-
tination file with file name extension and the destination path /setup/openvpn. If you use a
USB stick, unzip the .zip file to the client directory /setup/openvpn.

2. In the Scout Console, for the relevant device, open Advanced device configuration > VPN cli-
ent. Then, in the list-field, select OpenVPN Client.

3. Select the option Start VPN client automatically.

4. In the Configuration field, enter the name of the OpenVPN configuration file without the file name
extension .ovpn.

On the next restart of the device, the VPN configuration file is transferred to the device and activated
with another restart. TheOpenVPN logon dialog is displayed and the user can connect.

Note
TheOpenVPN client can only be used with a valid .ovpn configuration file under eLux.
Ensure that the configuration entries are correct. eLux does not accept the setting of an addi-
tional default route via the .ovpn configuration file. Some firewall vendors offer different con-
figuration files for different operating systems, with and without a default route. For example,
the Sophos configuration file for Android/iOS does not include this default route and can be
used for eLux.
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6.8. Files configured for transfer

This feature helps you transfer files to the devices. The defined files are transferred on the next device
restart. You can apply a file transfer to all devices, to individual devices or to OUs.

The source files are imported to the Scout Enterprise database and therefore are included in an SQL
database backup.

Example: Picture files are copied to the clients as screen savers.

Legend to numbers

1 The source files are
selected from the
file system via Add.

2 For each source
file, a destination
file on the device is
created:
Specify the relevant
destination dir-
ectory and option-
ally a different file
name.

3 Source files of the
current level can be
edited.

4 For entries of the
current level, you
can edit the des-
tination file prop-
erties.

5 Entries from a par-
ent OU or the global
file list are identified
by a >>.1

You cannot edit
these source files.
With the cor-
responding object
right, however, you
can view them,2

see below.

1fromScout EnterpriseManagement Suite 15.4
2fromScout Enterprise 15 2101
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Defining files for transfer

1. To configure a file transfer to all devices (global file list), clickOptions > Advanced Options.... On
top level, you can also define destination file templates for subordinate levels.

To configure a file transfer to the devices of an individual OU or to an individual device (individual
file list), on the context menu of the relevant OU or device, click Advanced device con-
figuration...

Note
Individual file lists have precedence over global file lists.

2. On the Files tab, click Add.

3. In the Add file entry dialog, to select the source file from the file system, click the button and
then select a file.

A new entry for the Source file and Destination file lists is created.

4. Under Destination file, if required, modify the directory and file name of the destination file on the
device.
The destination file namemay differ from the one of the source file.

If configured, alternatively use a destination file template from the Template list field.
The path and name of a destination file from a template cannot be changed later on.

5. Confirmwith OK

Source and destination are defined. The files are transferred on the next restart of the devices.
The files will not be reloaded unless youmodify the file configuration.

Re-using imported source files

You can re-use source files that you have imported for oneOU for the file transfer in other OUs.

1. In the Advanced device configuration of the sourceOU, on the Files tab, right-click the relevant
entry in the Source file list.

2. To copy the entry to the Clipboard, on the context menu, click Copy.

3. Open the Advanced device configuration of the target OU.

4. On the Files tab, right-click the Source file list. On the context menu, click Paste.

Removing transferred files

Once you have transferred files to a client they cannot be removed by using the feature Files con-
figured for transfer.

To remove all transferred files from a device, perform a factory reset.
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Source files from parent OUs or the top level

The Files dialog also displays entries from parent OUs or the global file list. These inherited source files
are identified by a >>1 character and are protected from access by default.

Legend to numbers

1 To show the origin
of a parent entry,
move themouse
pointer over the
entry.

2 You cannot edit
source files of par-
ent entries.

But, If the file pri-
vacy object right
has been disabled,
you can view the
content of a source
file.2

To disable the
object right, for
the required
OU and for the
required admin-
istrator, open
the object
rights, and then
navigate to Edit
properties >
Files > Inher-
ited file pri-
vacy.

For further inform-
ation, see
"Changing object
rights " on
page 308.

1fromScout EnterpriseManagement Suite 15.4
2fromScout Enterprise 15 2101
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6.9. Advanced file entries

The Advanced file entries tab allows you to set parameters in .ini files that cannot be set by using the
graphical user interface. For example, you can define additional layout parameters.

The following applies to the .ini files:

.ini files contain at least one section. Each section contains zero or more keywords.The
keywords contain zero or more values.

Each section is headed by a symbolic name enclosed in square brackets.

Each keyword and its value are in one line. Keyword and value are separated by an equal sign
(=).
A keyword can havemore than one value.

If a section name is usedmore than once in the same file, or if a keyword is usedmore than once
in the same section, the last occurrence has precedence.

6.9.1. Adding individual file entries

Legend to numbers

1 Entries from a parent OU or the global Advanced options are shownwith a >>.1

To show the origin, move themouse pointer over the relevant entry.

2 For a new entry, first select the relevant file or enter the path and filename.

3 For the new entry, then specify the section, key and value.

1for Scout EnterpriseManagement Suite 15.4 and later versions
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Legend to numbers

4 Click Add to add the new entry.

5 Click Replace to replace the selected entry in the list by the new entry.

1. In the Scout Console, clickOptions > Advanced Options.
Or:
For the relevant OU, open the context menu and click Advanced device configuration...1

2. Click the Advanced file entries tab.

3. Below the list, edit the following fields:

Option Description

File Enter the full path including file name or select from the list:

Terminal: /setup/terminal.ini
Citrix ICA: /setup/ica/wfclient.ini and /setup/ica/appsrv.ini
Cisco VPN: /setup/ciscovpn/sample.pcf

Section Section heading without brackets

Key Keyword

Value Value you want to assign to the keyword
Blanks, hyphens andmultiple values are allowed.

Example: valueA,valueB,valueC;comment

4. Click Add.

5. Confirmwith Apply andOK

The new entry is written to the .ini file on the next restart of the client.

6.9.2. Changing values of individual file entries

1. In the Advanced device configuration2 > Advanced file entries, select the entry whose value you
want to change.

2. Below, in the Value box, replace the current value.

3. Click Replace.

The new values are written to the .ini file on the next restart of the client.

1formerly Advanced settings
2formerly Advanced settings
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6.9.3. Deleting individual file entries

1. In Advanced device configuration > Advanced file entries, define a new entry: Enter File, Section
and Key of the relevant file entry, but leave the Value box empty.

2. Click Add.

The 'empty' file entry overrides previous instructions. The file entry is deleted from the relevant section
on the next restart.

Note
If you use the Delete button to delete a selected row from the list, then Scout Enterprise will no
longer update the respective entry.

6.9.4. Deleting complete sections

1. In the Advanced device configuration1 > Advanced file entries, define a new entry: Enter File and
Section of the relevant file entry, but leave the Key and Value boxes empty.

2. Click Add.

The 'empty' section overrides previous instructions. The section is deleted from the file on the next
restart even if it contains file entries.

6.10. Rules

Using this feature helps you define rules which can be executed when closing the last application or
using Scout Enterprise for the first time.

Option Description

After terminating the last application
execute the following action

Choose between the options of the list-field

For OUs and devices, the Use parent action option
is set by default to enable the rules defined for a higher
OU level.

Display amessage on the device for <x>
seconds

Enter a time period in seconds to inform the user

After first management contact execute
the following action

Select Update the device to ensure that the new
devices are all up-to-date.

Special case kiosk mode

If you use the browser in kioskmode to accessCitrix applications, the option After terminating the last
application execute the following action does not work. In this case, you can set an entry in the
terminal.ini file to determine an action that is performed after the last Citrix application is closed.

1formerly Advanced settings
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Define the following entry by using the Scout Enterprise feature Advanced file entries:

File /setup/terminal.ini

Section Global

Entry ActionAfterLastWfica

Value 0 Use parent action
1 Restart
2 Shutdown
4 Logoff
8 Lock

16 VPN disconnected
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6.11. Environment variables

– only available for individual devices andOUs –

Environment variables can be used locally on the client. They contain strings.

Defining environment variables

1. In the Advanced device configuration,1 click the Environment tab.

Previously defined variables are shown in the list. Entries from a parent OU are shownwith a
>>.2

2. Click New.

3. Enter the required variable using the format:
Variable name=value
and confirmwith OK.

The new variable is shown in the list.

4. To encrypt the value of the variable, right-click the variable. Then on the context menu, click
Encrypt value.

Note
When you apply variables, the variable namesmust begin with a dollar sign: $<Variable
name>

6.12. TPM 2.0 support

– for eLux RP 6.7 and later versions –

A TPM2.0 chip built into the thin client can be used for basic security functions:

Encryption of the setup partition3 and system partition4

The setup partition on the thin client's flashmemory contains the device configuration, application
definitions, and certificate store. The system partition holds the software packages of the firm-
ware.

In order to protect the system frommanipulation, in addition to encryption, the disk is sealed with
securitymeasurements.5

Store the private key of a SCEP client certificate inside the TPM2.0module

1formerly Advanced settings
2for Scout EnterpriseManagement Suite 15.4 and later versions
3from eLux RP 6.7
4from eLux RP 6.10
5from eLux RP 6.10

172



To store the key inside the TPM2.0module, a scep.ini entry is required. For further inform-
ation, see Certificates for SCEP in the SCEP guide.

Requirements for disk encryption

The devices are provided with a TPM2.0module.

The devices are started in UEFI mode.

Disk encryption via TPM 2.0

– from eLux RP 6.10 –

If the device-side requirements aremet, encryption can be enabled using two different mechanisms:

Via the configuration parameter DiskEncryption

Via the feature package Partition encryption installed with the image

If the BaseOS package for eLuxRP 6.10 or later is installed on the deviceswith the feature pack-
age Partition encryption enabled, the system is automatically encrypted. The parameter DiskEn-
cryption is then ignored.

The feature package Partition encryption is enabled by default.

To encrypt the disk, the partitionsmust first be formatted. Therefore - as soon as the encryption is activ-
ated - a firmware update with previous formatting for the relevant devices is forced.

Encrypting the disk via parameter

– from eLux RP 6.10 –

1. In the Scout Console, for the relevant devices, open Advanced device configuration1 >
Advanced file entries.

2. Define the following entry:

File /setup/terminal.ini

Section Security

Entry DiskEncryption

Value true By default, the value is false.

For further information, see Advanced file entries.

For the relevant devices a firmware update is forced with previous disk formatting.

The configuration parameter has no effect on thin clients without TPM2.0.

1formerly Advanced settings
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Note
You can find information on whether the disk of the device is encrypted in the Properties win-
dow.1

When new clients with TPM2.0 chip are added to the Scout Enterprise infrastructure (onboarding) and
the destination OU is configured with DiskEncryption, it is ensured that the configuration data
stored in the Scout Console is only saved locally on the thin client after the setup partition has been
encrypted.

Update from earlier versions to eLux RP 6.10

Updateswith disk encryption can only be performed from eLux RP 6.x. Upgrades from eLux RP 5 are
not supported.

If you enable encryption when updating to eLuxRP 6.10, another updatemay be required on the next
device restart. This is due to the partition formatting that is required for encryption.

The DiskEncryption parameter replaces the CryptSetupPartition parameter of previous versions,2 but
ismaintained for backward compatibility. From eLuxRP 6.10, CryptSetupPartition has the same func-
tion asDiskEncryption and therefore encrypts setup and system partition.

Error handling

If a device fulfills the above-mentioned requirements for encryption and disk encryption still fails during
the update, the setup partition will be partially cleaned like it is for a factory reset without deleting the
Scout Enterprise-Server address. The device status in the Scout Console is then displayed with a yel-
low icon (initialization).

Resetting the disk encryption

Requires
The feature package Partition encryptionmust be uninstalled on the relevant devices. This
requiresmodifying the image definition file on the web server via ELIAS.

Set the advanced file entry DiskEncryption3 to the value false.

or

Perform a factory reset for the devices. To do so, use the Remote factory reset commandwith the
option Delete Scout Server address on the device.

During the restart of the relevant devices, the disk is decrypted. That is why the start up process takes
longer.

1for Scout Enterprise 15.8 and later versions
2eLux RP 6.7 to eLux RP 6.9
3alternatively CryptSetupPartition
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Downgrade to earlier versions < eLux RP 6.10

Deviceswith encrypted disk cannot be downgraded to eLux RP 6.9.100. If a downgrade is necessary,
the diskmust be decrypted first.
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7. Defining applications

The clients can be supplied with the following types of applications:

Applications providing access to back-end systems

Local applications

The definition of applications and the installation of the related software are independent of each other.
Defining applicationsmeans to configure the applications provided for the users. Additionally, to enable
the users to operate the applications, the relevant software packagesmust be installed on the client via
IDF configuration. For further information, see Creating an image in the ELIAS 18 guide.

Note
The term applications refers to application definitions.
The term software refers to the required software packages.

Applications can be inherited from the top of the organization structure to subordinate OUs. The lowest
level to define an application is anOU, the highest level is the root level.

7.1. General

Note
You can define actions to be performed after the last application has been closed. For further
information, see Rules.

Additionally note that application definitions can be

copied from oneOU to another

exported from oneOU and imported to another OU (context menu > Edit).

7.1.1. Adding applications

1. In the tree view, right-click the Applications icon of the relevant OU.

2. On the context menu, click Add.

The Application Properties dialog opens. This dialog provides several tabs, each of them relating to a
particular application type.

The following options of the Application Properties are available for most application types:

Option Description

Name Name of the application shown in the Scout Console
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Important Applications are identified by their name. Make sure to use a unique name for
them.

Display name
(optional)

Name of the application shown on the client (control panel, start menu)

Sorting ID1 Specifies the sorting order for applications pinned to the system bar

1 sorts alphabetically (default)

Server Name of the server the application connects to

Login The user is automatically logged on to the terminal server by using predefined cre-
dentials (username, password, domain).

Pass-through
login

The values of the local user variables $ELUXUSER, $ELUXPASSWORD and
$ELUXDOMAIN are used to log on to the authentication server. This allows to use
the AD logon data of the eLux desktop for automatic logon to the configured
applications (single sign-on).

For further information, see User variables.

Application restart The application is immediately restarted after it has been closed either unex-
pectedly or by the user.

Start automatically
after

The application starts automatically after eLux has been started. Optionally, you
can delay the auto-start process by defining the required number of seconds.

Desktop icon Provides an additional desktop shortcut for the application (icon and display
name)

(except for PN Agent)

Free Parameters Individual parameters for program start

7.1.2. Editing application properties

Open the context menu of the relevant application and click Properties.

The Application Properties dialog for the application opens. Depending on the application, different
properties can be configured.

Note
Properties of the selected application can be displayed in the Properties windows of the Scout
Console. They cannot bemodified there.

For each administrator, you can control the object rights for individual application types.2Object rights
for the advanced settings and free parameters can be assigned separately.

1fromScout Enterprise 15.10 and eLux RP 6.10
2for Scout EnterpriseManagement Suite 15.5 and later versions
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7.1.3. Defining free application parameters

Free application parameters are individual parameters which can be used to start an application. You
can define free application parameters for all applications, except for SAP-GUI and Emulation.

1. Open the Application properties of the relevant application.

2. Click Free Parameters.

3. Click Add and enter one or more parameters in the following format:

FreeRDPParams=<Parameter> <Parameter> <Parameter>...

Separatemultiple parameters by spaces.

4. Confirm twice with OK.

The defined parameters are saved with the application definition. Theywill be inserted for the relevant
application into the file \setup\sessions.ini.

Note
Access to the free parameters can be restricted via the object rights.1

For information on which parameters are available, refer to the description of the respective application
definition.

The following parameters can be used across applications:

Parameter Values Description

pinned2 true The application is pinned on the system bar.

1for Scout EnterpriseManagement Suite 15.5 and later versions
2for eLuxRP 6.8 and later versions
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7.1.4. Using parent applications

By default, applications are inherited to subordinate OUs. This allows you to define applications in only
few but central places.

For the subordinate OUs, in the tree view, on the Applications context menu, the option Use parent
applications > All is enabled (checkmark). With the checkmark set, all applications are active that
have been defined for higher-level OUs or for the top-level OU. In addition to these applications, you can
definemore applications valid for this individual OU (and subordinate OUs).

Disabling inheritance of applications

1. For anOU that you do not want to receive higher-level applications, open the context menu.

2. Click Use parent applications > All to remove the checkmark.

TheOU cannot use higher-level applications and cannot inherit them to subordinate OUs any-longer.
Only applications defined within that OU are active.

Inheriting only individual applications

1. For the OU that you want to receive some of the applications defined for a higher-level OU or at
top-level, open the context menu.

2. Make sure that the option Use parent applications > All is cleared (no checkmark).

3. On the sub-menu Use parent applications, under All, select the application you want to inherit
from above.

The selected application, on the sub-menu, receives a checkmark, and its definition is provided on the
next restart of the clients for that OU.

Note
Inherited properties of the selected applicationswill be lost if youmove the respective OU to

179



another parent OU. For movedOUs, the system automatically enablesUse parent applic-
ations > All.1

Show defined applications for an OU

1. Click View > Window > OU devices/applications to display the relevant window.

2. In the tree view, click the Applications icon below anOU.

For the selectedOU, all defined applications are listed. TheOrigin column shows theOU fromwhich an
application is inherited. Top-level applications show the value Enterprise.

The selectedOU of the figure above has one own application (no entry in the Origin column), four applic-
ations from the higher-level OU DE, and one top-level application.

Note
To also apply the default settings of the parent applications, on the Applications context
menu, select the Use parent defaults option.

7.1.5. Defining application templates

– for Scout Enterprise 15.7 and later versions –

As an administrator, you can create a template for each application type, for example, a browser tem-
plate: In the template, you specify values that users will find filled out when they create a browser applic-
ation. If you create a browser template and specify the browser type Firefox and System proxy as
proxy, as a result users at all levels will see Firefox and system proxy as predefined valueswhen they
create a new browser application.

Note that the values can be overwritten. However, if you disable the object rights for the advanced
options or free parameters of an application type, these values remain because the relevant users do
not have access to them in the application definition.

Application templates are defined at the top level. You can define exactly one template for each applic-
ation type.

1fromScout Enterprise 15 2101
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Creating a application template

Requires
Administrators' base right: Edit base application

1. In the tree view, on the top level, right-click the Applications icon.

2. On the context menu, click Define application templates...

The Definition of application templates dialog opens. Each tab contains the application prop-
erties of an application type.

3. Switch to the tab that contains the required application type.

4. Edit any options you want to predefine.

5. Confirmwith Apply andOK.

For each new application definition of this application type, the predefined valueswill be set.

Modifying or resetting application templates

1. In the tree view, on the top level, right-click the Applications icon and select Define applic-
ation templates...

The Definition of application templates dialog contains for each application type a tab with its
application properties. Non-empty fields contain values that are used when new applications of
this type are created.

2. For the relevant application type, edit the options you want to change.

3. To reset all values that you have predefined for an application type, click Reset.
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7.1.6. Defining software defaults

Software default settings for all applications of the same type can be defined centrally or onOU-level.
Software default settings are available for Citrix applications (CitrixWorkspace app)1 and for
browsers.2

We recommend to apply the default settings at top-level (root applications) to use inheritance over all
OUs.

1. In the tree view, for the relevant level, open the Applications context menu and click Software
defaults...

Note
If inheritance is enabled, you can only open andmodify the Software defaults... of the
top-level instance or parent instance. To use different default settings for different OUs,
inheritancemust be disabled.

2. In the list-field, select the relevant software and click Edit.

3. Edit the relevant options on the tabs and confirmwith OK.

1formerly Citrix Rreceiver
2for Scout EnterpriseManagement Suite 15.0 and later versions
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7.1.7. Uploading applications from Thin Client to Scout Enterprise

Application definitions of a reference client with an up-to-date eLux version can be uploaded to the
Scout Console and assigned to anyOU.

Important If you upload applications to anOU, all existing applications in this OU will be
deleted.

Uploading from any client (outside of Scout Enterprise Management Suite)

1. In Scout Enterprise, click File > Application upload....

The Application upload dialog opens.

2. Enter the IP address or name of the client device you want to upload application definitions from.

3. Select the Destination OU.

4. Click Start.

The application definitions of the specified Thin Client (of its OU) are uploaded to the specified OU.
Already existing applications are deleted.

Uploading from a client managed by Scout Enterprise Management Suite

1. In the Scout Console, select the device you want to upload application definitions from.

2. Click File > Application upload....

The Application upload dialog opens. The IP address of the selected device is already set in the field
IP-name or IP-address of the device.

3. Select the destination OU to which the application definitions are to be copied.

4. Click Start.

The application definitions of the specified Thin Client (of its OU) are uploaded to the specified OU.
Already existing applications are deleted.

7.1.8. Defining application icons

You can define custom icons for applications to be displayed on the client desktop. For the icon files, in
Scout EnterpriseManagement Suite 15.2 and later versions, the high-resolution formats .svg und
.png are supported. These file types replace the bitmap formats .xpm, .ico and .gif which can be
used in Scout EnterpriseManagement Suite and earlier versions.

1. In the tree view, for the top-level Applications, on the context menu, click Define application
icons...

2. Click Add and select the relevant file from the file system.

3. Confirmwith Open andOK.

183



The application icon is shown in the dialog. The icon is defined but has not been assigned yet.

7.1.9. Assigning custom application icons

Note
Before you assign an application icon other than the default icon, make sure that the icon is
already defined. For further information, see Defining Application Icons.

1. For the relevant application, on the context menu, click Properties....

2. Select the Desktop icon option.

3. Click ... and select one of the icons.

4. Confirmwith OK and Apply.

The application icon is shown for the selected application on the next client restart.

7.1.10. Defining a service app

– for eLuxRP 6.4 and later versions –

Note
To use this feature, user authentication via Active Directory is required.

If you use AD, you can allow users to start eLux in servicemodewithout logging on. To do so, define
one or more service apps. The AD logon dialog then provides an additional Service button that starts
eLux in a protectedmode (servicemode). In servicemode, eLux only offers the defined service apps on
the desktop. In the Configuration panel, only the Information dialog is shown.

1. To define a service app, open the Application properties of the relevant application.

2. Click Free Parameters and add the following parameter:

ServiceApp=true

3. Confirmwith OK.

After the parameter is transferred to the client, the AD logon dialog contains a Service button.

7.1.11. Limiting applications to one logon domain

– for eLuxRP 6.4 and later versions –

Note
To use this feature, user authentication via Active Directory is required.
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If users have configuredmultiple AD domains for log-on, you can limit the display of an application to
one of the configured domains. This option is defined via a free parameter in the application definition.

1. Open the Application properties of the relevant application.

2. Click Free Parameters and add the following parameter:

ShowInDomain=<AD logon domain>

The AD logon domainmust match with one of the domains specified in the device configuration
under Security > User authentication > AD directory.

Example:
int.sampletec-01.com

3. Confirmwith OK.

After the parameter is transferred to the client, the relevant application is only shown if users log on to
the specified AD domain.
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7.2. Connecting to a Citrix farm

Users can connect to sessions running on a Citrix back-end. Once the connection has beenmade, the
user can access published desktops and applications.

Connecting the Thin Client to a Citrix back-end is performed by one of the following applications:

by a StoreFront application to a StoreFront server

by the Citrix Self-Service user interface to a StoreFront server

via browser to a StoreFront server or Web Interface server

by a PNAgent application to a StoreFront server (XenApp Services Support must be enabled on
the Citrix farm) or Web Interface server

by an ICA application to a virtual desktop or published applications

Note
Access via the ICA application type is deprecated and only supported byCitrix up to XenApp
version 6.x.

Requirements

The eLux package Citrix Workspace app for Linux or Citrix Receiver for Linux must be
installed on the clients.

To connect via HTTPS, for the application types Storefront, Self Service and PNAgent, the rel-
evant root and intermediate certificatesmust be available on the clients.

Root certificatesmust be transferred to /setup/cacerts.

Intermediate certificatesmust be transferred to /setup/cacerts/intcerts.

For further information, see Certificates in the Installation guide.

To connect via HTTPS, for the application type Browser, the relevant root and intermediate cer-
tifcatesmust be available on the clients.

Firefox: Root certificates and intermediate certificatesmust be transferred to
/setup/cacerts/firefox

Chromium: Root certificates and intermediate certificatesmust be transferred to
/setup/cacerts/browser

The eLux taskbar should be enabled on the clients if published applications are provided as seam-
less applications. Seamless applications behave like local applications and users can only
restore them fromminimized window size by using the taskbar. For further information, see
Advanced desktop settings.
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7.2.1. StoreFront application

By using the application type StoreFront, users can connect to a Citrix StoreFront server. Virtual
desktops and published applications are aggregated and provided through stores. The Citrix products
mainly used are XenApp and Citrix XenDesktop. StoreFront sites can be accessed via HTTP or
HTTPS.

The StoreFront application enables users to accessCitrix resources of one or more stores together with
other configured applications, such asRDP or Browser sessions by using only one interface – the
eLux RP 6 User Interface. For further information, see eLuxRP 6User Interface.

Defining a StoreFront application

Note
HTTPS connections require the relevant SSL certificates on the device.

1. Add a new application and select the application type StoreFront.

2. Edit the following fields:

Option Description

Name Name of the application shown in the Scout Console

Use Provisioning
File (.cr)1

Enter the Citrix store provisioning file namewithout the file name extension.
The Provisioning file must be located on the client in the directory
/setup/ica/. For further information, see StoreFront / Store pro-
visioning file.

This option excludes the specification of Store URLs (next option).

Stores Specify the URL of one or more stores

Click Add and replace the automatically created default value by your
individual value (double-click or F2)

Example: (https://CtrXd76.sampletec-
01.com/Citrix/Store33/discovery)

This option excludes the use of a Provisioning file (previous option).

Logon The user is automatically logged on to the store by using the specified cre-
dentials (username, password, domain).

Pass-through
logon

The user is logged on to the store via single sign-on. The AD user cre-
dentials are used.

If AD users log on via smart card, and if Citrix Receiver for Linux 13.4.x or
later versions are used, the authenticationmethod Domain pass-through
on the Citrix server must be disabled.

1for Scout EnterpriseManagement Suite 15.5 and later versions
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Note
If you want to use predefined credentials or pass-through authentication, the eLux pack-
age Citrix Receiver Extensions and the included feature package Dialog Extension
must be installed on the clients.

For further information, see "StoreFront / Authentication" on page 190.

Show last user The user credentials (except for password) of the last logon are displayed in
the XenApp logon dialog.
This option has no effect if you specify fix user credentials for automatic
logon under Logon.

Autostart Specify the names of those StoreFront applications you want to have star-
ted automatically. Make sure to spell the names exactly as in StoreFront.
Separatemultiple application names by semicolon.
Example: MyApp1;MyApp2

If only one resource is defined for a store, alternatively use the free para-
meter AutostartUniqueResource=true1

Application
restart
Start auto-
matically
Desktop icon

See Adding applications

Free parameters
(optional)

Individual parameters for application start

For further information, see Defining free application parameters.

3. To delete an entry from the Stores list, select the entry and click Delete.

4. To configure further settings, click Advanced and edit the following fields:

Option Description

Windows prop-
erties

Desktops can be launched in full-screen or window mode.

Timed logoff To enable automatic logoff from the StoreFront server, select the Logoff
after option and specify a delay in seconds. Automatic logoff does not affect
the launched desktop.

Alternatively, automatic logoff can be configured to be performed after the
last StoreFront application has been closed.

1for eLuxRP 6.4 and later versions (CitrixWorkspace app)
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Option Description

Application recon-
nection

Determine the actions to be done on a reconnect to the StoreFront server

Do not reconnect: The connection to the desktop or the published applic-
ations is not restored (default).

Disconnected sessions only: The connection to a disconnected session is
restored.

Active and disconnected sessions: The connection to a disconnected or
active session is restored.

Manual logoff Determine the actions to be carried out upon logoff from the StoreFront
server

Logoff only server: Logoff is performed only from the StoreFront server

Logoff server and applications: Logoff is performed from the StoreFront
server and from the virtual desktop or published applications.

Logoff server and disconnect session: Logoff is performed from the
StoreFront server but the virtual desktop session is only disconnected. This
enables the user to reconnect later on.

Note
Access to the advanced settings can be defined via the object rights.1

5. Confirmwith Apply andOK.

After users have logged on to a StoreFront server or Web Interface server, they can show all provided
resources by double-clicking the StoreFront icon on the eLux desktop.

7.2.2. StoreFront / Store provisioning file

– for eLuxRP 6.3 and later versions –

A Citrix store provisioning file can be created by the Citrix back-end and contains all relevant connection
information. Using this file allows to switch automatically fromCitrix StoreFront connection data to Citrix
AccessGateway connection data if StoreFront is not reachable (scenario of switching between com-
pany office and home office).

To use a store provisioning file for your eLux clients, note the following:

The file must be located on the clients in the directory /setup/ica/
Transfer the .cr file by using the Scout Enterprise feature Files configured for transfer. For fur-
ther information, see Files configured for transfer.

1for Scout EnterpriseManagement Suite 15.5 and later versions
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For Scout EnterpriseManagement Suite 15.4 and earlier, add two free parameters to the Cítrix
StoreFront application definition:

UseCrFile=true
CrFile=<filename>.cr

Leave the Stores field empty.

7.2.3. StoreFront / Authentication

If on the client, smart card packages are installed and the CitrixWorkspace app for Linux identifies
smart cardmiddleware on the client, smart card logon has precedence by default. In order to still authen-
ticate via username and password for certain clients, define the authenticationmethod via a parameter:

Controlling the authentication method via eLux

The logonmethod can be changed to username and password regardless of the smart card packages
installed.

Define the following entry by using the Scout Enterprise feature Advanced file entries:

File /setup/sessions.ini

Section ICADefaults

Entry StoreFrontLogOnWithPassword

Value true| false (Default: false)

Configuring smart card behavior

If you use smart card authentication for StoreFront, you can configure the behavior of the smart card
when it is removed.

Note
Using a smart card requires the smart cardmiddleware to be installed on the client. In addi-
tion, smart card authenticationmust be enabled on the Citrix farm.

Define the following entry by using the Scout Enterprise feature Advanced file entries:

File /setup/sessions.ini

Section ICADefaults

Entry SmartcardRemovalAction

Value noaction | forcelogoff (Default: noaction)
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Further parameters for authentication1

To define further parameters for authentication, use the configuration file
/setup/ica/AuthManConfig.xml.template. This file is transferred to the clients during install-
ation. Using the Diagnosis and Files configured for transfer features, you can retrieve the file, edit it
and transfer it back to the relevant clients. For further information, see Advanced device configuration >
Files.

For the function to become active on the client, a restart is necessary for the transfer to the client and
another restart to activate the new parameters.

1for eLuxRP 6.8 and later versions
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7.2.4. Self-Service user interface

The Self-Service user interface (UI) replaces the configurationmanager wfcmgr and allows access to
Citrix services providing published ressources. After users are set up with an account, they can sub-
scribe to desktops and applications, and then start them.

Defining Citrix Self-Service as local application

Note
The eLux package Citrix Workspace app for Linux1 and the included feature package Self-
servicemust be installed on the clients. Thismay requiremodifications of the image definition
file on the web server via ELIAS.

1. Add a new application and select the application type Local.

2. Edit the following fields:

Option Description

Name Name for the application

Local application Select Custom.

Parameter
(manatory)

Enter the following program name to start the application:

selfservice

3. Confirmwith Apply andOK.

Note
The selfservice application cannot be configured individually. To use configuration
options, alternatively use the Self-Service UI with extensions (ucselfservice) for eLuxRP
5 clients. For eLuxRP 6.2 and later versions, you can use the see Citrix Self-Service UI in
kioskmode.

1formerly Citrix Receiver for Linux
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7.2.5. Self-Service user interface with extensions

TheCitrix Self-Service user interface (UI) can also be used in an extended version with further func-
tionality1

Configuration of the stores

Logoff and reconnect options

Dialog and window layout

Defining Citrix Self-Service UI with extensions

– Steps for eLuxRP 5 / for eLuxRP 6.2 and later versions, see Citrix Self-Service UI in kioskmode –

Note
The eLux package Citrix Workspace app for Linux or Citrix Receiver for Linux 13.x must
be installed on the clients.
The eLux package Citrix Extensions 2.x2 or later and the included feature package Self-ser-
vice wrapper must be installed on the clients.

For modifications on the Citrix dialog design, further feature packagesmust be installed on the
clients:
Dialog Extension and Self-service dialog themes

Thismay requiremodifications of the image definition file on the web server via ELIAS.

1. Add a new application and select the application type Local.

2. Edit the following fields:

Option Description

Name Name for the application

Local application Select Custom.

Parameter
(mandatory)

Enter the following program name to start the application:
ucselfservice

1for eLuxRP 5.6 CR and later versions
2formerly Citrix Receiver Extensions
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Option Description

Free parameters Define StoreFront URLs for all stores you want to provide as Free applic-
ation parameters as shown below:

StoreUrl1=<URL to store1>

StoreUrl2=<URL to store2>

StoreUrl3=<URL to store3>

Alternatively, you can provide the users with a range of predefined stores to
choose from.1For further information, see Self-Service user interface with
multistore option.

3. Optionally, define further parameters and values for window properties and connection options.
For further information, see Parameters for the Self-Service extension (ucselfservice).

4. Confirmwith Apply andOK.

5. To change the design of the Citrix dialogs for all Citrix connections, use the Scout Enterprise fea-
ture Advanced file entries. For further information, see Parameters for the Self-Service exten-
sion (ucselfservice).

7.2.6. Self-Service user interface with MultiStore option

TheCitrix Self-Service user interface with extensions can also be used with a different option allowing
to provide users with a range of predefined stores. The users can then select one of the provided stores
to connect to when they log in.2

Defining Citrix Self-Service UI with extensions and MultiStore option

– Steps for eLuxRP 5 / for eLuxRP 6.2 and later versions, see Citrix Self-Service UI in kioskmode –

Note
The eLux package Citrix Workspace app for Linux or Citrix Receiver for Linux 13.x must
be installed on the clients.
The eLux package Citrix Extensions 2.x3 or later and the included feature package Self-ser-
vice wrapper must be installed on the clients.

For modifications on the Citrix dialog design, further feature packagesmust be installed on the
clients:
Dialog Extension and Self-service dialog themes

Thismay requiremodifications of the image definition file on the web server via ELIAS.

1for eLuxRP 5.5.1000 LTSR CU and later versions
2for eLuxRP 5.5.1000 LTSR CU and later versions
3formerly Citrix Receiver Extensions
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1. Add a new application and select the application type Local.

2. Edit the following fields:

Option Description

Name Name for the application

Local application Select Custom.

Parameter
(mandatory)

Enter the following program name to start the application:
ucselfservice

Free parameters Configure access to the stores you want the users to choose from. Use the
Free application parameters as shown below:

Stores=<number of store entries>

Store1=<store display name>,<store url>

Store2=<store display name>,<store url>

...

Domains=<number of domain entries>

Domain1=<domain display name>,<domain>

Domain2=<domain display name>,<domain>

...

ShowLastUser=<0|1>

Note: You can predefinemultiple stores andmultiple domains using the
format shown above.

3. Optionally, define further parameters and values for window properties and connection options.
For further information, see Parameters for the Self-Service extension (ucselfservice).

4. Confirmwith Apply andOK.

5. To change the design of the Citrix dialogs for all Citrix connections, use the Scout Enterprise fea-
ture Advanced file entries. For further information, see Parameters for the Self-Service exten-
sion (ucselfservice).
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7.2.7. Parameters for the Self-Service extension (ucselfservice)

Parameters for window properties and connection options

In the application properties, define the following options as free parameters
(Steps for eLuxRP 5):

Parameter Description Origin

SharedUserMode=<true|false> Shared User Mode allows you to use
one system user account for multiple
users. When users log off or close the UI,
the user data are removed.

Citrix

FullscreenMode=<0|1|2> 0 Not full-screen
1 Full-screen
2Maximized and undecorated, taskbar
remains visible
This can be useful as users can launch
seamless applications.

Default: 0 (not full-screen)

Citrix

SelfSelection=<true|false> Used to disable the search box and the
self-selection panel

Disabling prevents users from sub-
scribing to extra applications.

Default: false

Citrix

ReconnectOnLogon=<true|false> Tries to reconnect to all sessions, for a
given store, immediately after logon to
that store

Citrix

StoreGateway=<store gateway> If required, specify a gateway Citrix

ReconnectOnLaunchOrRefresh=

<true|false>
Tries to reconnect to all sessionswhen
an application is launched or the store is
refreshed

Citrix

SessionWindowedMode=<true|-
false>

true: Display desktopswindowed
false: Display desktops in full-screen

Citrix

UseLogoffDelay=<0|1> To activate automatic logoff, set
UseLogoffDelay=1.

Unicon

LogoffDelay=<seconds> Delay in seconds for automatic logoff Unicon

ForcedLogoff=<0|1> 1 Logoff timer is started with logon
0 Logoff timer is started when the last
Citrix app is closed.

Unicon
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Parameter Description Origin

LogoffInfoTimeout=<seconds> During logoff (selfservice restart), an info
dialog can be shown to the user for some
seconds.

Unicon

For further information, see Defining free application parameters.

Important To provide stores to the users, you can either predefine them as fixed values or
predefine a range of stores the user can choose from in a pre-logon dialog.1For further
information, see Self-Service user interface with extensions or Self-Service user interface
with MultiStore option.

Parameters for the design of the Citrix dialogs

Tomodify the design of the Citrix dialogs for all Citrix connections, use the Scout Enterprise feature
Advanced file entries and set the following entries:

File Section Entry Value

/setup/sessions.ini ICADefaults UiDialogTheme ucselfservice

/setup/sessions.ini ICADefaults UiDialogDecorated <true|false>

/setup/sessions.ini ICADefaults UiDialogKeepAbove <true|false>

/setup/sessions.ini ICADefaults UiDialogKeepBelow <true|false>

/setup/sessions.ini ICADefaults UiDialogColorHover <color> Example:
#b0b0b0

/setup/sessions.ini ICADefaults UiDialogColorUnselected <color> Example:
#a0a0a0

/setup/sessions.ini ICADefaults UiDialogColorSelected <color> Example:
#c0c0c0

For further information, see Advanced file entries.

Note
After the terminal.ini file has been updated on the client, another client restart might be
required to enable the new setting.

1for eLuxRP 5.5.1000 LTSR CU and later versions
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7.2.8. Custom design for Citrix Workspace app

– for eLuxRP 6.4 and later versions –

Note
The eLux package Citrix Workspace app 18.08 or a later versionmust be installed on the cli-
ents.

To customize the layout of your Citrix session, transfer the relevant layout files to the clients into the
Citrix directory structure. The files then aremerged with the Citrix layout files.

To transfer the files, use the Scout Enterprise feature Files configured for transfer. For further inform-
ation, see Files configured for transfer.

As destination specify the provided Citrix directories. Example:

Default /setup/ica/site_custom

If Shared User Mode is used /setup/ica/site_custom/sum_screen

TheCitrix directory structuremust be retained.The original structure can be found under
/opt/Citrix/ICAClient/site_orig.
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7.2.9. Browser session to access published resources

Users can access applications and desktops that have been published through a store on the Citrix
StoreFront server or through CitrixWeb Interface by using a local browser.

Defining a browser application to access published resources

Note
To provide the users with a browser application to be used directly on the client, the relevant
software package for Firefox or Chromiummust be installed on the clients. Thismay require
modifications of the image definition file on the web server via ELIAS.

Note
HTTPS connections require the relevant SSL certificates on the client.

1. Add a new application and select the application type Browser.

2. Edit the following fields:

Option Description

Name Name for the browser session

Browser type Firefox or Chromium

Called page URL of theWeb Interface homepage or StoreFront store.

Examples:
https://<Servername>/Citrix/StoreWeb
https://<Servername>/Citrix/XenApp

3. For the remaining parameters, see Defining a browser application.

The local user starts the browser and is forwarded to the defined page. After successful logon to the
StoreFront server or Web Interface server, the published applications, desktops and contents available
are shown in the browser window.

7.2.10. PNAgent application

An application of the type PNAgent (ProgramNeighborhood Agent) enables users to access published
resources through a server running a XenApp Services site. Published resources can be published
applications, published desktops, or published contents (files).

Customizable options for all users are defined in the configuration file config.xml which is stored on
theWeb Interface server (by default in the directory //Inetpub/wwwroot/Citrix/PNAgent).
When a user starts one of the published programs, the application reads the configuration data from the
server. The configuration file can be configured to update the settings and user interface regularly.

The config.xml file affects all connections defined by the XenApp Services site. For further inform-
ation, see the Citrix eDocs on http://support.citrix.com.

199



Defining a PN Agent application

Note
HTTPS connections require the relevant SSL certificates on the client.

1. Add a new application and select the application type PNAgent.

2. Edit the following fields:

Option Description

Name Name of the application

Server Specify the address of the configuration file on theWeb Interface server
(URL).
If you use the default directory and port 80, the server address is sufficient.

Examples:
https://CtrXd.sampletec-

01.com/Citrix/PNAgent/config.xml
https://192.168.10.11:81

Login The user is automatically logged on to theWeb Interface server by using the
specified credentials (username, password, domain).

Pass-through
logon

The user is logged on to the store via single sign-on. The AD user cre-
dentials are used.

Note: Kerberos authentication is no longer supported with Citrix Receiver
for Linux 13.x.and later versions.

Autostart applic-
ation/folder

Specify the names of those applications you want to have started auto-
matically.

Alternatively, you can specify an autostart folder containing the relevant pub-
lished applications. The folder must have already been created on theWeb
Interface server.

Show last user The user credentials (except for password) of the last logon are displayed in
the PNAgent logon dialog.
This option has no effect if you specify fixed user credentials for automatic
logon under Logon.

Allow cancel Allows the user to close the PNAgent logon dialog.

Application
restart
Start auto-
matically
Desktop icon

See Adding applications
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Option Description

Free parameters
(optional)

Individual parameters for application start

Example: PNATimeout=60 bringsCitrixWorkspace app1 to try for 60
seconds to enumerate the published applications and desktops.

To configure dual-monitor mode, you can also use the Free parameters,
see below.

For further information, see Defining free application parameters.

3. To configure further settings, click Advanced and edit the following fields:

Option Description

Window prop-
erties

For resolution/window size, color depth and audio output, select Use
default (server settings) or select one of the values from the list-field.

Timed logoff To enable automatic logoff from theWeb Interface server, select the Logoff
after option and specify a delay in seconds. Automatic logoff does not affect
the launched desktop.

Alternatively, automatic logoff can be configured to be performed after the
last PNAgent application has been closed.

Application recon-
nection

Determine the actions to be done on a reconnect to theWeb Interface
server

Do not reconnect: The connection to the desktop or the published applic-
ations is not restored (default).

Disconnected sessions only: The connection to a disconnected session is
restored.

Active and disconnected sessions: The connection to a disconnected or
active session is restored.

Manual logoff Determine the actions to be carried out upon logoff from theWeb Interface
server

Logoff only server: Logoff is performed only from theWeb Interface server

Logoff server and applications: Logoff is performed from theWeb Inter-
face server and from the virtual desktop or published applications.

Logoff server and disconnect session: Logoff is performed from theWeb
Interface server but the virtual desktop session is only disconnected. This
enables users to reconnect later on.

1formerly Citrix Receiver
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Note
Access to the advanced settings can be defined via the object rights.1

4. Confirmwith Apply andOK.

Program Neighborhood variables

For example, variables can be used to define a unique client name for a Citrix XenApp session. To log
on to aWeb Interface server with ProgramNeighborhood, you can use the following variables:

$ICAUSER Username

$ICADOMAIN Domain for this user

$ICAAPPLICATION Name of the PNAgent application definition

Creating a domain list

For PNAgent applications, you can create a domain list fromwhich the user can select a domain.

1. Create the text file icadomains without file name extension.

2. Enter the required domain names, one domain per line.

3. Save the file to the Scout Enterprise installation directory.

4. Transfer the file to the /Setup directory on the Thin Client by using the Scout Enterprise feature
Files.

If some of the configuration data aremissing when a PNAgent application is started, themissing data
are requested by a CitrixWeb Interface logon dialog. The defined domains are listed in a drop-down list.

Note
In the PNAgent application definition, you can predefine a specific domain.
Example: work.sampletec-01.com.

Settings for dual monitor mode

For PNAgent sessions, you can configure a dual-monitor mode by using one of the followingmethods.
The Citrix session can be transferred to the first monitor, to the secondmonitor, or to both of them.

1for Scout EnterpriseManagement Suite 15.5 and later versions
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Method 1:

Use the Advanced file entries feature of the Scout Console andmodify the ICA software defaults:

File /setup/sessions.ini

Section ICADefaults

Entry Xinerama

Value -1|0|1

For further information, see Advanced file entries.

Method 2:

In the Scout Console, in the application definition, set the following Free parameters:

Key=Xinerama
Value=-1|0|1

For further information, see Free parameters.

The valuesmean the following:

-1 bothmonitors

 0 first monitor

 1 secondmonitor

7.2.11. Defining an ICA application

Note
Access via the ICA application type is deprecated and only supported byCitrix up to XenApp
version 6.x.
For elux RP 6, the local application definition does not support the ICA type.

1. Add a new application and select the application type ICA.

2. Edit the following fields:

Option Description

Name Name of the application

Published applic-
ation

Configures direct access to a published application

To provide access to complete desktops, clear the option.

Server IP address or name of the Citrix server (terminal server)
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Option Description

Application Only relevant if you have selected the Published application option

Name of theWindows application including path (see Citrix server)

Note: The Browse option applies to the Citrix farm but is no longer sup-
ported.

Working dir-
ectory
(optional)

Only relevant if you have selected the Published application option

Working directory for the application

Login The user is automatically logged on to the Citrix server by using the spe-
cified credentials (username, password, domain).

Pass-through
logon

The user is logged on to a Citrix server via single sign-on. The AD user cre-
dentials are used.

Note: Kerberos authentication is no longer supported with Citrix Receiver
for Linux 13.x and later versions.

Smart card logon The client uses a smart card for logon.

Application
restart
Start auto-
matically
Desktop icon

See Adding applications

Free parameters
(optional)

Individual parameters for application start

For further information, see Defining free application parameters.

Connection
options

Advanced (eLux)

Opens the Citrix configuration dialog (wfcmgr)

Edit the relevant options.

The CitrixWorkspace app1 configuration is saved to the file
/setup/ica/wfclient.ini on the Thin Client and can be viewed from
the Scout Console via the Diagnostic files feature.

3. Confirmwith Apply andOK.

A published application is displayed on the eLux client in the sameway as local applications.

1formerly Citrix Receiver
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7.2.12. Citrix software defaults

For all Citrix applications, in the Scout Console, you can define CitrixWorkspace app1 software defaults
that are applied to all devices of the relevant OU and subordinate OUs if configured.

The following options are available:

Client drivemapping

COMport mapping

Firewall settings

Citrix keyboard shortcuts

Window properties

Connection options

Bitmap caching

To edit the software defaults, see Defining software defaults.

Note
To define parameters in individual configuration files, use the Advanced file entries feature. All
parameters defined by using the Advanced ini entries override the software defaults.

Some of the Citrix default options are described below. For further information, see the Citrix doc-
umentation.

General tab

Option Description

TW2StopwatchMinimum Scrolling speed for remote applications (such as Adobe Acrobat Reader,
Microsoft Excel)

The higher the value, the slower the speed when scrolling

Note for Excel: A low value increases scrolling speed but delays as soon
as a selection is drawn down out of the visible screen area.

Default = 25

Client name template Definition of the client name in the Citrix session

Note: You can use the ProgramNeighborhood variables $ICANAME and
$ICADOMAIN to set a unique client session name. This is required for
Citrix Roaming and some XenApp programs. For further information, see
PNAgent application.

1formerly Citrix Receiver
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Drive Mapping tab

Option Description

A-Z The letters A to Z represent the logic drive names on the terminal server. In the
field on the right, you can assign a local resource to a drive letter that is to be
shown in the Citrix session.

Enter themount point relating to the local access path of the resource. The
mount points are provided by eLux: /media/usbdisk or /media/cdrom

Attributes E / R /
W

Type of access right

E = enable

R = read

W = write

Enable DriveMap-
ping

Must be selected to enable the defined drivemappings

Enable Dynamic
Mapping

Availablemass storage devices are assigned to the next free drive letter.

For further information, seeMount points.

COM ports tab

To connect via COMport, the device name of the Thin Client COMport is required.

The COMport device name always beginswith the string /dev. Device names are case-sensitive.

Examples:

Port device name COM port

/dev/ttyS0 COM1

/dev/ttyS1 COM2

The availability of COMports depends on the hardware platform.

Note
The client portsmust bemapped on the Citrix resource (such as desktops) accordingly. To do
so, use a net use command.
Example: net use com1: \\Client\COM2: /persistent:yes
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7.2.13. Citrix Connection Center

Bymeans of the Citrix Connection Center, users can see all current server connections and can log off,
disconnect or close themwithout operating the application. In addition, the connection transport stat-
istics can be viewed whichmight be helpful for slowing connections.

The Connection Center is provided as a desktop application.1

Defining the Citrix Connection Center

Note
If you use Citrix Receiver for Linux, the eLux package Citrix Receiver Extensions and the
included feature package Connection Center must be installed on the clients. If you use the
later Citrix Workspace app, the included feature package Utilities and tools must be
installed on the clients. Thismay requiremodifications of the image definition file on the web
server via ELIAS.

1. Add a new application and select the application type Local.

2. Edit the following fields:

Option Description

Name Name for the application

Local application Select Citrix Connection Center.

Parameter
(optional)

Command-line parameters for program start

3. Confirmwith Apply andOK.

7.2.14. Logging for Citrix Workspace app

For the CitrixWorkspace app, you can enable and configure logging via a configuration parameter.

Configuring the log level

1. In the Scout Console, for the relevant devices, open Advanced device configuration >
Advanced file entries.

1formerly as a systray icon on the taskbar
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2. Define the following entry

File /setup/ica/module.ini

Section WFClient

Entry SyslogThreshold

Value 0|3|7 0 Logging disabled (default)
3 Only errors are logged
7 Logs for all levels are generated

For further information, see Advanced file entries.

As soon as the new configuration is active, logs are written to /var/log/messages.

Enabling detailed logging for Microsoft Teams

Note
The eLux package Citrix Workspace app for Linux version 21.9.0.25-5 (available with
eLux RP 6 2110) or later and the included feature packageMicrosoft Teams Optimization
must be installed on the devices.

1. Create a configuration file named config.json and enter the following:

{
  "WebrtcLogLevel" : 0,
  "WebrpcLogLevel" : 0
}

2. Transfer the config.json file to the devices to /setup/ica/hdx_rtc_engine

For further information, see Files configured for transfer.

WhenMicrosoft Teams (in VDI) is used on the devices, the relevant log files are written.

To access the log files, use the diagnostics function. To do so, create a diagnostic template that con-
tains the following entries:

/tmp/hdxrtcengine/*/*
/tmp/webrpc/*/*

For further information, see "Configuring diagnostic files" on page 277.

After retrieving the diagnostic files, you can find the log files in the hdxrtcengine and webrpc dir-
ectories .
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7.2.15. Updating Citrix Workspace app

To install later versions of the CitrixWorkspace app on the devices, perform a firmware update.

Note
The existing /setup/ica/AuthManConfig.xml template will be overwritten with the tem-
plate of the new version. Individual entriesmust then be set again.
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7.3. RDP

TheRDP application type uses theMicrosoft Remote Desktop Protocol (RDP) to connect to aMicrosoft
terminal server. The provided RDP client is eLuxRDP that is based on the free software implementation
FreeRDP.

There are two options for configuration:

WindowsDesktop: The user accesses the desktop of a terminal server by using a remote
desktop session. The user can use any application available on the desktop.

Individual / seamless application: The user can only access one particular application of the ter-
minal server.

7.3.1. Defining an RDP Windows desktop session

1. Add a new application and select the application type RDP.

2. Edit the following fields:

Option Description

Name Name for the RDP application

Server IP address or name of the server

Application Leave the field empty.

Working directory Leave the field empty.

Logon The user is automatically logged on to the server by using the specified cre-
dentials (username, password, domain).

Pass-through
login

The user is logged on via single sign-on. The AD user credentials are used.

Free parameters Allows to define any parameters supported by eluxRDP in the format:

FreeRDPParams=<Parameter> <Parameter> <Parameter>...

Separatemultiple parameters by spaces.

Examples:
FreeRDPParams=/microphone:sys:pulse +fonts /cert-ignore

To view the allowed parameters, enter the eluxrdp command in a shell.

For further information, see Defining free application parameters.

3. Confirmwith Apply andOK.

Note
Defining a server-independent application as local hidden application named RDP_
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TEMPLATE allows you to configure a connection template without back-end. The user starts
rdpconnect from the shell and, subsequently, specifies the server to be connected to.
This feature requires the eLux software package RDPConnect.

7.3.2. Defining an RDP application

To configure an individual application via RPD, theWindows desktop definition requires additional data
about the relevant application.

1. Add a new application and select the application type RDP.

2. Edit the following fields:

Option Description

Name Name for the RDP application

Server IP address or name of the server

Application Name of theWindows application including path name

System variables are allowed.

Examples:
c:\Program Files\Microsoft Office\Office\EXCEL.EXE
%SystemRoot%\system32\notepad.exe

Working directory
(optional)

Working directory of theWindows application

Logon The user is automatically logged on to the server by using the specified cre-
dentials (username, password, domain).

Pass-through
logon

The user is logged on via single sign-on. The AD user credentials are used.

3. Confirmwith Apply andOK.

For the user, the application runs full-screen in the session window.

7.3.3. Advanced application settings / RDP and VMware

The settings described below apply to the following applications:

RDP applications

VMware applications

If you select a protocol other than RDP, some options are not available.

211



Accessing advanced application settings

Note
Access to the advanced settings can be restricted via the object rights.1

Scout Enterprise: In the Application properties dialog of an RDP or VMware application, click the
Advanced button.

eLuxRP 6: In the Application properties dialog of an RDP or VMware application, under Prop-
erties, expand the relevant section.

View tab

Option Description

Window size Full-screen or a specific resolution

Full-screen on
monitor

If you have selected the window size Full-screen, select if you want to dis-
play on one specific or all monitors. Up to eight monitors are supported.2

Colors Color depth for the session (8-32 Bit)

Note
If you usemultiple monitors but wish to display content on only one of them, under Device con-
figuration>3 > Desktop > Advanced > Windowmanager, theMaximize/fullscreen to
single monitor optionmust be selected.

Local Resources tab

Note
– for terminal servers supporting RDP protocol version 5.2 or later –
The settings take effect only if, on the Advanced tab, the value of the Protocol field is not set to
RDP V4.

1for Scout EnterpriseManagement Suite 15.5 and later versions
2for Scout EnterpriseManagement Suite 15.0 and later versions
3formerly Setup
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Option Description

Drivemapping Select drive, mount point and drive letter that you want to show in the
RDP/VMware session.
Themount points correspond to the local access paths of the resources and are
provided by eLux.

For USB devices themount points are
/media/usbdisk
/media/usbdisk0
and so on.
For further information, seeMount points.

Connect printer Up to four printer definitions can be created automatically for a session. The print-
ersmust be configured on the Printer tab in the eLux device configuration and
have the correct driver name as defined on the server (case-sensitive!). The first
four profiles can be used with drivers. To define a default printer, choose Set as
default in the eLux printer configuration.

Sound Play local reproduces the sound locally on the client. Play remote causes play-
back on the remote server.

Connect ports Makes the defined port connections accessible in the session

Enable smartcard Smart cards based on a certificate can be used for logon.

Advanced tab

Option Description

Protocol (only RDP) Enables you to set the RDP protocol to version 4 or 5
Normally, the protocol is recognized automatically.

Keyboard language Defines the keyboard layout within a session
The default is Auto which corresponds to the keyboard setting of
the eLux device configuration.

Important If you define a specific language, it must be identical to the keyboard language
defined in the eLux device configuration, in the Keyboard dialog.

DeactivateWindow-Manager
Decorations

The frames of the eLuxwindows are hidden.

Deactivate encrypting The server does not accept encrypted sessions. You can use this
option to increase performance.
By default, the option is disabled.

Deactivatemousemove events Mouse position data are not transferred to the server constantly,
but with everymouse click. This increases system performance
and is especially helpful for connectionswith small bandwidth.
By default, the option is disabled.
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Show connection bar on full
screen

Shows connection list in full-screenmode

Bandwidth Choose between standard, modem, broadband or LAN.

7.3.4. Configuring RemoteFX

Microsoft RemoteFX™ offers comprehensive functionality for Virtual Desktop Infrastructure (VDI) by
providing a virtual 3D adapter, intelligent codecs and the ability to redirect USB devices to virtual
machines.

Note
RemoteFX only works if the server supports RemoteFX and is configured in the right way.
The only parameter to be configured on the client is bandwidth.

1. For your RDP application, open the Application properties dialog and click Advanced.

2. On the Advanced tab, in the Bandwidth field, select LAN.

3. Confirmwith Apply andOK.
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7.4. Virtual Desktop

Note
For eLuxRP 6, instead of Virtual Desktop, the application type VMware Horizon is available.

The Virtual Desktop tab helps you define Citrix or VMware connectionswith with a VD broker.1For
Citrix XenDesktop, the logon data are defined according to an ICA connection.

7.4.1. Defining a virtual desktop

1. Add a new application and select the application type Virtual Desktop.

2. Edit the following fields:

Option Description

Name Name for the application

VD Broker Select a virtual desktop application from the list.

Server Enter the server IP address (or name)

Logon
Pass-through
logon

See Adding applications

Protocol
(VMware Hori-
zon only)

Choose between the following values:
RDP
PCoIP
VMware Blast2

3. To configure further settings for XenDesktop or VMware Horizon, click Advanced. For further
information, depending on the broker selected, see

Advanced application settings / RDP and VMware (for VMware Horizon)

Advanced XenDesktop settings or

4. Confirmwith Apply andOK.

7.4.2. VMware Horizon

Note
This application type is available only on the eLuxRP 6 device. In the Scout Console, choose
the Virtual desktop application type and, under VD broker, select VMware View.

1FromScout EnterpriseManagement Suite 15.8, only VMware Horizon is supported.
2for Scout EnterpriseManagement Suite 15.2 and later versions
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Option Description

Name Name for the application

Auto-start The application starts automatically after eLux has been started.

Desktop icon Provides a desktop shortcut on your personal desktop

VD broker VMware Horizon

Server IP address or name of the server

Pass-through
logon

The user is logged on via single sign-on. The AD user credentials are used.
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Option Description

Username, Pass-
word, Domain

The user is automatically logged on to the server by using the specified cre-
dentials.

Use SSL Forces the connection via HTTPS

Note that HTTPS connections require the relevant SSL certificates on the client.

Show last user The user credentials (except for password) of the last logon are displayed in the
logon dialog

Protocol Choose between the following protocols:
RDP
PCoIP
VMware Blast1

For information on Display, Local resources and Advanced settings, see Advanced application set-
tings.

You can configure the VMware Horizon client by using the application definition in the Scout Console or
locally on the client. To set additional parameters that are not included in the interface, use a con-
figuration file:

With the help of VMware documentation,2 create the file view-userpreferences. Transfer the
file via the Scout feature Files configured for transfer to the clients to
/setup/elux/.vmware/view-userpreferences

Note
The configuration on the Scout or eLux interface has precedence over the configuration file
and will overwrite values of the configuration file.

1for Scout EnterpriseManagement Suite 15.2 and later versions
2Installation guide for VMware Horizon Client for Linux
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7.5. Browser

Supported browsers areMozilla Firefox andGoogle Chromium.

In addition, the Builtin Browser is available as a slimmed-down browser.1The Builtin Browser is based
on theWebKit2 engine which is part of the Desktop environment2 package. By default, the Builtin
Browser is run without address and navigation bar. These and somemore features can be configured
for the kioskmode.

Note
If you use Chromium, we recommend that you equip your Thin Clients with 2 GB of RAM.

For eLuxRP 6 and later versions, the Java browser plugin is no longer supported.

7.5.1. Defining a browser application

1. Add a new application and select the application type Browser.

2. Edit the following fields:

Option Description

Name Name of the browser shown in the Scout Console

Browser type Select Firefox, Chromium or Builtin Browser.3

Start page Web page (URL) that openswhen you click Home

Called page Web page (URL) that opens after starting the browser

Proxy type No proxy: No proxy server is used

Manual (Proxy:Port): Specify a proxy server and port number

Auto (URL): Use a proxy configuration file

Use system proxy (default):4 'System-wide' proxy setting
defined in the device configuration under Network > Advanced per
network profile

Note that the setting behind System proxy can also be No
proxy).

For further information, see Proxy configuration.

1for Scout EnterpriseManagement Suite 15.4 / eLuxRP 6.5 and later versions
2formerlyMATE Desktop
3for Scout EnterpriseManagement Suite 15.4 / eLuxRP 6.5 and later versions
4for Scout EnterpriseManagement Suite 15.5 and later versions
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Note
For the Builtin Browser, the settingmust be left on Use system proxy.

Application
restart
Start auto-
matically
Desktop icon

See Adding applications

Free parameters
(optional)

Individual parameters for application start
see Defining free application parameters

3. To enable the Kiosk mode for Firefox, see Configuring kioskmode.

4. Confirmwith Apply andOK.

Note
By default, all browser files (cache, history, bookmarks, etc.) are saved temporarily to the flash
memory but are deleted with each restart. We recommend that you configure the browser
home directory on a network drive. For further information, see Browser home directory.

Further browser-specific preferences can be set through policies (Chromium) or configuration file
entries (Firefox.). For further information, see the Scout Enterprise guide:

PreferencesChromium

Preferences Firefox

Deploying SSL certificates for the browser

Use the Scout Enterprise feature Files configured for transfer to transfer certificate files to the
required target directory on the client:

Mozilla Firefox /setup/cacerts/firefox for eLuxRP 6.4 and earlier versions
/setup/cacerts/browser for eLuxRP 6.5/Firefox 60.5 and later ver-
sions1

Google Chro-
mium

/setup/cacerts/browser

For further information, see Files configured for transfer.

Note that a second restart of the client is required to assign the certificates that have been transferred
during the first boot to the certificate store of the browser.

7.5.2. Preferences Chromium

By using policies, you can set mandatory (managed) and recommended preferences for the Chromium
browser. Mandatory preferences define fixed values that cannot be changed by the user.

1The certificates can be located in either directory.
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Recommended preferences define default values that can be changed by the user. For further inform-
ation, see https://www.chromium.org/administrators/.

Use the Scout Enterprise feature Files configured for transfer to transfer policy files (.json) to
the required target directory on the client:

Fixed values /setup/chromium/managed

Default values /setup/chromium/recommended

For further information, see Files configured for transfer.

7.5.3. Preferences Firefox

For version 60 ESR and later versions, Firefox supports enterprise policies that are deployed via .json
files and are cross-platform compatible.1Starting with RP 6.5 and later versions, Firefox is installed with
enterprise policies enabled that block access to about:config and other configuration options by
default.

Setting preferences with .json files (policies)

– for eLuxRP 6.5 / Firefox 60 ESR and later versions –

You can use all options that are listed in the README on theMozilla GitHub repository.2

One or more options are transferred in a .json file to the client by using the Scout Enterprise feature
Files configured for transfer.

Note
By default, access to the Firefox configuration is blocked.

1. Create a .json file (any file name) and insert one or more options separated by commas.

Example:
{
"BlockAboutConfig": false,

"DisableBuiltinPDFViewer": true
}

2. In the Scout Console, for the relevant clients, open Advanced device configuration3 > Files.

Define your .json file as source file. For the destination folder, use
/setup/firefox/policies/.
Example: /setup/firefox/policies/custom_A.json

For further information, see Files configured for transfer.

On the next client restart, the files are transferred and evaluated.

1Thismethod will not work if Firefox is already beingmanaged by usingWindows group policies.
2Note that the current Firefox versionmay differ from that of the eLux version you are using.
3formerly Advanced settings
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Note
You can deploymultiple .json files to the client to /setup/firefox/policies/. The
files aremerged in alphabetical order: For identical options, values from files with descending
names have precedence (B overrides A).

7.5.4. Preferences Builtin Browser

Display options

By default, the Builtin browser openswith only the title bar, but no navigation bar.

To display the navigation bar with additional functions, open the properties of your browser applic-
ation and click Advanced.1

With which functions the navigation bar is displayed, you also define in the Advanced browser settings:

1 Back

2 Forward

3 Home button to open home page

4 Refresh

5 Adress bar

6 Print

The title bar is always shown.

User Agent-String

With each page request, the Builtin browser transmits a 'User Agent' string, which is predefined by the
WebKit2 engine. It contains information likeMozilla compatibility and operating system.

To transmit individual information, define an Advanced file entry:2

1. In the Scout Console, for the relevant devices, open Advanced device configuration >
Advanced file entries.

2. Define the following entry:

File /setup/sessions.ini

Section [BuiltinBrowserDefaults]

1from 15 2101 und eLux RP 6 2103
2from eLuxRP 6.8.2
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Entry UserAgentString

Value <name/version> <individual string>
Example: Mozilla/5.0 (X11; Linux x86_64)

For further information, see Advanced file entries.

Note
Name and versionmust be included in the User Agent string.

DNS cache

– from eLux RP 6 2104 –

The DNS cache of the Builtin browser is set to 120 seconds by default. To configure the timeout value
individually, define an environment variable in the Advanced device configuration:

1. In the Scout Console, for the relevant devices, open Advanced device configuration > Envir-
onment.

2. To define a new variable, click New.

3. Enter the variable using the format:
WEBKIT_DNS_CACHE_EXPIRE_TIMEOUT=<number of seconds>
and confirmwith OK.

The new variable is shown in the list.

For further information, see "Environment variables" on page 172.
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7.5.5. Browser home directory

By default, the browser settings are temporarily saved to the flashmemory. However, they are deleted
with each client restart.

If you define a browser home directory on the network, browser settings such as bookmarks can be
saved andmade available to the user after each client restart. Use a network share that you have con-
figured for access:

Requires
ConfiguredWindows network share (Defined drive).
Example: /smb/share
For further information, see Defining a network drive.

Defining browser home directory

Note
The following information refers to Scout EnterpriseManagement Suite 15.0 and later ver-
sions. Documentation for earlier versions can be found in the Archive section of the PDF
downloads page.

1. In the tree view, for the relevant level, open the Applications context menu and click Software
defaults...

For further information, see Defining software defaults.

2. In the list-field, select the relevant browser and click Edit.

3. In the Browser home directory field, enter the name of one of the defined drives in Device con-
figuration1 > Drives. The namemust correspond to the name on the list.
Example: /smb/share

4. Confirmwith OK.

The browser settings are saved to the specifiedWindows directory.

1formerly Setup
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7.5.6. Kiosk mode for Firefox

– for Firefox up to version ESR 52.8 1 and from version 71.0 –

Note
For eLux RP 6.5 and later versions, you can use the Builtin Browser in kioskmode. For further
information, see Builtin Browser in kioskmode.

The kioskmode starts the browser in full-screenmode and with limited user rights. The user cannot
open other windows and cannot exit the browser.

By default, the browser window is displayed without address bar and navigation buttons. So users are
forced to stay on the predefined web page and cannot exit.

Kioskmode is suitable if the users are supposed to see only one website and not use further applic-
ations on the Thin Client. For correct use of the kioskmode, we recommend that you disable related
functions of the Thin Client such as restarting the device and opening the control panel. For further
information, see Device configuration > Security.

Configuring kiosk mode

Note
Firefox supports kioskmode again starting with version 71.0, but without configuration
options.With Scout 15 2110, the Firefox application definition is adapted and offers only the
option Enable kiosk mode.

1. In the application properties of your browser application, click Advanced.

2. On the Kiosk mode tab, edit the following fields:

Option Description

Enable kiosk
mode

Activates the kioskmode

Display nav-
igation bar2

Allows using browser tabs despite kioskmode

Users can view multiple web pages of the defined web site concurrently

Add print button3 Allows using browser tabs and provides a Print feature despite kioskmode

Add address
bar4

Allows using browser tabs and provides the address bar including nav-
igation buttons despite kioskmode

3. Confirmwith Apply andOK.

1included in eLuxRP 6.4
2up to Scout 15 2107
3up to Scout 15 2107
4up to Scout 15 2107
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On the next restart, the Firefox browser opens in kioskmode.
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7.6. Local and user-defined applications

Defining local commands is particularly important as they enable the definition of applicationswhich can
be launched within a shell. This feature assumes knowledge about the commands that average users
may not have.

Note
Make sure that the user is authorized to start the application. All commands are executed by
the UNIX user eLux (UID = 65534).

Some of the local applications are predefined. If an application ismissing, you can define your own
application or command via the Custom option of the Local Application list-field.

Error messageswill not be shown. If your command does not include an X client application, nomes-
sages are shown during execution. For this reason, we recommend first running the commandwithin an
XTerm session for testing purposes.

7.6.1. Defining predefined local applications

1. Add a new application and select the application type Local.

2. Edit the following fields:

Option Description

Name Name of the application shown in the Scout Console

Local application In the list-field, select a predefined application.

Parameter
(optional)

Command-line parameters for application start

Application restart
Start automatically
Desktop icon

See Adding applications

Free parameters
(optional)

Individual parameters for application start
see Defining free application parameters.

3. Confirmwith Apply andOK.

7.6.2. Defining custom applications

1. Add a new application and select the application type Local.

2. Edit the following fields:

Option Description

Name Name of the application shown in the Scout Console

Local application Select Custom.
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Option Description

Parameter
(mandatory)

Enter the program name required to start the application.
If required, add start parameters.

Example:
calibrator calls the Calibrator tool
squid calls the Squid application
squid /tmp/mycache calls Squid using the specified cache directory

Hidden The application is not shown on the Application tab of the client control panel.
The option Start automatically or Application restart must be active.

Application restart
Start automatically
Desktop icon

See Adding applications.

Free parameters
(optional)

Individual parameters for application start
see Defining free application parameters

3. Confirmwith Apply andOK.

The figure shows the application definition for the calibration tool Calibrator. After the next client restart,
the Calibration application is provided on the client and can be started via the control panel, start menu,
or desktop icon (provided that the Calibrator tool is included in the image).

7.6.3. Defining Zoom for Linux

The native Zoom client for Linux is a Video Conferencing andWebConferencing service and offers
high-quality video, audio, and screen-sharing experience.
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The video and audio devices are configured via the application interface.

1. Add a new application and, in the Application properties, select the application type Local.

2. Edit the following fields:

Option Description

Name Name for the application

Application Custom

Parameter zoom

3. Confirmwith Apply andOK.
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7.6.4. Defining Ekiga SIP Softphone

Ekiga is a free software application for audio and video telephony (VoIP) that supports the SIP protocol.
Configuration is based on a SIP account.

1. Add a new application and, in the Application properties, select the application type Local.

2. Edit the following fields:

Option Description

Name Name for the application

Application Custom

Parameter ekiga

3. Click Free parameters and then Add to define the following free parameters:

Variable Value

account <Name of the SIP account>

server <server URL>

user <SIP username>

password <password>

outbound_proxy <proxyURL >

Example: password=424242
For further information, see Using free application parameters.

4. In the Free application parameters dialog, right-click the variable name password and click
Encrypt.

5. Confirmwith Apply andOK.
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7.7. Emulation

FromScout 15 2110, the following emulations are supported:1

PowerTerm InterConnect

Licensed emulation suite that allows you to connect to IBMmainframes, IBMAS/400, Unix,
VAX/AlphaOpenVMS, Tandem (NSK), HP-3000, Data General andmore

5250 terminal emulation

7.7.1. Configuring PowerTerm InterConnect

Note
The use of PowerTerm InterConnect requires the relevant application licenses.

The configuration of PowerTerm InterConnect is carried out in two steps:

Define a PowerTerm application on a reference device and transfer the created configuration
files

Define a PowerTerm application for all devices by using the configuration files created on the ref-
erence device

Defining a PowerTerm InterConnect application for a reference device

Note
The PowerTerm software packagemust be installed on the device. Thismay requiremodi-
fications of the image definition file on the web server via ELIAS.

1. On the reference device or in the Scout Console, define a PowerTerm application containing only the
application name (for details see below).

2. Start the PowerTerm application on the reference device and configure the applicationmanually.

The configuration is saved to the local client directory /setup/PowerTerm/ in the following four
files
ptdef.pts
ptdef.ptc
ptdef.ptk
ptdef.ptp

3. Close the PowerTerm application.

4. Copy the four configuration files via network or USB stick andmake them available to Scout
Console.
Or:

1Applications of the Emulation type can only be defined in the Scout Console but not locally on
eLux RP 6 devices.
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Transfer the files from the device to the Scout Console remotely by using Request diagnostic files
with an individual template. For further information, see Configuring diagnostic files.

The configuration files for the PowerTerm configuration are provided. The second stepmay be carried
out.

Defining a PowerTerm InterConnect application for all devices

1. In the Scout Console, add a new application for the relevant OU.

2. On the Emulation tab, in the Emulation type list, select PowerTerm.

3. Edit the following fields:

Option Description

Name of application Enter an appropriate namewithout using white spaces.

Parameters Optional starting parameters for the PowerTerm application:
-fullscreen
-maximize
-no-menu-bar
-no-tool-bar
[myName].pts

full screen
maximized window
nomenu bar
no toolbar
name of an individual PowerTerm configuration
file of the client

Example 1: -fullscreen -no-menu-bar -no-tool-bar

Example 2: -fullscreen ptconfig001.pts

Terminal setup file Select the relevant .pts file of the reference device from the file system.

Communication file Select the relevant .ptc file of the reference device from the file system.

Keyboard file Select the relevant .ptk file of the reference device from the file system.

Power PAD file Select the relevant .ptp file of the reference device from the file system.

x button Delete previously selected configuration file from the Scout Enterprise
database if required.
To delete the file physically from the device, you need to perform a fact-
ory reset.

4. Confirmwith Apply andOK.

PowerTerm InterConnect is available for all devicesof the relevant OU on the next restart.
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7.8. Applications in kiosk mode

Some applications can be configured so that users can only operate them in kioskmode.

In kioskmode, the application opens as a full-screen window. Users cannot open any additional win-
dows and cannot close the application. The connection settings and the resources that users are
allowed to access at the back-end, such asCitrix stores, are predefined in a configuration file. As a con-
sequence, defining applications for the user becomes obsolete.

After system start, the client starts the application defined by the configuration files in kioskmode, ensur-
ing that the user is directly in the intended work environment and cannot break out.

Version information for kiosk mode support

Configuration via
.ini file

Configuration via console (GUI)

Citrix Self-Service-user interface with
extensions

from eLuxRP 6.2 fromScout 15 2107 and
eLux RP 6 2110.1

Builtin Browser from eLux RP 6.51 fromScout 15 2107 and
eLux RP 6 2110.1

Konfigurationsdatei kioskmode.ini kioskconfig.ini

7.8.1. Setting up kiosk mode via console

– fromScout 15 21072 –

The Scout Console interface allows you to define kioskmode for Citrix Self-Service (A) aswell as for
the Builtin Browser (B). The corresponding function is located in the device configuration under Secur-
ity. The kioskmode can be configured differently depending on theOU.

1For earlier versions, use Firefox in kioskmode.
2The devices support the new settings only from eLux RP 6 2110.1.
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1 Enable kioskmode and select type

2 Import existing configuration

3 View configuration

4 Configure kioskmode for selected type (browser or
Citrix)

1. For the relevant devices, open Device configuration > Security.

2. Under Kiosk mode in the list-field, choose whether you want to activate the kioskmode for Citrix
Self-Service (A) or Browser (B).

3. If you already have a kioskmode.ini or kioskconfig.ini, click Import...

4. Click Edit.

Depending on the selected type, the configuration dialog for Citrix Self-Service stores (A) or for
browsers (B) opens.

1 Create new browser

2 Edit selected browser

3 Set selected browser as default

4 Mark selected browser as favor-
ite

5. Create and configure at least one store (A) / browser (B) for kioskmode.

6. If you have createdmultiple stores (A) / browsers (B), you can then set one as default.

On logon, default stores (A) / browsers (B) are pre-selected or started automatically.

7. If you have createdmultiple stores (A) / browsers (B), you canmark one or more as favorites.

Favorites are shown to the user on the store selector of the system bar with an asterisk.
Favorites for stores can only be defined without MultiStore.
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Your configuration is written to the kioskconfig.ini file. To check it, click the Preview button. The
next time the server connects to the devices, your selected kioskmode type (terminal.ini entry)
will be transferred along with the kioskconfig.ini.

(A): On the devices, after start-up, the Citrix Self-Service interface opens in kioskmode. The configured
stores are available to the user. No other applications can be started apart from the Self-Service inter-
face.

(B): On the devices, after start-up, the Builtin browser opens in kioskmode. The configured functions
are available to the user. No other applications can be started apart from the browser.

Note
For correct use of the kioskmode, we recommend that you restrict the user rights for the client
as required.

7.8.2. Configuring browser for kiosk mode

– fromScout 15 21071 –

1. In the Kiosk-Modus / Browser dialog, create a new browser definition. To do so, click New.

2. Select and edit the newly created browser definition:

1 Display name of the browser

2 Web page (URL) that opens
after starting the browser

3 Web page (URL) that opens
when you click HomeHome

4 The first URL users load after
the home page will be saved as
new startup page.2

5 Unhide navigation bar

6 Elements of the navigation bar
to be shown

3. Confirmwith OK.

1The devices support the new settings only from eLux RP 6 2110.1.
2How users access the Home page (Home button, link on the startup page, address bar or configured
Home page is identical to startup page) is irrelevant. Nevertheless, we recommend that you show the
navigation bar with Home button when selecting this option.
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7.8.3. Configuring Citrix Self-Service for kiosk mode

– fromScout 15 21071 –

Note
The eLux package Citrix Workspace app for Linux must be installed on the clients.
The eLux package Citrix Extensions 2.x or later and the included feature package Self-ser-
vice wrapper must be installed on the clients.

For modifications on the Citrix dialog design, further feature packagesmust be installed on the
clients:
Dialog Extension and Self-service dialog themes

Thismay requiremodifications of the image definition file on the web server via ELIAS.

1. For Citrix Self-Service, first configure the settings, see below. These apply to all stores.

2. In the Kiosk mode / Citrix Self-Service dialog, ceate a new store. To do so, click New.

3. Edit the new store:

Option Description

Name Display name of the Citrix-Store

Store URL Web page (URL) that opens immediately after starting the browser

Autostart
resources

List of Citrix applications/desktops you want to start automatically after
logon

Currently only available in combination with theMultiStore option

4. Confirmwith OK.

If multiple stores are defined, users can switch between stores using the Store button on the system bar
(store selector). Storesmarked as favorites are displayed with an asterisk. If MultiStore is configured,
users can switch between stores via the logon dialog. For further information on theMultiStore option,
see below.

Self-Service settings for kiosk mode

To access the general settings, in the Kiosk mode / Citrix Self-Service dialog, click Settings.

1The devices support the new settings only from eLux RP 6 2110.1.
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1 MultiStore: During logon, users can
choose between pre-defined stores.

2 Logon can be done without passthrough
credentials, via Active Directory or with a
defined username+password. The pass-
wordmust be ICA-encrypted.

3 Logoff can be done automatically. Set
the timer for it.

4 Delay in secondswhen the logoff timer is
started

5 Display duration for message on logoff

6 Self-Service tries to reconnect all ses-
sions for a store directly after logon to
that store (Citrix Self-Service option).

7 Self-Service tries to reconnect all ses-
sions as soon as an application is started
or the store is updated (Citrix Self-Ser-
vice option).

8 Users are allowed to subscribe to extra
applications (Citrix Self-Service option)

9 Use one system account for multiple
users (Citrix Self-Service option)

The user data are deleted when they
close the app or log off.

We do not recommend combining this
option with MultiStore.

10 The session is displayed in windowed
mode (instead of full-screen) (Citrix Self-
Service option).

11 Define domains

12 Define helpers for MultiStore

You no longer have to group stores into environments.

MultiStore

TheMultiStore option allows you to predefinemultiple stores - optionally in different domains. Define
one of the stores as the default store. Users are then presented with a Citrix Self-Service logon dialog
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fromwhich they can choose between the preconfigured domains and stores. The default store is pre-
selected as the Home location with its domain.

1 Configurable title text (MultiStore title)

2 Usersmust log on with their username and pass-
word.

3 Predefined domains

4 Predefined stores

5 Users are redirected to your password reset page,
to be defined under Helper.

If you have defined auto resources for a store, the specified desktops or applications are started auto-
matically after logon.

Note
The store selector on the system bar is not available to the users. To switch to another store,
users log off and return to the logon dialog.

Note the following for configuration:

Define one domain as aminimum.

If you definemultiple stores, one storemust be set as the default.

Logon with passthrough is not available.

We do not recommend combiningMultiStore with Shared User Mode.

Domains

Domain definition is required if you useMultiStore or – without MultiStore – if you configure
Passthrough for Active Drectory.

In the Self-Service / Settings dialog, click New to create one or more domains. Then edit the new
entries.
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1 Display
name for
domain

2 Domain as
FQDN

3 URL for a
page that
allows
resetting
passwords
(MultiStore
only).

Helper

– onlyMultiStore –

A helper URL links to an existing password reset page. To access this page, users click a button in the
MultiStore logon dialog.

Note
You can define one helper URL per domain. This is normally done when you define a domain.

To configure the button for the users and the behavior of the browser with reset page, use the Helper
dialog.

In the Self-Service / Settings dialog, under Domains, click Helper.

Option Description

Button text Button label in theMultiStore logon dialog

Example: Forgot password?

By default, this text is additionally shown in the browser title
bar above the reset page.

Timeout Timeout for launching the Bultin browser and loading the
password reset page

Options Optionally, specify additional parameters for the browser
start.

Example: --title "Reset password"

If users do not remember their password, they click the relevant button in theMultiStore logon dialog.
This launches the Builtin browser and loads the helper URL defined for the domain the user is logging
on to.
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Design of the Citrix dialogs

To change the design of the Citrix dialogs for all Citrix connections, in the Kiosk mode / Citrix Self-
Service dialog, click Theme.

Option Description

Name Name of the Citrix theme

Default: ucselfservice

Window decoration The windows are displayed with window decoration.

On hovering… Background color for list elements onmouse hover (Citrix list
selection widgets)

Default: #e6f1f7

Unselected… Background color for unselected list elements(Citrix list selec-
tion widgets)

Default: #ffffff

Selected… Background color for selected list elements (Citrix list selec-
tion widgets)

Default: #cce3f0

7.8.4. Citrix Self-Service in kiosk mode (< eLux RP 6 2110.1)

– for eLuxRP 6.2 and later versions –

The Citrix Self-Service user interface with extensions is no longer configured as a user-defined applic-
ation ucselfservicewith free parameters. For eLuxRP 6.2 and later versions, you do not need to
define an application; instead, you configure the kioskmode. All relevant parameters are defined in the
configuration file kioskmode.ini. Advanced functionality andMultiStore option are also con-
figurable.
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Defining Citrix Self-Service UI in kiosk mode

Note
The eLux package Citrix Workspace app for Linux or Citrix Receiver for Linux 13.x must
be installed on the clients.
The eLux package Citrix Extensions 2.x1 or later and the included feature package Self-ser-
vice wrapper must be installed on the clients.

For modifications on the Citrix dialog design, further feature packagesmust be installed on the
clients:
Dialog Extension and Self-service dialog themes

Thismay requiremodifications of the image definition file on the web server via ELIAS.

1. For the relevant clients, open Advanced device configuration2 > Advanced file entries and
define the following entry:

File /setup/terminal.ini

Section Layout

Entry KioskMode

Value 1

For further information, see Advanced file entries.

This parameter enables the kioskmode for the Citrix Self-Service user interface with extensions.

2. Create a text file named kioskmode.ini and add the section header [Parameters]. Enter
the relevant parameters:3

Parameter Description

ReconnectOnLogon=true|false Determineswhether the Self-Service UI tries to recon-
nect to all sessions for a given store, immediately after
logon to that store (Citrix Self-Service option)

ReconnectOnLaunchOrRefresh=true|
false

Determineswhether the Self-Service UI tries to recon-
nect to all sessionswhen an application is launched or
the store is refreshed (Citrix Self-Service option)

1formerly Citrix Receiver Extensions
2formerly Advanced settings
3Default values are displayed in bold
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Parameter Description

SharedUserMode=true|false If the Shared User Mode is enabled, the Self-Service
UI uses one technical user account for multiple users.
The user data are removed from the device when
users log off or close the UI.
(Citrix Self-Service option)

We recommend that you do not use this parameter
together with Prelogin=true

SelfSelection=true|false Is used to disable the search box and the Self-Selec-
tion panel (legacyUI)

Disabling these UI elements prevents users from sub-
scribing to extra applications.

LogoffMode=0|1|2|3 0 = No automatic logoff
1 = Logoff timer is started with logon
2 = Logoff timer is started when the last Citrix
app/desktop is closed
3 = Logoff timer is started when the first Citrix
app/desktop is opened

LogoffDelay=<seconds> Delay in seconds after the logoff timer is started

LogoffInfoTimeout=<seconds> Shows amessage for n seconds during logoff

ShowLastUser=true|false Shows last logged-on username in User field

PreLogin=true|false Determines, whether on logon a dropdown list with
pre-configured stores is shown (MultiStore).

We recommend that you do not use this parameter
together with SharedUserMode=true

PreLoginTitle Dialog title for the stores list (MultiStore)

PassThroughMode=0|1 0 No pass-through logon data
1 Active Directory

Domain<1-N>=<Domain display
name,domain>

Each entry contains a domain.

3. To define access to the stores, in the kioskmode.ini file, add one or more sections named
[Store<1-N>] or [Environment_Store<1-N>].

If you define stores by using [Environment_Store<N>], the user can switch between the
stores by clicking the Store button on the taskbar. The Stores are shown in groups (Environment)
as defined.

[Store<1-N>]
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Parameter Description

Url=<Store URL> URL of the Citrix store

FriendlyName=<Store display name> Display name for the Citrix store

Default=true|false Determineswhether this store is displayed as default
store

AutostartResources=
<App/Desktop1;App/Desktop2;...>

List of Citrix applications/desktops to be started auto-
matically after logon

Currently only available with PreLogin=true

[Environment_Store<1-N>].

Parameter Description

Url=<Store-URL> URL of the Citrix store

FriendlyName=<Anzeigename> Display name for the Citrix store

Default=true|false Determineswhether this store is displayed as default
store

Environment=<Gruppenname> Specifies the group bywhich the stores are grouped
(freely definable character string)

AutostartResources=
<App/Desktop1;App/desktop2;...>

List of Citrix applications/desktops to start auto-
matically after logon

Currently only available with PreLogin=true

4. To change the design of the Citrix dialogs for all Citrix connections, in the kioskmode.ini file,
add a section named [Theme]:

Parameter Description

ThemeName=<Themes> Name of the Citrix theme

Default: ucselfservice

Decorated=true|false Determineswhether the windows are shownwith win-
dow decoration

ColorHover=<RGB-Farbcode> Background color for list elements onmouse hover
(Citrix list selection widgets)

Default: #e6f1f7

ColorUnselected=<RGB-Farbcode> Background color for unselected list items(Citrix list
selection widgets)

Default: #ffffff
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Parameter Description

ColorSelected=<RGB-Farbcode> Background color for selected list elements (Citrix list
selection widgets)

Default: #cce3f0

5. Transfer the kioskmode.ini file to the clients to /setup/kioskmode.ini. To do so, use
the Scout Enterprise feature Files configured for transfer. For further information, see Files con-
figured for transfer.

The terminal.ini entry along with the kioskmode.ini file on the client will cause the client to
open the Citrix Self-Service interface in kioskmode after start-up. The configured stores are available to
the user. No other applications can be started apart from the self-service interface.

Note
If more than one store is configured, users can switch between the stores by clicking the Store
button on the taskbar while pressing SHIFT.

Example for kioskmode.ini

[Parameters]
ReconnectOnLogon=true
ReconnectOnLaunchOrRefresh=true
SharedUserMode=true
SelfSelection=false
ShowLastUser=true
LogoffMode=3
LogoffDelay=10

[Store1]
Url=https://xd7a/int.sampletec-01.com/Citrix/Store/discovery
FriendlyName=XenApp A

[Environment_Store1]
Url=https://xd7b./int.sampletec-01.com/Citrix/Store/discovery
FriendlyName=XenApp B
Default=true
Environment=PROD

[Environment_Store2]
Url=https://xd7c./int.sampletec-01.com/Citrix/Store/discovery
FriendlyName=XenAppC
Default=false
Environment=INT

[Theme]
ThemeName=ucselfservice
Decorated=false
ColorHover=#b0b0b0
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ColorUnselected=#a0a0a0
ColorSelected=#c0c0c0

7.8.5. Browser in kiosk mode (< eLux RP 6 2110.1)

– for eLuxRP 6.5 and later versions –

For kioskmode, the Builtin Browser is used. In kioskmode, the browser is started in full-screenmode
and with limited user rights. The user cannot open other windows and cannot exit the browser. Note
that the Builtin Browser if defined as a browser application is not run in kioskmode even if address and
navigation bar are hidden.

Note
Firefox can be run in kioskmode up to version ESR 52.8 1. Mozilla supports kioskmode again
starting with version 71.0, but without configuration options. For further information, see Kiosk
mode for Firefox.

1. For the relevant devices, open Advanced device configuration > Advanced file entries and
define the following entry:

File /setup/terminal.ini

Section Layout

Entry KioskMode

Value 2

For further information, see Advanced file entries.

This parameter enables the kioskmode for the browser application.

2. Create a text file named kioskmode.ini and add the section header [Browser1].

3. Below, enter the relevant parameters:2

Parameter Description

Url=<URL of star-
tup page>

Web page (URL) that opens after starting the browser

Homepage=<URL
of homepage>

Web page (URL) that openswhen you click Home

SaveFirstLink=true|
false

If true, the first URL loaded when coming from the startup page will be
saved as new startup page.

Navbar=true|false Determineswhether the navigation bar is shown

1included in eLuxRP 6.4 container
2Default values are displayed in bold
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Parameter Description

NavbarPrint=
true|false

Determineswhether the Print button is shown on the navigation bar

NavbarForward=
true|false

Determineswhether the Forward button is shown on the navigation bar

NavbarBackward=
true|false

Determineswhether the Backward button is shown on the navigation bar

NavbarHome=
true|false

Determineswhether the Home button is shown on the navigation bar

NavbarUrl=
true|false

Determineswhether the address bar is shown

NavbarRefresh=
true|false

Determineswhether the Refresh button is shown on the navigation bar

4. Transfer the kioskmode.ini file to the clients to /setup/kioskmode.ini. To do so, use
the Scout Enterprise feature Files configured for transfer. For further information, see Files con-
figured for transfer.

The terminal.ini entry along with the kioskmode.ini file on the client will cause the Builtin-
Browser to open in kioskmode after system start-up. The configured functions are available to the user.
No applications other than the browser can be started.

Note
For correct use of the kioskmode, we recommend that you restrict the user rights for the client
as required.

Defining different web pages for devices/OUs

– from eLuxRP 6.7 –

If you want your devices to start with different browser startup pages (Url) or have different home
pages (Homepage), you can parameterize the web pages using environment variables. Carry out the
steps described above with the following differences:

1. In the kioskmode.ini, in the [Browser1] section, for the first and/or second value, set a vari-
able. Example:
Url=$URL1
Homepage=$URL2

2. Define the varables used in the kioskmode.ini as environment variables for the relevant
devices (Advanced device configuration). Example:
URL1=https://www.unicon-software.com
URL2=https://www.unicon-software.com/myeluxcom/

For further information, see Environment variables.
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7.9. Local web sites

– from eLux RP 6 2110 –

On the devices, browser applications can be configured to run without a network connection. To do so,
the required HTML pages and scripts are transferred to the devices and the Builtin browser is con-
figured accordingly.This allows you to provide users with a web application that starts automatically and
serves as an entry point.

Define all allowed links from here asHTML links in your scripts.

Configure all allowed actions via the browser properties.

Combined with kioskmode, users are restricted to a specific start application and use it as a kind of land-
ing page.

Providing local web sites

1. Pack all files needed for displaying the local web pages into a file named landingPage.zip.

Startup page <start>.html, example: index.html

Additional HTML pages and Javascript files (optional)

Stylesheet (optional)

Note
The file name for the archive is predefined and case-sensitive (landingPage.zip).
The archive with this name is also required for a single HTML page.

2. Transfer the file to the devices to /setup/browser/landingPage.zip
To do so, use the Files configured for transfer feature. For further information, see Files con-
figured for transfer.

Note
Note case-sensitivity (landingPage.zip).

The next time the Builtin browser is launched on the devices, the archive will be unpacked to
/tmp/browser/landingPage/

3. Tomake the web pages available in kioskmode, enable and configure the kioskmode.When
doing so, set the browser startup page to
file:///tmp/browser/landingPage/<start>.html

For further information, see "Applications in kioskmode" on page 232.

4. Tomake the web pages available without kioskmode, define a browser application with the fol-
lowing properties:

Browser type: Builtin

Startup page: file:///tmp/browser/landingPage/<start>.html

Optionally, select Start Automatically and, under Advanced, specify navigation elements you
want to display
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At the next browser start (if configured: automatically after device restart) the startup page is displayed.
From here, users can connect to the link destinations you have configured via the local web pages.

Even in kioskmode, you are free to definemultiple browser applications. Each browser application has
its individual startup page, and one of the browser applications is defined as the default. Users can then
switch between the applications using the selector on the system bar.
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7.10. Troubleshooting application definition

Error / problem Reason Solution

Missing firmware The required software is not installed on the
Thin Client

Install the software on the Thin Client. For further information, see Creating an
IDF in the ELIAS guide and Firmware update.

Doubled names Two applications have the same name. This
causes conflicts because applications are
identified by their names.

Use unique names.

Hidden application cannot be
executed

Applications are invisible for the user when
they run in hiddenmode. This option is avail-
able for applications of the custom type.

Enable the option Start automatically or Application restart to start hidden
applications on start or to run them non-stop, respectively.

Problemswith certificates in
combination with VMware
server

Server problem occurred: 
After successful installation, the VMware
server uses a self-signed certificate. If a
Thin Client is configured correctly, it will not
accept. The reason is that the FQDN (fully
qualified domain name) ismandatory for
server certificates.

Create a server certificate in theWindows-CA with FQDN.

If you usemmc: Create a server certificate using the Snap-In Certificates
(Local computer).

The keymust be exportable.

The display name of the server must be vdm. The namemust be unique in the
certificate store Local computer / Personal.
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Error / problem Reason Solution

COMport redirection in RDP
session does not work

Communication errors such as high laten-
cies in the network between your serial
device and the virtual desktop do not allow
serial communication.

Use the permissivemode for the RDP application. This parameter causes com-
munication errors to be downgraded to warnings, and communication becomes
more tolerant of timeouts.

Define a free parameter in your RDP application definition with the permissive
option.

Example:
FreeRDPParams=/serial:COM1,/dev/ttyS0,Serial,permissive

For further information, see Defining free application parameters.
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7.11. Third party software

To install additional applications on the devices, carry out the following steps:

1. From our portal www.myelux.com, for the relevant eLux version, download the specified soft-
ware package.

2. In ELIAS, import the software package into your container. For further information, see Importing
packages into a container in the ELIAS guide or Importing software packages in the ELIAS 18
guide.

3. In ELIAS, add the package to your to your image (IDF), and then save themodified image file.
For further information, see Creating an IDF in the ELIAS guide or Creating an image in the
ELIAS 18 guide.

4. For the relevant clients, perform a firmware update to themodified image. For further information,
see Firmware Update.

The software package is installed on the devices.

5. Configure the software in the back-end environment.

7.11.1. Avaya Equinox

Soft phone application providing access to Unified Communications (UC) andOver the Top (OTT) ser-
vices

Package name: Avaya Equinox VDI Client

7.11.2. Cisco JVDI

Jabber Softphone for VDI (JVDI)1 extends the Cisco collaboration experience to virtual deployments.
With supported versions of Cisco Jabber for Windows, users can send and receive phone calls on their
hosted virtual desktops (HVD). The JVDI software routes all audio and video streams directly from one
Thin Client to another, or to a phone, without going through the HVD.

Package names: Cisco JVDI Client and Utilities for Cisco JVDI Client

Follow the Cisco Deployment and Installation Workflow on the Cisco website in order to con-
figure the JVDI system environment.

7.11.3. deviceTRUST

Dynamic context awareness, allowing users to access their corporate workspace from any location on
any device while meeting IT governance requirements

Package name: deviceTRUST Contextualizing IT

1formerly VXME
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7.11.4. DriveLock

DriveLock provides endpoint security for USB interfaces on the Thin Client.

Package name: DriveLock

7.11.5. Grundig Citrix Extensions

Digital dictation solution byGrundig Business Systems

Package name: Grundig Citrix Extensions

7.11.6. HDX RealTime Media Engine

TheHDX RealTimeMedia Engine (RTME) enables better audio and video quality for VOIP and video
chat.

Package name: Citrix HDX RTME

ConfigureMicrosoft Lync or Skype for Business in the back-end environment.

7.11.7. JabraXpress Device Updater

Solution installed on an end user’s thin client that governs Jabra device configurations such as firmware
versions and device settings

A detailed description of how to use the Jabra XpressDevice Updater can be found in the doc-
umentation of Jabra Xpress for Linux: https://-
jabraxpress.jabra.com/Downloadables/Linux/UserGuide.pdf

Package name: JabraXpress Device Updater

7.11.8. Microsoft Teams

Enterprise video conferencing with real-timemessaging and content sharing

Package name: Microsoft Teams Client

Microsoft TeamsClient for Linux is a local application on eLux.

Parameter for the application definition: teams

7.11.9. Nutanix Frame

Cloud- hosted Desktop as a Service (DaaS) that empowers any organization to deliver andmanage
their desktops via a single console for seamless control and administration, providing a true hybrid exper-
ience.

Package name: Nutanix Frame Client

Nutanix FrameClient for Linux is a local application on eLux.

Parameter for the application definition: Frame
Parameter with URL: Frame -url=console.nutanix.com
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7.11.10. Olympus Dictation

Digital dictation solution byOlympus

Package name: Olympus Dictation Drivers

7.11.11. Philips Speech

Digital dictation solution fromPhilips Speech Processing Solutions

Package name: Philips Speech Drivers

7.11.12. SecMaker

– for eLuxRP 6.5 and later versions –

SecMaker Net iD Enterprise is amiddleware supporting SSL 3.0/TLS 1.0 (client identification), PKCS
#7 (digital signatures), and PKCS #10 (certificate requests). To use SecMaker Net iD 6.x on the client, a
separate license is required.

Package name: SecMaker NetID

Use the Scout Enterprise feature Files to tranfer the license file to the clients to
/setup/iid/netidlicense.lic.

For further information, see Files configured for transfer in the Scout Enterprise guide.

Note
The license agreement (EULA) is available on the client client under /etc/iid/SecMaker
License and Support Conditions 20150202.pdf

7.11.13. Zoom

Enterprise video conferencing with real-timemessaging and content sharing

Package name: Zoom Client for Linux

ZoomClient for Linux is a local application on eLux that enables peer-to-peer connections between con-
nected devices.

Package name: Zoom Citrix Plugin

With the ZoomCitrix plugin, ZoomVDI can be used in a virtual desktop infrastructure with a Citrix solu-
tion. Peer-to-peer connections are not supported in this scenario.
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8. Client remote management by commands

Administrators can use Scout commands to change the status of the devices, perform updates and
sendmessages. The commands can be executed immediately or can be scheduled to be run once or
periodically.

You can apply the commands on individual devices, on OUs and on Dynamic Client Groups.

In addition, the context menu of an individual device provides the commands for device diagnostics and
for mirroring.

8.1. Available commands

The context menu of a device, OU or Dynamic Client Group provides the following Command options
resulting in the Execute/Schedule command dialog for further configuration:

Command Description

Switch on... Switches on the device/devices

Switch off... Switches off the device/devices

Restart desktop... Restarts the eLux interface.

Restart device... Restarts the device/devices
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Command Description

Sendmessage... Sends amessage to the device/devices

Themessage text can be formatted by using HTML-tags.

Themessage title can bemodified.

Delivery... Delivers software for a firmware update

Update... Performs a firmware update

UEFI update... Performs an update of the UEFI firmware

For further information, see UEFI update in analogy to firmware update in the
BIOS update guide.

Refresh device
status...

Requests the current device status and refreshes the status of the
device/devices in the tree view

Remote factory
reset...

Sets the device back to initial state

The configuration is deleted, the IDF remains.

For further information, see Factory reset command.

User-defined com-
mand...

Enter a user-defined command that will be sent to the device/devices

Examples: Renew license lease, performBIOS update

Note
After having executed a user-defined command, after a time span of 30 seconds, you can run
the next user-defined command or update command.

Predefined com-
mand...

Provides user-defined commands that have been predefined globally. For further
information, see Predefined commands.

Suspend eLux
command sched-
uler

If recurring commands that are scheduled locally on the device by the eLux
Command Scheduler (cron jobs) have been defined by the administrator, the exe-
cution of these commands is temporarily stopped until the next restart of the
device.

Configuration
run...
(not available for
individual devices)

Prepares the configuration data for anOU or Dynamic Client Group. For further
information, see Configuration run.
This command is not available for an individual device.

The following options open the relevant log file:

Command Description

Delivery Info... Opens the log file of the latest software delivery

Update Info... Opens the log file of the latest firmware update

Command Info... Opens the log file of the latest user-defined command
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8.2. Executing commands

1. For the relevant device, OU or Dynamic Client Group, on the context menu, click Commands.

2. On the sub-menu, choose a command.

The Command dialog opens. The options shown depend on the selected command.

3. To show the complete title, move themouse pointer over the title bar.

The title bar shows the affected device or OU.
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4. Edit the following fields:

Option Description

Command Allows to switch to other commands

Inform user The user is informed by a notification before the command is executed.

Specify a time period in seconds for displaying the notification. The com-
mandwill be executed after the time period has expired.

If the time period is set to 0, the notification will be displayed until the user
confirms the execution of the command via button.

User can cancel Users are allowed to prevent the execution of the command via button.

Run with system
rights

Some commands require system rights which are checked before exe-
cution.

Now/Once/Every Specify the time of execution or define a periodic scheduling.

Onmore devices
wait

Delay after execution if more than one device is concerned

Include sub-OUs Include subordinate OUs, if available

5. Confirmwith Execute or Schedule.

The command is executed at the specified time. Depending on the command, you are asked to confirm.

8.3. Scheduling commands

The execution of most commands can be scheduled for a specified time instead of being executed imme-
diately. Many commands such as firmware updates can also be scheduled on a recurringmonthly or
weekly basis.

1. For the relevant device, OU or Dynamic Client Group, from the context menu, choose Com-
mands.

2. From the sub-menu, choose a command.

3. To schedule a command to be executed once, select Once. Then select the date and time.

4. To schedule repeated execution, select Every. Then select the day of themonth or week and Um
the time.

5. Edit the other options of the Command dialog.

6. Confirmwith Execute.

The command is executed at the defined time. All scheduled commands (once and repeating) can be
displayed, modified and deleted under View > Schedule...
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8.4. Command results and update information

Feedback on performed update, delivery and user-defined commands is available both for

individual devices in their Properties window

all devices in the Command history window.

All processes are recorded, even if they turn out to be obsolete and haven't been run or if they are abor-
ted. If they have been completed successfully, they have a green symbol. For further information on the
command history, see Command history.

Viewing command results on a particular device

Note
The following instructions are related to Update commands. Viewing results of a UEFI update,
delivery or user-defined command is done accordingly.

1. To show the Properties window, click View > Window > Properties.

The Properties window is shown permanently in the upper right. For the selected device some

properties are shown. Properties can be shown or hidden by using the icon.

2. Select the relevant device in the tree view.

In the Properties window, in the Update section, the following fields are provided:

Image Current image

Update
time

Exact point in time of the latest update

Update
status

Current status such as Update in progress, Update successful or
Update not necessary

Update pro-
vider

Origin of software packages (web server or proxy)

Update size Size of the transferred packages in compressed format

Note
The properties Update provider and Update size are evaluated for updates, but not for
themigration to amajor version or a downgrade.

3. Double-click the termUpdate status or click ... at the end of the line.

The Update Info window is displayed. On the left, you can see all updates that have been pro-
cessed, aborted or not processed because the image had been up-to-date. For a selected update
command, you can view all logged data on the right side, among them the installed software pack-
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ages.

Note
Information on the last update of the relevant device can also be viewed by using the context
menu and Commands > Update Info...

Any performed commands are recorded and shown independently of the device in the Command his-
tory window. For further information, see Command history.

8.5. Command history

All of the executed Update, Delivery, and User-defined commands can be viewed in the command his-
tory. When calling the command history, the object rights of the administrator management are respec-
ted.

Click View > Command history...

The Command history window opens and displays one job (command for 1 to n devices) per line provid-
ing the following information:

Option Description

Type Type of object the command is applied to. This can be an individual device, an
OU with sub units (OU+), an OU without sub units (OU) or a Dynamic Client
Group.

Name Object name (name of device, OU or Dynamic Client Group)

Command Executed command (Update, Delivery or User-defined command)

Devices Number of devices concerned

Start Date and time of sending command to the devices / starting time

258



Option Description

End Date and time of sending command to the devices / ending time

The ending time of a job is reached when either the devices report back
Successful or Failed or when the timeout of 5minutes for feedback is
passed. If the administrator terminates a job, the ending time is defined by the ter-
minating time.

Successful Number of devices that have successfully processed the command

Failed Number of devices that have reported failure during command processing

Timeout Number of devices that haven't reported feedbackwithin the defined time period
of 5minutes

Progress% Progress of command processing in percent, across all concerned devices

Administrator Administrator who ran the command

Apply the following options to the job list:

Option Action

Refresh Press F5.

Sort table rows Click the column title bywhich you want to sort.

A first click sorts the jobs ascending and the second one sorts descending.
To reproduce the default sorting order click F5.

Apply the following options to a selected job:

Option Action

View details Click Details....

The Command details window displays all processing details of the concerned
devices. Amongwith starting and ending times you can find the current status
and the command processing result for each device.

Search object in
Scout Enterprise
tree view

Right-click an object name, and then click Find in tree view.

The first result is selected in the tree view.

Terminate running
job

Select the running job, and then click Terminate.

A command terminating request is sent to the Scout Server and the transmission
of the command to the devices is stopped.
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8.6. Factory reset command

Use the Remote factory reset command to reset the relevant devices to their initial state. By default,
the local device configuration and local application definitions are deleted.

The following data are retained by default:

Connection data to the Scout Server including server address andOU ID

License information

The installed image with all software packages (firmware)

After the device has received the Remote factory reset command, the current configuration of the client
is reset and the device is restarted. The device connects to the Scout Server and obtains the con-
figuration of the OU to which it is assigned.

The command can be run with the following additional options:

Option Description

Retain local con-
figuration
(unlocked fields)1

User-defined values of the local device configuration in unlocked fields are
retained. This only applies to fields that the user is allowed to edit.

– only available if allowed in Advanced options > Devices –

For further information, see Supporting local configuration.

Delete Scout
Server address on
the client

In addition to the configuration, the following data are deleted:

Address of the Scout Server machine

Certificates in /setup/cacerts

WLAN configuration

802.1X configuration

Private key of SCEP client certificate stored in TPM2.0module2

An encrypted setup partition (TPM2.0) is decrypted.3

Delete license
information stored
on device4

The license lease is deleted in addition to the configuration and the data listed
above. This option can be used for the resale of devices, for example.

Subsequently, the device is shut down and remains switched off.

If this option is used to run the Remote factory reset command, the function cor-
responds to resetting the client locally by using the Factory reset button of the
extended eLuxCommand panel. For further information, see Resetting thin cli-
ent to factory status in the eLux RP guide.

1fromScout Enterprise 15.7 and eLuxRP 6.7
2from eLuxRP 6.7
3from eLuxRP 6.7
4for Scout EnterpriseManagement Suite 14.9 / eLuxRP 5 and earlier versions
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Note
The Remote factory reset affects the setup partition of the thin client. The system partition
with the installed firmware is not affected by the factory reset and is only changed using the
Update commandwith the option Format system partition before update.
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8.7. Creating predefined commands

User-defined commands can be pre-defined and provided globally to administrators via Commands >
Predefined Command... For example, you can pre-define scripts for the BIOS update of particular hard-
ware or a script to renew the license lease of eLuxRP 6 clients.

These commands are then available via the Command dialog and can be used by authorized admin-
istrators. To create a predefined command:

1. On the Scout Enterprisemenu, clickOptions > Advanced options > Predefined commands.

2. Click Add.
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3. For your new entry, edit the following options:

Option Description

Name The command name is shown to administrators in the Commands dialog.
The command is not shown.

Command Syntax for the command to be executed

To enable administrators to set individual valueswhen executing a pre-
defined command, you can use variables.1The values for each variable are
prompted when the administrator selects the predefined command in the
Command dialog.

Example: ls -%PARAM% %FILES%

Correct spelling of variables: Free variable name surrounded by percent
signs%variable%2

The variable namemay contain upper and lower case letters, numbers and
special characters.

To use a percent sign in the command definition outside the variable name,
type %%

System System rights are required to execute the command.

Activated The command is displayed in the list-field for predefined commands.

Admins3 A predefined command is shared with all administrators by default.

To restrict to specific administrators or groups,4 click the cell under
Admins and then select the desired administrators/groups from the list.

Note that in the default case (no restrictions) the list of administrators dis-
played does not contain a selection. The command is nevertheless enabled
for all administrators.

4. Confirmwith Apply andOK.

1fromScout EnterpriseManagement Suite 15.9
2for Scout EnterpriseManagement Suite 15.9: __variable__ (two underscores each)
3fromScout EnterpriseManagement Suite 15 2101
4with active adminstrator policies
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You can find all activated predefined commands under Commands > Predefined command... in the rel-
evant list-field. They can be applied on individual devices, on OUs and on Dynamic Client Groups.

For authorized administrators, the name of the command is displayed instead of the command itself.

in the Command dialog

in the device properties window under Command line1

in the Command Info window (command history for relevant device)2

8.8. Defining templates for standard commands

For standard commands such asRestart or Update, you can define preferences via templates.3

1. On the Scout Enterprisemenu, clickOptions > Advanced options> Predefined commands.

2. Under Command templates, select Use template for command and then, in the list-field, select
the relevant command.

3. To define the preferences asmandatory, select Template is mandatory.

If a template is not mandatory, the operative administrators can overwrite the specified default val-
ues.

4. Specify the values for the selected command.

A templatemay contain command-specific preferences aswell as general preferences such as

Inform user for x seconds

User can cancel command

1fromScout EnterpriseManagement Suite 15.7
2fromScout EnterpriseManagement Suite 15.7
3fromScout EnterpriseManagement Suite 15.2
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Note
Templates for standard commands are only available in the Scout Console but not in the
Scout Dashboard.
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8.9. eLux Command Scheduler

– from eLuxRP 6.8 and Scout Enterprise 15 2103 –

Recurring commands can be defined so that they are scheduled and executed locally on the device by
the eLuxCommand Scheduler. Like cron jobs, these commands are initiated by the device at defined
points in time, whereas Scout Enterprise commands are initiated on the server side. The time of exe-
cution depends on the time zone in which the device is located.

The eLuxCommand Scheduler can process the following commands:

Update firmware

Synchronize device configuration

Restart device

Shut down device

User-defined command

The commands for the eLuxCommand Scheduler may be defined either on the top level in the
Advanced options or in the Advanced device configuration of anOU. For eachOU, you can define
whether you want the jobs of the eLuxCommand Scheduler defined and scheduled above to be applied
or not.

8.9.1. Defining eLux Commands

– fromScout Enterprise 15 2103 –

The eLuxCommand Scheduler is configured in the Scout Console.
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1 Select
command

2 Configure
periodic
scheduling

3 Configure
user inter-
action and
deferment
options

4 Generate
random
delays
between
devices

5 Missed
jobs are
caught up

6 Devices
are woken
up from
suspend
to execute
jobs

1. OpenOptions > Advanced options or the Advanced device configuration of anOU. Then
choose the eLux Command Scheduler tab.

2. To define a new command, click Add.

3. In the Define eLux Command dialog, edit the following fields:

Option Description

Command Type of command

To execute user-defined commands, system rights are required. Therefore,
include the password.

Schedule Periodic scheduling of the command

If the provided options are still too few, in the schedule.ini, you can define a
string using the systemd syntax. For further information, see "Command definition
parameters" on page 269.
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Option Description

User inter-
action

Determine whether and how long you want to inform the users before the com-
mand is executed, and whether they are allowed to defer it. For further inform-
ation, see "Deferment options for users" below.

Spread
factor

Time span in which random delays are generated to prevent simultaneous exe-
cution onmany devices

Example 600 seconds:
If the execution time is 6:00 pm, a randomly generated time value for the execution
of the command per device, whichmay be amaximumof 600 seconds, is added to
the time 6:00 pm. The command is therefore executed between 6:00 and 6:10 for
all devices.

Default: 0

Persistent Missed command executions (jobs) are immediately caught up after the next
device start. If multiple repetitions of the same commandwere scheduled, the com-
mand is repeated once.

Wake
device
from sleep

Deviceswill be woken up from sleepmode (suspend) to execute scheduled com-
mands.

4. Confirmwith OK and Apply.

The scheduled command is displayed in the eLux Command Scheduler tab of the Advanced
Options and in the eLux Command Scheduler tab of the Advanced Device Configuration for all
OUs. Creating and editing is only allowed in the Advanced Options.

5. Define which OUs you want (not) to inherit the jobs of the eLuxCommand Scheduler. By default,
the settings (jobs) in Advanced Device Configuration > eLux Command Scheduler are inher-
ited from the next higher instance.

The scheduled command is executed by all deviceswhoseOU inherits the jobs of the eLuxCommand
Scheduler at the next due point in time.

Note
To view information on the status and the next execution of a command, on the device, use
systemctl status <jobId>.service and
systemctl status <jobId>.timer.

8.9.2. Deferment options for users

Similar to Scout Enterprise commands you can also define for the command definitions of the eLux
Command Scheduler whether the users are informed before the command is executed and whether
they are allowed to cancel or defer it.

268



Option Description

Inform user The user is informed by a notification before the command is
executed.

Specify the time period in seconds for displaying the notification.
The command is subsequently executed.

If the value is 0, the notification will be displayed until the user con-
firms the execution of the command via button.

User can cancel The user is allowed to prevent the execution of the command via
button.

Reminder > Number of allowed
deferments

Define how often the user is allowed to postpone.

Reminder > Delays until next
reminder

Select one or more time periods users can choose to defer.

For further information, see also "User information before update" on page 289

8.9.3. Suspending eLux Command Scheduler

The recurring execution of defined commands by the eLuxCommand Scheduler can be temporarily sus-
pended from the Scout Console. To do so, the administrator sends a command to the relevant devices,
which stops the eLuxCommand Scheduler until the next restart of the devices. After the next device
restart, the eLuxCommand Scheduler continues to process the scheduled commands as planned.

1. For the relevant device, OU or Dynamic Client Group, on the context menu, click Commands >
Suspend eLux Command Scheduler.

2. Confirmwith Execute.

The execution of all commands scheduled by the eLuxCommand Scheduler is suspended with imme-
diate effect until the next restart of the devices.

Note
If commands are defined with Persistent=true and the device is switched off at the time
of scheduled command execution, these commands (persistent jobs) are started sub-
sequently after the next restart.

8.9.4. Command definition parameters

For each command definition, in the scheduler.ini file, a new [Job<N>] section is created. Find all
command definition parameters with their possible values below.
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Parameter Description

Id Character string for unique identification of the command

Type Command type

1 Update
2 Synchronize configuration
3 Restart device
41 User-defined
52 Shut down

Schedule The format follows the systemd calendar events. Syntax for a timestamp:
Tue 2020-01-21 11:12:13

Minutely *-*-* *:*:00

Hourly *-*-* *:00:00

Daily *-*-* 00:00:00

Monthly *-*-01 00:00:00

Weekly Mon *-*-* 00:00:00

Examples:

*-*-* 4:00:00 Every day at 4:00 am
Mon..Fri *-*-* 22:30 Every workday at 10:30 pm
-*-1,5 11:12 Every first and fifth day of anymonth at 11:12. am
Sun 2020-*-* 17:15 Every Sunday of the year 2020 at 5:15 pm

For further information, see https://www.-
freedesktop.org/software/systemd/man/systemd.time.html

SpreadFactor Time span in which random delays are generated to prevent simultaneous execution
onmany devices

Default: 0

Persistent true|false

If true, missed command executions (jobs) are immediately recovered after the next
device start.

Command Only for Type=4: Command for user-defined command

WakeSystem true|false

If true, the systemwill be woken up from sleepmode (suspend) to execute sched-
uled commands.

1fromScout Enterprise 15 2103
2from eLux RP 6.9.1000
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9. Remote maintenance

For maintenance, user help-desk and troubleshooting purposes, the administrator can use different
tools to access the client devices.

9.1. Device identifier for support

– fromScout Enterprise 15 2101 and eLux RP 6 2101–

To provide support for users, the first step is to identify the relevant device. As an alternative to the IP
address or MAC address in the Information dialog, eLux provides a temporary device identifier that
users can easily request.

The users have a questionmark icon on the system bar if the user right Request
simple device identifier is enabled, which is by default.

To request the so-called Simple device identifier, users click 1 the question
mark icon and then Request.

The system generates and transmits a temporary device identifier for the request-
ing device.

The user gives this device identifier to the support staff or administrator. By
default, the device identifier has a validity of fiveminutes.

The validity time and optional additional text to be displayed can be specified by
the administrator in the Scout Console under Options > Advanced options >
Rules.

9.2. Mirroring

Note
This feature can only be applied to an individual device.

Mirroring (Shadowing) allows administrators to either view or take control of eLux user sessions. On the
mirrored device, control of themouse and keyboard can be given to themirroring administrator. This
can be very helpful in a variety of scenarios such aswhen administrators assist users or when admin-
istrators need to check correct functioning of firmware updates or newly installed software.

1or right-click
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9.2.1. Requirements

VNC viewer
On the administrator's system, a VNC viewer must be installed. This is provided by the Scout Con-
sole

VNC server
On the target device, a VNC server must be installed. For eLux clients, the VNC Server exten-
sion feature package which is part of the XOrg eLux package needs to be installed. Thismay
requiremodifications of the image definition file on the web server via ELIAS.

Configuration
For the target device, in Device configuration>1 > Security > Mirror settings, mirroringmust be
enabled and configured. For further information, see ConfiguringMirroring.

9.2.2. Mirroring from Scout Console

Throughout amirror session, the user receives a systemmessage which is displayed on both the client
screen and the administrator's screen. The systemmessage remains in the foreground and allows the
user to cancel themirror session at any time by clicking theQuit button.

Launching a mirror session

Note
If there are twomonitors connected to the device, bothmonitors aremirrored. To obtain the
best result, on the Scout Consolemachine, connect twomonitors with the same or a higher
resolution.

Note
During themirror session, the keyboard layout of the Scout Consolemachine is used and not
the one of the client.

1. For the relevant device, on the context menu, clickMirror...

2. On theMirroring dialog, confirmwith OK.

3. Depending on your configuration in Device configuration > Security, the session can only be
started after

the administrator enters the defined password

the user confirms themirror session

For further information, see ConfiguringMirroring.

Themirror session is started. On the client screen, a systemmessage is displayed that can bemoved
but not closed unless themirror session is closed.

1formerly Setup
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The user has the following options:

Option Description

Read only The administrator has only read-access on themirrored device. Mouse and key-
board input are not transmitted into themirror session.

Quit The connection is disconnected andmirroring is stopped.

Quit and logoff
(only if configured)

The connection is disconnected and the user is logged off.

This option is only available if, in Device configuration > Security, the option
Logoff after disconnect is selected.

Themirror session is closed when

the administrator closes the session window or clicks the Quit button of the systemmessage, or

the user clicks the Quit button of the systemmessage.

If configured in Device configuration > Security, themirror session is logged in a *mirror.txt file
and saved to a sub-directory of the Scout Server files directory.1

9.2.3. Troubleshooting mirroring

Error / problem Reason Solution

From a Scout
Server with mul-
tiple network
adapters, estab-
lishing amirror
session fails

Themirror
session is
not set up
via the cor-
rect net-
work
adapter.

In the Registry, set the key BindIPAddress to the IP address of the
network adapter the client is connected to:

HKEY_CURRENT_
USER\Software\Unicon\Scout\Settings\BindIPAddress

1for Scout Enterprise 15.4 and later versionswith the device'sMAC address
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9.3. Device diagnostics

Note
This feature can only be applied to an individual device.

Device diagnostics help you run predefined commands on the client and retrieve protocol and con-
figuration files from the client. These are then sent to Scout Enterprise or other destinations for dia-
gnostic purposes. The requested client files support the administrator in error analysis and are required
when opening a support ticket.

Depending on the user rights, the reverse way can be used: Users send diagnostic files or screenshots
from the client.

Administrators are free to use the Request diagnostic files feature to request freely definable files from
a device.

Note
To compare actual and target device configuration settings of individual devices, use a report.
For further information, see Evaluating configuration data.

9.3.1. Logging on the devices
Two log levels are provided in the device configuration of the eLux devices: Standard and Enhanced.
These levels correspond to the debug levelsOn andOff in the Scout Console.
In normal operation, the standard level is adequate. Before performing device diagnostics, however,
temporarily enable the enhanced log level on the device tomake sure you retrieve all data needed. After
the device diagnostics, we recommend that you reset the log level in order not to unnecessarily strain
the flashmemory capacity of the device.

Enabling enhanced logging

1. Open the device's context menu and click Device configuration....

2. On theGeneral tab, clear the option Use parent device configuration.

3. On the Diagnostics tab, set the Debug level option to On.

4. Confirm and restart the device.

Enhanced logging for the device is active and you can pull off the diagnostic files.

Disabling enhanced logging

1. Open the device's context menu and click Device configuration....

2. On the Diagnostics tab, set the Debug level option to Off.

3. On theGeneral tab, select the option Use parent device configuration.

4. Confirmwith Apply andOK.
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Enhanced logging for the device is reset to standard and device configuration inheritance is restored.

9.3.2. Requesting diagnostic files

Note
Before you perform device diagnostics, we recommend that you temporarily enable enhanced
logging on the device. For further information, see "Logging on the devices" on the previous
page.

1. From the device context menu, choose Device diagnostics > Request files...

In the Edit diagnostic files dialog all templates defined so far are shown. Only active templates
(checkmark) are processed.

2. If you have the required object right, you can select or clear further templates of the list.

3. Click Request.

All scripts defined in the active templates are executed on the client.
All files defined in the active templates are retrieved from the client and saved as a .zip file in the
local user directory <userprofile>\Documents\UniCon\Scout\Console\Diag.

4. Click Explorer.

TheWindowsExplorer opens showing the diagnostics target directory.
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Legend to numbers

1 Predefined template
#System

This template is always act-
ive and can neither be
deleted nor edited.

2 Provided an administrator is
given the object Edit dia-
gnostic templates, he can
create, edit and delete addi-
tional templates.

3 Log and configuration files
defined by the selected tem-
plate and requested by the
device

4 Additional commands
defined by the selected tem-
plate to be executed on the
device

5 The defined files are reques-
ted from the device and the
defined commands are
executed.

6 Once the requested files are
available, open the Explorer
with the diagnostics target
directory.
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9.3.3. Configuring diagnostic files

TheDiagnostic files dialog provides a predefined template called #System. This template includes a
file list containing relevant configuration and log files plus a script code to be run on the client. Neither of
them can be edited .The #System template is used each time a device diagnosis is performed via
Request.

In addition, authorized administrators can define further templates containing file lists and script. The
templates are available globally, nomatter where you define them.

Defining a template for device diagnostics

Requires
Object right Edit diagnostic templates (disabled by default)1

1. Open the context menu of a device and click Device diagnostics > Request files.

In the Edit diagnostic files dialog, the predefined #System template and, if defined, further tem-
plates are shown .

2. Click New... Enter a name for your new template and confirmwith OK.

3. To define diagnostic files for your template, select the new template and, next to the file list, click Edit.

4. In the text box, enter the relevant file nameswith path line by line. Confirmwith Save.

1fromScout Enterprise 15.8
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5. To enter script code you want to run on the device, next to Additional script, click Edit... Authenticate
with the device password.1

6. In the text box, enter your code and confirmwith Save.

Note
When you perform the device diagnostics feature with Request, all active templates are
included. However, whether all of the listed files of the #System template are written and
transferred, depends on the selected debug level. For further information, see Device con-
figuration2 > Diagnostics.

9.3.4. Further diagnostic adjustments

– fromScout Enterprise 15.11 and eLux RP 6.11 –

Diagnostic files over multiple device restarts

Requires
Enhanced loggingmust be enabled.

When you request diagnostic files, a set of log and configuration files is retrieved and packed on the tar-
get device. Included is the file last_boot.zip, which contains diagnostic files over a device restart.
This .zip file contains all files defined for the system template plus some additional ones. The number
of cycles for which the file is created and saved on shutdown of the client device is configurable. The
default is five.

Themost recent file is named last_boot.zip.0. The further back a file was created, the later its
sequential number in the file name.

To define the number of cycles yourself, use the Advanced file entries feature with the following
parameter:

File /setup/terminal.ini

Section Global

Entry LogCycles

Value 2-n The default value is 5.

Note that the last_boot.zip file is only created, if enhanced logging is active. For further inform-
ation, see "Requesting diagnostic files" on page 275.

Store diagnostic files persistently

By default, the diagnostic files are stored on the device under /setup/logs.

1fromScout 15 2107
2formerly Setup
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To define a different storage location, use the Advanced file entries feature with the following para-
meter:

File /setup/terminal.ini

Section Global

Entry LogPath

Value <Directory on the device>

Example: /update/logs

The default is /setup/logs

A location on the update partitionmay also be defined.

If you use disk encryption via TPM2.0, the setup partition will be encrypted. To have the diagnostic files
accessible, define the update partition as their storage location. The update partition is thenmounted
automatically.

Diagnostic adjustments via software package

Provide diagnostic settings for new devices you wish to connect before their initial contact with the
Scout Server,during installation. To do so, integrate the eLux software package Diagnostic adjust-
ments into the image to be installed.

The Diagnostic adjustments package contains two feature packages that you can activate separately:

Enhanced logging: Corresponds to the device configuration Diagnosis > Debug level and
enables enhanced logging

Logs on update partition: Sets the location for diagnostic files to /update/logs

Note that the diagnostic settings set via software package are only effective until the first contact of the
device to its Scout Server. Then the device configuration is synchronized and the device receives the
configuration data defined for its OU.
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10. Firmware Update

On delivery, the Thin Clients are normally equipped with the operating system and the basic software
components such as ICA client, RDP client, browser and emulations. This software called firmware is
stored on the flash drive. Whenever new software versions are available or demands change and soft-
ware components need to be added or removed, the firmware can be updated.

Basic steps

Download the relevant software packages frommyelux.com

Modify the image file (IDF) on the web server via ELIAS.

Check firmware configuration of the relevant Thin Clients

Perform the update

Software delivery

Installing new software packages

To perform the update in one step, use an Update command. In this case, the required software pack-
ages are delivered and then automatically installed. Alternatively, the two actions can be uncoupled:
The software is delivered in a first step when you use a Delivery command. It is subsequently installed
when you run the Update command.

Note
To save bandwidth, you can use a proxy client for updates. For further information, see
Update through proxy client.

Ways to initiate a firmware update

Updates can be performed immediately or initiated automatically at a defined point in time:

Firmware updates can be executed or scheduled (once or periodically) via the Update command
feature.

The devices can be configured to automatically check for new image versions on start or shut-
down. If an updated version is available, the update process is started.

The Check for new version option is part of Device configuration > Firmware and can be
applied to individual devices, OUs and all devices.

The definition of an Update notification results in updating the firmware on the next device restart

If configured, users can defer the execution of a firmware update to a later point in time.

Updates are only performed, when the relevant IDF has beenmodified. All update activities are logged.

Relevant devices

Commands and notifications can be applied to the following devices and groups:

280



Individual devices

Multiple devices selected in the All devices window (multiple selection via CTRL and SHIFT
allowed)

OU

Dynamic Client Groups

Recovery-Installation

To reset your devices to initial state, perform a recovery installation. A recoverymight also be required if
critical feature packages of the BaseOS have been changed, or if your operating system has not been
updated for a long time.With a recovery installation, all data on the storagemedium are wiped (except
license data) and the eLux software is installed. For further information, see Recovery procedures in the
Recovery short guide.

10.1. Requirements

The following components are required to perform a firmware update: 

Web server (for example IIS) to provide the eLux software packages and image definition files
(.idf) via HTTP/HTTPS or FTP/FTPS, with the relevant web server role enabled.

Software container with eLux software packages on the web server

ELIAS (eLux Image Administration Service) to create andmodify image definition files in the soft-
ware container

Scout Console to configure firmware updates for the devices

Scout Server, Scout Console and ELIAS1 are part of the Scout EnterpriseManagement Suite. The cur-
rent software bundle eLuxversion_AllPackages.zip and further optional software packages
are installed with the eLux container.

Alternatively, install ELIAS 18 and import the software bundle into your container. Then there is no need
for the container installation.

For further information on the installation of the Scout EnterpriseManagement Suite and the eLux con-
tainer, see the Installation guide.

10.2. Access to applied images

Firmware images are created andmodified in ELIAS. They are applied to the devices in the Scout Con-
sole, in the firmware configuration. To open an image used for specific devices directly in the relevant
ELIAS container, you have two options in the Scout Console:

1Choose user-defined installation and select it as a feature.
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In the Properties window of a device, double-click the image link.

In the device configuration of anOU or device, in the Firmware dialog, click the ELIAS button.

The connection to ELIAS ismade with the data from the ELIAS settings. Here, you set either the legacy
ELIAS or ELIAS 181 as the default application for editing images:

Specifying ELIAS settings

1. Select Options > ELIAS settings.

1 Legacy ELIAS

2 ELIAS 18

2. If you use the legacy ELIAS, in the top section, click Browse. From your web server, for the
required container, select the container.ini file.

Optionally specifymultiple containers.

3. If you use ELIAS 18, select the option in the bottom section.2

Enter your ELIAS 18 URL including the container path.
(ELIAS 18 is designed tomanagemultiple versions in one container.)

4. Confirmwith OK.

1fromScout 15 2110
2fromScout 15 2110
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Note
Themenu entry View > ELIAS offers another way to call ELIAS from the console.
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10.3. Planning and performing firmware updates

Note
With the appropriate firmware configuration of the devices, you only need to provide an
updated image to trigger a firmware update.

Providing new image

1. Download new software packages that are not included in your container from our portal and
import them into your container in ELIAS. For further information, see Importing packages into a
container in the ELIAS guide or Importing software packages in the ELIAS 18 guide.

2. In ELIAS, add the relevant software packages to your image. Then save themodified image file.
For further information, see Creating an IDF in the ELIAS guide or Creating an image in the
ELIAS 18 guide.

Checking firmware configuration of the devices

1. For the relevant devices, open the Device configuration > Firmware1.
To apply the update to all devices, chooseOptions > Base device configuration.

2. Checkwhether the following fields are configured correctly for a firmware update: Protocol,
Server, Path and Image file.

The URL shown below the Path box is generated based on this data. The URL is relevant for the
transfer of the image file (.idf and eLux software packages.

The specified image file namemust be identical to the name of the image file updated in ELIAS.

3. For firmware updates via command: To allow users to postpone the update, configure the
reminder settings. User can then control the time of execution themselves. For further inform-
ation, see Update deferment by user.

4. To update the devices automatically on start or shutdown, select the relevant Check for new ver-
sion option in the bottom area.

Note
Since in this case the update is initiated by the device, the firmware parameters stored
locally on the device are used.

5. Confirmwith OK.

For further information on the firmware update configuration, see Device configuration > Firm-
ware.

As soon as an updated image file is available on the web server and if one of the Check for new ver-
sion options is selected, the update is performed on the next device restart or shutdown.

1formerly Setup
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Note
If the device is connected via VPN, the Check for new version options cannot be used. Use
an Update notification instead.

Alternatively, you can initiate a firmware update via one of the following procedures:

Perform an update command

Schedule an update command for a specified time, once or periodically

Define an update notification
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10.3.1. Performing updates via command

Note
To deliver the software packages in a separate step before performing the update, use the
Delivery command.

1. Select a device, an OU, a Dynamic Client Group or deviceswithin the All devices window.

2. On the context menu, click Commands > Update...

3. To inform users before the update, select the Inform user option. Optionally, specify the display
duration of the systemmessage in seconds.With 0 seconds, the systemmessage will be shown
until the user clicks one of the buttons.

This option triggers a systemmessage displayed to users immediately before the update pro-
cess. Depending on the configuration (Firmware > Reminder setttings), users can defer a
requested firmware update.

Optionally select the User can cancel command option.

For further information on the impact, see User information before update.

4. To format the system partition of the device's' flashmemory before writing, select the option
Format system partition before update.
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5. Define the point in time for the update process. For further information, see Executing
commands.

6. Click Execute.

The update process is triggered at the defined time. The update status is displayed for each device in its
Properties window. During the update process, the status Update in progress is shown. Detailed
information about the currently processed action with time stamp is shown additionally.1Example:

Update in progress (Transfer started – 2018-08-20 11:34:23)

Update in progress (Transfer completed – 2018-08-20 11:35:45)

Update in progress (Installation started – 2018-08-20 11:35:48)

Update in progress (Installation completed – 2018-08-20 11:37:56)

For further information, see Command results and update information.

Note that updates are only performed, if the relevant IDF has beenmodified. If an update fails, no efforts
will bemade to retry.

Note
When you execute an Update command, the relevant information is transferred to the clients
as a URL. To create the URL, the system uses the values set in Device configuration > Firm-
ware at the time when the command is run. Note that if the client initiates the update, the local
Firmware configuration is relevant.

10.3.2. Performing updates via notification

By using update notifications, you can send an explicit one-time update request to selected devices to
be evaluated with the next connection. The devices then are updated to the image configured in the
Scout Enterprise firmware configuration.

1. Select a device, an OU, a Dynamic Client Group or deviceswithin the All devices window.

2. On the context menu, click Notifications > Initiate firmware update...

The Firmware update notification dialog is shown.

3. Specify whether you want to inform users, and if they are allowed to cancel the command.
For further information, see Performing updates via command.

4. To format the system partition before performing the update, select the relevant option.

5. Confirm the notification and confirmation.

The notifications for firmware updates are defined for the relevant devices.

For each device, in the Properties window, the Update notification field shows the value
Activated.

1for Scout Enterprise 15.3 and later versions
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Note

If the Update notification field in the Properties window is hidden, click to define
which fields you want to show.

For the relevant devices, a firmware update notification is set. As soon as a device restarts and recon-
nects to Scout Enterprise, it receives an update request1 and the firmware update notification is auto-
matically deleted.

Depending on how you have configured the notification and the device configuration in Firmware >
Reminder settings, the update is performed immediately or the user receives a systemmessage includ-
ing deferment options. For further information, see User information before update.

The update status is displayed for each device in its Properties window. For further information, see
Update log. If an update fails, no system-side efforts will bemade to retry.

For deviceswithout update partition2, an update request might be shown although an update is not
required.When the user clicks the Update button, the window is closed, no update is initiated.

Note
In the Scout Report Generator, you can filter devices by the field Image update notification.

Deleting the update notification for one or more devices

An update notification can be deleted before the firmware has been updated:

On the context menu, click Notifications > Delete update notification.

Note
Notifications are always set or deleted for all selected devices regardless of whether they are
only available for individual devices.

10.3.3. Updates initiated by system

The client can be configured to automatically check on start-up or shutdownwhether a firmware update
is available and install it.

Procedure for system-side initiated firmware update

Depending on the configuration, the client checks on each system start or shutdownwhether a
firmware update is necessary.

An update is necessary, if the image definition file on the web server specified by the firmware
configuration has changed compared to the local version.The client determines the delta

1Note that updates are only performed if the relevant IDF has beenmodified.
2flashmemory less than 4GB
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between the software packages defined by the image definition file on the web server and the
installed software packages. If a delta exists, a firmware update is necessary.

If a firmware update is necessary, the client downloads all software packages defined in the
image that are not yet on its update partition from the web server or proxy server.

Subsequently, the installation starts.

Note
Since the update is initiated by the client, in this case, the firmware parameters locally
stored on the device are used.

Exception for VPN connections

If Check for new version / On Start is configured and the VPN connection can only be set up after the
eLux desktop is loaded, the firmware will not be updated regardless of whether an update is
necessary.1The user can continue working without interruption.

Configuring firmware updates initiated by the system

For the relevant clients, in the device configuration, under Firmware, select Check for new
version. Then select whether the check is to be done on the system start or shutdown.

For further information, see Device configuration/Firmware.

After the clients have received the new device configuration, the option to check for new firmware ver-
sions becomes active.

10.4. User information before update

Note
This feature refers to firmware updates and UEFI updates.2

AnyUpdate command run with the Inform user option selected, provokes a systemmessage on the
device which includes the defined user options. If configured in Firmware > Reminder settings, users
are provided with buttons they can use to defer or abort the request.

1for eLuxRP 6.7 and later versions
2from eLux RP 6 2107
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While themessage is displayed, usersmay close applications, disconnect sessions, or - if configured -
defer the update. If the display duration for themessage has been set to 0, themessage will be dis-
played until the user clicks a button.

Users have the following options:

1 Select a time interval until the next reminder for the firmware update

The list-field contains the values specified in Firmware > Reminder > Delays until next
reminder.

Displayed only, if the Number of allowed deferments is set to 1 or higher, and if at least onemore
deferment is possible.

2 Perform firmware update immediately

3 Postpone firmware update by the time period selected (1)

If the device is shut down before the time interval expires, the update is performed during shut-
down.

Displayed only, if the Number of allowed deferments is set to 1 or higher, and if at least onemore
deferment is possible.

4 Abort update process definitively

Displayed only, if the command option User can cancel the command is selected.

There will be no automatic restart of the update process.

290



10.5. Delivering software in advance

Before performing a firmware update, you can deliver the required software packages in a separate
step. Only after the software deployment has been reported as successful on all relevant devices, start
the installation by using an Update command or notification.

Requires

Clients are provided with an update partition, see eLux partitions

Firmware device configuration of the relevant clientsmust be configured correctly, see
Planning an update

The software delivery can be triggered by a Scout Enterprise command or a notification1.

During delivery, a live information icon is shown on the system bar.

The subsequent installation of the software packages and the update to the new IDF is initiated with an
update command or an update notification.

Note
If you initiate the subsequent firmware update via an Update commandwith Format system
partition, the systemmight have to download additional packages. This is because a Delivery
command only triggers the download of packages that are not installed on the system partition
and are not available on the update partition.

10.5.1. Performing deliveries via command

1. Select a device, an OU, a Dynamic Client Group or devices in the All devices window.

2. From the context menu, choose Commands > Delivery...

3. In the Command dialog, specify whether and how long you want to inform the user.

4. To allow users to deny the delivery, select User can cancel command.

On the device, a pop-up dialog is displayed that allows users to cancel or start the delivery.

5. To first clean the update partition of the devices, select the Clean update partition before deliv-
ery option.

Note
After cleanup, all files of the current software imagemust be re-transferred and the
dynamic proxy cache rebuilt.

6. Specify a time for the delivery.

1fromScout Enterprise 15.10

291



For further information, see Scheduling and executing commands.

7. Click Execute.

The delivery is triggered at the defined time. If there is an updated IDF, and if the required software pack-
ages do not exist on the update partition of the relevant devices, the delivery of the software packages is
started. The systemwill only download the packages that aremissing. If there is less than 30MB stor-
age space available on the update partition, old packages are deleted before new packages are trans-
ferred.

To checkwhich files have actually been transferred, view the diagnostic file
/var/lib/rpm/eluxman.log

In the Scout Console, for each device, the delivery status is shown in the Properties window. During the
delivery process, the status Delivery in progress is shown, including detailed information about
the currently processed action with time stamp.1Example:

Delivery in progress (Transfer started – 2018-08-20 11:34:23)

Delivery in progress (Transfer in progress – 2018-08-20 11:35:45)

Delivery in progress (Transfer completed – 2018-08-20 11:35:48)

For further information, see Command results per device.

10.5.2. Performing deliveries via notification

– for Scout Enterprise 15.10 and later versions–

By using delivery notifications, you send an explicit one-time delivery request to selected devices. The
request is evaluated with the next connection of the device to its Scout Server. Then, the delivery of all
required software packages for the image configured in the Scout Enterprise firmware configuration is
started for this device.

1. Select a device, an OU, a Dynamic Client Group or devices in the All devices window.

2. From the context menu, choose Notifications > Initiate software delivery...

The Software delivery notification dialog is shown.

3. Specify whether and how long you want to inform the user, and if the user is allowed to cancel the
command.
For further information, see "Performing deliveries via command" on the previous page.

4. To clean the update partition before performing the delivery, select the relevant option.

5. Confirm the notification and confirmation.

The notifications for software deliveries are defined for the relevant devices.

1for Scout Enterprise 15.3 and later versions
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For each device, in the Properties window, the Delivery notification field shows the value
Activated.

Note

If the Delivery notification field in the Properties window is hidden, click to define
which fields you want to show.

For the relevant devices, a delivery notification is set. As soon as a device restarts and reconnects to its
Scout Server, it receives a delivery request and the delivery notification is automatically deleted.

The delivery status of a device is shown in its Properties window. For further information, see
Command results and update information. If an update fails, no efforts will bemade to retry.

Note
In the Scout Report Generator, you can filter devices by the field Image delivery notification.

Deleting the delivery notification for one or more devices

Delivery notifications can be deleted before the software is delivered:

From the context menu, choose Notifications > Delete delivery notification.

Note
Notifications are always set or deleted for all selected devices, regardless of whether they are
only available for individual devices.
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10.6. Dynamic proxy client

You can use dynamic proxy clients for the software package distribution to all devices in the same sub-
net. A dynamic proxy client is an automatically selected device in a subnet that downloads the relevant
software packages from the configured web server, and then provides them to all other devices in the
subnet.

The solution is based on the device roles Provider and Consumer.

The fully automated provisioning (provider) and discovering (consumers) of the proxy service within sub-
nets is realized in eLuxRP by using the zero-configuration networking implementation Avahi.

The following instructions refer to Scout Enterprise Version 15.3 and later versions.

Up to eLux RP 6.8, the concept of a dedicated proxy client was also supported.

10.6.1. Requirements

To be able to perform updates by using a dynamic proxy client, next to the eLux operating system, the
following eLux packagesmust be installed on the devices of the relevant subnet:

Dynamic Proxy update

Avahi

Squid Update Proxy

The proxy client must have an update partition. For further information on update partitions, see eLux
partitions.

10.6.2. Frame conditions and roles

The dynamic proxy client concept is based on the following roles:

Provider

Requires
In the device configuration, under Firmware > Proxy type, the devicemust be configured to
Dynamic.

The provider is the device that acts as the Dynamic Proxy client. All deviceswith an update partition can
be selected for the provider role. Once a provider is selected, the device remains in the provider role for
the upcoming updates. In case the provider is not available at the required point in time, another device
with an update partition takes over the provider role. The provider is selected automatically and dynam-
ically.

To exclude devices from the provider role, under Firmware > Proxy type, select None.
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Consumer

Requires
In the device configuration, under Firmware > Proxy type, the devicemust be configured to
Dynamic.

All devices of a subnet that are not selected for the provider role are consumers. The consumers per-
form their update through the provider of the subnet. The consumers do not need to download software
packages from the web server.

To exclude devices from the consumer role, under Firmware > Proxy type, select None.

Note
In the Firmware configuration, if HTTP is used, the User and Password fieldsmust remain
empty.

10.6.3. Update procedure

Update check

In the case of an update request coming either from the Scout Server or from the local Firmware con-
figuration (Update on start / shutdown), the consumers download the latest IDF file from the web
server and check if they need to perform an update.

Discover proxy service

If software packages are required, the consumers try to discover the proxy service in the subnet. If there
is no provider existing in the subnet so far, one of the deviceswith update partition automatically takes
over the provider role and provides the proxy service.

Download software packages

The provider checks the availability of the requested software packages on its update partition and
downloadsmissing packages from the web server specified by the consumers.

Deploy and install software packages

The software packages are transferred from the provider to the consumers, and the consumers install
the packages. Deviceswithout update partition use the rhythm 'fetch one package - install one package'
while deviceswith update partition fetch all required packages in one step and install them sub-
sequently. Only after the last consumer was provided with the relevant software packages, the provider
updates its own system, if needed.

Update information is recorded for both, the consumers and the provider:
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For each updated device, the Update Info including the provider can be viewed by double-click-
ling Update Status in the Properties window.
For further information, see Update log.

The provider has a local file /tmp/dynamic-proxy.log containing the consumers that have
been provided with software packages.
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10.7. Troubleshooting firmware update

Errormessages

Error message Reason Solution

Bad container Containers are hardware-spe-
cific.

Check if the container matches
your Thin Client specifications.

Bad flash size IDF size exceeds flash size Verify if the image size defined by
the IDF matcheswith the actual
flash size of the Thin Client.

Bad authorization Incorrect device password Correct the entry in Device con-
figuration1 > Security.

Client needs recovery inform-
ation

If critical feature packages (.fpm)
are updated in the baseOS, the
Thin Client requires a recovery
installation before it can be
updated.

For further information see Recov-
ery procedures in the eLux Recov-
ery procedures short guide.

Updateoptions

If the update is still faulty, try to modify the update settings. For further information, see Advanced setup
> Update options.

1formerly Setup
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11. Passwords

eLux users and administratorsmay be required to enter passwords in various situations, for example

AD logon for user authentication after eLux system start

Application logon

Device password to unlock the device configuration
On the Scout Enterprise side, the device password applies to all devices of an infrastructure and
is used for additional functions.

Accessing a password-protectedOU

Defining amirror password

Setting up network profiles

Further features of the device configuration
Example: Defining a network drive

To view and verity a password after typing, next to the Password entry field, click .
1

To reset a password entry, click .

11.1. Local device password

The device password affects the local devices. All thin clientsmanaged by a particular Scout Server
receive the same device password so that it is used to verify the access rights for the devices. The
device password is requested by Scout Enterprise for management tasks such as discovery.

The device password can only be changed centrally for all devices in the Scout Console. The initial pass-
word is set to elux.

Note
We recommend changing the password immediately to avoid unauthorized configuration
caused by local users.

Usually, the access rights do not allow users tomodify their local device configuration in the Security dia-
log. However, if the user or administrator changes the device password locally for a device, this device
can no longer bemanaged by Scout Enterprise.

For further information, see Device password in the eLux guide.

1for eLuxRP 6.7 and later versions
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11.1.1. Changing local device password via Scout Console

Important Using this function you change the device password of all devicesmanaged by
this Scout Server

1. In the Scout Console, clickOptions > Base device configuration... > Security. Under Local secur-
ity, click User rights.

2. In the User rights dialog, in the Device password field, type the new password and repeat it in the
Conform device password field.

3. Confirmwith OK.

The new device password is assigned to the devices on the next restart.

Note
To immediately activate the new password, perform a Scout Enterprise Restart command for
the relevant devices (now or scheduled). For further information, see Scheduling and execut-
ing commands.
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11.1.2. Changing local device password on the device

1. In the eLuxConfiguration panel, click Security > Device password.

2. Under Current password, type the old password.and in the next two fields type the new pass-
word.

To view your entry after typing, click .
1

3. Confirmwith Apply.

Important The device can no longer bemanaged by Scout Enterprise.

1for eLuxRP 6.7 and later versions
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11.2. Scout Console password

The default account Administratorwith console password is only active, if the Activate Admin-
istrator Policies... option is disabled.

In initial state, the Administrator policies are disabled and the console password is set to elux (all lower-
case).

Note
We strongly recommend that you change the password immediately in order to prevent unau-
thorized access.

To change the console password, log in to Scout Enterprise as administrator and clickOptions >
Change console password...

or

Enable the Administrator policies.

As soon as the administrator policies are enabled, the default account and console password are
disabled.

We recommend enabling the Administrator policies and using your AD accounts for Scout Enterprise.
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12. Managing administrators

12.1. Activating administrator policies

Managingmore than one Scout Enterprise administrators requires enabling the Administrator policies
feature. Scout Enterprise administrator accounts are based on AD accounts whichmust be defined
before. Scout Enterprise administrator accounts can be configured inmanyways.

By default, the administrator policies are disabled.

Note
Enabling the administrator policies requires being logged in as a full-access administrator. The
initial account is Administratorwith the password set to elux.

1. In the Scout Console, click Security > Activate administrator policies.

2. Confirmwith OK.

You are logged off and, from now on, you can only log on by using your WindowsAD account.
The Security menu options then become active. For example, you can enable pass-through authen-
tication now.

The Administrator default account is not available any longer and the Change console pass-
word... option is disabled.

12.2. Adding administrators

You can define any AD users and groups as Scout Enterprise administrators.

1. In the Scout Console, click Security > Manage administrators...

2. In the Administrator rights dialog, click Add Administrators...

The Initial administrator profile dialog opens.

3. Select the access range for the new admin and confirmwith OK.

TheWindowsAdministrator rights dialog opens.

4. Below of the Group or usernames field, click Add...

TheWindowsSelect Users or Groups dialog opens.

5. Enter the relevant AD username or AD group name, and then click Check Names.
Or:
Search for the AD user or AD group by using the Advanced... button.

6. Confirmwith OK.

The new user or group is added to the list of administrators. You can assign the appropriate rights to the
user or group now. For further information, see Administrator policy.

New administrators can log on by using their Windows account information.
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Note
If you use AD groups only, and if a user is amember of more than one group, the access rights
of the groups are not consolidated, but the rights of the first group found apply.
If users are authorized with their AD users and if they are authorized with one or more AD
groups at the same time, the access rights are not consolidated but the rights of the AD user
apply.

12.3. Deleting administrators

1. In the Scout Console, click Security > Managing administrators.

2. In the Administrator rights dialog, select the relevant administrator.

3. Click Delete administrator.

The selected administrator is deleted from the Scout Enterprise administrators list without an 'Are you
sure?' verification.
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12.4. Administrator policy

For all Scout Enterprise administrators there are three different kinds of access rights:

Base rights Main access rights organized in functional blocks

Menu rights Access rights for specificmenu commands

Object rights Access rights onOU or device level for properties, device configuration, applications
and some other functions

Default object
rights

Default access rights for all OUs or devices for which no different object rights have
been defined

Note that in the dialog youmust always first select the relevant administrator for whom you want to edit
the access rights. To edit object rights, first select the relevant OU or device.

In the Administrator rights dialogs, the provided rights are displayed with a green or red symbol:

Access granted

Access denied

To toggle between Access granted and Access denied, double-click the relevant right or press the
space key.

If you click the Full access or No access buttons, all of the displayed rights are set to green or red,
respectively.
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Important For all kinds of access rights, the following applies: If a right is disabled, the rel-
evant administrator has no longer access to the related function. For the last or the only
administrator existing, you cannot disable the access rights. This is to prevent being locked
out of the Scout Console
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12.4.1. Changing base rights

Administrator base rights refer to entire functional blocks such as using the Scout Report Generator or
configuring FollowMeDesktop.

1. In the Scout Console, click Security > Managing administrators.

2. In the Administrator rights dialog, select the relevant administrator.

3. Click Base rights....

The Administrator rights > Base rights dialog opens.

4. Change the relevant rights by double-clicking or by pressing the SPACE bar.

5. Confirmwith OK.
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12.4.2. Changing menu rights

Menu rights refer to the executability of menu functions. If you deny an administrator access to amenu
option, themenu item is dimmed and the administrator cannot perform the function.

1. In the Scout Console, click Security > Menu rights....

2. In theMenu rights dialog, select the relevant administrator.

3. ClickMenu rights....

TheMenu rights dialog opens.

4. Change the relevant rights by double-clicking or by pressing the SPACE bar.

5. Confirmwith OK.
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12.4.3. Changing object rights

Object rights refer to anOU or a device. You can define object rights for selectedOUs or devices that dif-
fer from the general default object rights.

1. In the tree view, select an OU or device.

1. Click Security > Object rights... or, on the context-menu, clickObject rights...

2. In the Object rights dialog, select the relevant administrator.

3. Click Edit object rights....

TheObject rights for <OU> dialog opens.

4. Change the relevant rights by double-clicking or by pressing the SPACE bar.

5. Confirmwith OK.

Resetting object rights to default

You can reset object rights that you have defined differently for anOU or a device:

1. In the Object rights dialog of the OU or device, select the relevant administrator.

2. Click Delete object rights.

12.4.4. Changing default object rights

Default object rights apply to all levels to all OUs or devices for which no specific object rights are
defined.

1. In the Scout Console, click Security > Managing administrators.

2. In theAdministrator rights dialog, select the relevant administrator.
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3. Click Default object rights....

The Default object rights dialog opens.

4. Change the relevant rights by double-clicking or by pressing the SPACE bar.

5. Confirmwith OK.

12.4.5. Defining a Start OU

This feature lets you deterrmine that an administrator is allowed to see only a particular start OU includ-
ing its subordinate OUs.

1. In the Scout Console, click Security > Manage administrators.

2. In the Administrator rights dialog, select the relevant administrator.

3. Click Set root OU ....

The Root organization unit dialog opens.

4. Check the Use the following root organization unit option.

5. Select the relevant root OU.

6. Confirmwith OK.

12.5. Viewing administrator activities

The activities of all administrators are logged according to the definedmonitoring level in Security >
Manage administrators.

You can view the logs in the Scout Console and you can export them.

1. In the Scout Console, select Security > Manage administrators.

2. Under Monitoring, click View protocol.

The Activities dialog opens and shows the activities of all administrators.

3. To export log entries into a text file, select the relevant entries and click Export selected items.

Monitoring levels

Themonitoring levels 0-3 build on each other. Level 0 only logs changes to themonitoring level itself.1

Logging with monitoring level 3 is themost detailed.

Note
Usemonitoring level 3 only temporarily for diagnostic purposes, since all database trans-
actions are additionally logged.

1fromScout EnterpriseManagement Suite15 2101
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Activities / level
1

Activities / level 21 Activities / level 32

Log on Save / Delete / Rename application All SQL statements executed due to
administrator activities in the console

Log off Upload application

Deny logon Save3 / Delete / Rename device

Add / Activate /
Delete license

Save4 / Delete / RenameOU

Add admin-
istrator

Save device configuration

Edit / Delete
administrator
rights

Save advanced device configuration

Change admin-
istrator policies

Save advanced options

Request mir-
roring of a device

Discover devices

Schedule/performScout Enterprise-
command5

Set / Delete relocation notification

Set / Delete update notification

Set / Delete delivery notification

Set / Delete UEFI update notification

Service Provider Mode: Assign tenant
- device / Remove assignment

12.6. Pass-through authentication

The pass-through authentication enables Single-Sign-On. Your Windows account information is used
to automatically log you on to Scout Enterprise. The Scout Enterprise log-on window is not shown any
longer.

1in addition to level 1 activities
2in addition to level 1+2 activities
3also applies toMove device
4also applies toMoveOU
5specifying command type and target device/OU
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12.7. Maintenance windows

– for Scout Enterprise 15.7 and later versions –

A maintenance window is a time period that is scheduled for maintenance work. In the Scout Console,
authorized administrators can definemaintenance windows to keep this period free for necessary IT
maintenance tasks such as installing server updates. While amaintenance window is active, non-author-
ized administrators cannot use the Scout Console and cannot start jobs.

Defining a maintenance window

Requires
Menu right: Menu: View > System diagnostics > Maintenance windows

1. In the Scout Console, click themenu entry View > System diagnostics > Maintenance win-
dows...

2. Click Add.

3. In the Edit Maintenance window dialog, specify the following options for your new maintenance
window:

Option Description

Name With descriptive names, you can distinguishmultiple maintenance windows.

From Date and time when themaintenance period will be started for the first time

for Time period of themaintenance window

Specify number and unit (hours or minutes)
Example: 2 hours

Repeat Repeats themaintenance window periodically, see example below

4. Confirmwith OK.

Themaintenance window is defined and shown in the list of maintenance windows.
For the duration of a definedmaintenance window, the console will be blocked for administrators who
do not have theMaintenance window menu right. The affected administrators can then only close the
console, other actions are disabled. After themaintenance window has expired, they can restart the con-
sole as usual.

Note
By default, theMaintenance window menu right is active andmaintenance windows have no
effect. If you disable themenu right for certain administrators, theywill not be able to work with
the console during the definedmaintenance windows. Administrators with activeMain-
tenance windows menu right are not subject to any restrictions.
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Example of a periodic maintenance window

For amaintenance window, for example defined from Friday, 06.09.2019, 20:00 for 2 hours, you can
set the following repeat options:

Every day Daily, starting on Friday, 06.09.2019

Every week Every Friday of a week

Everymonth Every 6th of amonth

Every first weekday inmonth Every Friday of the first week of themonth

Every second weekday inmonth Every Friday of the second week of themonth

Every third weekday inmonth Every Friday of the third week of themonth

Every fourth weekday inmonth Every Friday of the fourth week of themonth

Every last weekday inmonth Every Friday of the last week of themonth
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13. Scout Statistics Service

The Scout Statistics Service provides the following features:

Evaluation of configurable statusmessages (keep alivemessages) from the clients

Within a defined time interval the configured clients send statusmessages to the Scout Statistics
Service. These statusmessages allow to refresh the status of the relevant clients in the Scout
Console.

Processing of dynamic asset details for statistical analysis

In the Scout Console, you can configure if and which asset data of the devices are transferred.
Analysis and display of the statistical data is done in Scout Dashboard.
The statistical data are stored in a separate SQL database.

The 'keep alive' messages' and the dynamic asset data are transferred from the devices to the Scout
Statistics Service by using the HTTPS protocol. This requires a valid SSL certificate. For further inform-
ation, see Certificate for Scout Enterprise Statistics Service.

Note
The Scout Statistics Service is part of the Scout EnterpriseManagement Suite installation.
For further information , see Installing Scout EnterpriseManagement Suite in the Installation
guide.

13.1. Defining status messages (keep alive messages)

The Scout Statistics Service helps you configure automatic updating of the statusmessages (keep alive
messages).

1. In the Scout Console, select Options > Base device configuration > Network > Advanced or
open, for the relevant device or OU, the Device configuration > Network > Advanced dialog.

313



2. Select the Send keepalive packet option.

3. Enter a time interval in seconds.

4. Confirmwith OK.

Within the defined time interval, the configured clients send their statusmessages to the statistics ser-
vice. The statusmessages result in a refresh of the client icons in the tree view and of the relevant prop-
erty:

If, however, a statusmessage within the defined interval ismissing, the device status in the Scout Con-
sole is set to Switched off:

13.2. Examples of status messages

The color of the client icons in the tree view indicates the status of the devices:

The client is properly working. Statusmessages are forwarded to the Scout Statistics Service.

The client is without network connection or is switched off. Statusmessages cannot be forwarded
to the Scout Statistics Service.

The client is reconnected to the network. Statusmessages are forwarded to the Scout Statistics
Service.

For further information on client icons, see Scout Enterprise interface/Icons.
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13.3. Dynamic asset details for statistical analysis

Use the Advanced file entries feature of the Scout Console to configure how to transfer asset data for
statistical analysis.

File /setup/terminal.ini

Section Statistics

Entry Supervise

Value usb|pci

For further information, see Advanced file entries.

If you specify usb and/or pci as value, the asset data of the relevant OU are sent to the Scout Statistics
Service via HTTPS and they are saved to the Statistics database. This feature requires the Scout Stat-
istics Service being installed within the Scout Enterprise installation routine stating a certificate for
server authentication.

Analysis and display of the statistical data is done in the Scout Dashboard. The Scout Dashboard is
installed with the Scout EnterpriseManagement Suite specifying the relevant databases (Scout
Enterprise, Statistics and Dashboard).

For further information, see Installing Scout EnterpriseMangement Suite.
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14. Console communication

14.1. Closing the console

1. In the Scout Console, click File > Console Management > Close console.

The Close console dialog opens.

2. Click Refresh to receive an up-to-date list showing all active consoles.

3. Choose Find to filter the list.

4. If you want the user to receive amessage, check the Inform user for option and enter the seconds as
desired.

5. If you want to give the user the chance to cancel the command, check the Command can be can-
celed by the user option .

6. Select the relevant consoles in the list.

7. Click Close selected consoles or Close all consoles, respectively.

The command is communicated to the consoles. Closing the consolesmight take several minutes. The
dialog waits up to 5minutes for receiving the confirmation of all consoles. The list of all active consoles is
updated continuously within the time period.

14.2. Sending messages

With the aid of this function you can sendmessages to other console instances. Every console instance
shows amessage only once. If the console instances have not been started within the whole period of
validity, themessage is not shown. If a user starts within the period of validity a console instance which
was not yet involved in the database, themessage will only be shown in the case the option To all con-
soles was activated.

1. Choose Receiver and which console should receive themessage.

2. Choose in time period how long themessage should be displayed.

3. Enter in Message the text.

4. The option inform user... closes themessage located in the receiver console automatically after
expiration of the time period stated.

5. The option Command can be canceled by the user allows the user to close themessage in the
receiver console without confirming the receipt of themessage. In this case this particular mes-
sage will be displayed again after a reboot of the console executed within the time of validity. If the
time of validity is expired and the user selected no button themessage can be seen as received.

6. Choose Send.
Themessage will be sent to the consoles selected.
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14.3. Managing consoles

As soon as a console is opened by an administrator it is registered to the Scout Enterprise database.
The registered consoles are displayed in theManage consoles dialog.

Click File > Console management > Manage consoles.

For every console available, the logged-in user, the name of the computer aswell as the log-on domain
is shown. The active console is hidden. If a user has opened various console instances on its computer,
the consoles are numbered serially. For example is mfr #2 the second console instance of the user
mfr.

You can deactivate console instances by clearing the option for the relevant instance. This console
instance is no longer displayed in any of the console communication dialogs.

If you delete a console instance, all commands concerning this console are deleted and you lose part of
the command history. Possibly, commandswhich are not yet processed are deleted. The Delete com-
mand is needed for deleting consoles from thememory that are not used anymore. There is no affect of
this procedure concerning currently opened and active consoles.

You can check if all users are registered in the Active Directory. Unknown users can be selected and
can possibly be deleted or added to the Active Directory.

By using the Search command you can search in each column of the list. The place holders * and ? are
accepted within the search text and text searches are case-insensitve. By clicking the button X the
search field is closed.

14.4. Managing commands

Any console commands that have been run such asClose console... and Send message... can be
viewed. Moreover, in the bottom list, the receiving consoles can be viewed and filtered.

Displaying commands

1. If you want to filter the commands, use one of the options: All, Active, Inactive, Older than and Youn-
ger than.

2. If you want to display a search field for one of the columns, click Find.

Changing validity of commands

Select a command andmodify date and time under Valid until.

Deleting commands

1. If you want to delete all commands, click Delete all.

2. If you want to delete a particular command, select the command and click Delete.
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14.5. Managing reports for Scout Dashboard

Reports that have been saved to the database are globally available and can be used by all authorized
Scout Enterprise administrators (base right: Report Generator) in the Scout Report Generator. Addi-
tionally, all reports stored in the database can be used in Scout Dashboard.

The availability of reports in Scout Dashboard can be restricted bymeans of the report management in
the Scout Console: Here, you can assign reports to AD users or AD groups, or vice versa.

Requires

Activated administrator policies (Security > Activate administrator policies).

Menu right for File > Console management > Dashboard > Manage reports...

Assigning administrators to a report

1. Click File > Console management > Dashboard > Manage reports...

2. Make sure that the reports are shown on the left. If required, click Change view...

3. In the Reports list, select a report, and then, under the Administrators list, click Add...

All Scout Enterprise administrators are displayed.

4. Select one or more administrators or groups and confirmwith OK.

For the selected report, the authorized administrators are displayed.

5. Select the option Use report assignment for Dashboard.

The authorized administrators can use the selected report in Scout Dashboard.

Assigning reports to an administrator or administrator group

1. Click File > Console management > Dashboard > Manage reports...

2. Make sure that the administrators are shown on the left. If required, click Change view...

3. In the Administrators list, select a user or group, and then, under the Reports list, click Add...

All reports stored in the Scout Enterprise database are displayed.

4. Select one or more reports and confirmwith OK.

For the selected administrator/group, the allowed reports are displayed.

5. Select the option Use report assignment for Dashboard.

The selected administrator or administrator group can use the assigned reports in Scout Dashboard.

Important If the option Use report assignment for Dashboard is not selected, all reports
saved to the database are available for all administrators.
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15. Import/Export

All import and export functions can be performed via the Scout Console or the SCMD interface.

Exported files are saved in an XML format. The file name extension depends on the data category.

Data category for export/import Filename extension

Device configuration of OUs .oustp

Device configuration of devices .devstp

Properties of OUs .oupro

Properties of devices .devpro

Properties of applications .apppro

Device list .csv

OU tree .outree

15.1. Exporting

1. Select the OU you want to export data from.

2. Click File > Export and what you want to export.

3. Select a folder to save and apply with OK.

15.2. Importing

You can import device configuration data, device properties and application properties. In addition, you
can import device lists andOU trees. The import file must have the relevant file name extension.

1. Select the OU you want to import data into.

2. Click File > Import and the data category you want to import.

3. Apply with OK.
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16. Log files and optimizing

16.1. Log files

Scout Enterprise provides three logging optionswhich are saved as .log files on the Scout Server.

Option Log file Description

Scout Con-
sole

scout.log Required for debugging

Path:
%USERPROFILE%\Documents\UniCon\Scout\Console

In the Scout Console, click
View > System diagnostics > Console log.

Scout
Enterprise-
Server

eluxd.log Log file of the Scout Enterprise service, required for support calls

Default path:
%PUBLIC%\Documents\UniCon\Scout\Server

Previous versions are renamed in
elux.log.1...elux.log.3 etc.

In the Scout Console, click
View > System diagnostic > Server log (only if the Scout Con-
sole is installed on the samemachine as the Scout Server).

Server keep
alive log

keepAlive.log Log file for keep alive-entries of the Scout Server

created every 10minutes

Default path:
%PUBLIC%\Documents\UniCon\Scout\Server

For the Scout Statistics Service,the following log file is provided:
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Scout
Stat-
istics
Ser-
vice

UniconStatisticServic
e.log

Rotating log file with configurable path1

Default path:

%USERPROFILE%
\Documents\UniCon\Scout\StatisticService2

The location and themaximum size fromwhich a new file is
written can be configured in
%PROGRAMFILES%
\Unicon\Scout\Statistic\statisticservice.
exe.config

For further information about file paths, see Program and file directories.

Note
Click View > System diagnostic > Server files to open the Unicon server files directory in
theWindows File Explorer (if console and server are installed on the samemachine). The
Unicon directory contains all configuration and log files organized in their application dir-
ectories.

The following additional logs are available via the Scout Console and can be exported:

Option Description

License log All actions related to licenses such as entering, deleting and exporting licenses

View > System diagnostics > License log

Administrator
activity log

All administrator activities depending on the definedmonitoring level

Security > Manage administrators > View protocol

For further information, see Viewing administrator activities.

1from 15 2101
2up to Scout Enterprise15.10:
%USERPROFILE%\AppData\Local\Temp\UniconStatisticService.log
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16.1.1. Enabling logging

1. In the Scout Console, clickOptions > Logging options.

2. For the desired options, in the list field, select On.

The selected log files are created by the system as described.

16.1.2. Configuring Scout Server log

For the Scout Server log file eluxd.log the Scout Server createsmore than one backup (Log rota-
tion). Once a new eluxd.log is created, the previous version is saved to the file eluxd.log.1,
while the old eluxd.log.1 is saved to eluxd.log.2 and so on.

The log files continue recording when the server is restarted. The creation of a new log file is triggered
by the following parameters:

log file size

maximumnumber of log files

You are free to configure both thresholds by yourself.

In addition, youmaymodify the location of the server log file and the keep alive log file (by default in
%PUBLIC%\Documents\UniCon\Scout\Server). Specify any local directory for them, but no net-
work directory.

Modifying log rotation and location

1. In the file system, in %PUBLIC%\Documents\UniCon\Scout\Server, open the
eluxd.ini file for editing.

2. Tomodify the rotation parameters, add the following entries:
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Section Entry Default Description

[ELUXD] MaxLogFileSizeMB 100 Maximum size of a log file in MB

[ELUXD] MaxLogFiles 10 Maximumnumber of log files
(eluxd.log plus backups)

3. Tomodify the log file location, add the following entry:

Section Entry Example Description

[ELUXD] LogFileLocation c:\log Local directory to be used for the
log files eluxd.log and
keepAlive.log

Important Specify a local directory to which the Scout Server can write. Do not use the UNC
(UniformNaming Convention) format.

After the Scout service has restarted, the log files are written to the specified directory.

If the Scout Enterprise service cannot access the directory, it cannot start and creates an entry in the
WindowsEvent Viewer. If the Scout service is running but cannot write the log file, it creates an alert
message in the Scout Console.

16.1.3. Cleaning up mirror log files

– fromScout Enterprise 15 2101 –

If configured for mirroring, Scout Enterprise creates a log file for eachmirroring session and stores it in
the mirror directory under the Scout Server files. For further information, see "Configuringmirroring "
on page 118.

You can have these log files deleted automatically via a command.

1. In the Scout Console, click View > System diagnostics > Mirror log cleanup.

The Command dialog openswith the commandMirror log cleanup.

2. To select the period relative to the current date, under Delete log files older than, enter the num-
ber of days before which you want to delete log files.

3. Specify the point in time of the execution. To define periodic scheduling of the cleanup process,
select Every. Then, specify a day of themonth or a weekday and then the time.

4. Confirmwith Schedule.

Periodic scheduling of the command ensures that mirror log files have only a limited lifetime. Example: If
you define 90 days and Friday, the log files will remain available for amaximumof one week longer
than 90 days.

Note
Other log data such as administrator activities, executed commands, or alarms in the Scout
Console can be deleted via database cleanup. For further information, see "Database
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cleanup" on page 326.
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16.2. Optimizing

To optimize the performance and deal with high network loads you can use the following options:

Configuring handshake options for a device, OU or all devices

ManagerLoadBalancing to configure load distribution if you use a SQL database
For further information, see the Installation short guide.

Configuring the number of ODBC connections if you use a SQL database
For further information, see the Installation short guide.

16.2.1. Optimizing with handshake

During each start-up the Thin Clients contact their Scout Server and check for new configuration data
and application definition data. If they can't access the Scout Server, they retry to connect and syn-
chronize according to their handshake configuration.

Activating new configuration datamight require a restart of the client. Then the user is informed and has
the chance to suppress restarting.

Handshake parameters can be set in the terminal.ini file of the client by using the Advanced file
entries feature. For further information, see Advanced file entries.

Handshake can be configured for the entire organization or for a particular OU or device.

The values shown in the figure above are examples and can bemodified. By default, handshake is not
configured.
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The section ScoutHandshake provides the following configurable parameters:

Parameter Description

MaxRetries Number of connection attempts
The value 0 deactivates handshake.

RetryTimer Period of time in seconds until next connection attempt (start value)

After each attempt the interval is doubled (+/- random value).

Example: Having defined 8 connection retries and a RetryTimer start
value of 5 seconds, the 8. connection attempt is carried out after about
21minutes.

PermanentRetriesAfterDays Number of days (maximum) from the last successful connection until
next connection attempt

Ensures that after n days latest the configuration data of device and
Scout Server is compared

Can be combined with MaxRetries and RetryTimer

WaitUser Waiting time before client restarts to give the user the chance to close
applications or log off.

CanCancel Defines, if the user is allowed to suppress a client restart (true |
false).

16.2.2. Database cleanup

Scout Enterprise stores huge amounts of data concerning various processes such as any performed
update commands. To purge the Scout Enterprise database tables, authorized administrators can
delete database entries from particular tables for a specified period of time.

The relevant tables are listed in the Database cleanup dialog, each table providing the total number of
entries and the creation date of the first entry. The administrator canmodify only the fields Selection
and to.
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Alerts in the Scout
Console

Alert messages (Error, Warning, Info),
can be viewed by double-clicking the
lamp icon on the Scout Enterprise
status bar

Logging of admin-
istrator activities

Log file entries about the activities per-
formed by an administrator according
to the definedmonitor level in Security
> Manage administrators...

For further information, see Viewing
administrator activities.

Device list in com-
mand history

History data of commands shown in View > Command history... of the Scout
Console (entries for particular devices)

Command history History data of commands shown in View > Command history... of the Scout
Console (entries for OUs)

Command results
of devices

Results of commands performed on the devices (Update, Delivery, user-defined
command). The log data can be viewed in the Scout Console in the Properties
window or by using the context menu of a device Commands > Update/De-
livery/Command.

For further information, see Update and delivery log.

Performing a database cleanup

1. Select View > System diagnostics > Database cleanup...

2. In the Database cleanup dialog, for the relevant table, in the to field, specify a date that indicates
the end of a time span for the deletion of the entries (all entries up to and including this date are
deleted).
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The Entries column at the right shows the number of entries to be deleted.

3. Click into the field of the Selection column on the left to activate this table for cleanup.

A checkmark indicates that entries from this table are selected for cleanup.

4. Click Cleanup.

A message shows the total of all entries in all tables which are intended for cleanup.

5. Confirmwith Yes.

From the selected tables, all entries up to the specified dates are deleted.

Note
Before you can delete command history entries, you are required to delete the according
device list entries.
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17. Appendix

17.1. Program and file directories

Program directory

Scout EnterpriseManagement Suite by default is installed to

%PROGRAMFILES%\Unicon\Scout

Scout Dashboard is installed on the web server (IIS) by default to

<root directory>\Scout\Dashboard
The directory name Dashboard is the application name shown in the URL and can bemodified dur-
ing installation.

The eLux container is installed on the web server to

<root directory>\eluxng

File path for Scout Server files

Scout Enterprise log files, configuration files andmore are saved to a subdirectory of

%PUBLIC%\Documents\Unicon

To open the server files directory in theWindowsExplorer, in the Scout Console, click View > Sys-
tem diagnostics > Server files (only if console and server are installed on the samemachine).

File path for user files

User files are saved to a subdirectory of the local user directory in

%USERPROFILE%\Documents\Unicon

Diagnostic files that are requested via the console are saved to

%USERPROFILE%\Documents\Unicon\Scout\Console\Diag

Diagnostic files that are requested via Scout Dashboard are saved on the web server to

<root directory>\Scout\Dashboard\Content\Diagnostic

Note
If you use anti-virus software on your Scout Server, we recommend that you exclude the spe-
cified directories from the virus scan to avoid side effects.

17.2. eLux partitions

A thin client’s flashmemory is generally divided into three or four partitionswhen eLux is installed. Each
partition is reserved for a dedicated purpose and is only touched when you perform special tasks that
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are related to this partition.

All partitions are created during a recovery installation.

Partition Requires Purpose Recreated with Other

System Reserved for the firmware
(software packages)

Scout Enterprise Update
commandwith option
Format system partition
before update

Size for
eLux RP 6
 2104 LTSR CU1 and
earlier versions:

1,77 GB / 1,84 GB
with/without encryption

Size for
eLux RP 6 2107 and
later versions:

2,35 GB / 2.41 GB
with/without encryption

Boot only
UEFI
and
USB

Boot section –

Setup Device configuration

Local application definitions

Factory reset command Does not affect the sys-
tem partition with
installed firmware

Update 4GB
flash
memory

Software delivery in
advance (before firmware
update) via Scout
Enterprise command or noti-
fication

Signature check for eLux
software packages

Deviceswith update par-
tition can be used as
Dynamic Proxy (Provider)
for firmware updates.

Scout Enterprise Deliv-
ery commandwith
option Format update
partition before delivery

The size of the update
partition complies with
the storage space
provided.

The update partition is
no larger than the stor-
age space provided.

Deviceswith less than
4GB flashmemory are
not provided with an
Update partition.

Note
In the Scout Console, in the Properties window of a device, the system, setup and update par-
titions are listed including their sizes.

Extended system partition starting with eLux RP 6 2107

When you perform an update installation or a new installation (recovery) to eLux RP 6 2107 or later, the
system partition is created with 2,35 GB / 2.41 GB (with/without encryption) instead of the previous
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almost 2.0 GB. This createsmore space for the firmware and allows larger images to be used.

Update installation

An update installation (firmware update) is still based on the previous partition sizes. The image
size is thus still limited to the earlier values. Afterwards, the extended system partition is available
and you can install images that may be up to 2.35GB / 2.41GB in size. Thismeans, to install lar-
ger images on the freshly resized partition of the devices, a second firmware update is required.

Recovery installation

Provided an up-to-date recovery system is available, with a PXE or USB recovery installation the
system partition can be partitioned to the new size directly during the installation process and a lar-
ger image with up to 2.35GB / 2.41GB can be written in the same process. A new installation or
recovery installation thus allows the partition to be resized and used in one step.

Downgrade

Important To downgrade deviceswith the extended system partition (eLux RP 6 2107 or
later) to an earlier version that only supports the previous system partition with less than 2
GB, you will have to go back to eLux RP 6 2104 LTSR CU1.

We therefore recommend that you update test devices to eLux RP 6 2107 or later as the first step to thor-
oughly test functionality.

17.3. IP ports

eLux / required ports

Port Type Description How to deactivate In/Out

ICMP pingmust be supported to verify the
status of the eLux devices

In/Out

80 TCP Firmware update by using HTTP (and
proxy port, if used)

Outgoing

443 TCP Firmware update via HTTPS/TLS Outgoing

5900 TCP Mirroring eLux desktop In Config1 > Security, dis-
ablemirroring
or uninstall VNC server in
X.Org package

Incoming

22123 TCP Scout Server (Scout EnterpriseMan-
ager / secure)

In/Out

1Device configuration, formerly Setup
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Port Type Description How to deactivate In/Out

22125 TCP Scout Server (Scout EnterpriseMan-
ager / TLS 1.2) 1

In/Out

22129 TCP VPN Outgoing

eLux / optional ports

Port Type Description How to deactivate In/Out

ESP VPN (data transfer) Uninstall package VPN
System

In/Out

21 TCP Update via FTP control port (dynamic
data port)

Outgoing

22 TCP SSH applications Outgoing

23 TCP 5250 emulations and telnet sessions Outgoing

53 TCP,
UDP

DNS server Outgoing

67 UDP DHCP server Configure a local IP address
(Config > Network)

Outgoing

68 UDP DHCP client (or: BootP client) Configure a local IP address
(Config > Network)

Incoming

69 UDP TFTP server (only used during PXE
recovery)

Outgoing

88 TCP,
UDP

AD authentication (Kerberos) Outgoing

111 TCP,
UDP

TCP port mapper – RPC internal use
only
Workswith lockd (random)

UDP port mapper – drive access on NFS
servers
Workswith NFSD drive access (port
2049) andmountd (random)

Uninstall Network Drive
Share package

In/Out

123 UDP Windows Time server (NTP) Do not configure a time
server
(Config > Desktop)

In/Out

1for Scout EnterpriseManagement Suite 15.1 / eLuxRP 6.1 and later versions
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Port Type Description How to deactivate In/Out

139 TCP,
UDP

SMB drivemapping, (NetBIOS) and
SMB user authentication (CIFS)

Uninstall Network Drive
Share package and User
authentication

modules package

Outgoing

161 UDP SNMP Uninstall SNMP
Environment package

In/Out

162 UDP SNMPTRAP Uninstall SNMP
Environment package

Outgoing

177 UDP XCMCP protocol Outgoing

389 TCP AD authentication with user variables Outgoing

443 TCP VPN (connecting) via HTTPS/TLS Uninstall package VPN
System

In/Out

464 TCP,
UDP

AD authentication (Kerberos) / Set pass-
word

Outgoing

514 TCP Shell, X11 applications Outgoing

515 TCP Printing via LPD Uninstall package Print
environment (CUPS)

In/Out

631 TCP,
UDP

CUPS (IPP) print client Uninstall package Print
environment (CUPS)

Outgoing

636 TCP LDAPS authentication with user vari-
ables

Outgoing

2049 UDP NFSD drive accessNFS Uninstall FPM NFS
Support in Network
Drive Share package

Outgoing

6000 TCP Remote X11 application In Config > Security, clear
Allow remote X11 clients
option

Incoming

7100 TCP Font server
can be assigned in (Config > Screen >
Advanced

Outgoing

8080 TCP Firmware update via Dynamic proxy
(Provider and Consumer)

Set Config > Firmware >
Proxy-Typ to None

In/Out

9100 TCP Printing directly to parallel port
can be assigned in (Config > Printer)

In Config > Printer, clear
TCP direct print option

Incoming

9101 TCP Printing directly to USB port
can be assigned in (Config > Printer)

In Config > Printer, clear
TCP direct print option

Outgoing
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Port Type Description How to deactivate In/Out

20000 UDP WakeOn LAN In/Out

22124 TCP Scout Enterprise Statistics Outgoing

Scout Server

Port Type Description In/Out

ICMP pingmust be supported to verify
the status of the eLux devices

In/Out

1433 TCP MS SQLServer Outgoing

1434 UDP MS SQLServer (Browser service) In/Out

22123 TCP Clients (Scout EnterpriseManager
/ secure)

In/Out

22124 TCP Scout Enterprise Statistics Incoming

22125 TCP Clients (Scout EnterpriseManager
/ TLS 1.2) 1

In/Out

Scout Console

Port Type Description How to deactivate In/Out

1433 TCP MS SQLServer Outgoing

1434 UDP MS SQLServer (Browser service) Outgoing

5900 TCP Mirroring the eLux desktop In Config > Security, disable
mirroring
or uninstall VNC server in
X.Org package

Outgoing

Scout Dashboard

Scout Dashboard can be installed with HTTP or HTTPS.

Port Typ Description How to deactivate In/Out

80 TCP Dashboard service / web server via
HTTP

Incoming

443 TCP Dashboard service / web server via
HTTPS/TLS

Incoming

1for Scout EnterpriseManagement Suite 15.1 / eLuxRP 6.1 and later versions
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Port Typ Description How to deactivate In/Out

5901 TCP Mirroring the eLux desktop In Config > Security, disable
mirroring
or uninstall VNC server in
X.Org package

Outgoing

Scout Cloud Gateway

Port Typ Description In/Out

22125 TCP Scout Server (Scout Enterprise
Manager / TLS 1.2)

In/Out

22129 TCP VPN Incoming
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17.4. SNMP

SNMP (Simple NetworkManagement Protocol) is a network protocol for monitoring and controlling net-
work devices.

For eLuxRP 5 and eLuxRP 6, version SNMPv3 is used.

Note
The command line program snmpget is not included in the software package. To query
SNMP status information, please use third party software.

17.4.1. Configuring SNMP

1. From our portal www.myelux.com, under eLux Software Packages, for your eLux version,
under Add-On, download the package SNMP Environment and deploy it to the clients.

2. If there is no /setup/snmp/snmpd.conf on the clients, transfer the configuration file
snmpd.conf to the clients to /setup/snmp/snmpd.conf by using the Scout Enterprise fea-
ture Files.

Or:

Modify the terminal.ini file by using the Advanced file entries feature of Scout Enterprise.
Example:

File /setup/terminal.ini

Section SNMPD

Entry rocommunity

Value secret

3. Optionally, to define further SNMPD Configuration Directives, use the Advanced file entries fea-
ture andmodify the terminal.ini file under SNMPD. Examples:

syscontact=contact@sampletec.com
syslocation=testcenter
doDebugging=1

For further information on SNMPD Configuration Directives, see http://www.net-snmp.org.

The section SNMPD of the terminal.ini file is evaluated by the client and the file
/setup/snmp/snmpd.local.conf is created. An existing /setup/snmp/snmpd.confwill be
overwritten.

If the configuration file does not exist, the file /setup/snmp/snmpd.local.conf is created with
default values.
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Notes on configuring SNMP v3

When you define users (createUser), set a password with at least 8 characters.

For the authenticationmethod, define authPriv or authNoPriv.

Note
For SNMP v2, you can use noAuthNoPriv as the authenticationmethod.
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17.4.2. SNMPD and SNMP Configuration Directives

The following table refers to the software package snmp-5.6.1.1-2 for eLux.
For further information on using SNMP with eLux, see SNMP.

For further information on SNMP commands, see http://www.net-snmp.org.

Application Command

authtrapenable 1 | 2 (1 = enable, 2 = disable)

trapsink host [community] [port]

trap2sink host [community] [port]

informsink host [community] [port]

trapsess [snmpcmdargs] host

trapcommunity community-string

agentuser agentuser

agentgroup groupid

agentaddress SNMP bind address

syslocation location

syscontact contact-name

sysservices NUMBER

interface name type speed

com2sec name source community

group name v1|v2c|usm security

access name context model level prefx read write notify

view name type subtree [mask]

rwcommunity community [default|hostname|network/bits] [oid]

rocommunity community [default|hostname|network/bits] [oid]

rwuser user [noauth|auth|priv] [oid]

rouser user [noauth|auth|priv] [oid]

swap min-avail

proc process-name [max-num] [min-num]

procfix process-name program [arguments...]

pass miboid command
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Application Command

pass_persist miboid program

disk path [ minspace | minpercent% ]

load max1 [max5] [max15]

exec [miboid] name program arguments

sh [miboid] name program-or-script arguments

execfix exec-or-sh-name program [arguments...]

file file [maxsize]

dlmod module-namemodule-path

proxy [snmpcmd args] host oid [remoteoid]

createUser username (MD5|SHA) passphrase [DES] [passphrase]

master pecify 'agentx' for AgentX support

engineID string

engineIDType num

engineIDNic string

SNMP Configuration Directives

Application Command

doDebugging (1|0)

debugTokens token[,token...]

logTimestamp (1|yes|true|0|no|false)

mibdirs [mib-dirs|+mib-dirs]

mibs [mib-tokens|+mib-tokens]

mibfile mibfile-to-read

showMibErrors (1|yes|true|0|no|false)

strictCommentTerm (1|yes|true|0|no|false)

mibAllowUnderline (1|yes|true|0|no|false)

mibWarningLevel integerValue

mibReplaceWithLatest (1|yes|true|0|no|false)

printNumericEnums 1|yes|true|0|no|false)

printNumericOids 1|yes|true|0|no|false)

escapeQuotes (1|yes|true|0|no|false)
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Application Command

dontBreakdownOids (1|yes|true|0|no|false)

quickPrinting (1|yes|true|0|no|false)

numericTimeticks (1|yes|true|0|no|false)

suffixPrinting integerValue

extendedIndex (1|yes|true|0|no|false)

printHexText (1|yes|true|0|no|false)

dumpPacket (1|yes|true|0|no|false)

reverseEncodeBER (1|yes|true|0|no|false)

defaultPort integerValue

defCommunity string

noTokenWarnings (1|yes|true|0|no|false)

noRangeCheck (1|yes|true|0|no|false)

defSecurityName string

defContext string

defPassphrase string

defAuthPassphrase string

defPrivPassphrase string

defVersion 1|2c|3

defAuthType MD5|SHA

defPrivType DES (currently the only possible value)

defSecurityLevel noAuthNoPriv|authNoPriv|authPriv
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