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1. Representation

The following representations and conventions for instructions are used throughout the documentation:

Representation Description

Control element All graphical user interface controls are displayed in bold

Menu > menu
command

Whenever running a command involves clicking a series of menus, the single
GUI controls such asmenu commands or dialog tabs are linked by >.

Value All data that have to be entered by the user or data that represent a field value
are displayed in Courier New. Also, file names and path names are displayed
in Courier New.

STRG Keys to be pressed are displayed in CAPITAL LETTERS.

<Placeholder> Placeholders in instructions and user input are displayed in italics and in <angle
brackets>.

1. Instruction Procedures to be carried out step by step are realized as numbered steps.

Result System responses and results are displayed in italics.

Abbreviations and acronyms

Abbreviation Description

AD Active Directory , directory service of Microsoft WindowsServer

EBKGUI Interface of the eLux Builder Kit (component of Scout Enterprise)

EPM eLux packagemodule (.epm, software package)

FPM Feature packagemodule (.fpm, part of a software package)

FQDN Fully qualified domain name

GB Gigabyte

GHz Gigahertz (processing speed)

HDD Hard disk drive (flashmemory)

IDF Image Definition File (.idf)

IIS Internet Information Services: Microsoft Web server

MB Megabyte

OU Organizational unit
Unit or group within the organizational structure

VPN Virtual Private Network
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2. Overview

The Scout Report Generator is used to create reports based on the devices, applications andOUs of
the Scout Enterprise database.

The Scout Report Generator is part of the Scout EnterpriseManagement Suite and is installed as a com-
ponent of it. For further information, see Installing Scout EnterpriseManagement Suite in the Install-
ation guide.

Themenu rights can be used for each administrator to control whether the Scout Report Generator may
be started. Use the basic administrator rights to allow or deny creating, editing and deleting database
reports and local reports.1

2.1. Starting Scout Report Generator

1. In the Scout Console, make sure that Security > Activate administrator policies... is selected.
For further information, seeMulti-client capability of the Report Generator.

2. In the Scout Console, select View > Report...

The Scout Report Generator window opens. For database access, the settings of the Scout Console
are used.

2.2. Multi-tenancy

To use the report generator, activate administrator management (Security > Activate administrator
policies...). The access rights defined there then are applied for creating reports. This is to ensure that
administrators can only create reports based on the devices visible to them.

The administrator policies are also required to control the use of reports in Scout Dashboard. The Scout
Console provides a feature that allows assigning reports to administrators and vice versa. The report
assignment ensures that reports in Scout Dashboard aremade available only to the relevant authorized
administrators.

1for Scout EnterpriseManagement Suite 15.5 and later versions
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3. Interface

The Scout Enterprise Report Generator application window is divided into two areas. On the left, all
reports defined are listed. They are organized into the four types organization units, devices, applic-
ations and inventory. The predefined reports provided can be used as templates.

On the right, a report output is displayed. The name and number of matching elements are displayed on
the status bar.

Note
The report output on the right does not necessarily correspond to the selected report on the

left. Click the button to refresh or create a selected report.

The toolbar buttons help define, create, print and browse reports.
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4. Basic functions

4.1. Creating and saving a new report

1. Click File > New Report or click the New report button.

2. Enter a name, and then select the storage location and report type.

If you select the storage location Local, the report is saved in the local user directory of the logged-in
user (<User>\Documents\UniCon\Scout\Report).

If you select Database, the report is saved to the Scout Enterprise database. It can then be viewed,
used and edited by other authorized Scout Enterprise administrators. Reports that have been saved
to the database can also be run in Scout Enerprise Dashboard. For further information, see Sharing
reports.

3. For the selected report, click Edit > Layout or, on the toolbar, click the Layout button.
In the Report Layout dialog, define the desired layout features. For further information, see Report
layout.

4. For the selected report, click Edit > Filter or, on the toolbar, click the Filter button.
In the Report Filter dialog, define the desired filter values. For further information, see Report filter.

Note
You can easily change the name later, but the report type and storage location cannot be
changed later. To change the storage location, create a new version by clicking Save as.
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4.2. Creating a report output

1. Select a report.

2. Click View > Create report.
Or:
Double-click a report definition.
Or:

Click the Create report button.

The report output is created and displayed on the right.

You can vary the display size of the report output, select page view (View > Page view), browse
through and search the report.

Report outputs can be printed and exported.

Note
A report, whose layout does not contain fields, cannot be executed.
If report outputs contain column titles but no elements, the filter has not been defined correctly.
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4.3. Report templates

When you install the Scout Report Generator, several report templates are added to the local user dir-
ectory Public\Documents\UniCon\Scout\Report. You can use themwhenever suitable.

In the tree view of the Scout Report Generator, the report templates are organized into different types.
They can bemodified as required.

Report type Devices

tpl_appl_licenses Deviceswith defined application licenses

tpl_assigned_OU Devices of definedOU

tpl_clients_of_subnet Devices of defined IP subnet

tpl_client_absence Deviceswith latest contact to Scout Server before defined date

tpl_image Deviceswith defined image name

tpl_lastupdvol_period Deviceswith software update between two defined dates

tpl_monitor_vendor Deviceswith monitors of a defined producer

tpl_noDDC_monitors Deviceswithout DDC information (EDID) of themonitor

tpl_OS_version Deviceswith definedOS version

tpl_supplier_ram Devices of defined producer with RAM less than defined value

tpl_vendor_model_type Devices of defined producer, model and type

Report type Assets

tpl_connected_USB_dev Deviceswith connected USB devices of a defined producer
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Note
Before creating a report output, youmust modify the filter values for most templates.
Use the Save as... feature to create copies or variants.
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4.4. Sharing reports

By using the storage location Database when you create a new report, you allow all authorized Scout
Enterprise administrators to use and edit this report definition.

An administrator is authorized to run reports if he has the base permission Report generator.
An administrator is authorized to edit reports if he has the base permission Edit database reports.

Reports saved to the database can also be run in Scout Dashboard. Access to the reports in the Dash-
board is configured in the Scout Console .

For further information, see Creating a new report andManaging reports for Dashboard in the Scout
Enterprise guide.

In contrast, any report defined with the option Local is only available in the local user directory of the cre-
ator.

Note
Use the Save as... feature to save locally defined reports to the database andmake them
available to other administrators.
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4.5. Saving, printing and deleting a report

All file-related features of the Scout Report Generator are provided on the File menu.

1. Select the relevant report.

2. Click File > Menu command.

Menu command Alternative

Rename F2

Delete ENTF

Save

Save as –

Print

Note
Use the Save as... feature to produce slightly different versions or to make locally saved
reports available to other administrators.

4.6. Exporting a report

1. Check the page layout for the relevant report. For further information, see Defining page layout for
print output.

2. Run the relevant report or make sure that the output shown on the right is up-to-date.

3. On the toolbar, click the Export button.

4. Select the export format Excel or PDF.

5. In the Save as dialog, enter a file name and storage location.

The currently generated report output is exported to the specified file.

Note
Exporting to a Dynamic Client Groupmakes the result set available in the Scout Enterprise
Console.

For further information, see Dynamic Client Groups in the Scout Enterprise guide.

4.7. Changing language

Click View > Language.
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Note
The Default option uses the language set in the operating system.
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5. Report definition

Defining a report includes two basic steps:

The layout of a report specifies the relevant database fields and their display properties. In addi-
tion, it determines the way the report output is formatted, including the font, page layout and head-
ers.

The filter is used to filter the selected fields for particular values. You can combine several filter
expressions by using operators.

5.1. Report layout

Defining the report layout consists of two steps:

Select the relevant field that you want to display as columns in the report output (Columns tab)

Determine the print page layout including the header/footer and page formatting (Header/Footer
tab andWorksheet tab)

5.1.1. Defining columns

In the report layout, choose the database fields you want to show as columns in the report. For the
columns and resulting elements, you can also specify an order and other layout criteria.

Choosing the relevant fields

Legend to numbers

1 Shows all available fields that
you can apply to the report as
columns

2 Shows all fields that will be
shown by the report

The order can be defined later
on.

Note the following for Scout Enterprise
15.10 and later versions:

The eLux portable field shows
whether it is a device or an eLux
Portable USB stick

The Client identifier field is used
for unique identification of
devices and elux portable sticks.

1. Select a report and click the Layout button or click Edit > Layout...
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2. In the Report layout dialog, on the Columns tab, click the +/- button. See screenshot above.

3. To add a field, select the relevant field on the right andmove it to the left by using the← button.

4. To remove a field, select the relevant field on the left andmove it to the right by using the→ button.

5. Confirmwith OK.

Note
Alternatively, to move elements between the two lists, double-click the element or use the INS
and DEL keys.

In the Report layout dialog, in the preview, the selected fields are shown in the Content column.

Specifying layout

In the Report layout dialog, on the Columns tab, define additional properties of the report layout.

1. To change a column header, for the relevant field (row), click into the cell of the first column. Then
enter the desired column title and confirm ith RETURN.

14



2. Specify further settings:

Option Description

↑ and↓ but-
tons

Change order of the columns

Alternatively, use a drag-and-drop operation.

Alignment
column

Defineswhether the text is left-aligned, right-aligned or centered

Min andMax
columns (column
width)

Columnwidth is calculated automatically. Youmay, however, specify amin-
imum andmaximumwidth for each column.

To define a fixed columnwidth, set the same values for minimumandmax-
imumwidth.

If theminimumwidth exceeds themaximumwidth, the column is not dis-
played in the report.

To reactivate the automatic column calculation, set both values to 0.

Valid units aremillimeters (mm), centimeters (cm), inches (in), points (pt)
and pica (pc).

Mark rows Each second row of the report is highlighted to improve readability.

Fill rows Highlighting of the row is continued until right pagemargin.

Font Defines font and font size for headers and rows.

Sorting Defines field bywhich the elements of the report are sorted.

3. Bestätigen Siemit OK.

Note

To run the report after you havemodified the report layout, click . Only then, the report out-
put is refreshed in the programwindow.
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5.1.2. Merging columns

Under certain conditions it might be useful to merge columns.

Example

You have created a list of all ICA and RDP applicationswith their names, their assigned organization
units and their server addresses...

... resulting in the following report:

As only one of the fields RPP Server and ICA Server contain a value, the two fields can bemerged.

Merging fields

Define the same column title for both fields.

In the example, both titles can be changed to Server.

Both fields are assigned to one column. The value of the first columnmerged that is not empty is dis-
played:
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5.1.3. Defining the page layout for print output

Before printing a report, check the page formatting tomake sure the page breaks for multiple pages are
correct.

You can define headers and footers that are shown on each page.

Defining headers and footers

1. In the Report Layout, on the Header/Footer tab, select Show headeror Show footer.

2. Into the text boxes Left text, Centered text and Right text, type the text you want to show on each
page, or select one or more fields from the dropdown list:

Name of the report

Page number

Number of pages

Date

Time

Number if items

You can insert more than one field and you can combine free text with fields.

Example: Created <Date>, <Time>

3. If required, click the ... button to specify the font and font size.

Defining page formats

1. On theWorksheet tab, under Page size, select a predefined page size and the page orientation Por-
trait or Landscape.

2. If you do not use one of the predefined page sizes, select User-defined to type in your individual page
dimensions.

3. If required, under Margins, modify the predefined values for themargins.

The page layout settings affect direct printing and documents exported to PDF and Excel.
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5.2. Report filter

Filtering helps you narrow down the result list pane to those objectsmatching the specified criteria. If
you do not define a filter, all devices, OUs or applications are displayed when running the according
report.

Note

Run the report by clicking clicking after you havemodified the filter definition. Only then,
the report output is refreshed in the programwindow.

5.2.1. Report filter dialog

The report filter includes one or more filter expressions. Each filter expression has its own table row.

A filter expression is based on one of the fields that you have selected as columns in the Report layout
dialog.

Legend to numbers

1 Logical operator AND | OR

Required for the second and further filter expressions

2 Optional, NOT reverses the logical value of the filter expression

3 Opening parenthesis (for closing parenthesis, see the logical operator field)

4 Field that has been added as column in the Report layout dialog
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Legend to numbers

5 Comparison operator depending on field data type

=
<>
<
>
<=
>=
LIKE

LIKE compares two strings. You can use the following wildcard characters:
_ substitute for a single character
% substitute for zero or more characters

6 Value that matches the data type of the field

7 Functions for editing rows

Inserting, deleting and sorting table rows

Select a row and use one of the following buttons:

Button Description

Append Adds a new row.
Alternatively, you can click into the next row.

Insert Inserts a new row above the selected row.

Delete Deletes the selected row.

↑ ,↓ Changes the order of the rows / filter expressions.
Alternatively, use a drag-and-drop operation.

5.2.2. Defining filters

1. Select a report, and then click Filter or click Edit > Filter...

2. In the Report filter dialog, define one or more filter expressions by specifying column, com-
parison operator and value. To define the column and operator, click the relevant cell and select
an entry from the list. For further information, see Report filter dialog.

3. If you definemore than one filter expression, join the expressions by using one of the logical oper-
ators AND or OR in the first column. If required, use parentheses to determine the sequence of
operation.

4. Confirmwith OK.

The entries are checked and white spaces are removed. If there are any invalid entries, they are
highlighted in red. The window can only be closed, if the filter definition is correct.
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5. Run the report by clicking .

5.2.3. Special options for date fields

The value of a date field can be set to a fixed date and time. For Scout EnterpriseManagement Suite
15.1 and later versions, you can refer to relative time periods, alternatively:

A period of time to be specified before or after the current day (Today)

A specific weekdaywithin the last week (Weekday)

If you work with relative time specifications such as -4d from today, you can run a report, let's say each
Friday, and always get the results for the last four dayswithout having to change the report definition.

TheWeekday option refers to the last seven days. The reference to a weekday allows you to query the
same time period or point in time with the same report definition every week.
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To define a date or time period for a date field, click in the table cell under Value.

Option Description

Date/Time Fixed date and time

Weekday If you select Monday, the value refers to the last Monday before the current day
at 0:00 o' clock.

Example:
With =Monday, on amondaymorning, you can show all IDFs of clients that have
been updated automatically at the weekend - with statusMonday at 0:00 o' clock.

Example:
With the expressions > Monday AND < Tuesday you will get results referring
to the wholeMonday (0:00 o' clock to 0:00 o' clock).

Today Time period relative to the current day, optionally including time

y Years
m Months
w Weeks
d Days
h Hours
mm Minutes

Example:
-4d
refers to the last four days before the current date
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6. Dynamic Client Groups

Dynamic Client Groups enable administrators to run cross-OU commands for freely definable device
groups. For example, you can send amessage to all deviceswith a specific image throughout the whole
organization. Or you can run a BIOS update on all deviceswith a specific BIOS version, across all OUs.
Even client relocation to another Scout Server can be applied to a Dynamic Client Group. The following
features can be applied:

Commands

Configuration run

Notifications for software deliveries or firmware updates

Notifications for relocation

Dynamic Client Groups are based on reports created in the Scout Report Generator. The reports are
exported to the Scout Console once, and from that point onward, are displayed as a Dynamic Client
Group. Commands applicable to OUs or to individual devices can also be applied to Dynamic Client
Groups.

Note
The report layout must include the Client identifyer1 or theMAC address2, respectively. The
report typemust be a list of Devices or Assets.
For further information on defining Dynamic Client Groups, see Creating Dynamic Client
Groups in the Scout Report Generator guide.

Dynamic Client Groups are displayed in the Scout Console in a special window and remain there for re-
use until they are deleted. They can be updated any-time with a click.

User rights

When you create Dynamic Client Groups, the user access rights are respected as defined in the admin-
istrator management.

By default, executing commands and other functions on a Dynamic Device Group is subject to the
object rights configured for the relevant devices andOUs.3This can result in a function not being
executed because at least one device does not have the required object rights. To avoid this, disable the
check for the underlying object rights under Security > Manage administrators > DCG rights.

6.1. Creating Dynamic Client Groups

Creating Dynamic Client Groups consists of two steps that are carried out in Scout Report Generator:

1fromScout Enterprise 15.10
2up to Scout Enterprise 5.9
3for Enterprise 15.1 and later versions
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Creating a report filtered by the desired properties

Exporting the report as a Dynamic Client Group to the Scout Console

Creating a report as basis for a Dynamic Client Group

1. Select File > New report... or click the New report button.

2. In the New report dialog, select the Report type Create list of devices or Create list
of asset entries and confirmwith OK.

3. For the selected report, on the toolbar, click the Layout button to define the report layout.

In the Report layout dialog, on the Columns tab, choose those database fields you want to filter by.

Important

Make sure to include the Client identifyer1 field or theMAC address2 field, respectively. This
field is required for unambiguous identification of the devices.

Specify the desired layout properties.

For further information, see Report layout.

4. For the selected report, on the toolbar, click the Filter button and define the filter criteria.

Example: OS version LIKE %4.8% extracts all deviceswith anOS version 4.8 installed.

For further information, see Report filter.

5. Run the report by clicking the Create report button.

The report output is created and displayed on the right.

6. Save the report.

Exporting a report as Dynamic Client Group

1. Select the report that you want to export.

2. Click Export > Dynamic Client Group... to start data export to the Scout Console.

The report is exported and provided asDynamic Client Group in the Scout Console in the Dynamic Cli-
ent Groups window. All available commands can be applied to the Dynamic Client Group.

1fromScout Scout Console 15.10
2up to Scout Scout Console 15.9
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For further information, see Using Dynamic Client Groups in the Scout Enterprise guide.
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