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1 Before You Begin 

1.1 Who Should Use This Manual 
This manual is for system administrators responsible for installing, configuring and using 
X32/X52 on a Linux system. This manual assumes knowledge of: 

• As a stand-alone program: The operating system Linux (SuSE 7.0 or higher or Red Hat 
7.0) 

• As an eLux plug-in: The Embedded Linux (eLux®) software 

1.2 About This Guide 
This documentation presents step-by-step directions on how to install, configure and use the 
X32 – 3270 and X52 – 5250 emulations for Motif as either a stand-alone program or as a plug-
in on a Thin Client running eLux software. Information in this manual is valid for both stand-
alone and plug-in programs. When X32/X52 as a stand-alone program differs from X32/X52 
as an eLux plug-in, this is noted. 

Due to the widespread use of X32/X52 on Thin Clients running eLux, pictures are of the X32 
emulation as an eLux plug-in. When the X52 emulation differs from X32 in appearance or 
function, this is noted. 

For convenience, the manual is divided into the following sections: 

Chapter Description 

1 Before You Begin Manual conventions, overview of X32/X52 functions and 
features 

2 Getting Started System requirements, detailed instructions on installing 
and starting X32/X52 

3 Licensing How to enter a license 

4 Connections and Sessions Connecting and disconnecting sessions, setting 
connection and session parameters 

5 Programming Key Functions Programmable keys, user keys, keyboard mapping, 
releasing IBM functions 

6 X32/X52 Functionality Copy and paste, cursor options, color options, printing, 
changing font size, saving data transfer to diagnosis files 

7 Troubleshooting Information regarding trace files, avoiding screen 
distortions, saving configuration file, and configuration file 
paths 

 

1.3 Conventions and Abbreviations 

Conventions 
The following are text formats and symbols that appear in the manual: 

Convention Description 
� Refers to a procedure. 

> Move to a menu. 
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Convention Description 

“ ... “ Quotation marks refer to screen text and text in pop-up 
dialog boxes. 

ALL UPPERCASE Represents keyboard keys (for example, ENTER, F4, 
CTRL). 

Bold Indicates boxes and buttons, column headings, dialog 
box titles, lists, menu names and menu commands and 
new terms. 

Courier New The Courier New font represents entries you can type at 
the command line and directory names. 

<Italics> Indicate a placeholder for information or parameters that 
you must enter. As an example, if the procedure asks you 
to type <IP address>, you must type the actual IP 
address. Italics can also refer to book titles. 

Commonly-Used Abbreviations 
The following are terms that appear in the manual: 

Abbreviation Description 

IP address Internet Protocol address. IP addresses are represented 
in four 3-digit groups separated by periods. 

Example:  192.45.85.1 

TCP Transmission Control Protocol 

1.4 Finding More Information 
This manual contains conceptual information, installation and configuration instructions for 
X32/X52 as a stand-alone program and as an eLux plug-in. Additional information is available 
from the following sources: 

• The X32 – 3270 / X52 –- 5250 for Motif Administrator’s Guide for previous releases of 
X32 and X52 

• The eLux Administrator’s Guide for information on using X32/X52 as a plug-in with the 
Thin Client software Embedded Linux (eLux�), which generates the configuration file 
automatically 

• The Felics Administrator’s Guide for information on the license server 

This guide as well as other X32/X52 documentation is available in Adobe PDF format. It can 
be found in the following locations: 

• The documentation folder on your eLux CD-ROM 

• The product documentation library at www.myelux.com 

1.5 X32/X52 on the World Wide Web 
Unicon offers online technical support at www.myelux.com. This includes the following: 

• PDF versions of the documentation 

• Downloadable software 

• The latest updates and hotfixes for download 

• A list of supported hardware 

To access the site you must complete a one-time, free registration. 
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1.6 Overview 

What is X32/X52? 
For everyone who wants to have a high-capacity UNIX workstation or an X terminal as a 
multifunctional workplace, X32/X52 now offers easier and more comfortable access to 
OS390/AS400. Our UNIX products can be used on all market-relevant UNIX systems. 

• X32 for Motif is a complete emulation of a connection independent 3270 terminal. 

• X52 for Motif is a complete emulation of a connection independent 5250 terminal.  

This manual describes in detail how to configure and use the 3270/5250 emulations. Please 
be aware that Unicon TCP/IP coupling products (currently X32, X52, X97) installed as stand-
alone programs require the Felics® license server for dynamic licensing. (See section 2.2 
Installation Procedure for information on installing Felics.) 

 

X32/X52 Features 
X32/X52 is available as stand-alone program or eLux software package. It offers the following 
features: 

• Full graphical desktop • One-step connection using a mouse click  

• Ability to save personal emulation 
environment to a configuration file, which 
can then be loaded at a later time or 
supplied to others 

• User definition of foreground and 
background colors, allowing for easy visual 
management of screen mask 

• Ability to define a personal configuration file 
as a start parameter 

• Color attribute feature for automatically 
determining color design 

• Visual display of function keys • Color files that can be saved and reloaded 

• 20 programmable keys and 20 user-defined 
keys with keyboard mapping 

• System bar displaying connection name, 
time and connection state 

• Printing hard copies, local hard copies and 
screen shots 

• Status line displaying line status, transaction 
state and cursor position 

• Printing to a file • Automatic font resizing 

• Integrated key editor for user allocation of 
IBM function keys - no knowledge of the key 
codes necessary 

• Printing on a bypass line from an OS390 
host 

• Keyboard mapping files that can be saved 
and reloaded 

• Copy and paste function to transfer data to 
other X applications  

• Resource file that can be modified to user’s 
needs 

• Tracing feature 
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2 Getting Started 
This chapter contains the introductory information you need to get X32/X52 running. 

 

Note This chapter contains installation information for X32/X52 as a stand-alone program. If you 
are using the emulation as an eLux plug-in, skip to section 2.5. 

 

Section Description 

2.1 System Requirements Operating system requirements needed to run X32/X52 

2.2 Installation Procedure Step-by-step instructions on how to extract X32/X52 from 
x32.tar/x52.tar and the different files that will be installed 

2.3 Removing How to remove X32/X52 

2.4 Starting How to start X32/X52 using command-line parameters 

2.5 Main Window A detailed description of the different screen elements 

2.6 Closing How to close X32/X52 
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2.1 System Requirements 
X32/X52 has the following minimum system requirements: 

• Stand alone: Linux operating system (SuSE 7.0 or higher, or Red Hat 7.0) 
X11 server 

• Plug-in: Embedded Linux (eLux�) 

2.2 Installation Procedure 
Note The following section describes the installation procedure for X32/X52 as a stand-alone 
program. Installing X32/X52 as an eLux plug-in is done using the image definition file (*.idf). 
See the eLux Administrator’s Guide and the Elias Administrator’s Guide for more details. If you 
are using X32/X52 with eLux, please skip to section 2.5. 

The installation file for X32/X52 is available on the Internet. Download x32.tar/x52.tar from 
www.unicon-ka.de (click on “Service”). You need a password to download software. To obtain 
a password, please contact vertrieb@unicon-software.com  

To install X32/X52, extract the archives on the root file system “/”. Example: 
cd / 

tar xvf /tmp/x32.tar (or the disk drive as installed on your machine) 

After installation, all files are found in /usr/u97. 

Connecting to the Felics License Server 
If you have not yet installed the Unicon license server, install it now (see also the Felics 
manual). It is not included in the tar file. You must download it from www.unicon-ka.de (click 
on “Service”). You need a password to download software. To obtain a password, please 
contact vertrieb@unicon-ka.de. 
Using the program /usr/felics/brandli (UNIX) or REMBRAND (Windows), enter the X32/X52 
licenses you purchased. 
Licensing information entered using Felics is valid for all Unicon terminal emulations (X32, 
X52, X97). 

2.3 Removing 
Note The following section describes the removal procedure for X32/X52 as a stand-alone 
program. Removing X32/X52 as an eLux plug-in is done using the image definition file (*.idf). 
See the eLux Administrator’s Guide and the Elias Administrator’s Guide for more details. 

To remove, delete all the installed files in /usr/u97 (see section 2.2, “Installation Procedure”). 
Example: 
cd /usr 

rm –rf u97 

2.4 Starting 
Stand Alone 
Before starting X32/X52, check that the program directory of X32/X52 contains the 
environment variable PATH (by default, /usr/u97/bin). The first time X32/X52 starts, the 
directory .xemu is created in the user directory and the configuration files from the central data 
directory (/usr/u97/data) are copied to .xemu. The following command line parameters can be 
entered: 
call: x32 -c <configuration file> 

-c (optional) The name of a configuration file can be entered here. By default, 
X32/X52 uses the configuration file 3270.cfg/5250.cfg in the directory 
$HOME/.xemu (see section 4.1 Configuration File). Do not enter a path or add the 
extension “.cfg” when calling a configuration file from the command line. 
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ELux Plug-in 

Figure 1: Application definition dialog for the X32 emulation with eLux 

 
���� To configure an application definition for the X32/X52 as an eLux plug-in 
From the Configuration tab, click New. 

1. The Application Definition dialog box appears. Click the Emulation tab. 
• Name: Enter an appropriate name for this application. 

• Emulation type: Click to select 3270 or 5250. 

• Configuration: Select a configuration file from the drop-down list. Note: You must define 
a configuration from within the emulation to be able to select it from the list. The default 
configuration file is 3270.cfg / 5250.cfg. 

• Application Restart: Immediately reconnects after the user logs off. When this feature is 
selected, the application automatically starts when the Thin Client starts or restarts. 

• Start automatically: Click this check box to open the session when the terminal starts. 
2. Click Apply and Finish. 

 
���� To start X32/X52 as an eLux plug-in 

Once you have configured an application, click the Applications tab. The application name 
appears in the alphabetical list. Either click to select the application and click Connect or 
double-click the application. 
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2.5 Main Window 
Starting X32/X52 displays the main window, which contains the following elements: 

 
  

Title Bar 
Displays the session name, if a session name has been set (see “Session name” in section 
4.3, “Session Parameters,” page 18). 
The two buttons in the right-hand corner adjust screen size. As a stand-alone program, the 
minimize button  minimizes the screen. (As an eLux plug-in, the minimize button works only 
when the eLux taskbar is turned on in the eLux starter: Setup > Desktop > Taskbar.) The full 
screen width button  toggles between full screen and the font width set in fonts, page 30. 

Main Menu 

 
The main menu contains six menus: File, Edit, Keyboard, P Keys, Add-On and ? Help. To 
open a menu, click with the mouse. To navigate using the keyboard, press ALT and the 
underlined letter - for example, ALT + F for “File“. 

Keyboard Window 

The keys displayed are a copy of the 3270/5250 terminal keyboard and can be activated 
directly by clicking with the left mouse button. The keyboard is shown if the menu command 
Add-On > Keyboard window has been activated. 

Worksheet 
Click with the left mouse button to move the cursor to any position the application mask 
allows.  
The NILS (array of dots) are shown if the menu command Add-On > Show NILS has been 
activated. The copy and paste feature is described in section 6.1 Copy and Paste. 

 

Status bar 
System bar 

Main menu 
Title bar 

 Worksheet 

Keyboard window 



  X32 – X52 

Build Nr. 1  11   

System time / Timer 

Status Line 

The status line displays the line status when connected to a host. In addition, it displays the 
address of the cursor position (in the format: yyxx) if the menu command Add-On > Show 
cursor position has been activated. 

 

Status Line Symbol Meaning 

 Input locked by host, wait until next message from host 

 A host response is running 

 User error, press Reset 

 Caps lock 

 Insert 

 Shift 

 

System Bar 

Displays the product name, connection name and time/timer (for licensed/not licensed 
products). The color box shows the state of the connection. 

• red no connection 

• yellow trying to connect 

• green connection established 

Quick connect: Double-click using the left mouse button on the color box to connect or 
disconnect. 

 

2.6 Closing 
To close X32/X52, use the file command File > Close or the keyboard equivalent ALT + 4. 

ELux plug-in: Always close the emulation from within the application. Do not use the 
Disconnect button in the eLux starter when connected to a host! The LU name remains 
occupied! 

Color box Connection name 

Line status Cursor position 

Product name 
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3 Licensing 
X32/X52 is a licensed product that must be purchased. As a stand-alone program, licensing takes 
place via the Felics license server. See section 2.2 Installation Procedure for more information. 

This chapter describes the licensing procedure for X32/X52 as an eLux plug-in. 

 

Section Description 

3.1 Licensing Using the Scout eL 
Management Tool 

How to use the Scout eL management tool to enter an 
X32/X52 license 

3.2 Licensing at the Thin Client How to use the X32/X52 emulation to enter a license 
server or a limited validity license key 

3.3 No License How to use X32/X52 without a license for testing purposes 
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3.1 Licensing Using the Scout eL Management Tool 
If you use the Scout eL management tool to manage Thin Clients, this is the easiest way to 
enter licenses. 
Enter the X32/X52 license using Scout eL menu command: Options > License information. 
(See the Scout eL Administrator’s Manual for step-by-step instructions on how to enter 
licenses.) The license is automatically transferred to the emulation and the X32/X52 menu 
command Add-On > Licensing is disabled. 

 

3.2 Licensing at the Thin Client 
To enter a license at the Thin Client, you must start the emulation. Open the License 
Management dialog box using the X32/X52 menu command Add-On > Licensing. 

Local Licensing 
For testing purposes, you can obtain a license key from Unicon with limited validity. Enter the 
local license key using the X32/X52 menu command Add-On > Licensing. The duration of 
the testing period is displayed after “Valid” (dd.mm.yyyy). 

License Server 
If your organization uses a Felics license server, enter the license server name (or IP 
address). 

 

3.3 No License 
X32/X52 is a licensed product that must be purchased. However, by default it can be used for 
15 minutes with full functionality without a license for testing purposes. The 15 minutes begin 
when you connect to a host. The time remaining is displayed in the status line (bottom right-
hand corner). 
After 15 minutes, a message appears saying your time has expired. The status line changes 
to red lettering on a black background for 30 seconds. This additional time is provided to allow 
you to log off from the host before the emulation ends. 

Local licensing 
with license key 

License server 
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4 Connections and Sessions 
This chapter describes the how to establish and end a connection, and the required session and 
connection parameters. 

 

Section Description 

4.1 Configuration File A description of the configuration file (3270.cfg/5250.cfg), 
and how to open and save. 

4.2 Connection Parameters A detailed description of how to set connection parameters 
(3270.tcp/5250.tcp). 

4.3 Session Parameters A detailed description of how to set session parameters. 

4.4 Connecting Mouse, menu and keyboard commands for establishing a 
session. 

4.5 Disconnecting Mouse, menu and keyboard commands for disconnecting 
a session. 
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Required path for 
eLux plug-in! 

Refresh button 

 

4.1 Configuration File 
X32/X52 administrates all session data in a configuration file. By default this is: 

• $HOME/.xemu/3270.cfg for X32 (stand alone) 

• $HOME/.xemu/5250.cfg for X52 (stand alone) 

• /setup/xemu/3270.cfg for X32 (eLux plug-in) 

• /setup/xemu/5250.cfg for X52 (eLux plug-in) 

 
This allows you to customize the emulation’s appearance and behavior to your needs as well 
as activate the start parameters. A configuration file must contain:  

• General session parameter 

• Link to a connection from the connection file. See 4.2 Connection Parameters  

• Link to programmable keys (for example, 3270.pt/5250.pt). See 5.1 Programmable Keys 
(P Keys)  

• Link to user keys (for example, 3270.bt/5250.bt). See 5.2 User Keys (B Keys) 

• Link to a keyboard file (for example, 3270.kbd/5250.kbd). See 5.3 Keyboard Mapping 

• Link to a trimodal keyboard file (for example, 3270tri.kbd/5250tri.kbd). See 4.3 Session 
Parameters, page 25. 

• Link to a color file (for example, 3270.frb/5250.frb). See 6.3 Colors 
Whenever you change one of the above file names (for example, by saving with a new name 
or loading a new file), you must use the menu command File > CONFIGURATION > Save to 
save the changes permanently! Otherwise the changes are valid for the current session only. 

 

Open Configuration 
The menu command 
File > CONFIGURATION > Open 
allows you to load a different 
configuration file. Enter the path and 
configuration file name in the Load 
Configuration dialog box. When you 
load a configuration file, existing 
X32/X52 settings are deleted and any 
existing connection is ended. 
Stand-alone: The default path is 
$HOME/.xemu. 
ELux plug-in: The default path is 
/setup/xemu. The path must be the default! 

 

 

 

 

 

 

X32 
configuration 
commands 
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Save Configuration 
The menu command File > CONFIGURATION > Save Configuration allows you to save the 
X32/X52 parameters to the currently loaded configuration file, for example, 
$HOME/.xemu/3270.cfg or $HOME/.xemu/5250.cfg for stand alone or the default 
/setup/xemu/3270.cfg or /setup/xemu/5250.cfg for an eLux plug-in. 

Save Configuration As 
Stand alone: The menu command File > CONFIGURATION > Save as allows you to save the 
settings to a new configuration file. Enter the name of the configuration file in the Save 
Configuration dialog box. You must enter the extension “.cfg”. 

ELux plug-in: The path must be the default /setup/xemu. 

 

4.2 Connection Parameters 

Connection Name 
Before connecting to a host, you must define a name for the connection. All connections with 
the relating parameters are saved in the file 3270.tcp/5250.tcp by their names. The connection 
parameter file name (3270.tcp/5250.tcp) cannot be changed. 

Connection Parameters 
To change the parameters of a connection or to start a certain connection, use the 
Connection Parameter TCP dialog box. 

� To define parameters for a new connection: 
1. Use the menu command File > Connection > Parameter to open the Connection 

Parameter dialog box. 

 

 

Connection 
commands 
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2. Click Edit to open the Connection Parameter TCP dialog box. 

 

 

3. In the Connection Parameter TCP dialog box enter the following: 

Connection name Enter an arbitrary name for the connection. 
Host name Enter the name of the LAN channel adapter or a similar system. 

Enter the IP address only if the name is not known. 
Port host Enter the port number at which the host can be reached. Use 

23 unless otherwise configured. 
Terminal type Click to select the type of emulation. See the appendix for 

information on the different screen sizes and 7.2 Screen for 
information on resolving screen distortion. Note that for terminal 
types with the extension “-E”, the Telnet E checkbox must be 
selected. 

LU name X32: Enter the LU name as provided by your host administrator.  

 X52: Enter the device description as provided by your host 
administrator.  

 You can set the LU name (“station name”) to a set value using 
an environment variable. “X97STATNAM” is the defined station 
name environment variable for all Unicon Software GmbH 
emulations (X32, X52, X97). Alternatively, you can set the 
station name to a variable. Requirement: The device must be 
managed by Scout NG. For more information, see the X97 
chapter or environment variable chapter in the Scout NG 
Administrator’s Guide. 

Telnet E Click to select for the extended telnet protocol. 
If you are uncertain what a parameter should be, ask your OS390/AS400 system 
administrator. 

4. Click Apply, Save and OK. 

 
Apply transfers the settings made on the right-hand side of the dialog box to the connection 
list on the left-hand side, identifying them by connection name. Save saves your connection 
modifications to the file 3270.tcp/5250.tcp. 
To remove a connection, in the Connection Parameter TCP dialog box select the connection 
name and click Delete. Click Save to save the changes and then OK. 

1 

2 
3 

To save 
changes, click 
 
1 Apply 
2 Save 
3 OK 
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Restoring Previous Settings 
The menu command File > Connection > Load allows you to load a connection parameter 
file. Current connection parameters are overwritten. This allows you to restore the original 
settings if connection parameters were modified but not saved. 

 

4.3 Session Parameters 
 

 

These settings define data relevant to a session. To adjust the session 
parameters, use the menu command File > SESSION > Parameter to 
open the Session Parameter dialog box. 

 

 

 

 

 
Automatically connect  When this check box is selected, 

the connection entered in 
Connection name is automatically 
established when X32/X52 starts. 

Show connection name Select this check box to display the 
connection name in the system bar 
when connected to a host. 

Trimodal keyboard Select this check box to support 
the K235 keyboard. To take effect, 
the Trimodal keyboard and 
Character Set session parameters 
must be configured before you 
open a connection. 

Character Set Select the character set from the 
drop-down list to display special 
characters such as ñ, ü, ä, ö, [, etc. 
The default is ASCII. 

Session Name The text entered in this box is 
displayed in the title bar. 

Connection Name Enter one of the connection parameter configurations you defined 
in section 4.2 Connection Parameters. To select a connection 
parameter configuration, place the cursor in the box and press any 
key. This opens the Connection Parameter dialog box. Select the 
desired connection parameter configuration and click OK in the 
Connection Parameter dialog box. Your selection is entered 
automatically. 

 
If you have made changes to session settings, use the menu command File > 
CONFIGURATION > Save to save your changes to the configuration file.  
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4.4 Connecting 
There are several different ways to establish a connection. 

Mouse In the status bar, double-click with the left mouse button on the red 
color box. This connects using the currently defined connection 
parameters. 

Menu Use the menu command File > Connection > Connect or File > 
Connection > Parameter. This opens the Connection 
Parameters dialog box, which lists all currently defined connection 
names. Select a defined connection and click Connect.  

Keyboard Press CTRL-C. Note: You must have entered a connection name 
in the session parameter (File > SESSION > Parameter > 
Connection Name) as described in section 4.3 Session 
Parameters and saved the configuration (File > CONFIGURATION 
> Save). 

When a connection has been established, the status bar color box is green. 

 

4.5 Disconnecting 
There are several different ways to disconnect: 

Mouse In the status bar, double-click with the left mouse button on the 
green color box. 

Menu Use the menu command File > Connection > Disconnect. 
Keyboard Press CTRL-D. 

 

When a connection has been disconnected, the status bar color box is red. 
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5 Programming Key Functions 
This chapter describes how to program the P keys, B keys and keyboard mapping. 

 

Section Description 

5.1 Programmable Keys 
(P Keys) 

How to edit, load and save P keys using the P Key Editor 

5.2 User Keys (B Keys) How to edit, load and save B keys using the B Key Editor 

5.3 Keyboard Mapping  How to map keyboard functions using the integrated keyboard 
compiler 

5.4 Keyboard How to release IBM functions 
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5.1 Programmable Keys (P Keys) 
X32/X52 offers 20 programmable keys (the so-called “P keys,” P1 to P20) that can be easily 
mapped using the P Key Editor. 
In addition, the emulation offers an additional 20 user keys (the so-called “B keys,” B1 to B20) 
that can be easily mapped using the B Key Editor (see section 5.2 User Keys (B Keys)). 
Use the menu command P Keys > Load / Save to load or save P key mapping files (*.pt). 

 
Loading P Keys 
From X32/X52, use the menu command P Keys > Load to load P key mappings. The file 
has the extension ".pt". 

 
Saving P Keys 
From X32/X52, use the menu command P Keys > Save to save a P key mapping file. 
You must enter the extension “.pt”. 

Stand-alone: The default path is $HOME/.xemu. 

ELux plug-in: The default path is /setup/xemu. The path must be the default! 

 

P Key Editor 
Use the menu command P Keys > Edit to open the P Key Editor. The 
currently defined P keys are shown. 
The P Key Editor offers two modes: View and Edit. The mode you are in is 
shown in the lower border. 

 

P key column 

View / Edit mode 
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Refresh button 

View Mode 
To enter View mode, in the P Key Editor: 

• click with the left mouse button on a P key in the P key column 

• or press the corresponding P key on the keyboard. 

The cursor jumps to the P key line, but the line is not highlighted. 
In View mode you can place the cursor anywhere within the keyboard mapping and delete 
single characters. Cursor right and cursor left (� �) move the cursor within the current 
keyboard mapping. Single characters may be deleted by delete key (DEL).  

 
Edit Mode 
To enter Edit mode, in the P Key Editor: 

• double-click with the left mouse button on a P key in the P key column 

• or press the corresponding P key on the keyboard twice. 

If you are already in the View mode, enter Edit mode with another left mouse click on the P 
key or pressing the P key on the keyboard again, or by means of the Insert function. (INS key) 
In Edit mode, any key you press is added to the P key mapping. From within the P Key Editor, 
the Keyboard menu allows you to map IBM functions to a P key. 

Return to View mode by clicking the P key again or by clicking on a different P key. 

 
Linking P Keys 

Each P key can save up to 512 characters. If you wish to extend this limit, you can link to 
another P key. The last character in a P key may be another P key to continue the first. 

Note To avoid continuous looping, P keys can only be linked in ascending order (for example, 
P1 � P3 or P3 � P4). Descending order (for example, P6 � P1) is not allowed. 

 
Loading P Keys 
From within the P Key Editor, use the menu command File > Load to load P key mappings. 
This is equivalent to the X32/X52 main menu command P Keys > Load. A P keys file has the 
extension ".pt". 

 
Saving P Keys 
From within the P Key Editor, use the menu command File 
> Save to save a P key mapping file. This is equivalent to 
the X32/X52 main menu command P Keys > Save. You 
must enter the extension “.pt”. 

Stand-alone: The default path is $HOME/.xemu. 
ELux plug-in: The default path is /setup/xemu. The path 
must be the default! 

 

 

 

 

 

Enter file name 
with extension “pt“ 
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Activating Changes for the Current Session 
To exit the P Key Editor, click Cancel to discard changes or OK to activate the changes. 
When you click OK, the keyboard mapping is valid for the current session. 

 
If you have changed the P key file name, use the menu command File > CONFIGURATION > 
Save to save your changes to the configuration file. 

 

5.2 User Keys (B Keys) 
The B-keys represent 20 additional P keys that can be mapped arbitrarily by the user and 
saved in files with the extension “.bt“. 

 

B Key Editor 
Use the menu command Add-Ons > User keys > Edit to 
open the B Key Editor. The currently defined B keys are 
shown. 

The B Key Editor offers two modes: View and Edit. The 
mode you are in is shown in the lower border. 

 

 

 

 

Programming and using the user-defined B keys is similar to the P keys (see section 5.1 
Programmable Keys (P Keys)), with the exception that B keys cannot be linked. 
As is true for P keys, at any time B keys can be loaded (Add-Ons > User keys > Load ) or 
saved to files (Add-On > User keys > Save ). When saving, you must enter the extension 
“.bt”. 

B key column 

View / Edit mode 
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Stand-alone: The default path is $HOME/.xemu. 

ELux plug-in: The default path is /setup/xemu. The path must be the default! 

 
If you have changed the B key file name, use the menu command File > CONFIGURATION > 
Save to save your changes to the configuration file. 

 

5.3 Keyboard Mapping 
The integrated keyboard compiler enables you to edit keyboard 
functions comfortably and administrate these as keyboard 
mapping files (*.kbd).  

 

 

 

 

 

 

� To map a key combination to a function: 
1. Use the menu command Add-Ons > Keyboard to open the Keyboard Compiler 

dialog box. 
2. Select the desired function (for example, “Field mark“) from the scroll-down list on the 

left-hand side of the dialog box. The right-hand side of the dialog box displays the 
corresponding key mapping (“Shift+3270_FieldMark“). No text appears if no key 
combination is assigned to this function. 

3. Click Enter key. The text “Press shortcut” appears in the dialog box. 

4. Press the combination of keys (shortcut) you want mapped to the function. The 
shortcut is displayed below “Enter Key”. 

5. Click OK. 

Local Functions 
The following local functions must be mapped before they can be used. 

 
Menu On/Off 
Toggle that displays the main menu (File, Edit, Keyboard, P Keys, Add-Ons, ? Help). 
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Crosshair 
Toggle that displays the crosshair. See 6.2 Cursor Options for information on configuring 
crosshair settings. 

By default, for trimodal keyboards crosshair is mapped to the LINE key. 
 
Hard Copy 
Prints a hard copy using current printer settings. By default, hard copy is mapped to the 
PRINT key. See 6.4 Printing for information on configuring printer settings. 

 

In addition, the keyboard compiler contains the following: 
Show: Displays the entire key mapping list, which can be printed. 
Delete: Erases the shortcut mapped to the currently selected function. Note: 

No confirmation box appears! 
Load: Opens the Keyboard File Load dialog box, which allows you to 

choose the path and file name of a keyboard mapping file (*.kbd). 
When a keyboard mapping file is loaded, the mapping is activated 
within the emulation immediately. 

Save: Saves the current keyboard mapping to a keyboard mapping file. 
Note: You must enter the extension “.kbd”. 

 Stand-alone: The default path is $HOME/.xemu. 
 ELux plug-in: The default path is /setup/xemu. The path must be the 

default! 

 
If you have changed the keyboard mapping file name, use the menu command File > 
CONFIGURATION > Save to save your changes to the configuration file. 

 

5.4 Keyboard 
When a key mapping is unknown, we recommend you use the 
menu command Add-Ons > Keyboard to release the IBM 
function. 
Use the left mouse button to navigate through the 
hierarchically organized Keyboard menu. To release an IBM 
function, click on it with the mouse. 
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6 X32/X52 Functionality 
This chapter describes the different features and settings of X32/X52. 

 

Section Description 

6.1 Copy and Paste How to copy and insert text 

6.2 Cursor Options How to set cursor and crosshair options 

6.3 Colors How to edit the foreground and background color files 

6.4 Printing How to print to a file, a local hard copy, hard copies, and 
the screen 

6.5 Fonts How to change the font size dynamically 

6.6 ? Help Menu How to use the help and emulation information functions 

6.7 Resource File How to set the value of certain parameters using the 
resource file 
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6.1 Copy and Paste 
Note This feature is available only when the emulation is connected to a host. 

 
This function allows you to copy data from the emulation screen (for example, article number) 
and insert it at another screen position or later in the work session. 

 

� To copy and insert text 

1. Use the left mouse button to select the desired text. 

2. From the Edit menu, click Copy. 

3. Move the cursor to the position you want to insert the text. 
4. From the Edit menu, click Paste. The text is inserted, as long as the application mask 

permits this. 

 

You can repeat the insertion procedure as often as you like. 

 

 

6.2 Cursor Options 

Cursor 
Use the menu command Add-Ons > Cursor Options to open 
the Cursor Options dialog box. You can choose from two 
forms, a block rectangle or a line. You can also set the cursor to 
blink.  

 

 

Crosshair 
To use the crosshair function, the crosshair display control character must be mapped to a 
key.  

 

� To map crosshair to a key 
1. Use the menu command Add-On > Keyboard to open the Keyboard Compiler. 

2. Select Crosshair from the left-hand window (may have to scroll down). 

3. Click Enter key. The text “Press shortcut“ appears. 

4. Press a shortcut key. The text appears on the right-hand side. Click OK. 

 

Trimodal keyboard: By default, crosshair is mapped to the LINE key. 

Cursor settings 
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� To set the crosshair form 
1. Use the menu command Add-On > Cursor Options to open the Cursor Options 

dialog box. 
2. Select the crosshair form you want: horizontal line, vertical line 

or cross. Click OK.  

3. In the worksheet, press the crosshair key shortcut. The crosshair 
is activated. 

4. Type text. The crosshair does not move. 
5. To deactivate the crosshair, press the crosshair shortcut key 

again. 
Alternatively, select Cursor follows from the Cursor Options 
dialog to have the crosshair move with the cursor. 

 

 
To save cursor/crosshair settings, the configuration must be saved using the menu command 
File > CONFIGURATION > Save. 

 

6.3 Colors 
Use the menu command Add-Ons → Colors to edit the 
foreground and background color files (*.frb) using the Color 
Setup dialog box. This dialog box allows you to assign the 
foreground and background colors for the individual display 
control characters. 

 
Select the required field combination in the list on the left-hand 
side and assign the foreground and background color. The 
colors are mapped immediately on the emulation screen. 

 

Crosshair settings 

Attribute button 
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Refresh button 

Required path for 
eLux plug-in! 

Attribute Function 
X32/X52 provides a useful automatic color attribute finder for when the field combination is 
unknown.  

� To use the automatic attribute finder function 
1. Click Attribute. The Color Setup dialog box is hidden. 

2. Move the mouse over text (do not click with the mouse!). The field combination 
currently assigned to the text is displayed in the system bar (bottom of the screen). 

3. Click on text with the mouse. The Color Setup dialog box reappears and the field 
combination is automatically highlighted so it can easily be modified. 

  
“Cursor” and “Selection” (selecting an area of text with the cursor for the copy 
function) cannot be reached using the color attribute finder. In this case, map them 
directly in the Color Setup. 

 

Color mapping is administrated in an *.frb file, which you 
can load, modify or save at any time. When saving a color 
file, you must enter the extension “.frb”. 

Stand alone: The default path is $HOME/.xemu. 
ELux plug-in: The default path is /setup/xemu. The path 
must be the default! 

 
If you have changed the color file name, use the menu 
command File > CONFIGURATION > Save to save your 
changes to the configuration file.  

 

 

 

 

 

6.4 Printing 
Configure printer settings before printing. 

Printer Setup 
Open the Printer Setup using the menu command Add-Ons > 
Printer. 
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File Defines the output device. Click to select this check box to print to 
a file. See “Extended file” and “Output file” below. 

Printer Defines the output device. Click to select this check box to print to 
a printer. 

Page break Adds FF (form feed) to page end. 
Extended file When this checkbox is selected, when printing to a file the data is 

appended. Otherwise the file is truncated. 
Printer Device Displays a list of all known UNIX printers. Choose one. 
Character Set Displays a list of all character sets supported by the printer. 

Choose one. 

CR >>>>>>>> CR + LF The character CR (carriage return) will be converted into the 
characters CR and LF (line feed). 

CR >>>>>>>> LF + CR The character CR (carriage return) will be converted into the 
characters LF (line feed) and CR. 

CR >>>>>>>> CR The character CR (carriage return) will not be changed. 

Ignore DEL The character DEL will not be transmitted to the output device. 
Output file Name of the output file, if the File check box has been selected 

above. 
Stand alone: By default, the file is saved to  
$HOME/.xemu/hardcopy.lp. 
ELux plug-in: By default, the file is saved to 
/setup/xemu/hardcopy.lp. 
Note Do not enter a path! The file must be printed to the default 
path. Do not use /tmp/<file path>! 

 

PRINT Key Mapping 
By default, the local function “hard copy” is mapped to the PRINT key (see 5.3 Keyboard 
Mapping). Printer settings must be configured before using the key. 

 

Print Screen 
Note This feature is available only when the emulation is 
connected to a host.  

 
Use the menu command Add-Ons > Print Screen to print a 
hard copy of the worksheet. Printer settings must have been 
configured previously. See 6.4 Printing. Only fields defined by 
the host as printable can be printed. 

Keyboard shortcut: CTRL + P. 
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6.5 Fonts 
By default, X32/X52 provides 12 different font sizes. Use the 
menu command Add-Ons > Fonts to open the Fonts 
Setup dialog box and change the font size dynamically.  

 
When a font size is selected, the 
main screen size automatically 
adjusts to allow you to preview 
your selection. Click OK to assign 
the font size to X32/X52. To save 
your changes to the X32/X52 
configuration file, use the menu 
command File > 
CONFIGURATION > Save. 

The full screen width button  in the title bar (upper 
right corner) toggles between full screen and the font 
width set in fonts (see Title Bar, page 4). In full screen 
mode, the font size is set automatically. 

 

 

 

 

 

 

6.6 ? Help Menu 
Help 
Clicking ? > Help starts the Netscape browser and points you to the Unicon docu-
mentation page (www.myelux.com). Here you can find a pdf version of the X32/X52 
manual. 

 

Info 
Clicking ? > Info displays the starting pop-up box which contains version information and 
release date. 

 

6.7 Resource File 
Details: 

File name:  .Xdefaults on Thin Client 

File format: UNIX 

File path (on terminal):  in the /setup area on the Thin Client (Klaus – pfad?) 

Can I edit it directly?: eLux Plugin: no, Stand-alone: yes 
How to make changes 
for eLux Plugin:  indirectly, creating a new file and transferring it via Scout eL 

 

X32/X52 uses a resource file. In the resource file you can: 

• enable/disable menus 

• turn off the starting pop-up dialog box 

• set the tone (beep) 

Tip Do not edit Xdefaults 
using Notepad, which will 
convert it to a DOS text file. 
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ELux plug-in 
The resource file is “.Xdefaults” and located in the /setup area on the Thin Client. It cannot be 
modified directly; however, you can create a new file and transfer it to the terminal using the 
Scout eL management tool. 

� To modify the resource file (eLux plug-in) 
1. Create a new file using a UNIX text editor (for example, PFE32, included on your eLux 

CD). 
2. Decide which changes to make in the emulation and enter the corresponding 

parameters. See XXX below. 

3. Save the file as “Xdefaults” (without period) to the Scout eL Server root directory. 
4. Transfer this file to the Thin Clients using the Scout eL “File List” function. See the 

Scout eL Administrator’s Manual for more information. 

 

Template 

Whereas you can create the file by hand, we highly recommend using the Thin Client system 
resource file as a template. Copy it to your workstation from the following directory on the 
terminal:  

/usr/X11R6/lib/X11/app-defaults/X32 : X32 

/usr/X11R6/lib/X11/app-defaults/X52 : X52 

Open it using a UNIX editor and make the desired changes.  

 
Stand alone 
The resource file is $HOME/.Xdefaults and must be edited with a UNIX editor. 

 

Resource File Format 
All parameters are listed with the emulation type prefix (x32 or x52) + period + parameter + 
semicolon + value: 

<prefix>.<parameter>:<value> 

 
Example: To disable the Edit menu (and all its options) for X32: 
x32.X32.appform.titlebar.bearbeiten.sensitive: False 

 

An exclamation point (“!”) in the first column comments out the line. 

Resource File Parameters 
Following is a selected list of parameters for the resource file. 

 

Prefix: x32.X32, x52.X52 Value: True/False 

Affected 
Component 

Parameter Action 

File menu appform.titlebar.datei.sensitive enable/disable 

Edit menu appform.titlebar.bearbeiten.sensitive enable/disable 

Keyboard menu appform.titlebar.tastatur.sensitive enable/disable 

P Keys menu appform.titlebar.ptasten.sensitive enable/disable 

Add-Ons menu appform.titlebar.zusaetze.sensitive enable/disable 

Help menu appform.titlebar.hilfe.sensitive enable/disable 

Warning Text below the line 
“Do not edit below this line” 
should not be changed! 
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Prefix: x32.X32, x52.X52 

Affected 
Component 

Parameter Action 

X appform.form.text.background X 
 

Prefix: x32, x52 Value: True/False 

Affected 
Component 

Parameter Action 

X followcursor X 

X fullscreen X 

starting pop-up 
dialog box 

infobox activate/deactivate 

 

Prefix: x32, x52 

Affected 
Component 

Parameter Action 

X cursormode X 

X crosslinecolor X 

X printtext X 

X ttf_font X 

beep (nur x97?) volume 
tone 
time 

volume 
frequence (in Hertz) 
length (in milliseconds) 

 

 

Following are several examples of X32 parameters. 

 
Enabling/Disabling Menus 
The first entries in the file are for menu operation and can be used to disable specific menus. 
For example, to disable the File menu: 

 
! Menu File 

x32.X32.appform.titlebar.datei.sensitive: False 

 

Note Disabling a menu disables all menu commands contained in that menu. If you disable 
the File menu, the menu command Close is also disabled and the emulation can no longer be 
shut down! 

 
Turning off the starting pop-up dialog box 
When you first start the emulation, a dialog box appears on the screen with the version 
number and release date. To turn off the starting pop-up dialog box, set: 
X32.infobox: False 

 
Setting tone 
To set the beep values: 
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X32.volume: 60 : Volume. Allowed values: 0 to 100 

X32.tone: 2000 : Frequency (in Hertz) 

X32.time: 300 : Length (in milliseconds) 

 
Setting Parameters for X52 

To define X52 parameters, replace “x32” with “x52” in the examples above. 

 

! Menu File : Enabling/Disabling Menus 
x52.X52.appform.titlebar.datei.sensitive: False 

 

X52.infobox: False : Turning off the starting pop-up dialog box 

 

X52.volume: 60 : Setting tone 
X52.tone: 2000 
X52.time: 300 

etc. 

Example Resource File 
! App Defaults File for X32 

! (c) Unicon Software GmbH Karlsruhe 

! $Id: X32.En_US,v 1.6 2002/04/11 09:27:43 eluxmake Exp $ 

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! 

! User Preferences 

! TRUE=Option is allowed; FALSE=Option is forbidden 

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! 

 

! File Menu 

x32.X32.appform.titlebar.datei.sensitive: True 

 

! File Menu > SESSION > Parameter... 

x32.X32.appform.popup_datei_men.datei_men.connection.sensitive: True 

 

! File Menu > CONFIGURATION > Open 

x32.X32.appform.popup_datei_men.datei_men.open.sensitive: True 

 

! File Menu > CONFIGURATION > Save 

x32.X32.appform.popup_datei_men.datei_men.save.sensitive: True 

 

! File Menu > CONFIGURATION > Save as 

x32.X32.appform.popup_datei_men.datei_men.save_as.sensitive: True 

 

! File Menu > Connection ... 

x32.X32.appform.popup_datei_men.datei_men.connection.sensitive: True 

! File Menu > Connection > Connect 

x32.X32.appform.popup_datei_men.popup_connect.connect.button_0.sensitive: True 

! File Menu > Connection > Disconnect 

x32.X32.appform.popup_datei_men.popup_connect.connect.button_1.sensitive: True 

! File Menu > Connection > Parameter ... 
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x32.X32.appform.popup_datei_men.popup_connect.connect.button_2.sensitive: True 

! File Menu > Connection > Load 

x32.X32.appform.popup_datei_men.popup_connect.connect.button_3.sensitive: True 

 

! File Menu > Diagnosis 

x32.X32.appform.popup_datei_men.datei_men.diagnose.sensitive: True 

 

! File Menu > Close 

x32.X32.appform.popup_datei_men.datei_men.quit.sensitive: True 

 

 

! Menu Edit 

x32.X32.appform.titlebar.bearbeiten.sensitive: True 

! Menu Edit > Copy 

x32.X32.appform.popup_bearbeiten_men.bearbeiten_men.kopieren.sensit
ive: True 

! Menu Edit > Paste 

x32.X32.appform.popup_bearbeiten_men.bearbeiten_men.einfuegen.sensi
tive: True 

 

 

! Menu Keyboard 

x32.X32.appform.titlebar.tastatur.sensitive: True 

! Menu Keyboard > Other 

x32.X32.appform.popup_tastatur_men.tastatur_men.sonst.sensitive: 
True 

! Menu Keyboard > Cursor 

x32.X32.appform.popup_tastatur_men.tastatur_men.cursor.sensitive: 
True 

! Menu Keyboard > Kxx 

x32.X32.appform.popup_tastatur_men.tastatur_men.Kxx.sensitive: True 

! Menu Keyboard > Fxx 

x32.X32.appform.popup_tastatur_men.tastatur_men.Fxx.sensitive: True 

! Menu Keyboard > Pxx 

x32.X32.appform.popup_tastatur_men.tastatur_men.Pxx.sensitive: True 

! Menu Keyboard > Bxx 

x32.X32.appform.popup_tastatur_men.tastatur_men.Bxx.sensitive: True 

! Menu Keyboard > LAxx 

x32.X32.appform.popup_tastatur_men.tastatur_men.LAxx.sensitive: 
True 

 

 

! Menu P Keys 

x32.X32.appform.titlebar.ptasten.sensitive: True 

! Menu P Keys > Edit 

x32.X32.appform.popup_ptasten_men.ptasten_men.editieren.sensitive: 
True 

! Menu P Keys > Load 
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x32.X32.appform.popup_ptasten_men.ptasten_men.laden.sensitive: True 

! Menu P Keys > Save 

x32.X32.appform.popup_ptasten_men.ptasten_men.speichern.sensitive: 
True 

 

! Menu Add-Ons 

x32.X32.appform.titlebar.zusaetze.sensitive: True 

! Menu Add-Ons > Keyboard Window 

x32.X32.appform.popup_zusaetze_men.zusaetze_men.tastaturfenster.sen
sitive: True 

! Menu Add-Ons > Print Screen (Hard Copy) 

x32.X32.appform.popup_zusaetze_men.zusaetze_men.drucken.sensitive: 
True 

! Menu Add-Ons > Show NILS 

x32.X32.appform.popup_zusaetze_men.zusaetze_men.nils.sensitive: 
True 

! Menu Add-Ons > Show Cursor Position 

x32.X32.appform.popup_zusaetze_men.zusaetze_men.cursor.sensitive: 
True 

! Menu Add-Ons > Keyboard Compiler 

x32.X32.appform.popup_zusaetze_men.zusaetze_men.tastatur.sensitive: 
True 

! Menu Add-Ons > Color Setup 

x32.X32.appform.popup_zusaetze_men.zusaetze_men.farben.sensitive: 
True 

! Menu Add-Ons > Printer Setup 

x32.X32.appform.popup_zusaetze_men.zusaetze_men.drucker.sensitive: 
True 

! Menu Add-Ons > Font Setup 

x32.X32.appform.popup_zusaetze_men.zusaetze_men.fonts.sensitive: 
True 

! Menu Add-Ons > User Keys 

x32.X32.appform.popup_zusaetze_men.zusaetze_men.btasten.sensitive: 
True 

 

! Menu Help 

x32.X32.appform.titlebar.hilfe.sensitive: True 

 

X32.cursormode: block 

X32.crosslinecolor: #00FFFF 

X32.followcursor: False 

X32.fullscreen: False 

X32.printtext: \n \nprint on device: 

x32.X32.appform.form.text.background: #000000 

X32.infobox: False 

X32.ttf_font: Andale Mono 

 

!    face size 14 
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*render1.FontName: -monotype-Andale Mono-medium-r-normal--14-*-100-
100-m-100-iso8859-1 

*render1.fontType: FONT_IS_FONT 

*render1.loadModel: LOAD_IMMEDIATE 

*render1.strikethruType: NO_LINE 

*render1.renditionForeground: black 

*render1.renditionBackground: gray67 

*render1.underlineType: NO_LINE 

!*render1.tag: TAG1 

!*render1.tabList: +1.0in, +1.0in, +1.0in 

 

! Info Box 

*render2.FontName: -monotype-Andale Mono-medium-r-normal--*-*-100-
100-m-100-iso8859-1 

*render2.fontType: FONT_IS_FONT 

*render2.loadModel: LOAD_IMMEDIATE 

*render2.strikethruType: AS_IS 

*render2.renditionForeground: black 

*render2.renditionBackground: gray 

*render2.underlineType: NO_LINE 

 

 

! Tastaturfenster 

*render3.FontName: -monotype-Andale Mono-medium-r-normal--10-*-100-
100-m-100-iso8859-1 

*render3.fontType: FONT_IS_FONT 

*render3.loadModel: LOAD_IMMEDIATE 

*render3.strikethruType: AS_IS 

*render3.renditionForeground: black 

*render3.renditionBackground: gray 

*render3.underlineType: NO_LINE 

 

 

*.renderTable: render1 
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7 Troubleshooting 
 

7.1 Diagnosis 
 

 
The data transfer between X32/X52 and OS390/AS400 can be traced 
and saved to diagnosis files. 
Use the menu command File > Diagnosis to switch the data trace on 
and off. 
The files are numbered and saved in the folder /tmp. The files are named 
X32.<number> or X52.<number>, where <number> begins with “000”. 
Before you switch on the diagnosis you should delete all files with this 
name. 

When the trace is finished, the diagnosis function must be deactivated. 
ELux plug-in: The emulation menu command Diagnosis creates the 
trace files. The eLux starter can be used to send these trace files to the 
destination of your choice (Setup > Diagnostics > X-Emulation files). 

 

7.2 Screen 
X32, Stand Alone and Plug-In 
If you change the terminal type during an X32 session and continue working, you may 
experience screen distortion. To avoid this, when changing terminal type use the following 
procedure: 

� To change terminal type in X32 
1. Open the Connection Parameter TCP dialog box using the menu command File > 

CONFIGURATION > Connection > Parameter > Edit > Terminal Type. Change the 
terminal type. Click Apply > Save > OK. 

 

Terminal type 

1 

2 
3 

To save 
changes, click 
 
1 Apply 
2 Save 
3 OK 
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2. Save your changes to the X32 configuration file by using the menu command File > 

CONFIGURATION > Save. 

3. Restart the emulation! Screen size settings are sent to the host when the emulation 
starts. Different emulation types have different screen sizes. If you continue to work 
and do not restart, you may experience screen distortions. 

See the appendix for the different screen sizes and terminal types. 

 
X52, Stand Alone and Plug-In 
It is not necessary to restart the X52 emulation when you change the terminal type in the 
Connection Parameters TCP dialog box during a session. However, you must click Apply > 
Save > OK and you must disconnect and reconnect. 

 

7.3 Saving Configuration File 
X32/X52 administrates all session data in a configuration file. If any of the following file names 
are changed: 

 

File Default File Name 
programmable keys (P keys) file : 3270.pt/5250.pt 

user keys (B keys) file : 3270.bt/5250.bt 

keyboard file : 3270.kbd/5250.kbd 

color file : 3270.frb/5250.frb 

 

either by loading a new file or using the “Save as” function, you must use the menu command 
File > CONFIGURATION >  Save to save the changes to the configuration file. This saves the 
changes permanently. Otherwise the changes are only valid for the current session. 

 

This is true for all other settings: 

 
Settings Menu Command 
show NILS : Add-Ons > Show NILS 

show keyboard window : Add-Ons > Keyboard window 

font size : Add-Ons > Fonts 

printer settings : Add-Ons > Printer 

 

as well as general session parameters, cursor settings, etc. 



  X32 – X52 

Build Nr. 1  40   

7.4 Save Configuration File As 
X32/X52, Plug-In 
As an eLux plug-in, by default the required configuration file path must be /setup/xemu! (This 
is not true for the stand-alone program.) This is due to flash size constraints on the Thin Client. 
If you try to save configuration files to other directories, they will not be saved. No error 
message will be displayed. 
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8 A P P E N D I X: Screen Size 
 
The Connection Parameter TCP dialog box offers several terminal types with different 
extensions. Different extensions have a different number of lines and columns in the emulation 
screen. The values are given below. 

 
3270 
Terminal types 3278, 3279 

Extension Lines x Columns 

-2 24 x 80 

-3 32 x 80 

-4 43 x 80 

 
5250 
All terminal types are 24 x 80 except for: 

Terminal Type Lines x Columns 

3477-FC 27 x 132 

3477-FG 27 x 132 

3180-2 27 x 132 
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9 I N D E X 

A 

abbreviations · 5 
about 

manual · 4 
X32/X52 · 6 

automatically connect · 17 

B 

B keys 
about · 22 
editor 

about · 22 
loading · 22 
saving · 22 

loading · 22 
saving · 22 

background color · 27 

C 

CD-ROM, documentation · 5 
character set 

keyboard · 17 
printing · 29 

closing X32/X52 · 10 
color box, system bar 

meaning of colors · 10 
using to connect · 18 
using to disconnect · 18 

colors, setting · 27 
configuration file 

about · 14 
opening · 14 
saving · 15 
saving as · 15 
what must contain · 14 

connecting 
via color box · 18 
via keyboard · 18 
via menu · 18 

 
connection name 

connection parameters · 15 
displaying in system bar · 10, 17 
entering in session parameters · 17 

connection parameters 
configuring · 15 
connection name · 15 
restoring previous settings · 16 

conventions used in manual · 4 
copying · 26 
crosshair options · 26 
cursor options · 26 
cursor position, show in status line · 10 

D 

diagnosing · 32 
disconnecting 

via color box · 18 
via keyboard · 18 
via menu · 18 

display 
fonts · 30 
main window · 9 

F 

features, X32/X52 · 6 
fonts, changing · 30 
foreground color · 27 

H 

hard copy, printing · 28 
help, information on X32/X52 · 5 

I 

installing 
Felics license server · 8 
X32/X52 

as eLux plug-in   See · eLux Administrator’s 
Manual 

as stand-alone program · 8 

K 

keyboard 
mapping · 23 
releasing IBM functions · 24 
trimodal · 17 

keyboard window · 9 

L 

licensing 
entering local license key · 12 
using without license · 12 
via Scout eL management tool · 12 

local hard copy, printing · 28 

M 

main menu 
about · 9 
copying and pasting · 26 
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main window · 9 
mapping keyboard · 23 
menu, about · 9 

N 

NILS · 9 

P 

P keys 
about · 20 
editor 

about · 20 
Edit mode · 21 
loading · 21 
saving · 21 
View mode · 21 

loading · 20 
saving · 20 

pasting · 26 
printing 

choosing character set · 29 
configuring settings · 28 

printing (continued) 
hard copies · 28 
local hard copies · 28 
page break · 29 
print screen · 29 
to file · 28, 29 

programmable keys   See · P keys 

R 

releasing IBM functions · 24 
removing X32/X52 · 8 
requirements, system · 8 
restoring previous connection settings · 16 

S 

session name 
displaying in title bar · 9, 17 
setting · 17 

session parameters 
about · 17 
automatically connect · 17 
character set · 17 
displaying connection name in system bar · 17 
entering connection name · 17 
setting session name · 17 
trimodal keyboard · 17 

starting X32/X52 · 8 
status line · 10 
system bar 

about · 10 
connection name · 17 

system requirements · 8 

T 

title bar, about · 9 
trimodal keyboard, setting · 17 
troubleshooting   See · diagnosing 

U 

user keys   See · B keys 

W 

window 
keyboard · 9 
main · 9 

work area   See · worksheet 
worksheet · 9 

copy and paste · 26 
fonts · 30 

X 

X32/X52 
about · 6 
closing · 10 
features · 6 
removing · 8 
starting · 8 
system requirements · 8 

 


